]> git.pld-linux.org Git - packages/evince-gtk.git/blob - evince-gtk.spec
- up to 2.29.5
[packages/evince-gtk.git] / evince-gtk.spec
1 #
2 # - are schemas (thus GConf) needed?
3 #
4 # Conditional build:
5 %bcond_without  dbus            # disable DBUS support
6 %bcond_without  apidocs         # disable gtk-doc
7 #
8 Summary:        Document viewer for multiple document formats -- the no libgnome version
9 Summary(pl.UTF-8):      Przeglądarka dokumentów w wielu formatach -- wersja nie wykorzystująca libgnome
10 %define         _realname       evince
11 Name:           evince-gtk
12 Version:        2.29.5
13 Release:        1
14 License:        GPL v2
15 Group:          X11/Applications/Graphics
16 Source0:        http://ftp.gnome.org/pub/gnome/sources/evince/2.29/%{_realname}-%{version}.tar.bz2
17 # Source0-md5:  6b847d060fe3cbe96a156f82a28ee4d9
18 URL:            http://www.gnome.org/projects/evince/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.71}
22 BuildRequires:  djvulibre-devel >= 3.5.17
23 BuildRequires:  ghostscript
24 %{?with_apidocs:BuildRequires:  gnome-doc-utils >= 0.3.2}
25 BuildRequires:  gtk+2-devel >= 2:2.10.6
26 BuildRequires:  intltool >= 0.35.0
27 BuildRequires:  kpathsea-devel
28 BuildRequires:  libglade2-devel >= 1:2.6.0
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtiff-devel
31 BuildRequires:  libxslt-progs >= 1.1.17
32 BuildRequires:  pkgconfig
33 BuildRequires:  poppler-glib-devel >= 0.6
34 BuildRequires:  python-libxml2
35 BuildRequires:  rpmbuild(macros) >= 1.197
36 BuildRequires:  scrollkeeper
37 Requires(post,postun):  desktop-file-utils
38 Requires(post,postun):  gtk+2 >= 2:2.10.6
39 Requires(post,postun):  scrollkeeper
40 Requires:       cairo >= 1.2.4
41 Requires:       djvulibre >= 3.5.17
42 Requires:       gtk+2 >= 2:2.10.6
43 Requires:       poppler-glib >= 0.6
44 Conflicts:      evince
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         backendsdir     %{_libdir}/evince/2/backends
48
49 %description
50 Evince is a document viewer for multiple document formats like pdf,
51 postscript, and many others. The goal of evince is to replace the
52 multiple document viewers that exist on the GNOME Desktop, like ggv,
53 gpdf, and xpdf with a single simple application.
54
55 This version doesn't use GNOME libraries, but only GTK+.
56
57 %description -l pl.UTF-8
58 Evince jest przeglądarką dokumentów w wielu formatach takich jak pdf,
59 postscript i wielu innych. W zamierzeniach program ma zastąpić
60 przeglądarki dokumentów dla środowiska GNOME, takie jak ggv, gpdf i
61 xpdf jedną prostą aplikacją.
62
63 Ta wersja nie korzysta z bibliotek GNOME, a jedynie z GTK+.
64
65 %package apidocs
66 Summary:        Evince API documentation
67 Summary(pl.UTF-8):      Dokumentacja API aplikacji Evince
68 Group:          Documentation
69 Requires:       gtk-doc-common
70
71 %description apidocs
72 Evince API documentation.
73
74 This version doesn't use GNOME libraries, but only GTK+.
75
76 %description apidocs -l pl.UTF-8
77 Dokumentacja API aplikacji Evince.
78
79 Ta wersja nie korzysta z bibliotek GNOME, a jedynie z GTK+.
80
81 %package devel
82 Summary:        Header files for Evince GTK+
83 Summary(pl.UTF-8):      Pliki nagłówkowe Evince GTK+
84 Group:          X11/Development/Libraries
85 Requires:       %{name} = %{version}-%{release}
86 Requires:       gtk+2-devel >= 2:2.16.0
87
88 %description devel
89 Header files for Evince GTK+.
90
91 %description devel -l pl.UTF-8
92 Pliki nagłówkowe Evince GTK+.
93
94 %prep
95 %setup -q -n %{_realname}-%{version}
96
97 %build
98 %{__intltoolize}
99 %{__aclocal}
100 %{__autoconf}
101 %{__autoheader}
102 %{__automake}
103 %configure \
104         %{!?with_apidocs:--disable-gtk-doc} \
105         %{!?with_apidocs:--disable-scrollkeeper} \
106         --disable-nautilus \
107         --disable-static \
108         --disable-schemas-install \
109         --enable-comics \
110         %{!?with_dbus:--disable-dbus} \
111         --enable-djvu \
112         --enable-dvi \
113         --enable-impress \
114         --enable-pdf \
115         --enable-pixbuf \
116         --enable-ps \
117         --enable-t1lib \
118         --enable-thumbnailer \
119         --enable-tiff \
120         --with-html-dir=%{_gtkdocdir} 
121
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT \
129         HTML_DIR=%{_gtkdocdir}
130
131 %{__rm} $RPM_BUILD_ROOT%{backendsdir}/*.la
132
133 %find_lang %{_realname}
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post
139 /sbin/ldconfig
140 %update_desktop_database_post
141 %scrollkeeper_update_post
142 %update_icon_cache hicolor
143
144 %preun
145
146 %postun
147 /sbin/ldconfig
148 %update_desktop_database_postun
149 %scrollkeeper_update_postun
150 %update_icon_cache hicolor
151
152 %files -f %{_realname}.lang
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog NEWS README TODO
155 %attr(755,root,root) %{_bindir}/evince
156 %attr(755,root,root) %{_bindir}/evince-previewer
157 %attr(755,root,root) %{_bindir}/evince-thumbnailer
158 %attr(755,root,root) %{_libdir}/libevdocument.so.*.*.*
159 %attr(755,root,root) %ghost %{_libdir}/libevdocument.so.2
160 %attr(755,root,root) %{_libdir}/libevview.so.*.*.*
161 %attr(755,root,root) %ghost %{_libdir}/libevview.so.2
162 %attr(755,root,root) %{_libdir}/evinced
163 %attr(755,root,root) %{_libdir}/evince-convert-metadata
164 %dir %{_libdir}/%{_realname}
165 %dir %{_libdir}/%{_realname}/2
166 %dir %{backendsdir}
167 %{backendsdir}/comicsdocument.evince-backend
168 %{backendsdir}/djvudocument.evince-backend
169 %{backendsdir}/dvidocument.evince-backend
170 %{backendsdir}/impressdocument.evince-backend
171 %{backendsdir}/pdfdocument.evince-backend
172 %{backendsdir}/pixbufdocument.evince-backend
173 %{backendsdir}/psdocument.evince-backend
174 %{backendsdir}/tiffdocument.evince-backend
175 %attr(755,root,root) %{backendsdir}/libcomicsdocument.so
176 %attr(755,root,root) %{backendsdir}/libdjvudocument.so 
177 %attr(755,root,root) %{backendsdir}/libdvidocument.so 
178 %attr(755,root,root) %{backendsdir}/libimpressdocument.so
179 %attr(755,root,root) %{backendsdir}/libpdfdocument.so
180 %attr(755,root,root) %{backendsdir}/libpixbufdocument.so
181 %attr(755,root,root) %{backendsdir}/libpsdocument.so
182 %attr(755,root,root) %{backendsdir}/libtiffdocument.so
183 %{_mandir}/man1/*
184 %{_datadir}/%{_realname}
185 %{_desktopdir}/*.desktop
186 %{_iconsdir}/*/*/*/*
187 %{_omf_dest_dir}/evince
188
189 %if %{with apidocs}
190 %files apidocs
191 %defattr(644,root,root,755)
192 %{_gtkdocdir}/*
193 %endif
194
195 %files devel
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_libdir}/libevdocument.so
198 %attr(755,root,root) %{_libdir}/libevview.so
199 %{_libdir}/libevdocument.la
200 %{_libdir}/libevview.la
201 %dir %{_includedir}/%{_realname}
202 %dir %{_includedir}/%{_realname}/2.29
203 %dir %{_includedir}/%{_realname}/2.29/libdocument
204 %dir %{_includedir}/%{_realname}/2.29/libview
205 %{_includedir}/%{_realname}/2.29/*.h
206 %{_includedir}/%{_realname}/2.29/libdocument/*.h
207 %{_includedir}/%{_realname}/2.29/libview/*.h
208 %{_pkgconfigdir}/evince-document-*.pc
209 %{_pkgconfigdir}/evince-view-*.pc
This page took 0.062614 seconds and 4 git commands to generate.