]> git.pld-linux.org Git - packages/eventum.git/commitdiff
fix scm integration
authorElan Ruusamäe <glen@delfi.ee>
Mon, 9 Feb 2015 12:44:22 +0000 (14:44 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 9 Feb 2015 12:44:22 +0000 (14:44 +0200)
eventum-apache.conf
eventum-cvs-config.patch
eventum-lighttpd.conf
eventum.spec

index 54f4d4377a411dd73ff9930e83d58c822b1dc2c5..63dcb7c27abeff8d7be75fe1a822c03fa1522950 100644 (file)
@@ -44,7 +44,7 @@ Alias /eventum /usr/share/eventum/htdocs
                </IfModule>
                # Apache 2.4
                <IfModule mod_authz_core.c>
-                       # Set here IP of host running CVS
+                       # SCM integration. Set here IP of host running CVS, SVN, Git
                        Require local
 #                      Require ip xxx.xxx.xxx.xxx
                </IfModule>
index 868ba045361a102d772e9b12497df5acf78796cf..610409cf1e43d2c52da112a61769dc00791b7a2f 100644 (file)
@@ -1,28 +1,26 @@
---- eventum-2.3.2/scm/eventum-cvs-hook.php~    2012-02-09 11:27:05.000000000 +0200
-+++ eventum-2.3.2/scm/eventum-cvs-hook.php     2012-02-09 11:29:22.671597765 +0200
-@@ -28,13 +28,7 @@
- // |          Elan Ruusamäe <glen@delfi.ee>                               |
- // +----------------------------------------------------------------------+
+--- eventum-3.0.0-pre1/scm/eventum-cvs-hook.php~       2014-11-30 13:48:18.000000000 +0200
++++ eventum-3.0.0-pre1/scm/eventum-cvs-hook.php        2015-02-09 14:39:22.881991719 +0200
+@@ -52,9 +52,7 @@
+ // SCM repository name. Needed if multiple repositories configured
+ $scm_name = 'cvs';
  
--// URL to your Eventum installation.
--// https is supported transparently by PHP 5 if you have openssl module enabled.
--$eventum_url = 'http://eventum.example.com/';
--
 -//
 -// DO NOT CHANGE ANYTHING AFTER THIS LINE
 -//
 +require_once '/etc/eventum/scm.php';
  
  // save name of this script
- $PROGRAM = basename(array_shift($argv));
---- eventum-2.2/scm/eventum-svn-hook.php~      2009-11-10 13:31:10.000000000 +0200
-+++ eventum-2.2/scm/eventum-svn-hook.php       2009-11-10 13:31:37.571582772 +0200
-@@ -36,7 +36,7 @@
+ $PROGRAM = basename(realpath(array_shift($argv)), '.php');
+--- eventum-3.0.0-pre1/scm/eventum-svn-hook.php~       2014-11-30 13:48:18.000000000 +0200
++++ eventum-3.0.0-pre1/scm/eventum-svn-hook.php        2015-02-09 14:40:05.184671966 +0200
+@@ -48,9 +48,7 @@
+ // SCM repository name. Needed if multiple repositories configured
+ $scm_name = 'svn';
  
- // URL to your Eventum installation.
- // https is supported transparently by PHP 5 if you have openssl module enabled.
--$eventum_url = 'http://eventum.example.com/';
+-//
+-// DO NOT CHANGE ANYTHING AFTER THIS LINE
+-//
 +require_once '/etc/eventum/scm.php';
  
- //
- // DO NOT CHANGE ANYTHING AFTER THIS LINE
+ // save name of this script
+ $PROGRAM = basename(realpath(array_shift($argv)), '.php');
index d8309e2abc6cf2ec6abea581d80aaa7d68b531dd..7ca717c21c069a475069fe3749ac2f42f89939af 100644 (file)
@@ -1,4 +1,3 @@
-# $Id$
 #
 # This config provides two kinds of configuration, for url based ("/eventum")
 # and vhost based ("http://eventum.example.org").
@@ -43,7 +42,7 @@ $HTTP["url"] =~ "^/eventum/" {
 #              )
 #      }
 
-       # SCM integration. Set here IP of host running your VCS
+       # SCM integration. Set here IP of host running CVS, SVN, Git
        $HTTP["remoteip"] != "127.0.0.1" {
                $HTTP["url"] =~ "/scm_ping\.php$" {
                        url.access-deny = ( "" )
index b2541200819840b01962f7c81d5b0915bb36e7f2..8d58392a22d9a95bfd0b375901228e6f0a8cbb97 100644 (file)
@@ -10,7 +10,7 @@
 %bcond_with    order   # with experimental order patch
 
 %define                subver  pre1
-%define                rel             0.6
+%define                rel             0.11
 %define                php_min_version 5.3.3
 %include       /usr/lib/rpm/macros.php
 Summary:       Eventum Issue / Bug tracking system
@@ -414,9 +414,9 @@ funkcji interfejsu WWW prosto z linii poleceń powłoki.
 Summary:       Eventum SCM integration
 Summary(pl.UTF-8):     Integracja SCM dla Eventum
 Group:         Applications/WWW
-Requires:      %{name}-base = %{version}-%{release}
 Requires:      php(core) >= %{php_min_version}
 Requires:      php(pcre)
+Suggests:      php(openssl)
 
 %description scm
 This feature allows your software development teams to integrate your
@@ -488,7 +488,7 @@ rm -f config/config.php
 
 # packaging
 %patch100 -p1
-#%patch101 -p1
+%patch101 -p1
 %patch105 -p1
 %patch107 -p1
 
@@ -518,6 +518,8 @@ install -d \
        localedir=%{_localedir} \
        DESTDIR=$RPM_BUILD_ROOT
 
+cp -p scm/helpers.php $RPM_BUILD_ROOT%{_sbindir}
+
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
@@ -771,9 +773,11 @@ done
 
 %files scm
 %defattr(644,root,root,755)
+%attr(751,root,root) %dir %{_sysconfdir}
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
+%attr(755,root,root) %{_sbindir}/helpers.php
 
 %files sphinx
 %defattr(644,root,root,755)
This page took 0.119001 seconds and 4 git commands to generate.