]> git.pld-linux.org Git - packages/eventum.git/commitdiff
Re-diff patches with --fuzz=0
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 10 Mar 2021 14:22:59 +0000 (16:22 +0200)
committerElan Ruusamäe <glen@pld-linux.org>
Wed, 10 Mar 2021 14:23:18 +0000 (16:23 +0200)
$ rpm-build-tools/rediff-patches.py -v *.spec

autoload.patch
eventum-paths.patch

index 1edbf88db95417421a49c1546d1cfdb90001aaef..4ee8f579c2786616a49787174d1d8fd4b0b8974c 100644 (file)
@@ -1,5 +1,5 @@
---- eventum-3.9.0/vendor/composer/autoload_classmap.php~       2020-07-02 00:40:49.265543161 +0300
-+++ eventum-3.9.0/vendor/composer/autoload_classmap.php        2020-07-02 00:41:19.715094975 +0300
+--- eventum-3.9.11.org/vendor/composer/autoload_classmap.php   2021-03-07 12:40:52.000000000 +0100
++++ eventum-3.9.11/vendor/composer/autoload_classmap.php       2021-03-10 15:18:19.159013641 +0100
 @@ -4,6 +4,7 @@
  
  $vendorDir = dirname(dirname(__FILE__));
@@ -8,7 +8,7 @@
  
  return array(
      'APIAuthToken' => $baseDir . '/lib/eventum/auth/APIAuthToken.php',
-@@ -88,8 +89,6 @@
+@@ -88,8 +89,6 @@ return array(
      'Note' => $baseDir . '/lib/eventum/class.note.php',
      'NoteSeeder' => $baseDir . '/db/seeds/NoteSeeder.php',
      'Notification' => $baseDir . '/lib/eventum/class.notification.php',
@@ -17,7 +17,7 @@
      'Pager' => $baseDir . '/lib/eventum/class.pager.php',
      'Partner' => $baseDir . '/lib/eventum/class.partner.php',
      'Phone_Support' => $baseDir . '/lib/eventum/class.phone_support.php',
-@@ -129,178 +128,6 @@
+@@ -129,178 +128,6 @@ return array(
      'SebastianBergmann\\Diff\\TimeEfficientLongestCommonSubsequenceCalculator' => $vendorDir . '/sebastian/diff/src/TimeEfficientLongestCommonSubsequenceCalculator.php',
      'Setup' => $baseDir . '/lib/eventum/class.setup.php',
      'Severity' => $baseDir . '/lib/eventum/class.severity.php',
 -    'Smarty_Variable' => $vendorDir . '/smarty/smarty/libs/sysplugins/smarty_variable.php',
 -    'SphinxClient' => $vendorDir . '/sphinx/php-sphinxapi/sphinxapi.php',
      'Sphinx_Fulltext_Search' => $baseDir . '/lib/eventum/search/class.sphinx_fulltext_search.php',
-     'SqlFormatter' => $vendorDir . '/jdorn/sql-formatter/lib/SqlFormatter.php',
      'Stats' => $baseDir . '/lib/eventum/class.stats.php',
-@@ -135,8 +135,6 @@
+     'Status' => $baseDir . '/lib/eventum/class.status.php',
+@@ -308,8 +135,6 @@ return array(
      'Support' => $baseDir . '/lib/eventum/class.support.php',
      'SupportLevelNotFoundException' => $baseDir . '/lib/eventum/crm/class.support_level.php',
      'Support_Level' => $baseDir . '/lib/eventum/crm/class.support_level.php',
 -    'TP_yyStackEntry' => $vendorDir . '/smarty/smarty/libs/sysplugins/smarty_internal_templateparser.php',
      'Template_Helper' => $baseDir . '/lib/eventum/class.template_helper.php',
      'Time_Tracking' => $baseDir . '/lib/eventum/class.time_tracking.php',
-     'User' => $baseDir . '/lib/eventum/class.user.php',
-@@ -144,4 +142,9 @@
+     'UnhandledMatchError' => $vendorDir . '/symfony/polyfill-php80/Resources/stubs/UnhandledMatchError.php',
+@@ -318,4 +143,9 @@ return array(
      'Validation' => $baseDir . '/lib/eventum/class.validation.php',
      'ValueError' => $vendorDir . '/symfony/polyfill-php80/Resources/stubs/ValueError.php',
      'Workflow' => $baseDir . '/lib/eventum/class.workflow.php',
 +    'Smarty' => $phpDir. '/Smarty3/Smarty.class.php',
 +    'SphinxClient' => $phpDir . '/sphinxapi.php',
  );
---- eventum-3.9.0/vendor/composer/autoload_files.php~  2020-07-02 00:42:27.240767700 +0300
-+++ eventum-3.9.0/vendor/composer/autoload_files.php   2020-07-02 00:47:15.896518354 +0300
+--- eventum-3.9.11.org/vendor/composer/autoload_files.php      2021-03-07 12:40:52.000000000 +0100
++++ eventum-3.9.11/vendor/composer/autoload_files.php  2021-03-10 15:18:19.159013641 +0100
 @@ -4,6 +4,7 @@
  
  $vendorDir = dirname(dirname(__FILE__));
 +$phpDir = PHP_DATADIR . '/php';
  
  return array(
-     '25072dd6e2470089de65ae7bf11d3109' => $vendorDir . '/symfony/polyfill-php72/bootstrap.php',
-@@ -15,8 +15,7 @@
-     '028fdea3165c4ba1ecccc83b7fec69fc' => $vendorDir . '/cakephp/collection/functions.php',
+     'a4a119a56e50fbb293281d9a48007e0e' => $vendorDir . '/symfony/polyfill-php80/bootstrap.php',
+@@ -12,8 +13,7 @@ return array(
+     '72142d7b40a3a0b14e91825290b5ad82' => $vendorDir . '/cakephp/core/functions.php',
      '948ad5488880985ff1c06721a4e447fe' => $vendorDir . '/cakephp/utility/bootstrap.php',
      '2cffec82183ee1cea088009cef9a6fc3' => $vendorDir . '/ezyang/htmlpurifier/library/HTMLPurifier.composer.php',
 -    'b2b3f01361f3aaeab67fde08ae76446f' => $vendorDir . '/smarty-gettext/smarty-gettext/block.t.php',
      'd12685060d57775f2bc3adf90c7d62bd' => $baseDir . '/lib/eventum/gettext.php',
 +    'b2b3f01361f3aaeab67fde08ae76446f' => $phpDir. '/Smarty3/plugins/block.t.php',
  );
---- eventum-3.9.8/vendor/composer/autoload_psr4.php~   2020-11-30 09:01:19.742816442 +0200
-+++ eventum-3.9.8/vendor/composer/autoload_psr4.php    2020-11-30 09:15:22.766959298 +0200
+--- eventum-3.9.11.org/vendor/composer/autoload_psr4.php       2021-03-07 12:40:52.000000000 +0100
++++ eventum-3.9.11/vendor/composer/autoload_psr4.php   2021-03-10 15:18:19.159013641 +0100
 @@ -4,9 +4,9 @@
  
  $vendorDir = dirname(dirname(__FILE__));
      'glen\\FilenameNormalizer\\' => array($vendorDir . '/glen/filename-normalizer/src'),
      'Xhgui\\Profiler\\' => array($vendorDir . '/perftools/php-profiler/src'),
      'TrueBV\\' => array($vendorDir . '/true/punycode/src'),
-@@ -51,7 +51,6 @@
+@@ -55,7 +55,6 @@ return array(
      'Silly\\' => array($vendorDir . '/mnapoli/silly/src'),
      'Seld\\Signal\\' => array($vendorDir . '/seld/signal-handler/src'),
      'Psr\\SimpleCache\\' => array($vendorDir . '/psr/simple-cache/src'),
      'Psr\\Container\\' => array($vendorDir . '/psr/container/src'),
      'Psr\\Cache\\' => array($vendorDir . '/psr/cache/src'),
      'Port\\Tests\\' => array($vendorDir . '/portphp/portphp/tests'),
-@@ -65,7 +65,6 @@
+@@ -67,7 +66,6 @@ return array(
      'Phlib\\Flysystem\\Pdo\\' => array($vendorDir . '/phlib/flysystem-pdo/src'),
      'Phinx\\' => array($vendorDir . '/robmorgan/phinx/src/Phinx'),
      'PackageVersions\\' => array($vendorDir . '/ocramius/package-versions/src/PackageVersions'),
      'League\\MimeTypeDetection\\' => array($vendorDir . '/league/mime-type-detection/src'),
      'League\\HTMLToMarkdown\\' => array($vendorDir . '/league/html-to-markdown/src'),
      'League\\Flysystem\\' => array($vendorDir . '/league/flysystem/src'),
-@@ -45,7 +53,6 @@
-     'League\\CommonMark\\' => array($vendorDir . '/league/commonmark/src'),
+@@ -80,7 +78,6 @@ return array(
+     'Laminas\\Config\\' => array($vendorDir . '/laminas/laminas-config/src'),
      'Invoker\\' => array($vendorDir . '/php-di/invoker/src'),
      'Interop\\Container\\' => array($vendorDir . '/container-interop/container-interop/src/Interop/Container'),
 -    'Eventum\\Test\\' => array($baseDir . '/tests'),
      'Eventum\\' => array($baseDir . '/src'),
      'EmailReplyParser\\' => array($vendorDir . '/willdurand/email-reply-parser/src/EmailReplyParser'),
      'Ds\\' => array($vendorDir . '/php-ds/php-ds/src'),
-@@ -60,2 +58,5 @@
-     'Cake\\Cache\\' => array($vendorDir . '/cakephp/cache'),
+@@ -93,6 +90,9 @@ return array(
+     'Doctrine\\Common\\Lexer\\' => array($vendorDir . '/doctrine/lexer/lib/Doctrine/Common/Lexer'),
+     'Doctrine\\Common\\Inflector\\' => array($vendorDir . '/doctrine/inflector/lib/Doctrine/Common/Inflector'),
+     'Doctrine\\Common\\Collections\\' => array($vendorDir . '/doctrine/collections/lib/Doctrine/Common/Collections'),
 +
 +    'Monolog\\' => array($phpDir . '/Monolog'),
 +    'Psr\\Log\\' => array($phpDir. '/Psr/Log'),
- );
+     'Doctrine\\Common\\Cache\\' => array($vendorDir . '/doctrine/cache/lib/Doctrine/Common/Cache'),
+     'Doctrine\\Common\\Annotations\\' => array($vendorDir . '/doctrine/annotations/lib/Doctrine/Common/Annotations'),
+     'Doctrine\\Common\\' => array($vendorDir . '/doctrine/common/lib/Doctrine/Common', $vendorDir . '/doctrine/event-manager/lib/Doctrine/Common', $vendorDir . '/doctrine/persistence/lib/Doctrine/Common', $vendorDir . '/doctrine/reflection/lib/Doctrine/Common'),
 --- eventum-3.6.3-29-g154295bd2/vendor/composer/autoload_real.php~     2019-03-26 09:59:16.000000000 +0200
 +++ eventum-3.6.3-29-g154295bd2/vendor/composer/autoload_real.php      2019-03-26 13:18:14.402093309 +0200
 @@ -23,7 +23,7 @@
index 1807677fc54cd6217aeccbfc3bc0a0dc5e12ac14..049f50013a9a79e4a2ee2221a2ba2b6fdd16af73 100644 (file)
 +    public const APP_FONTS_PATH = '/usr/share/fonts/TTF';
      public const APP_HELP_PATH = APP_PATH . '/docs/help';
  }
---- eventum-3.5.6-98-g5b87d2b0/src/Setup/Requirements.php~     2019-01-23 01:50:42.000000000 +0200
-+++ eventum-3.5.6-98-g5b87d2b0/src/Setup/Requirements.php      2019-01-24 22:18:56.047816296 +0200
-@@ -64,10 +64,6 @@
-         $configPath = Setup::getConfigPath();
+--- eventum-3.9.11.org/src/Setup/Requirements.php      2020-08-01 20:21:08.000000000 +0200
++++ eventum-3.9.11/src/Setup/Requirements.php  2021-03-10 15:18:12.361997906 +0100
+@@ -69,10 +69,6 @@ class Requirements
+         $privateKeyPath = Setup::getPrivateKeyPath();
          $setupFile = Setup::getSetupFile();
  
 -        $error = $this->checkPermissions($configPath, "Directory '" . $configPath . "'", true);
                  'check_permission' => true,
                  'permission' => 660,
                  'check_filesize' => true,
---- eventum-3.1.5/config/sphinx.conf.php~      2016-11-13 12:05:37.000000000 +0200
-+++ eventum-3.1.5/config/sphinx.conf.php       2016-11-23 03:10:05.855040510 +0200
-@@ -1,7 +1,7 @@
- #!/usr/bin/php
- <?php
+--- eventum-3.9.11.org/config/sphinx.conf.php  2020-05-05 08:20:33.000000000 +0200
++++ eventum-3.9.11/config/sphinx.conf.php      2021-03-10 15:18:12.361997906 +0100
+@@ -4,7 +4,7 @@
+ use Eventum\Config\SphinxConfig;
+ use Eventum\ServiceContainer;
  
 -require_once __DIR__ . '/../init.php';
 +require_once '/usr/share/eventum/init.php';
  
- if (!defined('SPHINX_LOG_PATH')) {
    define('SPHINX_LOG_PATH', '/var/log/sphinx/');
+ /** @var SphinxConfig $config */
$config = ServiceContainer::get(SphinxConfig::class);
 --- eventum-3.7.4-440-gcc5ad3db5/src/Attachment/StorageManager.php~    2019-08-11 22:49:07.000000000 +0300
 +++ eventum-3.7.4-440-gcc5ad3db5/src/Attachment/StorageManager.php     2019-08-21 23:33:19.325911295 +0300
 @@ -33,7 +33,7 @@
This page took 0.085945 seconds and 4 git commands to generate.