]> git.pld-linux.org Git - packages/eventum.git/commitdiff
- up to 2.3.3 RC3
authorElan Ruusamäe <glen@delfi.ee>
Tue, 10 Jul 2012 10:06:43 +0000 (13:06 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 10 Jul 2012 10:06:43 +0000 (13:06 +0300)
eventum-paths.patch
eventum.spec

index 7026a25b31f53728fff21a980e0acb281e1d071f..a0975771278000e78aa40b2d9ad20ddaae89cc1d 100644 (file)
          'check_permission' => true,
          'permission'       => 660,
          'check_filesize'   => true,
---- eventum-2.3.1/config/sphinx.conf.php~      2011-09-15 09:35:00.000000000 +0300
-+++ eventum-2.3.1/config/sphinx.conf.php       2011-09-15 10:05:10.051918895 +0300
-@@ -1,5 +1,5 @@
- <?php
+--- eventum-2.3.3/config/sphinx.conf.php~      2012-06-27 14:59:39.000000000 +0300
++++ eventum-2.3.3/config/sphinx.conf.php       2012-06-27 15:04:52.928810689 +0300
+@@ -26,7 +26,7 @@
+ // | Authors: Bryan Alsdorf <bryan@mysql.com>                             |
+ // | Authors: Elan Ruusamäe <glen@delfi.ee>                               |
+ // +----------------------------------------------------------------------+
 -require_once dirname(__FILE__) . "/../init.php";
 +require_once '/usr/share/eventum/init.php';
  
index da64d10a56b69deff0edfad0ee28bd25e7445882..20bf71895f26a79edce21d5296562df0f325a131 100644 (file)
 %bcond_without order   # with experimental order patch
 
 %define                php_min_version 5.1.2
-%define                subver  4470
-%define                rel             2.4
+%define                subver  RC3
+%define                rel             1
 %include       /usr/lib/rpm/macros.php
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl.UTF-8):     Eventum - system śledzenia spraw/błędów
 Name:          eventum
-Version:       2.3.1
-#Release:      %{rel}
-Release:       %{rel}.bzr%{subver}
+Version:       2.3.3
+Release:       %{rel}
+#Release:      %{rel}.bzr%{subver}
 License:       GPL
 Group:         Applications/WWW
 #Source0:      http://launchpad.net/eventum/trunk/%{version}/+download/%{name}-%{version}.tar.gz
-Source0:       %{name}-%{version}-dev-r%{subver}.tar.gz
-# Source0-md5: 41cdf607a180c5c94abc487a122893ea
+Source0:       https://launchpad.net/eventum/trunk/%{version}/+download/%{name}-%{version}RC3.tar.gz
+# Source0-md5: e1a5097d191468061865065678665f0e
+#Source0:      %{name}-%{version}-dev-r%{subver}.tar.gz
+#Source0:      %{name}-%{version}%{subver}.tar.gz
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
@@ -88,11 +90,12 @@ Requires:   webserver(alias)
 Requires:      webserver(indexfile)
 Requires:      webserver(php) >= 4.2.0
 Suggests:      localedb
+Suggests:      php-pear-Net_LDAP2
 Conflicts:     logrotate < 3.8.0
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautopear     pear(../init.php) pear(init.php) pear(/usr/share/eventum/init.php) pear(/etc/webapps/.*) pear(%{_appdir}/.*) pear(jpgraph_dir.php) pear(.*Smarty.class.php) pear(Services/JSON.php) pear(class.date_helper.php) pear(sphinxapi.php)
+%define                _noautopear     pear(../init.php) pear(init.php) pear(/usr/share/eventum/init.php) pear(/etc/webapps/.*) pear(%{_appdir}/.*) pear(jpgraph_dir.php) pear(.*Smarty.class.php) pear(Services/JSON.php) pear(class.date_helper.php) pear(sphinxapi.php) pear(Net/LDAP2.php)
 
 # exclude optional php dependencies
 %define                _noautophp      php-gnupg php-hash php-pecl-http php-tk
@@ -363,8 +366,8 @@ Summary(pl.UTF-8):  IRC-owy bot powiadamiający dla Eventum
 Group:         Applications/WWW
 Requires(post,preun):  /sbin/chkconfig
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-sockets
 Requires:      php-pear-Net_SmartIRC
+Requires:      php-sockets
 Requires:      rc-scripts >= 0.4.0.18
 
 %description irc
@@ -510,7 +513,7 @@ install -d \
        $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
        $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
        $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
-       $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
+       $RPM_BUILD_ROOT%{systemdtmpfilesdir}
 
 %{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
        sysconfdir=%{_webappdir} \
@@ -543,9 +546,9 @@ cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 # postfix router
 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
 
-install %{SOURCE17} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
+install %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
 
-%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ht
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
 
 %find_lang %{name}
 
@@ -697,6 +700,7 @@ done
 %dir %{_appdir}/upgrade
 %{_appdir}/upgrade/init.php
 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
+%attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
 %dir %{_appdir}/upgrade/v*
 %attr(755,root,root) %{_appdir}/upgrade/v*/*.php
 %{_appdir}/upgrade/patches
@@ -705,7 +709,7 @@ done
 %{_appdir}/lib/eventum
 %{_appdir}/lib/jpgraph
 %exclude %{_appdir}/lib/eventum/class.monitor.php
-/usr/lib/tmpfiles.d/%{name}.conf
+%{systemdtmpfilesdir}/%{name}.conf
 %dir %attr(730,root,http) /var/run/%{name}
 %dir %attr(730,root,http) /var/cache/%{name}
 
This page took 0.241594 seconds and 4 git commands to generate.