]> git.pld-linux.org Git - packages/eventum.git/commitdiff
up to bd09ead2 snapshot
authorElan Ruusamäe <glen@delfi.ee>
Wed, 20 Sep 2017 17:08:26 +0000 (20:08 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 20 Sep 2017 17:09:29 +0000 (20:09 +0300)
eventum.spec
update-source.sh

index e880a52ee4649d5c0d8deed317e5d82caca8e91d..f84a1a3a9ab0e1696a5484d941b653effd8454e4 100644 (file)
@@ -3,8 +3,8 @@
 %bcond_with    order   # with experimental order patch
 
 %define                rel             1
-#define                subver  347
-#define                githash 3d9195fa
+%define                subver  136
+%define                githash bd09ead2
 %define                php_min_version 5.5.0
 %include       /usr/lib/rpm/macros.php
 Summary:       Eventum Issue / Bug tracking system
@@ -14,9 +14,9 @@ Version:      3.2.3
 Release:       %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
 License:       GPL v2+
 Group:         Applications/WWW
-Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: ad50831d3c73b8df781618eceefab135
-#Source0:      https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.gz
+#Source0:      https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
+Source0:       https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.gz
+# Source0-md5: a8edbaab9794b68e84eec719e3841a78
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
index ffb609fb0d8801141366e01c35855b4bb31a4925..9c8c607af128e201ba3ce5074aa87845f75e74a6 100755 (executable)
@@ -1,6 +1,7 @@
 #!/bin/sh
 set -e
 dropin=
+repo_url=https://github.com/eventum/eventum
 specfile=eventum.spec
 
 # Work in package dir
@@ -13,6 +14,14 @@ if [ -f "$1" ]; then
        rev=${rev%.tar.gz}
 elif [ "$1" ]; then
        rev=$1
+else
+       # use tarball from "snapshot" build
+       git fetch "$repo_url" refs/tags/snapshot
+       out=$(git show FETCH_HEAD -s)
+       tarball=$(echo "$out" | grep -o 'eventum-.*\.tar.gz')
+       url="$repo_url/releases/download/snapshot/$tarball"
+       test -f "$tarball" || wget -c $url
+       exec "$0" "$tarball"
 fi
 
 subver=${rev%-*}
@@ -28,8 +37,8 @@ if [ "$oldsubver" = "$subver" -a "$oldgithash" = "$githash" ]; then
 fi
 
 echo "Updating $specfile for $rev (subver: $subver, githash: $githash)..."
-sed -i -e "
-       s/^\(%define[ \t]\+subver[ \t]\+\)[0-9]\+\$/\1$subver/
-       s/^\(%define[ \t]\+githash[ \t]\+\)[0-9a-fg]\+\$/\1$githash/
+sed -i -re "
+       s/^[#%](define[ \t]+subver[ \t]+)[0-9]+\$/%\1$subver/
+       s/^[#%](define[ \t]+githash[ \t]+)[0-9a-fg]+\$/%\1$githash/
 " $specfile
 ../builder -ncs -5 $specfile
This page took 0.061644 seconds and 4 git commands to generate.