]> git.pld-linux.org Git - packages/eventum.git/blobdiff - eventum.spec
use recommended pdo_mysql
[packages/eventum.git] / eventum.spec
index 994fcc43e367296369cc7e44b84f2196bf4ac08c..cbd34bd3f8241e8b19893856043d00676952814e 100644 (file)
@@ -3,19 +3,19 @@
 %bcond_with    order   # with experimental order patch
 
 %define                rel             1
-#define                subver  88
-#define                githash 58096f4
-%define                php_min_version 5.3.7
+#define                subver  51
+#define                githash 61de085
+%define                php_min_version 5.5.0
 %include       /usr/lib/rpm/macros.php
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl.UTF-8):     Eventum - system śledzenia spraw/błędów
 Name:          eventum
-Version:       3.0.12
+Version:       3.1.7
 Release:       %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
 License:       GPL v2+
 Group:         Applications/WWW
 Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 203a772c63be1e3209eb1022e350967a
+# Source0-md5: 4d1360473e9c473fa56242c4fd101cba
 #Source0:      %{name}-%{version}-%{subver}-g%{githash}.tar.gz
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
@@ -60,8 +60,8 @@ Requires:     php(iconv)
 Requires:      php(imap)
 Requires:      php(json)
 Requires:      php(mbstring)
-Requires:      php(mysqli)
 Requires:      php(pcre)
+Requires:      php(pdo_mysql)
 Requires:      php(session)
 Requires:      php-Smarty >= 3.1
 Requires:      php-Smarty-plugin-gettext
@@ -391,8 +391,9 @@ rm config/config.php
 %patch108 -p1
 
 rm htdocs/.htaccess.dist
-# deprecated in favour of process_all_emails.php
-rm bin/route_*.php
+
+mv config/irc_config{.dist.php,.php}
+rm config/config.dist.php
 
 # cleanup vendor. keep only needed libraries.
 # (the rest are packaged with system packages)
@@ -408,13 +409,12 @@ vendor() {
 vendor autoload.php
 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
 vendor composer/ClassLoader.php
-vendor ircmaxell/{password-compat,random-lib,security-lib}
+vendor ircmaxell/{random-lib,security-lib}
 vendor defuse/php-encryption
-vendor ramsey/array_column
 vendor willdurand/email-reply-parser
 vendor theorchard/monolog-cascade
-vendor symfony/polyfill-php55
-vendor symfony/polyfill-mbstring
+vendor malkusch/lock
+vendor phpxmlrpc/phpxmlrpc
 
 # remove backups from patching as we use globs to package files to buildroot
 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
@@ -464,8 +464,6 @@ cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
 
-cp -p config/irc_config.dist.php $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
-
 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
 
@@ -492,7 +490,7 @@ rm -rf $RPM_BUILD_ROOT
 for a in \
        errors.log login_attempts.log \
        eventum.log \
-       cli.log \
+       auth.log cli.log \
        irc_bot_error.log irc_bot_smartirc.log \
 ; do
        test -f /var/log/%{name}/$a && continue
@@ -523,13 +521,13 @@ if [ "$1" = "0" ]; then
 fi
 
 %post setup
-chmod 660 %{_webappdir}/{config,private_key}.php
-chown root:http %{_webappdir}/{config,private_key}.php
+chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
+chown root:http %{_webappdir}/{config,private_key,secret_key}.php
 
 %postun setup
 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
-       chmod 640 %{_webappdir}/{config,private_key}.php
-       chown root:http %{_webappdir}/{config,private_key}.php
+       chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
+       chown root:http %{_webappdir}/{config,private_key,secret_key}.php
 fi
 
 %post irc
@@ -582,6 +580,7 @@ done
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
 
This page took 0.036961 seconds and 4 git commands to generate.