]> git.pld-linux.org Git - packages/eventum.git/blobdiff - eventum.spec
fix phinx packaging
[packages/eventum.git] / eventum.spec
index 767fe1488cc80327c47ae0782b855b79a249c016..af526de1d7d0dd06f7976400527f1e952cb5e3b9 100644 (file)
@@ -2,21 +2,21 @@
 # Conditional build:
 %bcond_with    order   # with experimental order patch
 
-%define                rel             1
-#define                subver  51
-#define                githash 61de085
+%define                rel             0.2
+%define                subver  344
+%define                githash 7f34327f
 %define                php_min_version 5.5.0
 %include       /usr/lib/rpm/macros.php
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl.UTF-8):     Eventum - system śledzenia spraw/błędów
 Name:          eventum
-Version:       3.1.7
+Version:       3.1.10
 Release:       %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
 License:       GPL v2+
 Group:         Applications/WWW
-Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 4d1360473e9c473fa56242c4fd101cba
-#Source0:      %{name}-%{version}-%{subver}-g%{githash}.tar.gz
+#Source0:      https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
+Source0:       https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.gz
+# Source0-md5: d7001291388fedcb55f3d3ad4da947db
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
@@ -41,9 +41,7 @@ Patch108:     autoload.patch
 # some tests
 Patch200:      %{name}-fixed-nav.patch
 URL:           https://wiki.github.com/eventum/eventum/
-BuildRequires: /usr/bin/php
 BuildRequires: gettext-tools
-BuildRequires: php(core) >= %{php_min_version}
 BuildRequires: rpm-php-pearprov >= 4.0.2-98
 BuildRequires: rpmbuild(macros) >= 1.654
 BuildRequires: sed >= 4.0
@@ -69,9 +67,9 @@ Requires:     php-ZendFramework-Config >= 2.4
 Requires:      php-ZendFramework-Loader >= 2.4
 Requires:      php-ZendFramework-Mail >= 2.4.9-2
 Requires:      php-ZendFramework-Mime >= 2.4
+Requires:      php-ZendFramework-ServiceManager >= 2.4
 Requires:      php-ZendFramework-Validator >= 2.4
 Requires:      php-monolog >= 1.17.2
-Requires:      php-pear-DB
 Requires:      php-pear-Mail
 Requires:      php-pear-Mail_Mime
 Requires:      php-pear-Mail_mimeDecode
@@ -81,9 +79,9 @@ Requires:     php-pear-Net_Socket
 Requires:      php-pear-Net_URL
 Requires:      php-pear-PEAR-core
 Requires:      php-pear-Text_Diff
-Requires:      php-pear-XML_RPC
 Requires:      php-psr-Log >= 1.0.0-2
 Requires:      php-symfony2-Config >= 2.7.7
+Requires:      php-symfony2-Console >= 2.7.7
 Requires:      php-symfony2-Filesystem >= 2.7.7
 Requires:      php-symfony2-HttpFoundation >= 2.7.7
 Requires:      php-symfony2-OptionsResolver >= 2.7.7
@@ -329,7 +327,6 @@ Summary(pl.UTF-8):  Interfejs linii poleceń dla Eventum
 Group:         Applications/WWW
 Requires:      php(core) >= %{php_min_version}
 Requires:      php(phar)
-Requires:      php-pear-XML_RPC
 
 %description cli
 The Eventum command-line interface allows you to access most of the
@@ -412,6 +409,7 @@ vendor willdurand/email-reply-parser
 vendor theorchard/monolog-cascade
 vendor malkusch/lock
 vendor phpxmlrpc/phpxmlrpc
+vendor robmorgan/phinx
 
 # remove backups from patching as we use globs to package files to buildroot
 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
@@ -594,7 +592,9 @@ done
 %attr(755,root,root) %{_appdir}/bin/upgrade.php
 
 %{_appdir}/autoload.php
+%{_appdir}/globals.php
 %{_appdir}/init.php
+%{_appdir}/phinx.php
 %dir %{_appdir}/htdocs
 %{_appdir}/htdocs/*.php
 %{_appdir}/htdocs/*.ico
@@ -612,6 +612,9 @@ done
 %dir %{_appdir}/upgrade
 %{_appdir}/upgrade/*.sql
 %{_appdir}/upgrade/patches
+%dir %{_appdir}/db
+%dir %{_appdir}/db/migrations
+%{_appdir}/db/migrations/*.php
 
 %{_appdir}/res
 %{_appdir}/src
This page took 0.032812 seconds and 4 git commands to generate.