]> git.pld-linux.org Git - packages/eventum.git/blobdiff - eventum.spec
fix phinx packaging
[packages/eventum.git] / eventum.spec
index 65e5c74af1982815d315cd7ed9b4f407bcd48080..af526de1d7d0dd06f7976400527f1e952cb5e3b9 100644 (file)
@@ -2,21 +2,21 @@
 # Conditional build:
 %bcond_with    order   # with experimental order patch
 
-%define                rel             1
-#define                subver  51
-#define                githash 61de085
+%define                rel             0.2
+%define                subver  344
+%define                githash 7f34327f
 %define                php_min_version 5.5.0
 %include       /usr/lib/rpm/macros.php
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl.UTF-8):     Eventum - system śledzenia spraw/błędów
 Name:          eventum
-Version:       3.1.5
+Version:       3.1.10
 Release:       %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
 License:       GPL v2+
 Group:         Applications/WWW
-Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 078f52887859f10c7ca00f5f5aed900f
-#Source0:      %{name}-%{version}-%{subver}-g%{githash}.tar.gz
+#Source0:      https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
+Source0:       https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.gz
+# Source0-md5: d7001291388fedcb55f3d3ad4da947db
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
@@ -40,10 +40,8 @@ Patch107:    %{name}-gettext.patch
 Patch108:      autoload.patch
 # some tests
 Patch200:      %{name}-fixed-nav.patch
-URL:           http://eventum.mysql.org/
-BuildRequires: /usr/bin/php
+URL:           https://wiki.github.com/eventum/eventum/
 BuildRequires: gettext-tools
-BuildRequires: php(core) >= %{php_min_version}
 BuildRequires: rpm-php-pearprov >= 4.0.2-98
 BuildRequires: rpmbuild(macros) >= 1.654
 BuildRequires: sed >= 4.0
@@ -60,8 +58,8 @@ Requires:     php(iconv)
 Requires:      php(imap)
 Requires:      php(json)
 Requires:      php(mbstring)
-Requires:      php(mysqli)
 Requires:      php(pcre)
+Requires:      php(pdo_mysql)
 Requires:      php(session)
 Requires:      php-Smarty >= 3.1
 Requires:      php-Smarty-plugin-gettext
@@ -69,9 +67,9 @@ Requires:     php-ZendFramework-Config >= 2.4
 Requires:      php-ZendFramework-Loader >= 2.4
 Requires:      php-ZendFramework-Mail >= 2.4.9-2
 Requires:      php-ZendFramework-Mime >= 2.4
+Requires:      php-ZendFramework-ServiceManager >= 2.4
 Requires:      php-ZendFramework-Validator >= 2.4
 Requires:      php-monolog >= 1.17.2
-Requires:      php-pear-DB
 Requires:      php-pear-Mail
 Requires:      php-pear-Mail_Mime
 Requires:      php-pear-Mail_mimeDecode
@@ -81,9 +79,9 @@ Requires:     php-pear-Net_Socket
 Requires:      php-pear-Net_URL
 Requires:      php-pear-PEAR-core
 Requires:      php-pear-Text_Diff
-Requires:      php-pear-XML_RPC
 Requires:      php-psr-Log >= 1.0.0-2
 Requires:      php-symfony2-Config >= 2.7.7
+Requires:      php-symfony2-Console >= 2.7.7
 Requires:      php-symfony2-Filesystem >= 2.7.7
 Requires:      php-symfony2-HttpFoundation >= 2.7.7
 Requires:      php-symfony2-OptionsResolver >= 2.7.7
@@ -130,16 +128,13 @@ BuildRoot:        %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Eventum is a user-friendly and flexible issue tracking system that can
 be used by a support department to track incoming technical support
 requests, or by a software development team to quickly organize tasks
-and bugs. Eventum is used by the MySQL AB Technical Support team, and
-has allowed us to dramatically improve our response times.
+and bugs.
 
 %description -l pl.UTF-8
 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
 może być używany przez dział obsługi do śledzenia przychodzących żądań
 obsługi technicznej albo przez zespół tworzący oprogramowanie do
-szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
-Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
-reakcji.
+szybkiej organizacji zadań i błędów.
 
 %package setup
 Summary:       Eventum setup package
@@ -282,14 +277,14 @@ This package provides way of routing notes and emails back to Eventum
 via Postfix.
 
 The Postfix configuration instructions you can find from
-<http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
+<https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
 
 %description router-postfix -l pl.UTF-8
 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
 przez Postfiksa.
 
 Opis konfiguracji Postfiksa można znaleźć pod adresem
-<http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
+<https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
 
 %package irc
 Summary:       Eventum IRC Notification Bot
@@ -332,7 +327,6 @@ Summary(pl.UTF-8):  Interfejs linii poleceń dla Eventum
 Group:         Applications/WWW
 Requires:      php(core) >= %{php_min_version}
 Requires:      php(phar)
-Requires:      php-pear-XML_RPC
 
 %description cli
 The Eventum command-line interface allows you to access most of the
@@ -414,6 +408,8 @@ vendor defuse/php-encryption
 vendor willdurand/email-reply-parser
 vendor theorchard/monolog-cascade
 vendor malkusch/lock
+vendor phpxmlrpc/phpxmlrpc
+vendor robmorgan/phinx
 
 # remove backups from patching as we use globs to package files to buildroot
 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
@@ -596,7 +592,9 @@ done
 %attr(755,root,root) %{_appdir}/bin/upgrade.php
 
 %{_appdir}/autoload.php
+%{_appdir}/globals.php
 %{_appdir}/init.php
+%{_appdir}/phinx.php
 %dir %{_appdir}/htdocs
 %{_appdir}/htdocs/*.php
 %{_appdir}/htdocs/*.ico
@@ -614,6 +612,9 @@ done
 %dir %{_appdir}/upgrade
 %{_appdir}/upgrade/*.sql
 %{_appdir}/upgrade/patches
+%dir %{_appdir}/db
+%dir %{_appdir}/db/migrations
+%{_appdir}/db/migrations/*.php
 
 %{_appdir}/res
 %{_appdir}/src
This page took 0.192965 seconds and 4 git commands to generate.