]> git.pld-linux.org Git - packages/eventum.git/blobdiff - eventum.spec
- added tmpfiles config for systemd
[packages/eventum.git] / eventum.spec
index 6cf03940b808c66dc69772a2ae2649d38f2695f9..ac1e1808d64deed5f9d11b23e0f73ba2aa991df3 100644 (file)
@@ -7,27 +7,23 @@
 #  - A few other small javascript libraries
 #
 # Conditional build:
-%bcond_with    qmail   # build the router-qmail subpackage
 %bcond_without order   # with experimental order patch
 
-#define        snap    20060921
-%define        svn             r3834
-%define        rel             1.3
-#define        _rc             RC3
-
+%define                php_min_version 5.1.2
+%define                subver  4434
+%define                rel             2.3
 %include       /usr/lib/rpm/macros.php
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl.UTF-8):     Eventum - system śledzenia spraw/błędów
 Name:          eventum
-Version:       2.2
-Release:       %{?_rc:%{_rc}.}%{rel}%{?snap:.%{snap}}%{?svn:.%{svn}}
+Version:       2.3.1
+#Release:      %{rel}
+Release:       %{rel}.bzr%{subver}
 License:       GPL
 Group:         Applications/WWW
-#Source0:      http://downloads.mysql.com/snapshots/eventum/%{name}-nightly-%{snap}.tar.gz
-#Source0:      http://eventum.mysql.org/downloads/eventum-2.0.RC3.tar.gz
-#Source0:      http://mysql.easynet.be/Downloads/eventum/%{name}-%{version}.tar.gz
-Source0:       %{name}-%{svn}.tar.bz2
-# Source0-md5: c830b2bd1524d8579156e3d1dcc133fa
+#Source0:      http://launchpad.net/eventum/trunk/%{version}/+download/%{name}-%{version}.tar.gz
+Source0:       %{name}-%{version}-dev-r%{subver}.tar.gz
+# Source0-md5: 356e710384618aea1e6f3426a41dbc23
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
@@ -37,21 +33,20 @@ Source6:    %{name}-cvs.php
 Source7:       %{name}-irc.php
 Source8:       %{name}-irc.init
 Source9:       %{name}-irc.sysconfig
-Source10:      %{name}-router-qmail.sh
-Source12:      %{name}-upgrade.sh
+Source10:      sphinx.crontab
 Source13:      %{name}-router-postfix.sh
 Source14:      %{name}.logrotate
 Source15:      %{name}-lighttpd.conf
 Source16:      http://www.isocra.com/images/updown2.gif
 # Source16-md5:        deb6eeb2552ba757d3a949ed10c4107d
+Source17:      %{name}.tmpfiles
 Patch0:                %{name}-lf.patch
 Patch2:                %{name}-order.patch
+Patch3:                group-users.patch
 # packaging patches that probably never go upstream
 Patch100:      %{name}-paths.patch
 Patch101:      %{name}-cvs-config.patch
-Patch102:      %{name}-irc-config.patch
 Patch105:      %{name}-bot-reconnect.patch
-Patch106:      %{name}-mem-limits.patch
 Patch107:      %{name}-gettext.patch
 # some tests
 Patch200:      %{name}-fixed-nav.patch
@@ -60,20 +55,19 @@ BuildRequires:      gettext-devel
 BuildRequires: rpm-php-pearprov >= 4.0.2-98
 BuildRequires: rpmbuild(macros) >= 1.461
 BuildRequires: sed >= 4.0
-Requires(triggerpostun):       /usr/bin/php
-Requires(triggerpostun):       sed >= 4.0
 Requires:      %{name}-base = %{version}-%{release}
 Requires:      Smarty >= 2.6.10-4
-Requires:      php-common >= 4:5.0
+Requires:      php-common >= 4:%{php_min_version}
+Requires:      php-filter
 Requires:      php-gd
 Requires:      php-iconv
 Requires:      php-imap
+Requires:      php-json
 Requires:      php-mbstring
 Requires:      php-mysql
 Requires:      php-pcre
 Requires:      php-pear-DB
 Requires:      php-pear-Date
-Requires:      php-pear-HTTP_Request
 Requires:      php-pear-Mail
 Requires:      php-pear-Mail_Mime
 Requires:      php-pear-Mail_mimeDecode
@@ -86,21 +80,27 @@ Requires:   php-pear-Net_UserAgent_Detect
 Requires:      php-pear-PEAR-core
 Requires:      php-pear-Text_Diff
 Requires:      php-pear-XML_RPC
+Requires:      php-session
 Requires:      smarty-gettext
 Requires:      webapps
 Requires:      webserver(access)
 Requires:      webserver(alias)
 Requires:      webserver(indexfile)
 Requires:      webserver(php) >= 4.2.0
+Suggests:      localedb
 Conflicts:     logrotate < 3.7-4
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreq      'pear(/etc/webapps/.*)' 'pear(%{_appdir}/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)'
+%define                _noautopear     pear(../init.php) pear(init.php) pear(/usr/share/eventum/init.php) pear(/etc/webapps/.*) pear(%{_appdir}/.*) pear(jpgraph_dir.php) pear(.*Smarty.class.php) pear(Services/JSON.php) pear(class.date_helper.php) pear(sphinxapi.php)
+
+# exclude optional php dependencies
+%define                _noautophp      php-gnupg php-hash php-pecl-http php-tk
+
+%define                _noautoreq      %{_noautophp} %{_noautopear}
 
 %define                _libdir         %{_prefix}/lib/%{name}
 %define                _appdir         %{_datadir}/%{name}
-%define                _smartyplugindir        %{_appdir}/include/smarty
 %define                _smartydir      %{php_data_dir}/Smarty
 %define                _webapps        /etc/webapps
 %define                _webapp         %{name}
@@ -233,7 +233,7 @@ Summary(pl.UTF-8):  Monitor życia dla Eventum
 Group:         Applications/WWW
 Requires:      %{name} = %{version}-%{release}
 Requires:      crondaemon
-Requires:      php(posix)
+Requires:      php-posix
 
 %description monitor
 The heartbeat monitor is a feature designed for the administrator that
@@ -270,19 +270,19 @@ Requires: eventum(router)
 
 %description route-drafts
 The draft routing feature is used to automatically associate a thread
-of drafts into an Eventum issue. By setting up qmail (or even Postfix)
-to deliver emails sent to a specific address (usually
-draft-<number>@<domain>) to the above script, users are able to send
-drafts written in their mail client to be stored in Eventum. These
-drafts will NOT broadcasted to the notification list.
+of drafts into an Eventum issue. By setting up Postfix to deliver
+emails sent to a specific address (usually draft-<number>@<domain>) to
+the above script, users are able to send drafts written in their mail
+client to be stored in Eventum. These drafts will NOT broadcasted to
+the notification list.
 
 %description route-drafts -l pl.UTF-8
 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
-problemem w Eventum. Ustawiając qmaila (czy nawet Postfiksa), aby
-dostarczał pocztę wysłaną na podany adres (zwykle
-draft-<liczba>@<domena>) do tego skryptu umożliwia się użytkownikom
-wysyłanie szkiców napisanych w ich kliencie pocztowym do zapisania w
-Eventum. Szkice te NIE będą wysyłane na listę powiadomień.
+problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
+wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
+skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
+kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
+na listę powiadomień.
 
 %package route-emails
 Summary:       Eventum Email Routing
@@ -293,17 +293,17 @@ Requires: eventum(router)
 
 %description route-emails
 The email routing feature is used to automatically associate a thread
-of emails into an Eventum issue. By setting up qmail (or even postfix)
-to deliver emails sent to a specific address (usually
-issue-<number>@<domain>) to the above script, users are able to use
-their email clients to reply to emails coming from Eventum, and those
-replies will be automatically associated with the issue and
-broadcasted to the entire notification list.
+of emails into an Eventum issue. By setting up Postfix to deliver
+emails sent to a specific address (usually issue-<number>@<domain>) to
+the above script, users are able to use their email clients to reply
+to emails coming from Eventum, and those replies will be automatically
+associated with the issue and broadcasted to the entire notification
+list.
 
 %description route-emails -l pl.UTF-8
 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
-wątku listów ze sprawą w Eventum. Po ustawieniu qmaila (czy nawet
-postfiksa), aby dostarczał listy wysyłane na pewien adres (zwykle
+wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
+aby dostarczał listy wysyłane na pewien adres (zwykle
 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
 używać klientów pocztowych do odpowiadania na listy przychodzące z
 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
@@ -318,41 +318,22 @@ Requires: eventum(router)
 
 %description route-notes
 The note routing feature is used to automatically associate a thread
-of notes into an Eventum issue. By setting up qmail (or even postfix)
-to deliver emails sent to a specific address (usually
-note-<number>@<domain>) to the above script, users are able to use
-their email clients to reply to internal notes coming from Eventum,
-and those replies will be automatically associated with the issue and
-broadcasted to the notification list staff members.
+of notes into an Eventum issue. By setting up Postfix to deliver
+emails sent to a specific address (usually note-<number>@<domain>) to
+the above script, users are able to use their email clients to reply
+to internal notes coming from Eventum, and those replies will be
+automatically associated with the issue and broadcasted to the
+notification list staff members.
 
 %description route-notes -l pl.UTF-8
 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
-wątku notatek ze sprawą w Eventum. Po ustawieniu qmaila (czy nawet
-postfiksa), aby dostarczał listy wysyłane na pewien adres (zwykle
+wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
+dostarczał listy wysyłane na pewien adres (zwykle
 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
 
-%package router-qmail
-Summary:       Eventum Mail Routing - qmail
-Summary(pl.UTF-8):     Przekazywanie poczty Eventum - qmail
-Group:         Applications/Mail
-# loose dep is intentional. qmail subpackage isn't built on PLD
-# builders and there really nothing changes.
-Requires:      %{name} >= %{version}-%{release}
-Requires:      qmail >= 1.03
-Provides:      eventum(router)
-Obsoletes:     eventum(router)
-
-%description router-qmail
-This package provides way of routing notes and emails back to Eventum
-via qmail.
-
-%description router-qmail -l pl.UTF-8
-Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
-przez qmaila.
-
 %package router-postfix
 Summary:       Eventum Mail Routing - Postfix
 Summary(pl.UTF-8):     Przekazywanie poczty Eventum - Postfix
@@ -381,9 +362,8 @@ Summary:    Eventum IRC Notification Bot
 Summary(pl.UTF-8):     IRC-owy bot powiadamiający dla Eventum
 Group:         Applications/WWW
 Requires(post,preun):  /sbin/chkconfig
-Requires(triggerpostun):       sed >= 4.0
 Requires:      %{name} = %{version}-%{release}
-Requires:      php(sockets)
+Requires:      php-sockets
 Requires:      php-pear-Net_SmartIRC
 Requires:      rc-scripts >= 0.4.0.18
 
@@ -417,7 +397,7 @@ Summary(pl.UTF-8):  Interfejs linii poleceń dla Eventum
 Group:         Applications/WWW
 Requires:      %{name}-base = %{version}-%{release}
 Requires:      php-cli
-Requires:      php-common >= 4:5.0
+Requires:      php-common >= 4:%{php_min_version}
 Requires:      php-pear-XML_RPC
 
 %description cli
@@ -434,7 +414,7 @@ Summary(pl.UTF-8):  Integracja SCM dla Eventum
 Group:         Applications/WWW
 Requires:      %{name}-base = %{version}-%{release}
 Requires:      php-cli
-Requires:      php-common >= 4:5.0
+Requires:      php-common >= 4:%{php_min_version}
 Requires:      php-pcre
 
 %description scm
@@ -458,151 +438,128 @@ prawie każdym systemem SCM, jak np. CVS.
 Szczegóły na temat instalacji można przeczytać pod
 </eventum/help.php?topic=scm_integration_installation>.
 
+%package sphinx
+Summary:       Eventum Sphinx Search
+Group:         Applications/WWW
+Requires:      %{name} = %{version}-%{release}
+Requires:      crondaemon
+Requires:      sphinx
+
+%description sphinx
+Sphinx search integration for Eventum.
+
+This package contains the cron job.
+
 %prep
-%setup -q %{?snap:-n %{name}-%{snap}}%{?svn:-n %{name}-%{svn}}
+%setup -q
 
-rm -r misc/upgrade/*v1.[123]* # too old to support in PLD Linux
-rm -r misc/upgrade/v{1.,2.0,2.1_}* # no longer supported in PLD Linux
-rm misc/upgrade/flush_compiled_templates.php
-rm -r misc/upgrade/{*/,}index.html # not needed in PLD Linux
+# GPL v2
+rm docs/COPYING
 
-rm -r include/php-gettext
-# sample, not used in eventum
-rm rpc/xmlrpc_client.php
+rm -r upgrade/*v1.[123]* # too old to support in PLD Linux
+rm -r upgrade/v{1.,2.0,2.1_}* # no longer supported in PLD Linux
+rm upgrade/flush_compiled_templates.php
+rm -r upgrade/{*/,}index.html # not needed in PLD Linux
 
 # bug fixes / features
 %patch0 -p1
 %{?with_order:%patch2 -p1}
+%patch3 -p0
 
-cp -a %{SOURCE16} images
+cp -p %{SOURCE16} htdocs/images
 
 #%patch200 -p1
 
+# produce default sphinx config
+# must be run before paths.patch
+cat <<'EOF' > config/config.php
+<?php
+define('APP_SQL_DBTYPE', 'mysql');
+define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
+define('APP_SQL_DBPORT', 3306);
+define('APP_SQL_DBNAME', 'eventum');
+define('APP_SQL_DBUSER', 'mysql');
+define('APP_SQL_DBPASS', '');
+define('APP_TABLE_PREFIX', 'eventum_');
+EOF
+php config/sphinx.conf.php > config/sphinx.conf
+rm -f config/config.php
+
 # packaging
 %patch100 -p1
 %patch101 -p1
-%patch102 -p1
 %patch105 -p1
-%patch106 -p1
 %patch107 -p1
 
-cat <<'EOF'> mysql-permissions.sql
-# use this schema if you want to grant permissions manually instead of using setup
-# this schema is extracted from setup/index.php.
-GRANT SELECT, UPDATE, DELETE, INSERT, ALTER, DROP, CREATE, INDEX ON eventum.* TO 'eventum'@'localhost' IDENTIFIED BY 'password';
-EOF
-
-sed -e '1s,#!.*/bin/php -q,#!%{_bindir}/php,' misc/cli/eventum > %{name}-cli
-mv misc/cli/eventumrc_example eventumrc
-sed -i -e '1i#!%{_bindir}/php' misc/*.php
-chmod +x misc/*.php
-
 %{__sed} -i -e "
-s,require_once.*init.php.*;,require_once '%{_appdir}/htdocs/init.php';,
 s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
-/define('INSTALL_PATH'/d
-" misc/upgrade/{*/,}*.php
+" upgrade/{*/,}*.php
 
 # remove backups from patching as we use globs to package files to buildroot
 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
 
 %build
-%{__make} -C misc/localization
+%{__make} -C localization
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d \
        $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
-       $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
+       $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
        $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
        $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
        $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
        $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
+       $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
 
-cp -a *.php css customer images js manage reports rpc setup %{?with_order:ajax} $RPM_BUILD_ROOT%{_appdir}/htdocs
-cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
-cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
-cp -a templates $RPM_BUILD_ROOT%{_appdir}
-cp -a include/{customer,custom_field,jpgraph,workflow} $RPM_BUILD_ROOT%{_appdir}/include
-cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
-cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
-cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
-
-cp -a favicon.ico $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
-install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
-
-# cli
-install -d $RPM_BUILD_ROOT%{_appdir}/cli
-cp -a misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
-cp -a misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
-install %{name}-cli $RPM_BUILD_ROOT%{_bindir}/%{name}
-install misc/irc/bot.php $RPM_BUILD_ROOT%{_sbindir}/%{name}-bot
+%{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
+       sysconfdir=%{_webappdir} \
+       DESTDIR=$RPM_BUILD_ROOT
 
-# scm
-install misc/scm/process_cvs_commits.php $RPM_BUILD_ROOT%{_libdir}/process_cvs_commits
-install misc/scm/process_svn_commits.php $RPM_BUILD_ROOT%{_libdir}/process_svn_commits
-install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
+%{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
 
-# private key
-echo '<?php
-$private_key = "DEFAULTPRIVATEKEY";' > $RPM_BUILD_ROOT%{_webappdir}/private_key.php
 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
+cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
 
-cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
-cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
-cp -a %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
-cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
-cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
-cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
-cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
-cp -a %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
-cp -a %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
-cp -a %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
+install -d $RPM_BUILD_ROOT/etc/sphinx
+cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
+cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
 
+cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
+cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
+cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
+cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
+cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
 
-%{__sed} -i -e "/define('APP_VERSION'/ {
-    idefine('APP_VERSION', '%{version}%{?snap:-%{snap}}%{?_rc:-%{_rc}}%{?svn:-%{svn}}');
-    d
+cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
 
-}" $RPM_BUILD_ROOT%{_appdir}/htdocs/init.php
+install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
+cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
 
-# config
-> $RPM_BUILD_ROOT%{_webappdir}/setup.php
-cat <<'EOF'> $RPM_BUILD_ROOT%{_webappdir}/config.php
-EOF
+cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 
-install -d $RPM_BUILD_ROOT%{_smartyplugindir}
-# These plugins are not in Smarty package (Smarty-2.6.2-3)
-cp -a \
-       include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
-       include/Smarty/plugins/modifier.highlight_quoted.php \
-       $RPM_BUILD_ROOT%{_smartyplugindir}
-
-# qmail router
-%if %{with qmail}
-d=$RPM_BUILD_ROOT/var/lib/%{name}
-echo 'root' > $d/.qmail
-echo 'root' > $d/.qmail-default
-echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
-echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
-echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
-install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/router-qmail
-%endif
 # postfix router
-install %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
-
-install -D %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
-# locale
-cd misc/localization
-for a in */LC_MESSAGES/*.mo; do
-       d=${a%/*}
-       install -d $RPM_BUILD_ROOT%{_datadir}/locale/$d
-       cp -a $a $RPM_BUILD_ROOT%{_datadir}/locale/$d
-done
-cd -
+install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
+
+install %{SOURCE17} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
+
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ht
 
 %find_lang %{name}
 
+# scm
+install -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
+
+# old compat
+ln -s %{_sbindir}/eventum-cvs-hook $RPM_BUILD_ROOT%{_libdir}/process_cvs_commits
+ln -s %{_sbindir}/eventum-svn-hook $RPM_BUILD_ROOT%{_libdir}/process_svn_commits
+
+# skip pear for cli
+rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
+cp -a cli/lib/eventum $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -610,65 +567,10 @@ rm -rf $RPM_BUILD_ROOT
 %addusertogroup http %{name}
 
 %post
-# check if the package is configured.
-if grep -q "Header('Location: setup/')" %{_webappdir}/config.php; then
-if [ -f %{_appdir}/htdocs/setup/index.php ]; then
-%banner %{name} -e <<EOF
-
-You haven't yet configured Eventum!
-Please open in browser <http://localhost/eventum/>
-If you need access from elsewhere, you need to edit
-%{_webappdir}/apache.conf and restart apache.
-
-IMPORTANT: When You have configured Eventum, please uninstall the
-setup package, so that %{name}-setup is able to secure your Eventum
-installation.
-
-EOF
-#' vim syntax hack
-else
-%banner %{name} -e <<EOF
-
-You haven't yet configured Eventum!
-
-To setup eventum, please install %{name}-setup and open in browser
-<http://localhost/eventum/>.
-If you need access from elsewhere, you need to edit
-%{_webappdir}/*.conf depending on webserver and restart the webserver.
-
-IMPORTANT: When You have configured Eventum, please uninstall the
-setup package, so that %{name}-setup is able to secure your Eventum
-installation.
-
-EOF
-#' vim syntax hack
-fi
-
-elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
-%banner %{name} -e <<EOF
-
-You have default private key installed!
-
-Install %{name}-setup and open up http://yourserver/eventum/setup/
--- that will help you setup initial config.
-
-when have configured Eventum, please uninstall the setup package,
-so that %{name}-setup is able to secure your Eventum installation.
-
-EOF
-       elif [ -d %{_appdir}/setup ]; then
-%banner %{name} -e <<EOF
-
-If you have have configured Eventum, please uninstall the setup package,
-so that %{name}-setup is able to secure your Eventum installation.
-
-EOF
-fi
-
 # greate empty ghost files
 for a in cli.log errors.log irc_bot.log login_attempts.log; do
        if [ ! -f /var/log/%{name}/$a ]; then
-               install -m620 -oroot -geventum /dev/null /var/log/%{name}/$a
+               install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
        fi
 done
 
@@ -678,6 +580,10 @@ done
 # nuke Smarty templates cache after upgrade
 rm -f /var/cache/eventum/*.php
 
+# Restart webserver on upgrade to get .mo translations reloaded.
+# actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
+%php_webserver_restart
+
 %preun
 if [ "$1" = "0" ]; then
        # nuke cache
@@ -694,38 +600,14 @@ if [ "$1" = "0" ]; then
        %groupremove %{name}
 fi
 
-%post router-qmail
-CF=/etc/qmail/control/virtualdomains
-if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
-       FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_webappdir}/config.php 2>/dev/null)
-       [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
-       umask 022
-       echo "#${FQDN}:%{name}" >> $CF
-
-%banner %{name}-qmail -e <<EOF
-
-Added "#${FQDN}:%{name}" to $CF,
-Please verify that it is correct and restart qmail:
-# service qmail reload
-
-Consult qmail-send(8) for more information on virtualdomains.
-
-EOF
-fi
-
-%preun router-qmail
-if [ "$1" = "0" ]; then
-       sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
-fi
-
 %post setup
 chmod 660 %{_webappdir}/{config,private_key}.php
-chown root:eventum %{_webappdir}/{config,private_key}.php
+chown root:http %{_webappdir}/{config,private_key}.php
 
 %postun setup
 if [ "$1" = "0" ]; then
        chmod 640 %{_webappdir}/{config,private_key}.php
-       chown root:eventum %{_webappdir}/{config,private_key}.php
+       chown root:http %{_webappdir}/{config,private_key}.php
 fi
 
 %post irc
@@ -756,31 +638,46 @@ fi
 %triggerun -- lighttpd
 %webapp_unregister lighttpd %{_webapp}
 
-%triggerpostun -- eventum < 2.1.1-2.13
-%{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v2.1.1_to_v2.2 <<EOF
-db_version.php Add eventum_version table
-EOF
-# automated database update
-%{_appdir}/upgrade/update-database.php || :
+%triggerpostun -- %{name} < 2.2-2.57
+# switching eventum->http user
+chgrp http %{_webappdir}/config.php
+chgrp http %{_webappdir}/private_key.php
+chgrp http %{_webappdir}/setup.php
+chgrp http /var/log/%{name}/*
+# update crontab user
+for a in /etc/cron.d/eventum-*; do
+       [ -f "$a" ] || continue
+       awk '!/#/ && NR > 6 && $6 =="eventum" {sub("eventum", "http", $6)}{print}'  $a > $a.rpmtmp && cat $a.rpmtmp > $a
+       rm -f $a.rpmtmp
+
+       # crontabs moved to crons subdir
+       %{__sed} -i -e '
+               s,/usr/share/eventum/process_mail_queue.php,/usr/share/eventum/crons/process_mail_queue.php,
+               s,/usr/share/eventum/download_emails.php,/usr/share/eventum/crons/download_emails.php,
+               s,/usr/share/eventum/check_reminders.php,/usr/share/eventum/crons/check_reminders.php,
+               s,/usr/share/eventum/monitor.php,/usr/share/eventum/crons/monitor.php,
+       ' $a
+done
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc ChangeLog FAQ INSTALL README UPGRADE CONTRIB
-%doc docs/* setup/schema.sql mysql-permissions.sql
+%doc docs/* htdocs/setup/schema.sql
 %attr(751,root,root) %dir %{_webappdir}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
-%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
-%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
-%attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
+%attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
 
-%dir %attr(731,root,eventum) /var/log/%{name}
-%attr(620,root,eventum) %ghost /var/log/%{name}/*
+%dir %attr(731,root,http) /var/log/%{name}
+%attr(620,root,http) %ghost /var/log/%{name}/*
 %dir %attr(750,root,root) /var/log/archive/%{name}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
 
+%dir %{_appdir}/crons
+%{_appdir}/init.php
 %dir %{_appdir}/htdocs
 %{_appdir}/htdocs/*.php
 %{_appdir}/htdocs/*.ico
@@ -798,37 +695,30 @@ EOF
 %{_appdir}/templates
 
 %dir %{_appdir}/upgrade
-%attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
+%{_appdir}/upgrade/init.php
 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
 %dir %{_appdir}/upgrade/v*
 %attr(755,root,root) %{_appdir}/upgrade/v*/*.php
 %{_appdir}/upgrade/patches
 
-%{_smartyplugindir}
-
-%dir %{_appdir}/include
-%{_appdir}/include/customer
-%{_appdir}/include/custom_field
-%{_appdir}/include/jpgraph
-%{_appdir}/include/workflow
-%{_appdir}/include/class.*.php
-%{_appdir}/include/db_access.php
-%exclude %{_appdir}/include/class.monitor.php
-
-%dir %attr(730,root,eventum) /var/run/%{name}
-%dir %attr(730,root,eventum) /var/cache/%{name}
+%dir %{_appdir}/lib
+%{_appdir}/lib/eventum
+%{_appdir}/lib/jpgraph
+%exclude %{_appdir}/lib/eventum/class.monitor.php
+/usr/lib/tmpfiles.d/%{name}.conf
+%dir %attr(730,root,http) /var/run/%{name}
+%dir %attr(730,root,http) /var/cache/%{name}
 
 %files base
 %defattr(644,root,root,755)
 %attr(751,root,root) %dir %{_sysconfdir}
 %dir %{_libdir}
 %dir %{_appdir}
-# qmail will ignore user, if it's home directory is not owned
-%attr(750,eventum,eventum) %dir /var/lib/%{name}
+%dir /var/lib/%{name}
 # saved mail copies
-%attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
-%attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
-%attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
+%attr(770,root,http) %dir /var/lib/%{name}/routed_emails
+%attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
+%attr(770,root,http) %dir /var/lib/%{name}/routed_notes
 
 %files setup
 %defattr(644,root,root,755)
@@ -836,23 +726,23 @@ EOF
 
 %files mail-queue
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_appdir}/process_mail_queue.php
+%attr(755,root,root) %{_appdir}/crons/process_mail_queue.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
 
 %files mail-download
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_appdir}/download_emails.php
+%attr(755,root,root) %{_appdir}/crons/download_emails.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
 
 %files reminder
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_appdir}/check_reminders.php
+%attr(755,root,root) %{_appdir}/crons/check_reminders.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
 
 %files monitor
 %defattr(644,root,root,755)
-%{_appdir}/include/class.monitor.php
-%attr(755,root,root) %{_appdir}/monitor.php
+%{_appdir}/lib/eventum/class.monitor.php
+%attr(755,root,root) %{_appdir}/crons/monitor.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
 
 %files route-drafts
@@ -867,13 +757,6 @@ EOF
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_appdir}/route_notes.php
 
-%if %{with qmail}
-%files router-qmail
-%defattr(644,root,root,755)
-%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
-%attr(755,root,root) %{_libdir}/router-qmail
-%endif
-
 %files router-postfix
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/router-postfix
@@ -882,13 +765,12 @@ EOF
 %defattr(644,root,root,755)
 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
-%attr(755,root,root) %{_sbindir}/%{name}-bot
+%attr(755,root,root) %{_sbindir}/%{name}-irc-bot
 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
 
 %files cli
 %defattr(644,root,root,755)
-%doc eventumrc
-%config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
+%doc cli/eventumrc
 %attr(755,root,root) %{_bindir}/%{name}
 %{_appdir}/cli
 
@@ -897,3 +779,11 @@ EOF
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
 %attr(755,root,root) %{_libdir}/process_cvs_commits
 %attr(755,root,root) %{_libdir}/process_svn_commits
+%attr(755,root,root) %{_sbindir}/eventum-cvs-hook
+%attr(755,root,root) %{_sbindir}/eventum-svn-hook
+
+%files sphinx
+%defattr(644,root,root,755)
+%{_webappdir}/sphinx.conf.php
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.14952 seconds and 4 git commands to generate.