]> git.pld-linux.org Git - packages/eventum.git/blobdiff - eventum.spec
- gpl version
[packages/eventum.git] / eventum.spec
index e3bc2c45955cd106398ce8c54763cc4b8a38541e..824d1d96ed95703b5ee8d1f3c48cb838d50efdf3 100644 (file)
 %bcond_without order   # with experimental order patch
 
 %define                php_min_version 5.1.2
+#define                subver  RC3
+%define                rel             2
 %include       /usr/lib/rpm/macros.php
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl.UTF-8):     Eventum - system śledzenia spraw/błędów
 Name:          eventum
-Version:       2.3
-Release:       1
-License:       GPL
+Version:       2.3.3
+Release:       %{rel}
+#Release:      %{rel}.bzr%{subver}
+License:       GPL v2
 Group:         Applications/WWW
 Source0:       http://launchpad.net/eventum/trunk/%{version}/+download/%{name}-%{version}.tar.gz
-# Source0-md5: 31c16e53f799dd41df2f08cfff75247b
+# Source0-md5: e1a5097d191468061865065678665f0e
+#Source0:      %{name}-%{version}-dev-r%{subver}.tar.gz
+#Source0:      %{name}-%{version}%{subver}.tar.gz
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
@@ -29,13 +34,16 @@ Source6:    %{name}-cvs.php
 Source7:       %{name}-irc.php
 Source8:       %{name}-irc.init
 Source9:       %{name}-irc.sysconfig
+Source10:      sphinx.crontab
 Source13:      %{name}-router-postfix.sh
 Source14:      %{name}.logrotate
 Source15:      %{name}-lighttpd.conf
 Source16:      http://www.isocra.com/images/updown2.gif
 # Source16-md5:        deb6eeb2552ba757d3a949ed10c4107d
+Source17:      %{name}.tmpfiles
 Patch0:                %{name}-lf.patch
 Patch2:                %{name}-order.patch
+Patch3:                group-users.patch
 # packaging patches that probably never go upstream
 Patch100:      %{name}-paths.patch
 Patch101:      %{name}-cvs-config.patch
@@ -50,10 +58,12 @@ BuildRequires:      rpmbuild(macros) >= 1.461
 BuildRequires: sed >= 4.0
 Requires:      %{name}-base = %{version}-%{release}
 Requires:      Smarty >= 2.6.10-4
-Requires:      php-common >= 4:%{php_min_version}
+Requires:      php(core) >= %{php_min_version}
+Requires:      php-filter
 Requires:      php-gd
 Requires:      php-iconv
 Requires:      php-imap
+Requires:      php-json
 Requires:      php-mbstring
 Requires:      php-mysql
 Requires:      php-pcre
@@ -79,14 +89,15 @@ Requires:   webserver(alias)
 Requires:      webserver(indexfile)
 Requires:      webserver(php) >= 4.2.0
 Suggests:      localedb
-Conflicts:     logrotate < 3.7-4
+Suggests:      php-pear-Net_LDAP2
+Conflicts:     logrotate < 3.8.0
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautopear     pear(../init.php) pear(init.php) pear(/etc/webapps/.*) pear(%{_appdir}/.*) pear(jpgraph_dir.php) pear(.*Smarty.class.php) pear(Services/JSON.php)
+%define                _noautopear     pear(../init.php) pear(init.php) pear(/usr/share/eventum/init.php) pear(/etc/webapps/.*) pear(%{_appdir}/.*) pear(jpgraph_dir.php) pear(.*Smarty.class.php) pear(Services/JSON.php) pear(class.date_helper.php) pear(sphinxapi.php) pear(Net/LDAP2.php)
 
 # exclude optional php dependencies
-%define                _noautophp      php-gnupg php-hash php-pecl-http php-json php-tk
+%define                _noautophp      php-gnupg php-hash php-pecl-http php-tk
 
 %define                _noautoreq      %{_noautophp} %{_noautopear}
 
@@ -224,7 +235,7 @@ Summary(pl.UTF-8):  Monitor życia dla Eventum
 Group:         Applications/WWW
 Requires:      %{name} = %{version}-%{release}
 Requires:      crondaemon
-Requires:      php(posix)
+Requires:      php-posix
 
 %description monitor
 The heartbeat monitor is a feature designed for the administrator that
@@ -354,8 +365,8 @@ Summary(pl.UTF-8):  IRC-owy bot powiadamiający dla Eventum
 Group:         Applications/WWW
 Requires(post,preun):  /sbin/chkconfig
 Requires:      %{name} = %{version}-%{release}
-Requires:      php(sockets)
 Requires:      php-pear-Net_SmartIRC
+Requires:      php-sockets
 Requires:      rc-scripts >= 0.4.0.18
 
 %description irc
@@ -387,8 +398,8 @@ Summary:    Eventum command-line interface
 Summary(pl.UTF-8):     Interfejs linii poleceń dla Eventum
 Group:         Applications/WWW
 Requires:      %{name}-base = %{version}-%{release}
+Requires:      php(core) >= %{php_min_version}
 Requires:      php-cli
-Requires:      php-common >= 4:%{php_min_version}
 Requires:      php-pear-XML_RPC
 
 %description cli
@@ -404,8 +415,8 @@ Summary:    Eventum SCM integration
 Summary(pl.UTF-8):     Integracja SCM dla Eventum
 Group:         Applications/WWW
 Requires:      %{name}-base = %{version}-%{release}
+Requires:      php(core) >= %{php_min_version}
 Requires:      php-cli
-Requires:      php-common >= 4:%{php_min_version}
 Requires:      php-pcre
 
 %description scm
@@ -429,6 +440,18 @@ prawie każdym systemem SCM, jak np. CVS.
 Szczegóły na temat instalacji można przeczytać pod
 </eventum/help.php?topic=scm_integration_installation>.
 
+%package sphinx
+Summary:       Eventum Sphinx Search
+Group:         Applications/WWW
+Requires:      %{name} = %{version}-%{release}
+Requires:      crondaemon
+Requires:      sphinx
+
+%description sphinx
+Sphinx search integration for Eventum.
+
+This package contains the cron job.
+
 %prep
 %setup -q
 
@@ -443,11 +466,27 @@ rm -r upgrade/{*/,}index.html # not needed in PLD Linux
 # bug fixes / features
 %patch0 -p1
 %{?with_order:%patch2 -p1}
+%patch3 -p0
 
-cp -a %{SOURCE16} htdocs/images
+cp -p %{SOURCE16} htdocs/images
 
 #%patch200 -p1
 
+# produce default sphinx config
+# must be run before paths.patch
+cat <<'EOF' > config/config.php
+<?php
+define('APP_SQL_DBTYPE', 'mysql');
+define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
+define('APP_SQL_DBPORT', 3306);
+define('APP_SQL_DBNAME', 'eventum');
+define('APP_SQL_DBUSER', 'mysql');
+define('APP_SQL_DBPASS', '');
+define('APP_TABLE_PREFIX', 'eventum_');
+EOF
+php config/sphinx.conf.php > config/sphinx.conf
+rm -f config/config.php
+
 # packaging
 %patch100 -p1
 %patch101 -p1
@@ -468,11 +507,12 @@ find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
 rm -rf $RPM_BUILD_ROOT
 install -d \
        $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
-       $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
+       $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
        $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
        $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
        $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
        $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
+       $RPM_BUILD_ROOT%{systemdtmpfilesdir}
 
 %{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
        sysconfdir=%{_webappdir} \
@@ -481,29 +521,38 @@ install -d \
 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
 
 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
-cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
-cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
-cp -a %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
+cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
+
+install -d $RPM_BUILD_ROOT/etc/sphinx
+cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
+cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
 
-cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
-cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
-cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
-cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
+cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
+cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
+cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
+cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
+cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
 
-cp -a %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
+cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
 
-cp -a %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
-cp -a %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
+install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
+cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
+
+cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 
 # postfix router
-install %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
+install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
+
+install %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
 
-install -D %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
 
 %find_lang %{name}
 
 # scm
-install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
+install -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
 
 # old compat
 ln -s %{_sbindir}/eventum-cvs-hook $RPM_BUILD_ROOT%{_libdir}/process_cvs_commits
@@ -523,7 +572,7 @@ rm -rf $RPM_BUILD_ROOT
 # greate empty ghost files
 for a in cli.log errors.log irc_bot.log login_attempts.log; do
        if [ ! -f /var/log/%{name}/$a ]; then
-               install -m620 -oroot -geventum /dev/null /var/log/%{name}/$a
+               install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
        fi
 done
 
@@ -650,6 +699,7 @@ done
 %dir %{_appdir}/upgrade
 %{_appdir}/upgrade/init.php
 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
+%attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
 %dir %{_appdir}/upgrade/v*
 %attr(755,root,root) %{_appdir}/upgrade/v*/*.php
 %{_appdir}/upgrade/patches
@@ -658,7 +708,7 @@ done
 %{_appdir}/lib/eventum
 %{_appdir}/lib/jpgraph
 %exclude %{_appdir}/lib/eventum/class.monitor.php
-
+%{systemdtmpfilesdir}/%{name}.conf
 %dir %attr(730,root,http) /var/run/%{name}
 %dir %attr(730,root,http) /var/cache/%{name}
 
@@ -734,3 +784,9 @@ done
 %attr(755,root,root) %{_libdir}/process_svn_commits
 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
+
+%files sphinx
+%defattr(644,root,root,755)
+%{_webappdir}/sphinx.conf.php
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.051384 seconds and 4 git commands to generate.