]> git.pld-linux.org Git - packages/eventum.git/blobdiff - eventum.spec
- gpl version
[packages/eventum.git] / eventum.spec
index b12ce0de5558f6a62db87439368add241a069567..824d1d96ed95703b5ee8d1f3c48cb838d50efdf3 100644 (file)
 %bcond_without order   # with experimental order patch
 
 %define                php_min_version 5.1.2
-%define                subver  4428
-%define                rel             2.2
+#define                subver  RC3
+%define                rel             2
 %include       /usr/lib/rpm/macros.php
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl.UTF-8):     Eventum - system śledzenia spraw/błędów
 Name:          eventum
-Version:       2.3.1
-#Release:      %{rel}
-Release:       %{rel}.bzr%{subver}
-License:       GPL
+Version:       2.3.3
+Release:       %{rel}
+#Release:      %{rel}.bzr%{subver}
+License:       GPL v2
 Group:         Applications/WWW
-#Source0:      http://launchpad.net/eventum/trunk/%{version}/+download/%{name}-%{version}.tar.gz
-Source0:       %{name}-%{version}-dev-r%{subver}.tar.gz
-# Source0-md5: cfcf44e6aa430ce524c306b607bb60c2
+Source0:       http://launchpad.net/eventum/trunk/%{version}/+download/%{name}-%{version}.tar.gz
+# Source0-md5: e1a5097d191468061865065678665f0e
+#Source0:      %{name}-%{version}-dev-r%{subver}.tar.gz
+#Source0:      %{name}-%{version}%{subver}.tar.gz
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
@@ -39,6 +40,7 @@ Source14:     %{name}.logrotate
 Source15:      %{name}-lighttpd.conf
 Source16:      http://www.isocra.com/images/updown2.gif
 # Source16-md5:        deb6eeb2552ba757d3a949ed10c4107d
+Source17:      %{name}.tmpfiles
 Patch0:                %{name}-lf.patch
 Patch2:                %{name}-order.patch
 Patch3:                group-users.patch
@@ -56,7 +58,7 @@ BuildRequires:        rpmbuild(macros) >= 1.461
 BuildRequires: sed >= 4.0
 Requires:      %{name}-base = %{version}-%{release}
 Requires:      Smarty >= 2.6.10-4
-Requires:      php-common >= 4:%{php_min_version}
+Requires:      php(core) >= %{php_min_version}
 Requires:      php-filter
 Requires:      php-gd
 Requires:      php-iconv
@@ -87,11 +89,12 @@ Requires:   webserver(alias)
 Requires:      webserver(indexfile)
 Requires:      webserver(php) >= 4.2.0
 Suggests:      localedb
-Conflicts:     logrotate < 3.7-4
+Suggests:      php-pear-Net_LDAP2
+Conflicts:     logrotate < 3.8.0
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautopear     pear(../init.php) pear(init.php) pear(/usr/share/eventum/init.php) pear(/etc/webapps/.*) pear(%{_appdir}/.*) pear(jpgraph_dir.php) pear(.*Smarty.class.php) pear(Services/JSON.php) pear(class.date_helper.php)
+%define                _noautopear     pear(../init.php) pear(init.php) pear(/usr/share/eventum/init.php) pear(/etc/webapps/.*) pear(%{_appdir}/.*) pear(jpgraph_dir.php) pear(.*Smarty.class.php) pear(Services/JSON.php) pear(class.date_helper.php) pear(sphinxapi.php) pear(Net/LDAP2.php)
 
 # exclude optional php dependencies
 %define                _noautophp      php-gnupg php-hash php-pecl-http php-tk
@@ -362,8 +365,8 @@ Summary(pl.UTF-8):  IRC-owy bot powiadamiający dla Eventum
 Group:         Applications/WWW
 Requires(post,preun):  /sbin/chkconfig
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-sockets
 Requires:      php-pear-Net_SmartIRC
+Requires:      php-sockets
 Requires:      rc-scripts >= 0.4.0.18
 
 %description irc
@@ -395,8 +398,8 @@ Summary:    Eventum command-line interface
 Summary(pl.UTF-8):     Interfejs linii poleceń dla Eventum
 Group:         Applications/WWW
 Requires:      %{name}-base = %{version}-%{release}
+Requires:      php(core) >= %{php_min_version}
 Requires:      php-cli
-Requires:      php-common >= 4:%{php_min_version}
 Requires:      php-pear-XML_RPC
 
 %description cli
@@ -412,8 +415,8 @@ Summary:    Eventum SCM integration
 Summary(pl.UTF-8):     Integracja SCM dla Eventum
 Group:         Applications/WWW
 Requires:      %{name}-base = %{version}-%{release}
+Requires:      php(core) >= %{php_min_version}
 Requires:      php-cli
-Requires:      php-common >= 4:%{php_min_version}
 Requires:      php-pcre
 
 %description scm
@@ -509,6 +512,7 @@ install -d \
        $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
        $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
        $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
+       $RPM_BUILD_ROOT%{systemdtmpfilesdir}
 
 %{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
        sysconfdir=%{_webappdir} \
@@ -541,7 +545,9 @@ cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 # postfix router
 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
 
-%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ht
+install %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
+
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
 
 %find_lang %{name}
 
@@ -693,6 +699,7 @@ done
 %dir %{_appdir}/upgrade
 %{_appdir}/upgrade/init.php
 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
+%attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
 %dir %{_appdir}/upgrade/v*
 %attr(755,root,root) %{_appdir}/upgrade/v*/*.php
 %{_appdir}/upgrade/patches
@@ -701,7 +708,7 @@ done
 %{_appdir}/lib/eventum
 %{_appdir}/lib/jpgraph
 %exclude %{_appdir}/lib/eventum/class.monitor.php
-
+%{systemdtmpfilesdir}/%{name}.conf
 %dir %attr(730,root,http) /var/run/%{name}
 %dir %attr(730,root,http) /var/cache/%{name}
 
This page took 0.261706 seconds and 4 git commands to generate.