]> git.pld-linux.org Git - packages/eventum.git/blobdiff - eventum.spec
up to 3.7.4
[packages/eventum.git] / eventum.spec
index ec10c2ac2d64e8748e5127e4f4846aadf73c452d..718c7972850a93cca977e9c647ab3c27fd001c6c 100644 (file)
@@ -3,18 +3,18 @@
 %bcond_with    order   # with experimental order patch
 
 %define                rel             1
-#define                subver  73
-#define                githash a12094613
+#define                subver  60
+#define                githash b1bd92244
 %define                php_min_version 7.1.3
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl.UTF-8):     Eventum - system śledzenia spraw/błędów
 Name:          eventum
-Version:       3.7.1
+Version:       3.7.4
 Release:       %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
 License:       GPL v2+
 Group:         Applications/WWW
 Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: 41f91cc9c162061229c14324f7882a06
+# Source0-md5: e26f52a5545cacbd3fe6c9b6ead43243
 #Source0:      https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.xz
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
@@ -37,7 +37,7 @@ Patch107:     %{name}-gettext.patch
 Patch108:      autoload.patch
 # some tests
 Patch200:      %{name}-fixed-nav.patch
-URL:           https://wiki.github.com/eventum/eventum/
+URL:           https://github.com/eventum/eventum/wiki
 BuildRequires: gettext-tools
 BuildRequires: rpmbuild(macros) >= 1.654
 BuildRequires: sed >= 4.0
@@ -63,12 +63,6 @@ Requires:    php(pdo_mysql)
 Requires:      php(session)
 Requires:      php-Smarty >= 3.1
 Requires:      php-Smarty-plugin-gettext
-Requires:      php-ZendFramework-Config >= 2.4
-Requires:      php-ZendFramework-Loader >= 2.4
-Requires:      php-ZendFramework-Mail >= 2.4.13-2
-Requires:      php-ZendFramework-Mime >= 2.4
-Requires:      php-ZendFramework-ServiceManager >= 2.4
-Requires:      php-ZendFramework-Validator >= 2.4
 Requires:      php-monolog >= 1.17.2
 Requires:      php-psr-Log >= 1.0.0-2
 Requires:      phplot >= 5.8.0
@@ -319,13 +313,6 @@ rm -r vendor/psr/log
 rm -r vendor/smarty-gettext/smarty-gettext
 rm -r vendor/smarty/smarty
 rm -r vendor/sphinx/php-sphinxapi
-rm -r vendor/zendframework/zend-config
-rm -r vendor/zendframework/zend-loader
-rm -r vendor/zendframework/zend-mail
-rm -r vendor/zendframework/zend-mime
-rm -r vendor/zendframework/zend-servicemanager
-rm -r vendor/zendframework/zend-stdlib
-rm -r vendor/zendframework/zend-validator
 
 # remove backups from patching as we use globs to package files to buildroot
 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
@@ -461,19 +448,25 @@ fi
 %attr(771,root,http) %dir %{_webappdir}
 %attr(751,root,http) %dir %{_webappdir}/crm
 %attr(751,root,http) %dir %{_webappdir}/custom_field
+%attr(751,root,http) %dir %{_webappdir}/packages
+%attr(751,root,http) %dir %{_webappdir}/packages/prod
 %attr(751,root,http) %dir %{_webappdir}/partner
 %attr(751,root,http) %dir %{_webappdir}/templates
-%attr(751,root,http) %dir %{_webappdir}/workflow
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/bundles.php
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/routes.yml
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/services.yml
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/packages/doctrine.yml
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/packages/framework.yml
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/packages/security.yml
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/packages/prod/doctrine.yml
 
 %dir %attr(731,root,http) /var/log/%{name}
 %attr(620,root,http) %ghost /var/log/%{name}/*
@@ -485,6 +478,7 @@ fi
 
 %dir %{_appdir}/bin
 %attr(755,root,root) %{_appdir}/bin/console.php
+%attr(755,root,root) %{_appdir}/bin/export-issues.php
 %attr(755,root,root) %{_appdir}/bin/extension.php
 %attr(755,root,root) %{_appdir}/bin/ldapsync.php
 %attr(755,root,root) %{_appdir}/bin/migrate_storage_adapter.php
This page took 0.034851 seconds and 4 git commands to generate.