]> git.pld-linux.org Git - packages/eventum.git/blobdiff - eventum.spec
up to 3.3.3
[packages/eventum.git] / eventum.spec
index 58a751737d17ab92f2b32cfc8e314799fbe4c482..6f7d20332bf20b4a9a05192f1655595a19bd1fd2 100644 (file)
@@ -2,21 +2,21 @@
 # Conditional build:
 %bcond_with    order   # with experimental order patch
 
-%define                rel             0.3
-%define                subver  346
-%define                githash 8b147f6c
-%define                php_min_version 5.5.0
+%define                rel             1
+#define                subver  189
+#define                githash 7b4eddae
+%define                php_min_version 5.6.0
 %include       /usr/lib/rpm/macros.php
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl.UTF-8):     Eventum - system śledzenia spraw/błędów
 Name:          eventum
-Version:       3.1.10
+Version:       3.3.3
 Release:       %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
 License:       GPL v2+
 Group:         Applications/WWW
-#Source0:      https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
-Source0:       https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.gz
-# Source0-md5: e161cee555ffb0ff6ad9994efeaa10cc
+Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 7fde18feb868ad965aa186418eccd1c1
+#Source0:      https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.gz
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
@@ -65,12 +65,11 @@ Requires:   php-Smarty >= 3.1
 Requires:      php-Smarty-plugin-gettext
 Requires:      php-ZendFramework-Config >= 2.4
 Requires:      php-ZendFramework-Loader >= 2.4
-Requires:      php-ZendFramework-Mail >= 2.4.9-2
+Requires:      php-ZendFramework-Mail >= 2.4.11-4
 Requires:      php-ZendFramework-Mime >= 2.4
 Requires:      php-ZendFramework-ServiceManager >= 2.4
 Requires:      php-ZendFramework-Validator >= 2.4
 Requires:      php-monolog >= 1.17.2
-Requires:      php-pear-Mail
 Requires:      php-pear-Mail_Mime
 Requires:      php-pear-Mail_mimeDecode
 Requires:      php-pear-Math_Stats
@@ -80,13 +79,6 @@ Requires:    php-pear-Net_URL
 Requires:      php-pear-PEAR-core
 Requires:      php-pear-Text_Diff
 Requires:      php-psr-Log >= 1.0.0-2
-Requires:      php-symfony2-Config >= 2.7.7
-Requires:      php-symfony2-Console >= 2.7.7
-Requires:      php-symfony2-Filesystem >= 2.7.7
-Requires:      php-symfony2-HttpFoundation >= 2.7.7
-Requires:      php-symfony2-OptionsResolver >= 2.7.7
-Requires:      php-symfony2-Serializer >= 2.7.7
-Requires:      php-symfony2-Yaml >= 2.7.7
 Requires:      phplot >= 5.8.0
 Requires:      webapps
 Requires:      webserver(access)
@@ -410,6 +402,21 @@ vendor theorchard/monolog-cascade
 vendor malkusch/lock
 vendor phpxmlrpc/phpxmlrpc
 vendor robmorgan/phinx
+vendor mnapoli/silly
+vendor psr/container
+vendor phlib/flysystem-pdo
+vendor league/flysystem
+vendor php-di/invoker
+vendor container-interop/container-interop
+vendor symfony/config
+vendor symfony/console
+vendor symfony/debug
+vendor symfony/event-dispatcher
+vendor symfony/filesystem
+vendor symfony/http-foundation
+vendor symfony/options-resolver
+vendor symfony/serializer
+vendor symfony/yaml
 
 # remove backups from patching as we use globs to package files to buildroot
 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
@@ -424,7 +431,7 @@ install -d \
        $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
        $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
        $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
-       $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
+       $RPM_BUILD_ROOT/var/lib/%{name}/{routed_{emails,drafts,notes},storage} \
        $RPM_BUILD_ROOT%{systemdtmpfilesdir}
 
 %{__make} install-eventum install-cli install-localization \
@@ -590,6 +597,8 @@ done
 %{_appdir}/config
 
 %dir %{_appdir}/bin
+%attr(755,root,root) %{_appdir}/bin/extension.php
+%attr(755,root,root) %{_appdir}/bin/ldapsync.php
 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
 %attr(755,root,root) %{_appdir}/bin/upgrade.php
 
@@ -611,9 +620,6 @@ done
 %{_appdir}/htdocs/components
 %{_appdir}/templates
 
-%dir %{_appdir}/upgrade
-%{_appdir}/upgrade/*.sql
-%{_appdir}/upgrade/patches
 %dir %{_appdir}/db
 %dir %{_appdir}/db/migrations
 %{_appdir}/db/migrations/*.php
@@ -623,7 +629,11 @@ done
 %{_appdir}/vendor
 %dir %{_appdir}/lib
 %{_appdir}/lib/eventum
-%exclude %{_appdir}/lib/eventum/class.monitor.php
+%exclude %{_appdir}/src/Command/MailDownloadCommand.php
+%exclude %{_appdir}/src/Command/MailQueueProcessCommand.php
+%exclude %{_appdir}/src/Command/MailQueueTruncateCommand.php
+%exclude %{_appdir}/src/Command/MonitorCommand.php
+%exclude %{_appdir}/src/Command/ReminderCheckCommand.php
 
 %dir %{_libdir}
 
@@ -637,6 +647,8 @@ done
 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
+# attachment storage
+%attr(770,root,http) %dir /var/lib/%{name}/storage
 
 %files setup
 %defattr(644,root,root,755)
@@ -649,23 +661,27 @@ done
 
 %files mail-queue
 %defattr(644,root,root,755)
+%{_appdir}/src/Command/MailQueueProcessCommand.php
+%{_appdir}/src/Command/MailQueueTruncateCommand.php
 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
 
 %files mail-download
 %defattr(644,root,root,755)
+%{_appdir}/src/Command/MailDownloadCommand.php
 %attr(755,root,root) %{_appdir}/bin/download_emails.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
 
 %files reminder
 %defattr(644,root,root,755)
+%{_appdir}/src/Command/ReminderCheckCommand.php
 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
 
 %files monitor
 %defattr(644,root,root,755)
-%{_appdir}/lib/eventum/class.monitor.php
+%{_appdir}/src/Command/MonitorCommand.php
 %attr(755,root,root) %{_appdir}/bin/monitor.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
 
This page took 0.047118 seconds and 4 git commands to generate.