]> git.pld-linux.org Git - packages/eventum.git/blobdiff - eventum.spec
- add to PLD CVS
[packages/eventum.git] / eventum.spec
index 7a1321c4c21c4a0ae50a545320ef5fc886e50c10..4708028a95af3411cb4c02e4654c9513564b5f9f 100644 (file)
@@ -1,39 +1,43 @@
 # TODO
-# - system pear is incompatible, at least pear DB class seems broke Eventum
-# - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
 # - discard bundled packages (from INSTALL):
 #  - JpGraph 1.5.3 (last GPL version)
 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
 #  - A few other small javascript libraries
-# - need start-stop-daemon (from dpkg for now)
+# - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
 
-%bcond_with    pear    # build with system PEAR packages (or use bundled ones)
-
-%define        uid     146
-%define        gid     146
+%bcond_without pear    # build with system PEAR packages (or use bundled ones)
+%bcond_with    qmail   # build the router-qmail subpackage
 
 # snapshot: DATE
-#define _snap 20050227
+%define        _snap 20051227
+
+# release candidate
+#define _rc            RC1
+
+%define        _rel    4.45
 
+%if 0%{?_rc:1}
+%define        _source http://pessoal.org/%{name}-%{version}-%{_rc}.tar.gz
+%else
 %if 0%{?_snap}
-%define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
+%define        _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
 %else
-%define _source http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
+%define        _source http://mysql.dataphone.se/Downloads/%{name}/%{name}-%{version}.tar.gz
+%endif
 %endif
 
-%define _rel 265
-
+%{?with_pear:%include  /usr/lib/rpm/macros.php}
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl):   Eventum - system ¶ledzenia spraw/b³êdów
 Name:          eventum
-Version:       1.5.1
-Release:       0.%{?_snap:%{_snap}.}%{_rel}
+Version:       1.7.0
+Release:       %{?_snap:0.%{_snap}.}%{?_rc:%{_rc}.}%{_rel}
 License:       GPL
 Group:         Applications/WWW
 Source0:       %{_source}
-# Source0-md5: d326ef39b52001efcbbc0ae8db5454a5
+# Source0-md5: 37185deab6f5a1e388800e1fe182e64c
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
@@ -46,30 +50,35 @@ Source9:    %{name}-irc.sysconfig
 Source10:      %{name}-config.php
 Source11:      %{name}-router-qmail.sh
 Source12:      http://dev.mysql.com/common/favicon.ico
+# Source12-md5:        858be0130832da4144c08d4b59116411
+Source13:      %{name}-config-setup.php
+Source14:      %{name}-upgrade.sh
 Patch0:                %{name}-paths.patch
 Patch1:                %{name}-cvs-config.patch
 Patch2:                %{name}-irc-config.patch
 Patch3:                %{name}-PEAR.patch
-Patch4:                %{name}-db-20050227.patch
-Patch10:       %{name}-charset-recent-activity.patch
-Patch11:       http://glen.alkohol.ee/pld/eventum-cli-rpc-base64.patch
-Patch12:       http://glen.alkohol.ee/pld/eventum-send-height.patch
-Patch13:       http://glen.alkohol.ee/pld/eventum-reply-subject.patch
-Patch14:       http://glen.alkohol.ee/pld/eventum-rss-updates.patch
-Patch15:       http://glen.alkohol.ee/pld/eventum-opera.patch
-Patch16:       eventum-lf.patch
-Patch17:       eventum-iss-ass-fix.patch
-Patch18:       eventum-iss-close.patch
+Patch4:                http://glen.alkohol.ee/pld/%{name}-reply-subject.patch
+Patch5:                %{name}-lf.patch
+Patch6:                http://glen.alkohol.ee/pld/%{name}-maq-subject.patch
+Patch7:                %{name}-bot-reconnect.patch
+Patch8:                %{name}-perms.patch
+Patch9:                http://glen.alkohol.ee/pld/%{name}-httpclient-clientside.patch
+Patch10:       %{name}-cli-wr-separated.patch
+Patch11:       %{name}-php440.patch
+Patch12:       %{name}-htmloptions-truncate.patch
+Patch13:       http://glen.alkohol.ee/pld/%{name}-link_filter-updates.patch
 URL:           http://dev.mysql.com/downloads/other/eventum/
-BuildRequires: rpmbuild(macros) >= 1.177
+%{?with_pear:BuildRequires:    rpm-php-pearprov >= 4.0.2-98}
+BuildRequires: rpmbuild(macros) >= 1.223
 BuildRequires: sed >= 4.0
-Requires:      php >= 4.2.0
+Requires:      %{name}-base = %{epoch}:%{version}-%{release}
+Requires:      Smarty >= 2.6.2
+Requires:      php >= 3:4.2.0
 Requires:      php-gd
 Requires:      php-imap
 Requires:      php-mysql
 Requires:      php-pcre
-Requires:      %{name}-base = %{epoch}:%{version}-%{release}
-Requires:      Smarty >= 2.6.2
+Requires:      php-session
 %if %{with pear}
 Requires:      php-pear-Benchmark
 Requires:      php-pear-DB
@@ -78,29 +87,32 @@ Requires:   php-pear-HTTP_Request
 Requires:      php-pear-Mail
 Requires:      php-pear-Math_Stats
 Requires:      php-pear-Net_DIME
-Requires:      php-pear-Net_POP3
 Requires:      php-pear-Net_SMTP
-Requires:      php-pear-Net_SmartIRC
 Requires:      php-pear-Net_Socket
 Requires:      php-pear-Net_URL
 Requires:      php-pear-Net_UserAgent_Detect
-Requires:      php-pear-PEAR
+Requires:      php-pear-PEAR-core
 Requires:      php-pear-Text_Diff
 Requires:      php-pear-XML_RPC
+#Suggests:     php-pear-Net_POP3
 %endif
-Requires:      apache >= 1.3.33-2
-Requires:      apache(mod_dir)
+Requires(triggerpostun):       /usr/bin/php
 Requires(triggerpostun):       sed >= 4.0
+Requires:      apache(mod_dir)
+Requires:      webapps
+Requires:      webserver = apache
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _sysconfdir     /etc/%{name}
-%define                _libdir         %{_prefix}/%{_lib}/%{name}
-%define                _appdir %{_datadir}/%{name}
-%define                _smartyplugindir        %{php_pear_dir}/Smarty/plugins
+%define                _noautoreq      'pear(/etc/webapps/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)' 'pear(Net/POP3.php)'
 
-%define                _apache1dir     /etc/apache
-%define                _apache2dir     /etc/httpd
+%define                _libdir         %{_prefix}/lib/%{name}
+%define                _appdir %{_datadir}/%{name}
+%define                _smartyplugindir        %{_appdir}/include/smarty
+%define                _smartydir      /usr/share/php/Smarty
+%define                _webapps        /etc/webapps
+%define                _webapp         %{name}
+%define                _sysconfdir     %{_webapps}/%{_webapp}
 
 %description
 Eventum is a user-friendly and flexible issue tracking system that can
@@ -121,6 +133,14 @@ reakcji.
 Summary:       Eventum base package
 Summary(pl):   Podstawowy pakiet Eventum
 Group:         Applications/WWW
+Requires(postun):      /usr/sbin/groupdel
+Requires(postun):      /usr/sbin/userdel
+Requires(pre): /bin/id
+Requires(pre): /usr/bin/getgid
+Requires(pre): /usr/sbin/groupadd
+Requires(pre): /usr/sbin/useradd
+Provides:      group(eventum)
+Provides:      user(eventum)
 
 %description base
 This package contains base directory structure for Eventum.
@@ -132,7 +152,7 @@ Ten pakiet zawiera podstawow
 Summary:       Eventum setup package
 Summary(pl):   Pakiet do wstêpnej konfiguracji Eventum
 Group:         Applications/WWW
-PreReq:                %{name} = %{epoch}:%{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description setup
 Install this package to configure initial Eventum installation. You
@@ -149,8 +169,8 @@ Summary:    Eventum mail queue process
 Summary(pl):   Przetwarzanie kolejki poczty Eventum
 Group:         Applications/WWW
 Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      /usr/bin/php
 Requires:      crondaemon
-Requires:      php >= 4.1.0
 
 %description mail-queue
 Beginning with the first release of Eventum, emails are not directly
@@ -175,8 +195,8 @@ Summary:    Eventum email download
 Summary(pl):   ¦ci±ganie poczty Eventum
 Group:         Applications/WWW
 Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      /usr/bin/php
 Requires:      crondaemon
-Requires:      php >= 4.1.0
 
 %description mail-download
 In order for Eventum's email integration feature to work, you need to
@@ -196,7 +216,7 @@ Summary:    Eventum Reminder System
 Summary(pl):   System przypominania dla Eventum
 Group:         Applications/WWW
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      php >= 4.1.0
+Requires:      /usr/bin/php
 Requires:      crondaemon
 
 %description reminder
@@ -222,9 +242,9 @@ Summary:    Eventum Heartbeat Monitor
 Summary(pl):   Monitor ¿ycia dla Eventum
 Group:         Applications/WWW
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      php >= 4.1.0
-Requires:      php-posix
+Requires:      /usr/bin/php
 Requires:      crondaemon
+Requires:      php-posix
 
 %description monitor
 The heartbeat monitor is a feature designed for the administrator that
@@ -257,7 +277,7 @@ Summary:    Eventum Email Routing
 Summary(pl):   Przekazywanie poczty dla Eventum
 Group:         Applications/WWW
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      php >= 4.1.0
+Requires:      /usr/bin/php
 Requires:      eventum(router)
 
 %description route-emails
@@ -283,7 +303,7 @@ Summary:    Eventum Note Routing
 Summary(pl):   Przekazywanie notatek dla Eventum
 Group:         Applications/WWW
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      php >= 4.1.0
+Requires:      /usr/bin/php
 Requires:      eventum(router)
 
 %description route-notes
@@ -308,7 +328,9 @@ spraw
 Summary:       Eventum Mail Routing - qmail
 Summary(pl):   Przekazywanie poczty Eventum - qmail
 Group:         Applications/Mail
-Requires:      %{name} = %{epoch}:%{version}-%{release}
+# loose dep is intentional. qmail subpackage isn't built on PLD
+# builders and there really nothing changes.
+Requires:      %{name} >= %{epoch}:%{version}-%{release}
 Requires:      qmail >= 1.03
 Provides:      eventum(router)
 Obsoletes:     eventum(router)
@@ -342,8 +364,10 @@ przez Postfiksa.
 Summary:       Eventum IRC Notification Bot
 Summary(pl):   IRC-owy bot powiadamiaj±cy dla Eventum
 Group:         Applications/WWW
+Requires(triggerpostun):       sed >= 4.0
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      php >= 4.1.0
+Requires:      /usr/bin/php
+#Requires:     php-pear-Net_SmartIRC
 Requires:      php-sockets
 Requires:      rc-scripts >= 0.4.0.18
 
@@ -376,11 +400,11 @@ Summary:  Eventum command-line interface
 Summary(pl):   Interfejs linii poleceñ dla Eventum
 Group:         Applications/WWW
 Requires:      %{name}-base = %{epoch}:%{version}-%{release}
-Requires:      php >= 4.1.0
 Requires:      php-cli
+Requires:      php-common >= 3:4.1.0
 Requires:      php-curl
-Requires:      php-xml
 Requires:      php-pear-XML_RPC
+Requires:      php-xml
 
 %description cli
 The Eventum command-line interface allows you to access most of the
@@ -395,7 +419,9 @@ Summary:    Eventum SCM integration
 Summary(pl):   Integracja SCM dla Eventum
 Group:         Applications/WWW
 Requires:      %{name}-base = %{epoch}:%{version}-%{release}
-Requires:      php >= 4.1.0
+Requires:      php-cli
+Requires:      php-common >= 3:4.1.0
+Requires:      php-pcre
 
 %description scm
 This feature allows your software development teams to integrate your
@@ -421,40 +447,45 @@ Szczeg
 %prep
 %setup -q %{?_snap:-n %{name}-%{_snap}}
 # undos the source
-find . -type f -print0 | xargs -0 sed -i -e 's,
-$,,'
+find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
+
+rm -f setup.conf.php
+rm -rf misc/upgrade/*v1.[123]* # too old to support in PLD
+rm -rf misc/upgrade/flush_compiled_templates.php
+
+sed -e '1s,#!.*/bin/php -q,#!%{_bindir}/php,' misc/cli/eventum > %{name}-cli
+sed -e '1i#!%{_bindir}/php' misc/scm/process_cvs_commits.php > %{name}-scm
+
+# using system package
+#rm -rf include/pear/Net/SmartIRC*
 
 # packaging
 %patch0 -p1 -b .paths
 %patch1 -p1
-%patch2 -p1
+%patch2 -p1 -b .irc-config
 %{?with_pear:%patch3 -p1 -b .PEAR}
-%patch4 -p1
 
 # bug fixes.
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
+%patch9 -p1
 %patch10 -p1
 %patch11 -p1
-%patch12 -p0
+%patch12 -p1
 %patch13 -p1
-%patch14 -p1
-%patch15 -p1
-%patch16 -p1
-%patch17 -p1
-%patch18 -p1
 
 # replace in remaining scripts config.inc.php to system one
 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
        s,include_once(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
 '
-sed -i -e '
-       s,include(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
-' misc/download_emails.php
 
 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
        s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_sysconfdir}/private_key.php"),
 '
-
-rm -f */*~ */*/*~
+find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -462,6 +493,7 @@ install -d \
        $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_libdir}} \
        $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
        $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
+       $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
        $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
 
 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
@@ -475,18 +507,17 @@ cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
 
 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
+install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
+install %{SOURCE14} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
 
 # cli
 install -d $RPM_BUILD_ROOT%{_appdir}/cli
 install misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
 install misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
-sed -e 's,/usr/local/bin/php,/usr/bin/php4,' misc/cli/eventum \
-       > $RPM_BUILD_ROOT%{_bindir}/%{name}
+install %{name}-cli $RPM_BUILD_ROOT%{_bindir}/%{name}
 cp -f misc/cli/eventumrc_example eventumrc
 
 # scm
-echo '#!/usr/bin/php4 -q' > %{name}-scm
-cat misc/scm/process_cvs_commits.php >> %{name}-scm
 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
 
 # private key
@@ -497,6 +528,7 @@ s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
 ' $RPM_BUILD_ROOT%{_sysconfdir}/private_key.php
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
@@ -505,8 +537,14 @@ install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
-sed -e 's,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}},' \
-       %{SOURCE10} > $RPM_BUILD_ROOT%{_sysconfdir}/core.php
+
+sed -e '
+s,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}},
+s,%%{PHP_PEAR_DIR}%%,%{?with_pear:%{php_pear_dir}}%{!?with_pear:%{_appdir}/includes/pear},
+s,%%{APP_PATH}%%,%{_appdir},
+s,%%{SMARTY_DIR}%%,%{_smartydir},
+s,%%{SYSCONFDIR}%%,%{_sysconfdir},
+' %{SOURCE10} > $RPM_BUILD_ROOT%{_sysconfdir}/core.php
 
 # config
 > $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
@@ -524,10 +562,13 @@ rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
 # These plugins are not in Smarty package (Smarty-2.6.2-3)
-cp -a include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
+cp -a \
+       include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
+       include/Smarty/plugins/modifier.highlight_quoted.php \
        $RPM_BUILD_ROOT%{_smartyplugindir}
 
 # qmail router
+%if %{with qmail}
 d=$RPM_BUILD_ROOT/var/lib/%{name}
 echo 'root' > $d/.qmail
 echo 'root' > $d/.qmail-default
@@ -535,6 +576,7 @@ echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -543,35 +585,39 @@ rm -rf $RPM_BUILD_ROOT
 %addusertogroup http %{name}
 
 %post
-# apache1
-if [ -d %{_apache1dir}/conf.d ]; then
-       ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
-       if [ -f /var/lock/subsys/apache ]; then
-               /etc/rc.d/init.d/apache restart 1>&2
-       fi
-fi
-# apache2
-if [ -d %{_apache2dir}/httpd.conf ]; then
-       ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
-       fi
-fi
-
 # check if the package is configured.
 if grep -q 'header("Location: setup/")' %{_sysconfdir}/config.php; then
+if [ -f %{_appdir}/htdocs/setup/index.php ]; then
 %banner %{name} -e <<EOF
 
 You haven't yet configured Eventum!
+Please open in browser <http://localhost/eventum/>
+If you need access from elsewhere, you need to edit
+%{_sysconfdir}/apache.conf and restart apache.
 
-Install %{name}-setup and open up http://yourserver/eventum/
--- that will help you setup initial config.
+IMPORTANT: When You have configured Eventum, please uninstall the
+setup package, so that %{name}-setup is able to secure your Eventum
+installation.
 
-when have configured Eventum, please uninstall the setup package,
-so that %{name}-setup is able to secure your Eventum installation.
+EOF
+#' vim stupidity.
+else
+%banner %{name} -e <<EOF
+
+You haven't yet configured Eventum!
+
+To setup eventum, please install %{name}-setup and open in browser
+<http://localhost/eventum/>.
+If you need access from elsewhere, you need to edit
+%{_sysconfdir}/apache.conf and restart apache.
+
+IMPORTANT: When You have configured Eventum, please uninstall the
+setup package, so that %{name}-setup is able to secure your Eventum
+installation.
 
 EOF
 #' vim stupidity.
+fi
 
 elif grep -q 'DEFAULTPRIVATEKEY' %{_sysconfdir}/private_key.php; then
 %banner %{name} -e <<EOF
@@ -599,29 +645,13 @@ rm -f /var/cache/eventum/*.php
 
 %preun
 if [ "$1" = "0" ]; then
-       # apache1
-       if [ -f %{_apache1dir}/apache.conf ]; then
-               rm -f %{_apache1dir}/conf.d/99_%{name}.conf
-               if [ -f /var/lock/subsys/apache ]; then
-                       /etc/rc.d/init.d/apache restart 1>&2
-               fi
-       fi
-       # apache2
-       if [ -d %{_apache2dir}/httpd.conf ]; then
-               rm -f %{_apache2dir}/httpd.conf/99_%{name}.conf
-               if [ -f /var/lock/subsys/httpd ]; then
-                       /etc/rc.d/init.d/httpd restart 1>&2
-               fi
-       fi
+       # nuke cache
+       rm -f /var/cache/eventum/*.php 2>/dev/null || :
 fi
 
-%postun
-# nuke cache
-rm -f /var/cache/eventum/*.php
-
 %pre base
-%groupadd -P %{name}-base %{name}
-%useradd -P %{name}-base -d /var/lib/%{name} -g %{name} %{name} -c "Eventum User"
+%groupadd -P %{name}-base -g 146 %{name}
+%useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
 
 %postun base
 if [ "$1" = "0" ]; then
@@ -629,6 +659,7 @@ if [ "$1" = "0" ]; then
        %groupremove %{name}
 fi
 
+%if %{with qmail}
 %post router-qmail
 CF=/etc/qmail/control/virtualdomains
 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
@@ -652,6 +683,7 @@ fi
 if [ "$1" = "0" ]; then
        sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
 fi
+%endif
 
 %post setup
 chmod 660 %{_sysconfdir}/{config,private_key}.php
@@ -663,44 +695,132 @@ if [ "$1" = "0" ]; then
        chown root:eventum %{_sysconfdir}/{config,private_key}.php
 fi
 
-%triggerpostun base -- eventum-base < 1.4-2.20050222.212
-if [ "`getent passwd %{name} | cut -d: -f6`" = "%{_appdir}" ]; then
-       /usr/sbin/usermod -d /var/lib/%{name} %{name}
+%post irc
+/sbin/chkconfig --add eventum-irc
+if [ -f /var/lock/subsys/eventum-irc ]; then
+       /etc/rc.d/init.d/eventum-irc restart >&2
+else
+       echo "Run \"/etc/rc.d/init.d/eventum-irc start\" to start Eventum IRC Bot." >&2
 fi
 
-%triggerpostun -- eventum < 1.5-0.240
-scriptdir=%{_appdir}/upgrade/v1.4_to_1.5
-%banner %{name}-trigger-1.5 -e <<-EOF
+%triggerin -- apache1
+%webapp_register apache %{_webapp}
 
-       Running eventum upgrade scripts to 1.5 in $scriptdir
-       These will fail if your eventum user doesn't have ALTER privilege to database.
+%triggerun -- apache1
+%webapp_unregister apache %{_webapp}
 
-EOF
-#'
+%triggerin -- apache >= 2.0.0
+%webapp_register httpd %{_webapp}
 
-/usr/bin/php4 -q $scriptdir/database_changes.php || {
-       echo >&2 "Please run manually: /usr/bin/php4 -q $scriptdir/database_changes.php"
-}
+%triggerun -- apache >= 2.0.0
+%webapp_unregister httpd %{_webapp}
 
+# FIXME
+# only one upgrade trigger is called if you're upgrading over two
+# versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
+# use common trigger (the highest version and rpmvercmp from poldek?)
 %triggerpostun -- eventum < 1.5.1-0.257
-scriptdir=%{_appdir}/upgrade/v1.5_to_v1.5.1
-%banner %{name}-trigger-1.5.1 -e <<-EOF
+%{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
+database_changes.php Perform database changes
+EOF
+
+%triggerpostun -- eventum < 1.5.2-0.289
+%{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
+database_changes.php Perform database changes
+set_priority_ranks.php Fix the ranking of priority values
+EOF
+
+%triggerpostun -- eventum < 1.5.3-0.291
+%{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
+database_changes.php Perform database changes
+EOF
+
+%triggerpostun -- eventum < 1.5.4-1.12
+%{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
+database_changes.php Perform database changes
+EOF
+
+%triggerpostun -- eventum < 1.6.0-RC2.6
+%{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.5_to_v1.6.0 <<EOF
+database_changes.php Perform database changes
+upgrade_saved_searches.php Upgrade existing custom filters (saved searches)
+EOF
+
+%triggerpostun -- eventum < 1.6.1-0.2
+%{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.0_to_v1.6.1 <<EOF
+database_changes.php Perform database changes
+EOF
 
-       Running eventum upgrade scripts to 1.5.1 in $scriptdir
-       These will fail if your eventum user doesn't have ALTER privilege to database.
+%triggerpostun irc -- eventum-irc < 1.6.1-3.14
+sed -i -e '
+s,\$irc_host,$irc_server_hostname,
+s,\$irc_port,$irc_server_port,
+s,\$irc_nick,$nickname,
+s,\$irc_realname,$realname,
+s,\$irc_username,$username,
+s,\$irc_password,$password,
+' /etc/eventum/irc.php
+
+%triggerpostun -- eventum < 1.7.0-0.20051130.4.25
+# migrate from apache-config macros
+if [ -f /etc/%{name}/apache.conf.rpmsave ]; then
+       if [ -d /etc/apache/webapps.d ]; then
+               cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
+               cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
+       fi
 
+       if [ -d /etc/httpd/webapps.d ]; then
+               cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
+               cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
+       fi
+fi
+
+if [ -L /etc/apache/conf.d/99_%{_webapp}.conf ]; then
+       /usr/sbin/webapp register apache %{_webapp}
+       rm -f /etc/apache/conf.d/99_%{_webapp}.conf
+       if [ -f /var/lock/subsys/apache ]; then
+               /etc/rc.d/init.d/apache reload 1>&2
+       fi
+fi
+if [ -L /etc/httpd/httpd.conf/99_%{_webapp}.conf ]; then
+       /usr/sbin/webapp register httpd %{_webapp}
+       rm -f /etc/httpd/httpd.conf/99_%{_webapp}.conf
+       if [ -f /var/lock/subsys/httpd ]; then
+               /etc/rc.d/init.d/httpd reload 1>&2
+       fi
+fi
+
+%{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.1_to_v1.7.0 <<EOF
+database_changes.php Perform database changes
+set_root_message_ids.php Set iss_root_message_id
 EOF
-#'
 
-/usr/bin/php4 -q $scriptdir/database_changes.php || {
-       echo >&2 "Please run manually: /usr/bin/php4 -q $scriptdir/database_changes.php"
-}
+# regular configs
+for i in apache.conf config.php private_key.php setup.php; do
+       if [ -f /etc/eventum/$i.rpmsave ]; then
+               mv -f %{_sysconfdir}/$i{,.rpmnew}
+               mv -f /etc/eventum/$i.rpmsave %{_sysconfdir}/$i
+       fi
+done
+
+%triggerpostun cli -- %{name}-cli < 1.6.1-4.16
+if [ -f /etc/eventum/cli.php.rpmsave ]; then
+       mv -f %{_sysconfdir}/cli.php{,.rpmnew}
+       mv -f /etc/eventum/cli.php.rpmsave %{_sysconfdir}/cli.php
+fi
+
+%triggerpostun irc -- %{name}-irc < 1.6.1-4.17
+if [ -f /etc/eventum/irc.php.rpmsave ]; then
+       mv -f %{_sysconfdir}/irc.php{,.rpmnew}
+       mv -f /etc/eventum/irc.php.rpmsave %{_sysconfdir}/irc.php
+fi
 
 %files
 %defattr(644,root,root,755)
 %doc ChangeLog FAQ INSTALL README UPGRADE
 %doc docs/* rpc/xmlrpc_client.php setup/schema.sql
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
@@ -722,9 +842,11 @@ EOF
 %{_appdir}/htdocs/misc
 
 %{_appdir}/templates
-%{_appdir}/upgrade
+%dir %{_appdir}/upgrade
+%attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
+%{_appdir}/upgrade/[!u]*
 
-%{_smartyplugindir}/*
+%{_smartyplugindir}
 %if %{without pear}
 %{_appdir}/include/pear
 %endif
@@ -739,7 +861,6 @@ EOF
 %{_appdir}/include/class.mime_helper.php
 %{_appdir}/include/class.misc.php
 %{_appdir}/include/db_access.php
-%{_appdir}/include/jsrsServer.inc.php
 
 %dir %attr(730,root,eventum) /var/run/%{name}
 %dir %attr(730,root,eventum) /var/cache/%{name}
@@ -751,6 +872,10 @@ EOF
 %dir %{_appdir}
 # qmail will ignore user, if it's home directory is not owned
 %attr(750,eventum,eventum) %dir /var/lib/%{name}
+# saved mail copies
+%attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
+%attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
+%attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
 
 %files setup
 %defattr(644,root,root,755)
@@ -786,10 +911,12 @@ EOF
 %{_appdir}/route_drafts.php
 %{_appdir}/route_notes.php
 
+%if %{with qmail}
 %files router-qmail
 %defattr(644,root,root,755)
 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
 %attr(755,root,root) %{_libdir}/router-qmail
+%endif
 
 %files router-postfix
 %defattr(644,root,root,755)
This page took 0.631488 seconds and 4 git commands to generate.