]> git.pld-linux.org Git - packages/eventum.git/blobdiff - eventum.spec
fix Math_Stats autoload
[packages/eventum.git] / eventum.spec
index d835d1595422dad4ac45a86f72fa4e7e6074cbe7..38be70aa3ad80d4473cb4c4deeecce14edb9cb10 100644 (file)
@@ -2,28 +2,25 @@
 # Conditional build:
 %bcond_with    order   # with experimental order patch
 
-%define                rel             0.1
-#define                subver  347
-#define                githash 3d9195fa
-%define                php_min_version 5.5.0
-%include       /usr/lib/rpm/macros.php
+%define                rel             2
+#define                subver  7
+#define                githash f3c41492
+%define                php_min_version 5.6.0
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl.UTF-8):     Eventum - system śledzenia spraw/błędów
 Name:          eventum
-Version:       3.2.0
+Version:       3.5.4
 Release:       %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
 License:       GPL v2+
 Group:         Applications/WWW
-Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: c7d8a0653211ba6c17ad6d490197efb2
-#Source0:      https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.gz
+Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.xz
+# Source0-md5: 47414f0f8e5a1047f4b5478580c11bee
+#Source0:      https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.xz
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
 Source4:       %{name}-reminder.cron
 Source5:       %{name}-monitor.cron
-Source8:       %{name}-irc.init
-Source9:       %{name}-irc.sysconfig
 Source10:      sphinx.crontab
 Source13:      %{name}-router-postfix.sh
 Source14:      %{name}.logrotate
@@ -42,9 +39,11 @@ Patch108:    autoload.patch
 Patch200:      %{name}-fixed-nav.patch
 URL:           https://wiki.github.com/eventum/eventum/
 BuildRequires: gettext-tools
-BuildRequires: rpm-php-pearprov >= 4.0.2-98
 BuildRequires: rpmbuild(macros) >= 1.654
 BuildRequires: sed >= 4.0
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
+Requires(post):        sudo
 Requires(postun):      /usr/sbin/groupdel
 Requires(postun):      /usr/sbin/userdel
 Requires(pre): /bin/id
@@ -65,13 +64,11 @@ Requires:   php-Smarty >= 3.1
 Requires:      php-Smarty-plugin-gettext
 Requires:      php-ZendFramework-Config >= 2.4
 Requires:      php-ZendFramework-Loader >= 2.4
-Requires:      php-ZendFramework-Mail >= 2.4.9-2
+Requires:      php-ZendFramework-Mail >= 2.4.13-2
 Requires:      php-ZendFramework-Mime >= 2.4
 Requires:      php-ZendFramework-ServiceManager >= 2.4
 Requires:      php-ZendFramework-Validator >= 2.4
 Requires:      php-monolog >= 1.17.2
-Requires:      php-pear-Mail_Mime
-Requires:      php-pear-Mail_mimeDecode
 Requires:      php-pear-Math_Stats
 Requires:      php-pear-Net_SMTP
 Requires:      php-pear-Net_Socket
@@ -79,13 +76,6 @@ Requires:    php-pear-Net_URL
 Requires:      php-pear-PEAR-core
 Requires:      php-pear-Text_Diff
 Requires:      php-psr-Log >= 1.0.0-2
-Requires:      php-symfony2-Config >= 2.7.7
-Requires:      php-symfony2-Console >= 2.7.7
-Requires:      php-symfony2-Filesystem >= 2.7.7
-Requires:      php-symfony2-HttpFoundation >= 2.7.7
-Requires:      php-symfony2-OptionsResolver >= 2.7.7
-Requires:      php-symfony2-Serializer >= 2.7.7
-Requires:      php-symfony2-Yaml >= 2.7.7
 Requires:      phplot >= 5.8.0
 Requires:      webapps
 Requires:      webserver(access)
@@ -95,7 +85,6 @@ Requires:     webserver(php) >= 4.2.0
 Suggests:      localedb
 Suggests:      php(mcrypt)
 Suggests:      php(openssl)
-Suggests:      php-pear-Net_LDAP2
 Suggests:      php-pear-Net_POP3
 Suggests:      webserver(setenv)
 Provides:      group(eventum)
@@ -108,13 +97,6 @@ Conflicts:  logrotate < 3.8.0
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
-
-# exclude optional php dependencies
-%define                _noautophp      php-gnupg php-hash php-pecl-http php-tk
-
-%define                _noautoreq      %{_noautophp}
-
 %define                _libdir         %{_prefix}/lib/%{name}
 %define                _appdir         %{_datadir}/%{name}
 %define                _smartydir      %{php_data_dir}/Smarty
@@ -285,41 +267,6 @@ przez Postfiksa.
 Opis konfiguracji Postfiksa można znaleźć pod adresem
 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
 
-%package irc
-Summary:       Eventum IRC Notification Bot
-Summary(pl.UTF-8):     IRC-owy bot powiadamiający dla Eventum
-Group:         Applications/WWW
-Requires(post,preun):  /sbin/chkconfig
-Requires:      %{name} = %{version}-%{release}
-Requires:      php(pcntl)
-Requires:      php(sockets)
-Requires:      php-pear-Net_SmartIRC >= 1.1.9
-Requires:      rc-scripts >= 0.4.0.18
-
-%description irc
-The IRC notification bot is a nice feature for remote teams that want
-to handle issues and want to have a quick and easy way to get simple
-notifications. Right now the bot notifies of the following actions:
-- New Issues
-- Blocked emails
-- Issues that got their assignment list changed
-
-NOTE: You will need to manually edit the bot.php script to set your
-appropriate preferences, like IRC server and channel that the bot
-should join.
-
-%description irc -l pl.UTF-8
-IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
-zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
-uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
-następujących zdarzeniach:
-- nowych sprawach
-- zablokowanych listach
-- sprawach, dla których zmieniła się lista powiązań
-
-UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
-kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
-
 %package cli
 Summary:       Eventum command-line interface
 Summary(pl.UTF-8):     Interfejs linii poleceń dla Eventum
@@ -385,7 +332,6 @@ rm config/config.php
 
 rm htdocs/.htaccess.dist
 
-mv config/irc_config{.dist.php,.php}
 rm config/config.dist.php
 
 # cleanup vendor. keep only needed libraries.
@@ -409,6 +355,39 @@ vendor theorchard/monolog-cascade
 vendor malkusch/lock
 vendor phpxmlrpc/phpxmlrpc
 vendor robmorgan/phinx
+vendor mnapoli/silly
+vendor psr/container
+vendor phlib/flysystem-pdo
+vendor league/flysystem
+vendor php-di/invoker
+vendor container-interop/container-interop
+vendor symfony/config
+vendor symfony/console
+vendor symfony/debug
+vendor symfony/event-dispatcher
+vendor symfony/filesystem
+vendor symfony/http-foundation
+vendor symfony/options-resolver
+vendor symfony/serializer
+vendor symfony/yaml
+vendor symfony/ldap
+vendor paragonie/random_compat
+vendor symfony/polyfill-php70
+vendor symfony/polyfill-intl-normalizer
+vendor symfony/security-core
+vendor symfony/security-csrf
+vendor glen/filename-normalizer
+vendor doctrine/annotations
+vendor doctrine/cache
+vendor doctrine/collections
+vendor doctrine/common
+vendor doctrine/dbal
+vendor doctrine/inflector
+vendor doctrine/instantiator
+vendor doctrine/lexer
+vendor doctrine/orm
+vendor cebe/markdown
+vendor enrise/urihelper
 
 # remove backups from patching as we use globs to package files to buildroot
 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
@@ -423,7 +402,7 @@ install -d \
        $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
        $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
        $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
-       $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
+       $RPM_BUILD_ROOT/var/lib/%{name}/{routed_{emails,drafts,notes},storage} \
        $RPM_BUILD_ROOT%{systemdtmpfilesdir}
 
 %{__make} install-eventum install-cli install-localization \
@@ -458,9 +437,6 @@ cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
 
-install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
-cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
-
 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 
 # postfix router
@@ -485,7 +461,6 @@ for a in \
        errors.log login_attempts.log \
        eventum.log \
        auth.log cli.log \
-       irc_bot_error.log irc_bot_smartirc.log \
 ; do
        test -f /var/log/%{name}/$a && continue
        install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
@@ -493,7 +468,7 @@ done
 
 # run database update if configured
 test -s %{_webappdir}/config.php && \
-%{_appdir}/bin/upgrade.php || :
+sudo -H -u http -- %{_appdir}/bin/upgrade.php || :
 
 # nuke Smarty templates cache after upgrade
 rm -f /var/cache/eventum/*.php
@@ -524,16 +499,6 @@ if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
        chown root:http %{_webappdir}/{config,private_key,secret_key}.php
 fi
 
-%post irc
-/sbin/chkconfig --add eventum-irc
-%service eventum-irc restart "Eventum IRC Bot"
-
-%preun irc
-if [ "$1" = 0 ]; then
-       %service eventum-irc stop
-       /sbin/chkconfig --del eventum-irc
-fi
-
 %triggerin -- apache1 < 1.3.37-3, apache1-base
 %webapp_register apache %{_webapp}
 
@@ -552,20 +517,9 @@ fi
 %triggerun -- lighttpd
 %webapp_unregister lighttpd %{_webapp}
 
-%triggerpostun -- %{name} < 3.0.0-0.2
-for f in /etc/cron.d/eventum-*; do
-       # crontabs moved to bin
-       %{__sed} -i -e '
-               s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
-               s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
-               s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
-               s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
-       ' $f
-done
-
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%attr(751,root,root) %dir %{_webappdir}
+%attr(771,root,http) %dir %{_webappdir}
 %attr(751,root,http) %dir %{_webappdir}/crm
 %attr(751,root,http) %dir %{_webappdir}/custom_field
 %attr(751,root,http) %dir %{_webappdir}/partner
@@ -589,6 +543,9 @@ done
 %{_appdir}/config
 
 %dir %{_appdir}/bin
+%attr(755,root,root) %{_appdir}/bin/extension.php
+%attr(755,root,root) %{_appdir}/bin/ldapsync.php
+%attr(755,root,root) %{_appdir}/bin/migrate_storage_adapter.php
 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
 %attr(755,root,root) %{_appdir}/bin/upgrade.php
 
@@ -610,9 +567,6 @@ done
 %{_appdir}/htdocs/components
 %{_appdir}/templates
 
-%dir %{_appdir}/upgrade
-%{_appdir}/upgrade/*.sql
-%{_appdir}/upgrade/patches
 %dir %{_appdir}/db
 %dir %{_appdir}/db/migrations
 %{_appdir}/db/migrations/*.php
@@ -622,7 +576,11 @@ done
 %{_appdir}/vendor
 %dir %{_appdir}/lib
 %{_appdir}/lib/eventum
-%exclude %{_appdir}/lib/eventum/class.monitor.php
+%exclude %{_appdir}/src/Console/Command/MailDownloadCommand.php
+%exclude %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
+%exclude %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
+%exclude %{_appdir}/src/Console/Command/MonitorCommand.php
+%exclude %{_appdir}/src/Console/Command/ReminderCheckCommand.php
 
 %dir %{_libdir}
 
@@ -636,6 +594,8 @@ done
 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
+# attachment storage
+%attr(770,root,http) %dir /var/lib/%{name}/storage
 
 %files setup
 %defattr(644,root,root,755)
@@ -648,23 +608,27 @@ done
 
 %files mail-queue
 %defattr(644,root,root,755)
+%{_appdir}/src/Console/Command/MailQueueProcessCommand.php
+%{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
 
 %files mail-download
 %defattr(644,root,root,755)
+%{_appdir}/src/Console/Command/MailDownloadCommand.php
 %attr(755,root,root) %{_appdir}/bin/download_emails.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
 
 %files reminder
 %defattr(644,root,root,755)
+%{_appdir}/src/Console/Command/ReminderCheckCommand.php
 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
 
 %files monitor
 %defattr(644,root,root,755)
-%{_appdir}/lib/eventum/class.monitor.php
+%{_appdir}/src/Console/Command/MonitorCommand.php
 %attr(755,root,root) %{_appdir}/bin/monitor.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
 
@@ -672,13 +636,6 @@ done
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/router-postfix
 
-%files irc
-%defattr(644,root,root,755)
-%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
-%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
-%attr(755,root,root) %{_appdir}/bin/irc-bot.php
-%attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
-
 %files cli
 %defattr(644,root,root,755)
 %doc cli/eventumrc
This page took 0.118786 seconds and 4 git commands to generate.