]> git.pld-linux.org Git - packages/eventum.git/blobdiff - eventum.spec
- shellglob syntax fix
[packages/eventum.git] / eventum.spec
index 5685b6005d3c893eebef65f6349a57a77c687acd..369edbeddc40c44a57fc3256283bd9436b2bea12 100644 (file)
@@ -1,20 +1,21 @@
 # TODO
-# - where to put templates_c (templates cache dir)? /var/run/eventum? /var/run/php/eventum? /var/cache/eventum?
+# - system pear is incompatible, at least pear DB class seems broke Eventum
 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
 # - discard bundled packages (from INSTALL):
 #  - JpGraph 1.5.3 (last GPL version)
-#  - PEAR packages
 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
 #  - A few other small javascript libraries
-# - Command-line Interface (misc/cli/eventum)
-# - create eventum-router-qmail, eventum-router-postfix for -route-mails and -route-notes
 # - need start-stop-daemon (from dpkg for now)
-# - use eventum user for irc bot?
+
+%bcond_with    pear    # build with system PEAR packages (or use bundled ones)
+
+%define        uid     146
+%define        gid     146
 
 # snapshot: DATE
-#define _snap 20050117
+%define _snap 20050222
 
 %if 0%{?_snap}
 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
 %define _source http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
 %endif
 
-%define _rel 1.94
+%define _rel 222
 
-Summary:       Eventum Issue - a bug tracking system
+Summary:       Eventum Issue / Bug tracking system
 Summary(pl):   Eventum - system ¶ledzenia spraw/b³êdów
 Name:          eventum
 Version:       1.4
-Release:       %{?_snap:0.%{_snap}.}%{_rel}
+Release:       2.%{?_snap:%{_snap}.}%{_rel}
 License:       GPL
 Group:         Applications/WWW
 Source0:       %{_source}
-# Source0-md5: 361c1355e46a6bbfa54e420964ec92cf
+# Source0-md5: 035bd8f7890260c1c058eaf1d54dcc90
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
@@ -41,27 +42,60 @@ Source5:    %{name}-monitor.cron
 Source6:       %{name}-cvs.php
 Source7:       %{name}-irc.php
 Source8:       %{name}-irc.init
+Source9:       %{name}-irc.sysconfig
+Source10:      %{name}-config.php
+Source11:      %{name}-router-qmail.sh
 Patch0:                %{name}-paths.patch
-Patch1:                %{name}-clock-status.patch
-Patch2:                %{name}-scm-encode.patch
-Patch3:                %{name}-cvs-config.patch
-Patch4:                %{name}-irc-config.patch
-Patch5:                %{name}-scm_checkin_associated.patch
+Patch1:                %{name}-scm-encode.patch
+Patch2:                %{name}-cvs-config.patch
+Patch3:                %{name}-irc-config.patch
+Patch4:                %{name}-PEAR.patch
+Patch11:       %{name}-scm_checkin_associated.patch
+Patch12:       %{name}-mail-queue.tpl.patch
+Patch13:       %{name}-maildecode.patch
+Patch14:       %{name}-send-typo.patch
+Patch15:       %{name}-fixes.patch
+Patch16:       %{name}-rss-charset.patch
+Patch17:       %{name}-scm-silence-add.patch
+Patch18:       %{name}-default-TZ.patch
+Patch19:       %{name}-charset-mailsubj.patch
+Patch20:       %{name}-monitor-bot-process.patch
 URL:           http://dev.mysql.com/downloads/other/eventum/index.html
 BuildRequires: rpmbuild(macros) >= 1.177
 BuildRequires: sed >= 4.0
-Requires:      php >= 4.1.0
+Requires:      php >= 4.2.0
 Requires:      php-gd
 Requires:      php-imap
 Requires:      php-mysql
 Requires:      php-pcre
+Requires:      %{name}-base = %{epoch}:%{version}-%{release}
 Requires:      Smarty >= 2.6.2
-#Requires:     apache-mod_dir
-# conflict with non-confdir apache
-Conflicts:     apache1 < 1.3.33-1.1
+%if %{with pear}
+Requires:      php-pear-Benchmark
+Requires:      php-pear-DB
+Requires:      php-pear-Date
+Requires:      php-pear-HTTP_Request
+Requires:      php-pear-Mail
+Requires:      php-pear-Math_Stats
+Requires:      php-pear-Net_DIME
+Requires:      php-pear-Net_POP3
+Requires:      php-pear-Net_SMTP
+Requires:      php-pear-Net_SmartIRC
+Requires:      php-pear-Net_Socket
+Requires:      php-pear-Net_URL
+Requires:      php-pear-Net_UserAgent_Detect
+Requires:      php-pear-PEAR
+Requires:      php-pear-Text_Diff
+Requires:      php-pear-XML_RPC
+%endif
+Requires:      apache >= 1.3.33-2
+Requires:      apache(mod_dir)
+Requires(triggerpostun):       sed >= 4.0
+BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/%{name}
+%define                _libdir         %{_prefix}/%{_lib}/%{name}
 %define                _appdir %{_datadir}/%{name}
 %define                _smartyplugindir        %{php_pear_dir}/Smarty/plugins
 
@@ -83,6 +117,17 @@ szybkiej organizacji zada
 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
 reakcji.
 
+%package base
+Summary:       Eventum base package
+Summary(pl):   Podstawowy pakiet Eventum
+Group:         Applications/WWW
+
+%description base
+This package contains base directory structure for Eventum.
+
+%description base -l pl
+Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
+
 %package setup
 Summary:       Eventum setup package
 Summary(pl):   Pakiet do wstêpnej konfiguracji Eventum
@@ -105,7 +150,7 @@ Summary(pl):        Przetwarzanie kolejki poczty Eventum
 Group:         Applications/WWW
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      crondaemon
-Requires:      php4 >= 4.1.0
+Requires:      php >= 4.1.0
 
 %description mail-queue
 Beginning with the first release of Eventum, emails are not directly
@@ -131,7 +176,7 @@ Summary(pl):        
 Group:         Applications/WWW
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      crondaemon
-Requires:      php4 >= 4.1.0
+Requires:      php >= 4.1.0
 
 %description mail-download
 In order for Eventum's email integration feature to work, you need to
@@ -151,7 +196,7 @@ Summary:    Eventum Reminder System
 Summary(pl):   System przypominania dla Eventum
 Group:         Applications/WWW
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      php4 >= 4.1.0
+Requires:      php >= 4.1.0
 Requires:      crondaemon
 
 %description reminder
@@ -177,7 +222,8 @@ Summary:    Eventum Heartbeat Monitor
 Summary(pl):   Monitor ¿ycia dla Eventum
 Group:         Applications/WWW
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      php4 >= 4.1.0
+Requires:      php >= 4.1.0
+Requires:      php-posix
 Requires:      crondaemon
 
 %description monitor
@@ -211,8 +257,8 @@ Summary:    Eventum Email Routing
 Summary(pl):   Przekazywanie poczty dla Eventum
 Group:         Applications/WWW
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      php4 >= 4.1.0
-#Requires:     eventum-router
+Requires:      php >= 4.1.0
+Requires:      eventum-router
 
 %description route-emails
 The email routing feature is used to automatically associate a thread
@@ -237,8 +283,8 @@ Summary:    Eventum Note Routing
 Summary(pl):   Przekazywanie notatek dla Eventum
 Group:         Applications/WWW
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      php4 >= 4.1.0
-#Requires:     eventum-router
+Requires:      php >= 4.1.0
+Requires:      eventum-router
 
 %description route-notes
 The note routing feature is used to automatically associate a thread
@@ -258,12 +304,45 @@ u
 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
 
+%package router-qmail
+Summary:       Eventum Mail Routing - qmail
+Summary(pl):   Przekazywanie poczty Eventum - qmail
+Group:         Applications/Mail
+Requires:      %{name}-base = %{epoch}:%{version}-%{release}
+Requires:      qmail >= 1.03
+Provides:      eventum-router
+
+%description router-qmail
+This package provides way of routing notes and emails back to Eventum
+via qmail.
+
+%description router-qmail -l pl
+Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
+przez qmaila.
+
+%package router-postfix
+Summary:       Eventum Mail Routing - Postfix
+Summary(pl):   Przekazywanie poczty Eventum - Postfix
+Group:         Applications/Mail
+Requires:      %{name}-base = %{epoch}:%{version}-%{release}
+Requires:      postfix
+Provides:      eventum-router
+
+%description router-postfix
+This package provides way of routing notes and emails back to Eventum
+via Postfix.
+
+%description router-postfix -l pl
+Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
+przez Postfiksa.
+
 %package irc
 Summary:       Eventum IRC Notification Bot
 Summary(pl):   IRC-owy bot powiadamiaj±cy dla Eventum
 Group:         Applications/WWW
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      php4 >= 4.1.0
+Requires:      php >= 4.1.0
+Requires:      php-sockets
 # FIXME just need start-stop-daemon
 Requires:      dpkg
 
@@ -295,11 +374,12 @@ kana
 Summary:       Eventum command-line interface
 Summary(pl):   Interfejs linii poleceñ dla Eventum
 Group:         Applications/WWW
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      php4 >= 4.1.0
-Requires:      php4-cli
-Requires:      php4-curl
-#Requires:     php4-openssl
+Requires:      %{name}-base = %{epoch}:%{version}-%{release}
+Requires:      php >= 4.1.0
+Requires:      php-cli
+Requires:      php-curl
+Requires:      php-xml
+Requires:      php-pear-XML_RPC
 
 %description cli
 The Eventum command-line interface allows you to access most of the
@@ -313,8 +393,8 @@ funkcji interfejsu WWW prosto z linii polece
 Summary:       Eventum SCM integration
 Summary(pl):   Integracja SCM dla Eventum
 Group:         Applications/WWW
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      php4 >= 4.1.0
+Requires:      %{name}-base = %{epoch}:%{version}-%{release}
+Requires:      php >= 4.1.0
 
 %description scm
 This feature allows your software development teams to integrate your
@@ -324,7 +404,7 @@ The integration is implemented in such a way that it will be forward
 compatible with pretty much any SCM system, such as CVS.
 
 For installation see
-/eventum/help.php?topic=scm_integration_installation .
+</eventum/help.php?topic=scm_integration_installation>.
 
 %description scm -l pl
 Ten pakiet pozwala zespo³om programistów na integracjê systemu
@@ -335,38 +415,83 @@ Integracja jest zaimplementowana tak, aby by
 prawie ka¿dym systemem SCM, jak np. CVS.
 
 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
-/eventum/help.php?topic=scm_integration_installation .
+</eventum/help.php?topic=scm_integration_installation>.
 
 %prep
 %setup -q %{?_snap:-n %{name}-%{_snap}}
-%patch0 -p1
+# undos the source
+find . -type f -print0 | xargs -0 sed -i -e 's,
+$,,'
+
+# packaging
+%patch0 -p1 -b .paths
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
-%patch5 -p1
+%{?with_pear:%patch4 -p1 -b .PEAR}
+
+# bug fixes.
+%patch11 -p1
+#%patch12 -p1
+#%patch13 -p1
+#%patch14 -p1
+#%patch15 -p1
+#%patch16 -p1
+#%patch17 -p1
+#%patch18 -p1
+%patch19 -p1
+%patch20 -p1
+
+# replace in remaining scripts config.inc.php to system one
+grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
+       s,include_once(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
+'
+sed -i -e '
+       s,include(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
+' misc/download_emails.php
 
-%build
+grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
+       s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_sysconfdir}/private_key.php"),
+'
+
+rm -f */*~ */*/*~
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},/etc/{rc.d/init.d,cron.d},%{_appdir}/{locks,templates_c},/var/log}
-
-cp -a . $RPM_BUILD_ROOT%{_appdir}
-# argsh! say no words
-find $RPM_BUILD_ROOT%{_appdir} -type f -print0 | xargs -0 sed -i -e 's,
-$,,'
-sed -e 's,
-$,,' misc/cli/eventumrc_example > eventumrc
-
-> $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
-
-sed -i -e 's,/usr/local/bin/php,/usr/bin/php4,' $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum
-
+install -d \
+       $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_libdir}} \
+       $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
+       $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
+       $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc} \
+
+cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
+cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
+cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
+cp -a misc/irc $RPM_BUILD_ROOT%{_appdir}
+cp -a templates $RPM_BUILD_ROOT%{_appdir}
+cp -a include/{customer,jpgraph,pear,workflow} $RPM_BUILD_ROOT%{_appdir}/include
+cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
+cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
+
+# cli
+install -d $RPM_BUILD_ROOT%{_appdir}/cli
+install misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
+install misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
+sed -e 's,/usr/local/bin/php,/usr/bin/php4,' misc/cli/eventum \
+       > $RPM_BUILD_ROOT%{_bindir}/%{name}
+cp -f misc/cli/eventumrc_example eventumrc
+
+# scm
+echo '#!/usr/bin/php4 -q' > %{name}-scm
+cat misc/scm/process_cvs_commits.php >> %{name}-scm
+install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
+
+# private key
+mv $RPM_BUILD_ROOT{%{_appdir}/include/private_key.php,%{_sysconfdir}}
 # change private key, so we can easily grep
 sed -i -e '
 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
-' $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
+' $RPM_BUILD_ROOT%{_sysconfdir}/private_key.php
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
@@ -376,41 +501,47 @@ install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
+install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
+sed -e 's,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}},' \
+       %{SOURCE10} > $RPM_BUILD_ROOT%{_sysconfdir}/core.php
 
-# in conf
-mv $RPM_BUILD_ROOT%{_appdir}/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/config.php
-mv $RPM_BUILD_ROOT%{_appdir}/setup.conf.php $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
-mv $RPM_BUILD_ROOT%{_appdir}/include/private_key.php $RPM_BUILD_ROOT%{_sysconfdir}
-mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
-ln -s %{_sysconfdir}/config.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
-ln -s %{_sysconfdir}/setup.php $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
-ln -s %{_sysconfdir}/private_key.php $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
+# config
+> $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
+mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_sysconfdir}/config}.php
 
-# log directory
-mv $RPM_BUILD_ROOT%{_appdir}/logs $RPM_BUILD_ROOT/var/log/%{name}
+# sample, not used in eventum
+rm -f $RPM_BUILD_ROOT%{_appdir}/htdocs/rpc/xmlrpc_client.php
 
-# in doc
-rm -f $RPM_BUILD_ROOT%{_appdir}/{COPYING,ChangeLog,FAQ,INSTALL,README,UPGRADE}
-rm -rf $RPM_BUILD_ROOT%{_appdir}/{docs,misc/upgrade}
-# some sample, not used in eventum
-rm -rf $RPM_BUILD_ROOT%{_appdir}/rpc/xmlrpc_client.php
+%if %{with pear}
+# provided by PEAR
+rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
+%endif
 
 # use system Smarty
 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
 # These plugins are not in Smarty package (Smarty-2.6.2-3)
-cp -a include/Smarty/plugins/function.{calendar,get_display_style,get_innerhtml,get_textarea_size}.php $RPM_BUILD_ROOT%{_smartyplugindir}
-
-# in _bindir
-mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum $RPM_BUILD_ROOT%{_bindir}
-rm -f $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventumrc_example
+cp -a include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
+       $RPM_BUILD_ROOT%{_smartyplugindir}
+
+# qmail router
+d=$RPM_BUILD_ROOT/var/lib/%{name}
+echo 'root' > $d/.qmail
+echo 'root' > $d/.qmail-default
+echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
+echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
+echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
+install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%pre
+%addusertogroup http %{name}
+
 %post
 # apache1
-if [ -f %{_apache1dir}/apache.conf ]; then
+if [ -d %{_apache1dir}/conf.d ]; then
        ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
@@ -460,7 +591,6 @@ so that %{name}-setup is able to secure your Eventum installation.
 EOF
 fi
 
-
 %preun
 if [ "$1" = "0" ]; then
        # apache1
@@ -472,111 +602,211 @@ if [ "$1" = "0" ]; then
        fi
        # apache2
        if [ -d %{_apache2dir}/httpd.conf ]; then
-               rm -f %{_apache1dir}/httpd.conf/99_%{name}.conf
+               rm -f %{_apache2dir}/httpd.conf/99_%{name}.conf
                if [ -f /var/lock/subsys/httpd ]; then
                        /etc/rc.d/init.d/httpd restart 1>&2
                fi
        fi
 fi
 
+%postun
+# nuke cache
+rm -f /var/cache/eventum/*.php
+
+%pre base
+%groupadd -P %{name}-base %{name}
+%useradd -P %{name}-base -d /var/lib/%{name} -g %{name} %{name} -c "Eventum User"
+
+%postun base
+if [ "$1" = "0" ]; then
+       %groupremove %{name}
+       %userremove %{name}
+fi
+
+%post router-qmail
+CF=/etc/qmail/control/virtualdomains
+if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
+       FQDN=$(hostname -f 2>/dev/null || echo localhost)
+       umask 022
+       echo "#${FQDN}:%{name}" >> $CF
+
+%banner %{name}-qmail -e <<EOF
+
+Added "#${FQDN}:%{name}" to $CF,
+Please verify that it is correct and restart qmail:
+# service qmail reload
+
+Consult qmail-send(8) for more details on virtualdomains.
+
+EOF
+fi
+
+%preun router-qmail
+if [ "$1" = "0" ]; then
+       sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
+fi
+
 %post setup
 chmod 660 %{_sysconfdir}/{config,private_key}.php
-chown root:http %{_sysconfdir}/{config,private_key}.php
+chown root:eventum %{_sysconfdir}/{config,private_key}.php
 
 %postun setup
 if [ "$1" = "0" ]; then
        chmod 640 %{_sysconfdir}/{config,private_key}.php
-       chown root:http %{_sysconfdir}/{config,private_key}.php
+       chown root:eventum %{_sysconfdir}/{config,private_key}.php
+fi
+
+%triggerpostun -- eventum < 1.4-2.160
+cp -f %{_sysconfdir}/config.php{,.rpmsave}
+# very loose trigger
+sed -i -e '
+/config.php/,/SQL variables/d;/_LOG/d;/APP_VERSION/d;/APP_BENCHMARK/,/content-type:/d
+' %{_sysconfdir}/config.php
+
+%triggerpostun -- eventum < 1.4-2.174
+cp -f %{_sysconfdir}/apache.conf{,.rpmsave}
+# loosely fix htdocs directory
+sed -i -e '
+s,%{_appdir},%{_appdir}/htdocs,
+' %{_sysconfdir}/apache.conf
+
+%triggerpostun mail-download -- eventum-mail-download < 1.4-2.20050222.2.200
+sed -i -e 's,%{_appdir}/misc,%{_appdir},' /etc/cron.d/eventum-mail-download
+touch /etc/cron.d/eventum-mail-download
+
+%triggerpostun mail-queue -- eventum-mail-queue < 1.4-2.20050222.2.200
+sed -i -e 's,%{_appdir}/misc,%{_appdir},' /etc/cron.d/eventum-mail-queue
+touch /etc/cron.d/eventum-mail-queue
+
+%triggerpostun monitor -- eventum-monitor < 1.4-2.20050222.2.200
+sed -i -e 's,%{_appdir}/misc,%{_appdir},' /etc/cron.d/eventum-monitor
+touch /etc/cron.d/eventum-monitor
+
+%triggerpostun reminder -- eventum-reminder < 1.4-2.20050222.2.200
+sed -i -e 's,%{_appdir}/misc,%{_appdir},' /etc/cron.d/eventum-reminder
+touch /etc/cron.d/eventum-reminder
+
+%triggerpostun -- eventum < 1.4-2.20050222.2.208
+chgrp eventum %{_sysconfdir}/{core,config,private_key,setup}.php
+
+%triggerpostun irc -- eventum-irc < 1.4-2.20050222.2.208
+chgrp eventum %{_sysconfdir}/irc.php
+
+%triggerpostun base -- eventum-base < 1.4-2.20050222.212
+if [ "`getent passwd %{name} | cut -d: -f6`" = "%{_appdir}" ]; then
+       /usr/sbin/usermod -d /var/lib/%{name} %{name}
 fi
 
 %files
 %defattr(644,root,root,755)
-%doc ChangeLog FAQ INSTALL README UPGRADE misc/upgrade docs/* rpc/xmlrpc_client.php
-%attr(751,root,root) %dir %{_sysconfdir}
+%doc ChangeLog FAQ INSTALL README UPGRADE
+%doc misc/upgrade docs/* rpc/xmlrpc_client.php setup/schema.sql
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
-%attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
-
-%dir %attr(731,root,http) /var/log/%{name}
-%attr(620,root,http) %ghost /var/log/%{name}/*
-
-%{_smartyplugindir}/*
+%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
+%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
+%attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
+%attr(640,root,eventum) %config %verify(not mtime) %{_sysconfdir}/core.php
+
+%dir %attr(731,root,eventum) /var/log/%{name}
+%attr(620,root,eventum) %ghost /var/log/%{name}/*
+
+%dir %{_appdir}/htdocs
+%{_appdir}/htdocs/*.php
+%{_appdir}/htdocs/css
+%{_appdir}/htdocs/customer
+%{_appdir}/htdocs/images
+%{_appdir}/htdocs/js
+%{_appdir}/htdocs/manage
+%{_appdir}/htdocs/reports
+%{_appdir}/htdocs/rpc
+%{_appdir}/htdocs/misc
 
-%dir %{_appdir}
-%{_appdir}/*.php
-%{_appdir}/css
-%{_appdir}/customer
-%{_appdir}/images
-%{_appdir}/js
-%{_appdir}/manage
-%{_appdir}/reports
-%{_appdir}/rpc
 %{_appdir}/templates
 
-%dir %attr(730,root,http) %{_appdir}/locks
+%{_smartyplugindir}/*
+%if %{without pear}
+%{_appdir}/include/pear
+%endif
 
 %dir %{_appdir}/include
 %{_appdir}/include/customer
 %{_appdir}/include/jpgraph
-%{_appdir}/include/pear
 %{_appdir}/include/workflow
-%{_appdir}/include/*.php
-
-%dir %attr(730,root,http) %{_appdir}/templates_c
-
-%dir %{_appdir}/misc
-%{_appdir}/misc/blank.html
+%{_appdir}/include/class.[!m]*.php
+%{_appdir}/include/class.mail.php
+%{_appdir}/include/class.mail_queue.php
+%{_appdir}/include/class.mime_helper.php
+%{_appdir}/include/class.misc.php
+%{_appdir}/include/db_access.php
+%{_appdir}/include/jsrsServer.inc.php
+
+%dir %attr(730,root,eventum) /var/run/%{name}
+%dir %attr(730,root,eventum) /var/cache/%{name}
+
+%files base
+%defattr(644,root,root,755)
+%attr(751,root,root) %dir %{_sysconfdir}
+%dir %{_libdir}
+%dir %{_appdir}
+%attr(750,root,eventum) %dir /var/lib/%{name}
 
 %files setup
 %defattr(644,root,root,755)
-%{_appdir}/setup
+%{_appdir}/htdocs/setup
 
 %files mail-queue
 %defattr(644,root,root,755)
-%{_appdir}/misc/process_mail_queue.php
+%{_appdir}/process_mail_queue.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
 
 %files mail-download
 %defattr(644,root,root,755)
-%{_appdir}/misc/download_emails.php
+%{_appdir}/download_emails.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
 
 %files reminder
 %defattr(644,root,root,755)
-%{_appdir}/misc/check_reminders.php
+%{_appdir}/check_reminders.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
 
 %files monitor
 %defattr(644,root,root,755)
-%{_appdir}/misc/monitor.php
+%{_appdir}/include/class.monitor.php
+%{_appdir}/monitor.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
 
 %files route-emails
 %defattr(644,root,root,755)
-%{_appdir}/misc/route_emails.php
+%{_appdir}/route_emails.php
 
 %files route-notes
 %defattr(644,root,root,755)
-%{_appdir}/misc/route_drafts.php
-%{_appdir}/misc/route_notes.php
+%{_appdir}/route_drafts.php
+%{_appdir}/route_notes.php
+
+%files router-qmail
+%defattr(644,root,root,755)
+%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
+%attr(755,root,root) %{_libdir}/router-qmail
+
+%files router-postfix
+%defattr(644,root,root,755)
 
 %files irc
 %defattr(644,root,root,755)
-%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
-%{_appdir}/misc/irc
+%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
+%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
+%{_appdir}/irc
 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
 
 %files cli
 %defattr(644,root,root,755)
 %doc eventumrc
-%attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cli.php
-%attr(755,root,root) %{_bindir}/*
-%dir %{_appdir}/misc/cli
-%{_appdir}/misc/cli/include
+%attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
+%attr(755,root,root) %{_bindir}/%{name}
+%{_appdir}/cli
 
 %files scm
 %defattr(644,root,root,755)
 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
-%dir %{_appdir}/misc/scm
-%{_appdir}/misc/scm/process_cvs_commits.php
+%attr(755,root,root) %{_libdir}/scm
This page took 0.05028 seconds and 4 git commands to generate.