]> git.pld-linux.org Git - packages/eventum.git/blobdiff - eventum.spec
package new files
[packages/eventum.git] / eventum.spec
index 0afacdb50626e3d2f787bfb6b8d7d7c4b7cecf47..27badfa27b92eba08922cf81e3dc4db654bb4a7d 100644 (file)
@@ -3,19 +3,19 @@
 %bcond_with    order   # with experimental order patch
 
 %define                rel             1
-%define                subver  50
-%define                githash 34453995
-%define                php_min_version 5.6.0
+%define                subver  52
+%define                githash 4b3cb3541
+%define                php_min_version 7.1.3
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl.UTF-8):     Eventum - system śledzenia spraw/błędów
 Name:          eventum
-Version:       3.5.6
+Version:       3.7.2
 Release:       %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
 License:       GPL v2+
 Group:         Applications/WWW
 #Source0:      https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.xz
 Source0:       https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.xz
-# Source0-md5: 36ea0d8eb6a1c4bc51da0cbaf29fb8d9
+# Source0-md5: 5d023bcf496d16ecaa866e1b6477ba45
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
@@ -52,6 +52,7 @@ Requires(pre):        /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires:      fonts-TTF-RedHat-liberation
 Requires:      php(core) >= %{php_min_version}
+Requires:      php(ds)
 Requires:      php(filter)
 Requires:      php(iconv)
 Requires:      php(imap)
@@ -62,19 +63,7 @@ Requires:    php(pdo_mysql)
 Requires:      php(session)
 Requires:      php-Smarty >= 3.1
 Requires:      php-Smarty-plugin-gettext
-Requires:      php-ZendFramework-Config >= 2.4
-Requires:      php-ZendFramework-Loader >= 2.4
-Requires:      php-ZendFramework-Mail >= 2.4.13-2
-Requires:      php-ZendFramework-Mime >= 2.4
-Requires:      php-ZendFramework-ServiceManager >= 2.4
-Requires:      php-ZendFramework-Validator >= 2.4
 Requires:      php-monolog >= 1.17.2
-Requires:      php-pear-Math_Stats
-Requires:      php-pear-Net_SMTP
-Requires:      php-pear-Net_Socket
-Requires:      php-pear-Net_URL
-Requires:      php-pear-PEAR-core
-Requires:      php-pear-Text_Diff
 Requires:      php-psr-Log >= 1.0.0-2
 Requires:      phplot >= 5.8.0
 Requires:      webapps
@@ -85,7 +74,6 @@ Requires:     webserver(php) >= 4.2.0
 Suggests:      localedb
 Suggests:      php(mcrypt)
 Suggests:      php(openssl)
-Suggests:      php-pear-Net_POP3
 Suggests:      webserver(setenv)
 Provides:      group(eventum)
 Provides:      user(eventum)
@@ -267,21 +255,6 @@ przez Postfiksa.
 Opis konfiguracji Postfiksa można znaleźć pod adresem
 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
 
-%package cli
-Summary:       Eventum command-line interface
-Summary(pl.UTF-8):     Interfejs linii poleceń dla Eventum
-Group:         Applications/WWW
-Requires:      php(core) >= %{php_min_version}
-Requires:      php(phar)
-
-%description cli
-The Eventum command-line interface allows you to access most of the
-features of the web interface straight from your command shell.
-
-%description cli -l pl.UTF-8
-Interfejs linii poleceń Eventum pozwala na dostęp do większości
-funkcji interfejsu WWW prosto z linii poleceń powłoki.
-
 %package sphinx
 Summary:       Eventum Sphinx Search
 Group:         Applications/WWW
@@ -303,9 +276,7 @@ mv docs/examples .
 %{?with_order:%patch2 -p1}
 #%patch3 -p0
 #%patch4 -p1
-
 %{?with_order:cp -p %{SOURCE16} htdocs/images}
-
 #%patch200 -p1
 
 # produce default sphinx config
@@ -331,63 +302,17 @@ rm config/config.php
 %patch108 -p1
 
 rm htdocs/.htaccess.dist
-
 rm config/config.dist.php
 
-# cleanup vendor. keep only needed libraries.
-# (the rest are packaged with system packages)
-mv vendor vendor.dist
-vendor() {
-       local path dir
-       for path; do
-               dir=$(dirname $path)
-               test -d vendor/$dir || mkdir -p vendor/$dir
-               mv vendor.dist/$path vendor/$path
-       done
-}
-vendor autoload.php
-vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
-vendor composer/ClassLoader.php
-vendor ircmaxell/{random-lib,security-lib}
-vendor defuse/php-encryption
-vendor willdurand/email-reply-parser
-vendor theorchard/monolog-cascade
-vendor malkusch/lock
-vendor phpxmlrpc/phpxmlrpc
-vendor robmorgan/phinx
-vendor mnapoli/silly
-vendor psr/container
-vendor phlib/flysystem-pdo
-vendor league/flysystem
-vendor php-di/invoker
-vendor container-interop/container-interop
-vendor symfony/config
-vendor symfony/console
-vendor symfony/debug
-vendor symfony/event-dispatcher
-vendor symfony/filesystem
-vendor symfony/http-foundation
-vendor symfony/options-resolver
-vendor symfony/serializer
-vendor symfony/yaml
-vendor symfony/ldap
-vendor paragonie/random_compat
-vendor symfony/polyfill-php70
-vendor symfony/polyfill-intl-normalizer
-vendor symfony/security-core
-vendor symfony/security-csrf
-vendor glen/filename-normalizer
-vendor doctrine/annotations
-vendor doctrine/cache
-vendor doctrine/collections
-vendor doctrine/common
-vendor doctrine/dbal
-vendor doctrine/inflector
-vendor doctrine/instantiator
-vendor doctrine/lexer
-vendor doctrine/orm
-vendor cebe/markdown
-vendor enrise/urihelper
+# cleanup libs taken from system, everything else gets bundled
+rm -r vendor/fonts/liberation
+rm -r vendor/monolog/monolog
+rm -r vendor/php-gettext/php-gettext
+rm -r vendor/phplot/phplot
+rm -r vendor/psr/log
+rm -r vendor/smarty-gettext/smarty-gettext
+rm -r vendor/smarty/smarty
+rm -r vendor/sphinx/php-sphinxapi
 
 # remove backups from patching as we use globs to package files to buildroot
 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
@@ -400,12 +325,13 @@ rm -rf $RPM_BUILD_ROOT
 install -d \
        $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
        $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
-       $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
+       $RPM_BUILD_ROOT/var/{run,lib}/%{name} \
        $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
        $RPM_BUILD_ROOT/var/lib/%{name}/{routed_{emails,drafts,notes},storage} \
+       $RPM_BUILD_ROOT/var/cache/%{name}/doctrine/proxies \
        $RPM_BUILD_ROOT%{systemdtmpfilesdir}
 
-%{__make} install-eventum install-cli install-localization \
+%{__make} install-eventum install-localization \
        sysconfdir=%{_webappdir} \
        localedir=%{_localedir} \
        DESTDIR=$RPM_BUILD_ROOT
@@ -522,17 +448,25 @@ fi
 %attr(771,root,http) %dir %{_webappdir}
 %attr(751,root,http) %dir %{_webappdir}/crm
 %attr(751,root,http) %dir %{_webappdir}/custom_field
+%attr(751,root,http) %dir %{_webappdir}/packages
+%attr(751,root,http) %dir %{_webappdir}/packages/prod
 %attr(751,root,http) %dir %{_webappdir}/partner
 %attr(751,root,http) %dir %{_webappdir}/templates
-%attr(751,root,http) %dir %{_webappdir}/workflow
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/bundles.php
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/routes.yml
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/services.yml
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
-%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/packages/doctrine.yml
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/packages/framework.yml
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/packages/security.yml
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/packages/prod/doctrine.yml
 
 %dir %attr(731,root,http) /var/log/%{name}
 %attr(620,root,http) %ghost /var/log/%{name}/*
@@ -543,6 +477,8 @@ fi
 %{_appdir}/config
 
 %dir %{_appdir}/bin
+%attr(755,root,root) %{_appdir}/bin/console.php
+%attr(755,root,root) %{_appdir}/bin/export-issues.php
 %attr(755,root,root) %{_appdir}/bin/extension.php
 %attr(755,root,root) %{_appdir}/bin/ldapsync.php
 %attr(755,root,root) %{_appdir}/bin/migrate_storage_adapter.php
@@ -570,6 +506,8 @@ fi
 %dir %{_appdir}/db
 %dir %{_appdir}/db/migrations
 %{_appdir}/db/migrations/*.php
+%dir %{_appdir}/db/seeds
+%{_appdir}/db/seeds/*.php
 
 %{_appdir}/res
 %{_appdir}/src
@@ -589,6 +527,8 @@ fi
 %dir /var/lib/%{name}
 %dir %attr(730,root,http) /var/run/%{name}
 %dir %attr(730,root,http) /var/cache/%{name}
+%dir %attr(730,root,http) /var/cache/%{name}/doctrine
+%dir %attr(730,root,http) /var/cache/%{name}/doctrine/proxies
 
 # saved mail copies
 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
@@ -636,11 +576,6 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/router-postfix
 
-%files cli
-%defattr(644,root,root,755)
-%doc cli/eventumrc
-%attr(755,root,root) %{_bindir}/%{name}
-
 %files sphinx
 %defattr(644,root,root,755)
 %{_webappdir}/sphinx.conf.php
This page took 0.04417 seconds and 4 git commands to generate.