]> git.pld-linux.org Git - packages/eventum.git/blobdiff - eventum.spec
update monitor command packaging
[packages/eventum.git] / eventum.spec
index 5ae2c87eaeb2a682c6995641eca86d6709b28492..1ff8bf8d9b217fd5a435df78fd3012da54dfb73b 100644 (file)
@@ -2,27 +2,26 @@
 # Conditional build:
 %bcond_with    order   # with experimental order patch
 
-%define                rel             1.4
-%define                subver  187
-%define                githash acd7038
-%define                php_min_version 5.3.7
+%define                rel             1
+%define                subver  136
+%define                githash bd09ead2
+%define                php_min_version 5.6.0
 %include       /usr/lib/rpm/macros.php
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl.UTF-8):     Eventum - system śledzenia spraw/błędów
 Name:          eventum
-Version:       3.0.8
+Version:       3.2.3
 Release:       %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
 License:       GPL v2+
 Group:         Applications/WWW
 #Source0:      https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
-Source0:       %{name}-%{version}-%{subver}-g%{githash}.tar.gz
-# Source0-md5: ae49292484aa2271c82dea1262aead96
+Source0:       https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.gz
+# Source0-md5: a8edbaab9794b68e84eec719e3841a78
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
 Source4:       %{name}-reminder.cron
 Source5:       %{name}-monitor.cron
-Source6:       %{name}-cvs.php
 Source8:       %{name}-irc.init
 Source9:       %{name}-irc.sysconfig
 Source10:      sphinx.crontab
@@ -37,15 +36,12 @@ Patch2:             %{name}-order.patch
 #Patch4:               https://github.com/glensc/eventum/compare/cf_escape.patch
 # packaging patches that probably never go upstream
 Patch100:      %{name}-paths.patch
-Patch101:      %{name}-cvs-config.patch
 Patch107:      %{name}-gettext.patch
 Patch108:      autoload.patch
 # some tests
 Patch200:      %{name}-fixed-nav.patch
-URL:           http://eventum.mysql.org/
-BuildRequires: /usr/bin/php
-BuildRequires: gettext-devel
-BuildRequires: php(core) >= %{php_min_version}
+URL:           https://wiki.github.com/eventum/eventum/
+BuildRequires: gettext-tools
 BuildRequires: rpm-php-pearprov >= 4.0.2-98
 BuildRequires: rpmbuild(macros) >= 1.654
 BuildRequires: sed >= 4.0
@@ -62,28 +58,35 @@ Requires:   php(iconv)
 Requires:      php(imap)
 Requires:      php(json)
 Requires:      php(mbstring)
-Requires:      php(mysqli)
 Requires:      php(pcre)
+Requires:      php(pdo_mysql)
 Requires:      php(session)
 Requires:      php-Smarty >= 3.1
 Requires:      php-Smarty-plugin-gettext
 Requires:      php-ZendFramework-Config >= 2.4
+Requires:      php-ZendFramework-Loader >= 2.4
+Requires:      php-ZendFramework-Mail >= 2.4.11-4
+Requires:      php-ZendFramework-Mime >= 2.4
+Requires:      php-ZendFramework-ServiceManager >= 2.4
+Requires:      php-ZendFramework-Validator >= 2.4
 Requires:      php-monolog >= 1.17.2
-Requires:      php-pear-DB
-Requires:      php-pear-Mail
 Requires:      php-pear-Mail_Mime
 Requires:      php-pear-Mail_mimeDecode
 Requires:      php-pear-Math_Stats
-Requires:      php-pear-Net_DIME
 Requires:      php-pear-Net_SMTP
 Requires:      php-pear-Net_Socket
 Requires:      php-pear-Net_URL
-Requires:      php-pear-Net_UserAgent_Detect
 Requires:      php-pear-PEAR-core
 Requires:      php-pear-Text_Diff
-Requires:      php-pear-XML_RPC
 Requires:      php-psr-Log >= 1.0.0-2
+Requires:      php-symfony2-Config >= 2.7.7
+Requires:      php-symfony2-Console >= 2.7.7
+Requires:      php-symfony2-EventDispatcher >= 2.7.7
+Requires:      php-symfony2-Filesystem >= 2.7.7
 Requires:      php-symfony2-HttpFoundation >= 2.7.7
+Requires:      php-symfony2-OptionsResolver >= 2.7.7
+Requires:      php-symfony2-Serializer >= 2.7.7
+Requires:      php-symfony2-Yaml >= 2.7.7
 Requires:      phplot >= 5.8.0
 Requires:      webapps
 Requires:      webserver(access)
@@ -91,7 +94,10 @@ Requires:    webserver(alias)
 Requires:      webserver(indexfile)
 Requires:      webserver(php) >= 4.2.0
 Suggests:      localedb
+Suggests:      php(mcrypt)
+Suggests:      php(openssl)
 Suggests:      php-pear-Net_LDAP2
+Suggests:      php-pear-Net_POP3
 Suggests:      webserver(setenv)
 Provides:      group(eventum)
 Provides:      user(eventum)
@@ -122,16 +128,13 @@ BuildRoot:        %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Eventum is a user-friendly and flexible issue tracking system that can
 be used by a support department to track incoming technical support
 requests, or by a software development team to quickly organize tasks
-and bugs. Eventum is used by the MySQL AB Technical Support team, and
-has allowed us to dramatically improve our response times.
+and bugs.
 
 %description -l pl.UTF-8
 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
 może być używany przez dział obsługi do śledzenia przychodzących żądań
 obsługi technicznej albo przez zespół tworzący oprogramowanie do
-szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
-Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
-reakcji.
+szybkiej organizacji zadań i błędów.
 
 %package setup
 Summary:       Eventum setup package
@@ -274,14 +277,14 @@ This package provides way of routing notes and emails back to Eventum
 via Postfix.
 
 The Postfix configuration instructions you can find from
-<http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
+<https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
 
 %description router-postfix -l pl.UTF-8
 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
 przez Postfiksa.
 
 Opis konfiguracji Postfiksa można znaleźć pod adresem
-<http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
+<https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
 
 %package irc
 Summary:       Eventum IRC Notification Bot
@@ -324,7 +327,6 @@ Summary(pl.UTF-8):  Interfejs linii poleceń dla Eventum
 Group:         Applications/WWW
 Requires:      php(core) >= %{php_min_version}
 Requires:      php(phar)
-Requires:      php-pear-XML_RPC
 
 %description cli
 The Eventum command-line interface allows you to access most of the
@@ -334,40 +336,6 @@ features of the web interface straight from your command shell.
 Interfejs linii poleceń Eventum pozwala na dostęp do większości
 funkcji interfejsu WWW prosto z linii poleceń powłoki.
 
-%package scm
-Summary:       Eventum SCM integration
-Summary(pl.UTF-8):     Integracja SCM dla Eventum
-Group:         Applications/WWW
-Requires:      php(core) >= %{php_min_version}
-Requires:      php(json)
-Requires:      php(pcre)
-Requires:      php(spl)
-Suggests:      cvs
-Suggests:      git-core
-Suggests:      php(openssl)
-Suggests:      subversion
-
-%description scm
-This feature allows your software development teams to integrate your
-Source Control Management system with your Issue Tracking System.
-
-The integration is implemented in such a way that it will be forward
-compatible with pretty much any SCM system, such as CVS.
-
-For installation see
-</eventum/help.php?topic=scm_integration_installation>.
-
-%description scm -l pl.UTF-8
-Ten pakiet pozwala zespołom programistów na integrację systemu
-zarządzania źródłami (SCM - Source Control Management) z systemem
-śledzenia spraw.
-
-Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
-prawie każdym systemem SCM, jak np. CVS.
-
-Szczegóły na temat instalacji można przeczytać pod
-</eventum/help.php?topic=scm_integration_installation>.
-
 %package sphinx
 Summary:       Eventum Sphinx Search
 Group:         Applications/WWW
@@ -413,13 +381,13 @@ rm config/config.php
 
 # packaging
 %patch100 -p1
-%patch101 -p1
 %patch107 -p1
 %patch108 -p1
 
 rm htdocs/.htaccess.dist
-# deprecated in favour of process_all_emails.php
-rm bin/route_*.php
+
+mv config/irc_config{.dist.php,.php}
+rm config/config.dist.php
 
 # cleanup vendor. keep only needed libraries.
 # (the rest are packaged with system packages)
@@ -435,8 +403,13 @@ vendor() {
 vendor autoload.php
 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
 vendor composer/ClassLoader.php
-vendor ircmaxell/{password-compat,random-lib,security-lib}
+vendor ircmaxell/{random-lib,security-lib}
 vendor defuse/php-encryption
+vendor willdurand/email-reply-parser
+vendor theorchard/monolog-cascade
+vendor malkusch/lock
+vendor phpxmlrpc/phpxmlrpc
+vendor robmorgan/phinx
 
 # remove backups from patching as we use globs to package files to buildroot
 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
@@ -454,7 +427,7 @@ install -d \
        $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
        $RPM_BUILD_ROOT%{systemdtmpfilesdir}
 
-%{__make} install-eventum install-cli install-scm install-localization \
+%{__make} install-eventum install-cli install-localization \
        sysconfdir=%{_webappdir} \
        localedir=%{_localedir} \
        DESTDIR=$RPM_BUILD_ROOT
@@ -486,8 +459,6 @@ cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
 
-cp -p config/irc_config.dist.php $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
-
 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
 
@@ -500,9 +471,6 @@ cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
 
 %find_lang %{name}
 
-# scm
-cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -517,7 +485,7 @@ rm -rf $RPM_BUILD_ROOT
 for a in \
        errors.log login_attempts.log \
        eventum.log \
-       cli.log \
+       auth.log cli.log \
        irc_bot_error.log irc_bot_smartirc.log \
 ; do
        test -f /var/log/%{name}/$a && continue
@@ -548,13 +516,13 @@ if [ "$1" = "0" ]; then
 fi
 
 %post setup
-chmod 660 %{_webappdir}/{config,private_key}.php
-chown root:http %{_webappdir}/{config,private_key}.php
+chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
+chown root:http %{_webappdir}/{config,private_key,secret_key}.php
 
 %postun setup
 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
-       chmod 640 %{_webappdir}/{config,private_key}.php
-       chown root:http %{_webappdir}/{config,private_key}.php
+       chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
+       chown root:http %{_webappdir}/{config,private_key,secret_key}.php
 fi
 
 %post irc
@@ -599,18 +567,21 @@ done
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %attr(751,root,root) %dir %{_webappdir}
-%attr(751,root,root) %dir %{_webappdir}/custom_field
-%attr(751,root,root) %dir %{_webappdir}/templates
-%attr(751,root,root) %dir %{_webappdir}/workflow
+%attr(751,root,http) %dir %{_webappdir}/crm
+%attr(751,root,http) %dir %{_webappdir}/custom_field
+%attr(751,root,http) %dir %{_webappdir}/partner
+%attr(751,root,http) %dir %{_webappdir}/templates
+%attr(751,root,http) %dir %{_webappdir}/workflow
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
 
-%dir %attr(711,root,http) /var/log/%{name}
+%dir %attr(731,root,http) /var/log/%{name}
 %attr(620,root,http) %ghost /var/log/%{name}/*
 %dir %attr(750,root,root) /var/log/archive/%{name}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
@@ -623,7 +594,9 @@ done
 %attr(755,root,root) %{_appdir}/bin/upgrade.php
 
 %{_appdir}/autoload.php
+%{_appdir}/globals.php
 %{_appdir}/init.php
+%{_appdir}/phinx.php
 %dir %{_appdir}/htdocs
 %{_appdir}/htdocs/*.php
 %{_appdir}/htdocs/*.ico
@@ -638,20 +611,16 @@ done
 %{_appdir}/htdocs/components
 %{_appdir}/templates
 
-%dir %{_appdir}/upgrade
-%{_appdir}/upgrade/flush_compiled_templates.php
-%{_appdir}/upgrade/*.sql
-%attr(755,root,root) %{_appdir}/upgrade/change_usr_id.php
-%attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
-%attr(755,root,root) %{_appdir}/upgrade/ldap_update_users.php
-%attr(755,root,root) %{_appdir}/upgrade/scm_trac_import.php
-%{_appdir}/upgrade/patches
+%dir %{_appdir}/db
+%dir %{_appdir}/db/migrations
+%{_appdir}/db/migrations/*.php
 
-%{_appdir}/vendor
+%{_appdir}/res
 %{_appdir}/src
+%{_appdir}/vendor
 %dir %{_appdir}/lib
 %{_appdir}/lib/eventum
-%exclude %{_appdir}/lib/eventum/class.monitor.php
+%exclude %{_appdir}/src/Command/MonitorCommand.php
 
 %dir %{_libdir}
 
@@ -693,7 +662,7 @@ done
 
 %files monitor
 %defattr(644,root,root,755)
-%{_appdir}/lib/eventum/class.monitor.php
+%{_appdir}/src/Command/MonitorCommand.php
 %attr(755,root,root) %{_appdir}/bin/monitor.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
 
@@ -713,15 +682,6 @@ done
 %doc cli/eventumrc
 %attr(755,root,root) %{_bindir}/%{name}
 
-%files scm
-%defattr(644,root,root,755)
-%attr(751,root,root) %dir %{_sysconfdir}
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
-%attr(755,root,root) %{_sbindir}/eventum-cvs-hook
-%attr(755,root,root) %{_sbindir}/eventum-git-hook
-%attr(755,root,root) %{_sbindir}/eventum-svn-hook
-%attr(755,root,root) %{_sbindir}/helpers.php
-
 %files sphinx
 %defattr(644,root,root,755)
 %{_webappdir}/sphinx.conf.php
This page took 0.133706 seconds and 4 git commands to generate.