]> git.pld-linux.org Git - packages/eventum.git/blobdiff - eventum.spec
- updated to svn 3172
[packages/eventum.git] / eventum.spec
index d41cdf814bfc2f152604021594ce0b746583dfe8..1a7f67ca8bdc696864e168296959cd0e9a3eaa56 100644 (file)
@@ -9,12 +9,11 @@
 #
 # Conditional build:
 %bcond_with    qmail   # build the router-qmail subpackage
-%bcond_with    order_patch     # with custom issue order patch
 
 #define        _snap   20060921
-%define        _svn    20061107.3132
+%define        _svn    20061207.3172
 #define        _rc             RC3
-%define        _rel    4.129
+%define        _rel    5.146
 
 %include       /usr/lib/rpm/macros.php
 Summary:       Eventum Issue / Bug tracking system
@@ -26,7 +25,7 @@ License:      GPL
 Group:         Applications/WWW
 #Source0:      http://downloads.mysql.com/snapshots/eventum/%{name}-nightly-%{_snap}.tar.gz
 Source0:       %{name}-%{_svn}.tar.bz2
-# Source0-md5: 60b3bb2bd839131dd333f72ebe23bd00
+# Source0-md5: ab9893cd124b8229973907b58080de7f
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
@@ -45,15 +44,11 @@ Source15:   %{name}.logrotate
 Source16:      %{name}-lighttpd.conf
 Patch0:                %{name}-lf.patch
 Patch1:                %{name}-perms.patch
-Patch2:                %{name}-workflow-handlenewnote-note_id.patch
-Patch3:                %{name}-timetracking-advanced-logic.patch
-Patch4:                %{name}-email-notify-display.patch
-Patch5:                %{name}-backtraces.patch
-Patch6:                %{name}-errorhandler.patch
-Patch7:                %{name}-charset.patch
-
-Patch9:                %{name}-order4b.patch
-Patch10:       %{name}-fixed-nav.patch
+Patch2:                %{name}-timetracking-advanced-logic.patch
+Patch3:                %{name}-email-notify-display.patch
+Patch4:                %{name}-backtraces.patch
+Patch5:                %{name}-errorhandler.patch
+Patch7:                %{name}-mem2.patch
 # packaging patches that probably never go upstream
 Patch100:      %{name}-paths.patch
 Patch101:      %{name}-cvs-config.patch
@@ -63,7 +58,11 @@ Patch104:    %{name}-httpclient-clientside.patch
 Patch105:      %{name}-bot-reconnect.patch
 Patch106:      %{name}-private-key.patch
 Patch107:      %{name}-mem-limits.patch
+Patch108:      %{name}-gettext.patch
+# some tests
+Patch200:      %{name}-fixed-nav.patch
 URL:           http://dev.mysql.com/downloads/other/eventum/
+BuildRequires: gettext-devel
 BuildRequires: rpm-php-pearprov >= 4.0.2-98
 BuildRequires: rpmbuild(macros) >= 1.268
 BuildRequires: sed >= 4.0
@@ -72,13 +71,12 @@ Requires(triggerpostun):    sed >= 4.0
 Requires:      %{name}-base = %{version}-%{release}
 Requires:      Smarty >= 2.6.10-4
 Requires:      apache(mod_dir)
-Requires:      php >= 3:4.2.0
-Requires:      php-gd
-Requires:      php-imap
-Requires:      php-mbstring
-Requires:      php-mysql
-Requires:      php-pcre
-Requires:      php-pear-Benchmark
+Requires:      php(gd)
+Requires:      php(imap)
+Requires:      php(mbstring)
+Requires:      php(mysql)
+Requires:      php(pcre)
+Requires:      php(session)
 Requires:      php-pear-DB
 Requires:      php-pear-Date
 Requires:      php-pear-HTTP_Request
@@ -93,15 +91,15 @@ Requires:   php-pear-Net_UserAgent_Detect
 Requires:      php-pear-PEAR-core
 Requires:      php-pear-Text_Diff
 Requires:      php-pear-XML_RPC
-Requires:      php-session
 Requires:      smarty-gettext
 Requires:      webapps
 Requires:      webserver(access)
 Requires:      webserver(alias)
+Requires:      webserver(php) >= 4.2.0
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreq      'pear(/etc/webapps/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)'
+%define                _noautoreq      'pear(/etc/webapps/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)' 'pear(Benchmark/.*)'
 
 %define                _libdir         %{_prefix}/lib/%{name}
 %define                _appdir         %{_datadir}/%{name}
@@ -238,7 +236,7 @@ Summary(pl):        Monitor 
 Group:         Applications/WWW
 Requires:      %{name} = %{version}-%{release}
 Requires:      crondaemon
-Requires:      php-posix
+Requires:      php(posix)
 
 %description monitor
 The heartbeat monitor is a feature designed for the administrator that
@@ -388,8 +386,8 @@ Group:              Applications/WWW
 Requires(post,preun):  /sbin/chkconfig
 Requires(triggerpostun):       sed >= 4.0
 Requires:      %{name} = %{version}-%{release}
+Requires:      php(sockets)
 Requires:      php-pear-Net_SmartIRC
-Requires:      php-sockets
 Requires:      rc-scripts >= 0.4.0.18
 
 %description irc
@@ -438,9 +436,9 @@ Summary:    Eventum SCM integration
 Summary(pl):   Integracja SCM dla Eventum
 Group:         Applications/WWW
 Requires:      %{name}-base = %{version}-%{release}
+Requires:      php(pcre)
 Requires:      php-cli
 Requires:      php-common >= 3:4.1.0
-Requires:      php-pcre
 
 %description scm
 This feature allows your software development teams to integrate your
@@ -468,27 +466,30 @@ Szczeg
 # undos the source
 find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
 
-rm -f setup.conf.php # not to be installed by *.php glob
-rm -rf misc/upgrade/*v1.[123]* # too old to support in PLD Linux
-rm -f misc/upgrade/flush_compiled_templates.php
-rm -rf misc/upgrade/*/upgrade_config.php # not needed in PLD Linux
-rm -rf misc/upgrade/*/index.html # not needed in PLD Linux
+rm setup.conf.php # not to be installed by *.php glob
+rm benchmark.php
+rm -r misc/upgrade/*v1.[123]* # too old to support in PLD Linux
+rm misc/upgrade/flush_compiled_templates.php
+rm -r misc/upgrade/*/upgrade_config.php # not needed in PLD Linux
+rm -r misc/upgrade/*/index.html # not needed in PLD Linux
 
+rm -r include/php-gettext
 # sample, not used in eventum
-rm -f rpc/xmlrpc_client.php
+rm rpc/xmlrpc_client.php
 
 # bug fixes.
 %patch0 -p1
 %patch1 -p1
+
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
+cd include
 %patch7 -p1
+cd -
 
-%{?with_order_patch:%patch9 -p1}
-#%patch10 -p1
+#%patch200 -p1
 
 # packaging
 %patch100 -p1
@@ -499,6 +500,7 @@ rm -f rpc/xmlrpc_client.php
 %patch105 -p1
 %patch106 -p1
 %patch107 -p1
+%patch108 -p1
 
 cat <<'EOF'> mysql-permissions.sql
 # use this schema if you want to grant permissions manually instead of using setup
@@ -520,7 +522,6 @@ cp misc/localization/eventum.po misc/localization/de/LC_MESSAGES/eventum.po
 cp misc/localization/eventum.po misc/localization/es/LC_MESSAGES/eventum.po
 cp misc/localization/eventum.po misc/localization/fi/LC_MESSAGES/eventum.po
 cp misc/localization/eventum.po misc/localization/fr/LC_MESSAGES/eventum.po
-cp misc/localization/eventum.po misc/localization/it/LC_MESSAGES/eventum.po
 cp misc/localization/eventum.po misc/localization/nl/LC_MESSAGES/eventum.po
 cp misc/localization/eventum.po misc/localization/ru/LC_MESSAGES/eventum.po
 cp misc/localization/eventum.po misc/localization/en_US/LC_MESSAGES/eventum.po
@@ -825,7 +826,7 @@ EOF
 database_changes.php Perform database changes
 EOF
 
-%triggerpostun -- eventum < 1.7.1-4.123.20061009.3121
+%triggerpostun -- eventum < 1.7.1-4.132.20061119.3143
 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.7.1_to_v2.0 <<EOF
 database_changes.php Perform database changes
 EOF
This page took 0.089408 seconds and 4 git commands to generate.