]> git.pld-linux.org Git - packages/eventum.git/blobdiff - eventum.spec
up to 3.0.2
[packages/eventum.git] / eventum.spec
index e47570216fc136ff2fb1252a2fcdf85b4b5d0dff..18401720f223e1cc3d17c9f158fbbd22ddf060b0 100644 (file)
@@ -1,27 +1,22 @@
-# TODO
-# - discard bundled packages (from INSTALL):
-#  - JpGraph 1.5.3 (last GPL version)
-#  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
-#  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
-#  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
-#  - A few other small javascript libraries
 #
 # Conditional build:
 %bcond_with    order   # with experimental order patch
 
-%define                subver  pre1
-%define                rel             0.6
+%define                rel             1
+#define                subver  207
+#define                githash 0ce2ec6
 %define                php_min_version 5.3.3
 %include       /usr/lib/rpm/macros.php
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl.UTF-8):     Eventum - system śledzenia spraw/błędów
 Name:          eventum
-Version:       3.0.0
-Release:       0.%{subver}.%{rel}
+Version:       3.0.2
+Release:       %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
 License:       GPL v2
 Group:         Applications/WWW
-Source0:       https://github.com/eventum/eventum/releases/download/v%{version}-pre1/%{name}-%{version}-pre1.tar.gz
-# Source0-md5: 786930171e278f03baa7b174f52e43d0
+Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: c6a5236ddfb1ae47cb09b08babbc37df
+#Source0:      %{name}-%{version}-%{subver}-g%{githash}.tar.gz
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
@@ -51,26 +46,25 @@ Patch107:   %{name}-gettext.patch
 Patch200:      %{name}-fixed-nav.patch
 URL:           http://eventum.mysql.org/
 BuildRequires: /usr/bin/php
-BuildRequires: gettext-tools
+BuildRequires: gettext-devel
 BuildRequires: php(core) >= %{php_min_version}
 BuildRequires: rpm-php-pearprov >= 4.0.2-98
 BuildRequires: rpmbuild(macros) >= 1.654
 BuildRequires: sed >= 4.0
 Requires:      %{name}-base = %{version}-%{release}
-Requires:      Smarty >= 2.6.10-4
-Requires:      Smarty-plugin-gettext
+Requires:      fonts-TTF-RedHat-liberation
 Requires:      php(core) >= %{php_min_version}
 Requires:      php(filter)
-Requires:      php(gd)
 Requires:      php(iconv)
 Requires:      php(imap)
 Requires:      php(json)
 Requires:      php(mbstring)
-Requires:      php(mysql)
+Requires:      php(mysqli)
 Requires:      php(pcre)
 Requires:      php(session)
+Requires:      php-Smarty >= 3.1
+Requires:      php-Smarty-plugin-gettext
 Requires:      php-pear-DB
-Requires:      php-pear-Date
 Requires:      php-pear-Mail
 Requires:      php-pear-Mail_Mime
 Requires:      php-pear-Mail_mimeDecode
@@ -83,6 +77,7 @@ Requires:     php-pear-Net_UserAgent_Detect
 Requires:      php-pear-PEAR-core
 Requires:      php-pear-Text_Diff
 Requires:      php-pear-XML_RPC
+Requires:      phplot >= 5.8.0
 Requires:      webapps
 Requires:      webserver(access)
 Requires:      webserver(alias)
@@ -94,7 +89,7 @@ Conflicts:    logrotate < 3.8.0
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* jpgraph_dir.php .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
+%define                _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
 
 # exclude optional php dependencies
 %define                _noautophp      php-gnupg php-hash php-pecl-http php-tk
@@ -414,9 +409,14 @@ funkcji interfejsu WWW prosto z linii poleceń powłoki.
 Summary:       Eventum SCM integration
 Summary(pl.UTF-8):     Integracja SCM dla Eventum
 Group:         Applications/WWW
-Requires:      %{name}-base = %{version}-%{release}
 Requires:      php(core) >= %{php_min_version}
+Requires:      php(json)
 Requires:      php(pcre)
+Requires:      php(spl)
+Suggests:      cvs
+Suggests:      git-core
+Suggests:      php(openssl)
+Suggests:      subversion
 
 %description scm
 This feature allows your software development teams to integrate your
@@ -452,7 +452,7 @@ Sphinx search integration for Eventum.
 This package contains the cron job.
 
 %prep
-%setup -qn %{name}-%{version}%{?subver:-%{subver}}
+%setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
 
 mv docs/examples .
 
@@ -488,7 +488,7 @@ rm -f config/config.php
 
 # packaging
 %patch100 -p1
-#%patch101 -p1
+%patch101 -p1
 %patch105 -p1
 %patch107 -p1
 
@@ -505,7 +505,7 @@ find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d \
-       $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
+       $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
        $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
        $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
        $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
@@ -513,18 +513,19 @@ install -d \
        $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
        $RPM_BUILD_ROOT%{systemdtmpfilesdir}
 
-%{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
+%{__make} install-eventum install-cli install-irc install-scm install-localization \
        sysconfdir=%{_webappdir} \
        localedir=%{_localedir} \
        DESTDIR=$RPM_BUILD_ROOT
 
+# unsupported locale
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
+
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
 
-cp -a vendor $RPM_BUILD_ROOT%{_appdir}
-
 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
@@ -651,6 +652,9 @@ done
 %defattr(644,root,root,755)
 %doc docs/*
 %attr(751,root,root) %dir %{_webappdir}
+%attr(751,root,root) %dir %{_webappdir}/custom_field
+%attr(751,root,root) %dir %{_webappdir}/templates
+%attr(751,root,root) %dir %{_webappdir}/workflow
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
@@ -667,6 +671,7 @@ done
 %dir %{_appdir}/bin
 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
 
+%{_appdir}/autoload.php
 %{_appdir}/init.php
 %dir %{_appdir}/htdocs
 %{_appdir}/htdocs/*.php
@@ -694,11 +699,8 @@ done
 
 %dir %{_appdir}/lib
 %{_appdir}/lib/eventum
-%{_appdir}/lib/jpgraph
 %exclude %{_appdir}/lib/eventum/class.monitor.php
 
-%{_appdir}/vendor
-
 %{_examplesdir}/%{name}-%{version}
 
 %{systemdtmpfilesdir}/%{name}.conf
@@ -771,9 +773,12 @@ done
 
 %files scm
 %defattr(644,root,root,755)
+%attr(751,root,root) %dir %{_sysconfdir}
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
+%attr(755,root,root) %{_sbindir}/eventum-git-hook
 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
+%attr(755,root,root) %{_sbindir}/helpers.php
 
 %files sphinx
 %defattr(644,root,root,755)
This page took 0.065926 seconds and 4 git commands to generate.