]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
ee8b39c84a79ca3b938a06d3ee2198b3d3e3c2ba
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
9 #
10 # Conditional build:
11 %bcond_with     qmail   # build the router-qmail subpackage
12 %bcond_with     order_patch     # with custom issue order patch
13
14 #define _snap   20060330
15 #define _rc             RC3
16 %define _rel    2.21
17
18 %include        /usr/lib/rpm/macros.php
19 Summary:        Eventum Issue / Bug tracking system
20 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
21 Name:           eventum
22 Version:        1.7.1
23 Release:        %{?_snap:0.%{_snap}.}%{?_rc:%{_rc}.}%{_rel}
24 License:        GPL
25 Group:          Applications/WWW
26 #Source0:       http://downloads.mysql.com/snapshots/eventum/%{name}-nightly-%{_snap}.tar.gz
27 Source0:        http://mysql.dataphone.se/Downloads/eventum/%{name}-%{version}.tar.gz
28 # Source0-md5:  e1845de39b4d9bd30ddec9c26031a7d5
29 Source1:        %{name}-apache.conf
30 Source2:        %{name}-mail-queue.cron
31 Source3:        %{name}-mail-download.cron
32 Source4:        %{name}-reminder.cron
33 Source5:        %{name}-monitor.cron
34 Source6:        %{name}-cvs.php
35 Source7:        %{name}-irc.php
36 Source8:        %{name}-irc.init
37 Source9:        %{name}-irc.sysconfig
38 Source10:       %{name}-config.php
39 Source11:       %{name}-router-qmail.sh
40 Source12:       %{name}-config-setup.php
41 Source13:       %{name}-upgrade.sh
42 Source14:       %{name}-router-postfix.sh
43 Patch0:         %{name}-lf.patch
44 Patch1:         %{name}-perms.patch
45 Patch2:         %{name}-cli-wr-separated.patch
46 Patch3:         %{name}-scm-parse-response.patch
47 Patch4:         %{name}-double-decode.patch
48 Patch5:         %{name}-route-mem.patch
49 Patch6:         %{name}-scm-pluscharisbad.patch
50 Patch7:         %{name}-scm-updates.patch
51 Patch8:         %{name}-close-signature.patch
52 Patch9:         %{name}-list-sorting.patch
53 Patch10:        %{name}-workflow-handlenewnote-note_id.patch
54 Patch11:        %{name}-order4b.patch
55 Patch12:        %{name}-cli-errorcheck.patch
56 Patch13:        %{name}-combined.patch
57 Patch14:        %{name}-xml-inline.patch
58 Patch15:        %{name}-timetracking-advanced-logic.patch
59 Patch16:        %{name}-timedisplay.patch
60 Patch17:        %{name}-bug-17267.patch
61 # packaging patches that probably never go upstream
62 Patch100:       %{name}-paths.patch
63 Patch101:       %{name}-cvs-config.patch
64 Patch102:       %{name}-irc-mem.patch
65 Patch103:       %{name}-irc-config.patch
66 Patch104:       %{name}-PEAR.patch
67 Patch105:       %{name}-httpclient-clientside.patch
68 Patch106:       %{name}-bot-reconnect.patch
69 Patch107:       %{name}-private-key.patch
70 URL:            http://dev.mysql.com/downloads/other/eventum/
71 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
72 BuildRequires:  rpmbuild(macros) >= 1.268
73 BuildRequires:  sed >= 4.0
74 Requires(triggerpostun):        /usr/bin/php
75 Requires(triggerpostun):        sed >= 4.0
76 Requires:       %{name}-base = %{version}-%{release}
77 Requires:       Smarty >= 2.6.10-4
78 Requires:       apache(mod_dir)
79 Requires:       php >= 3:4.2.0
80 Requires:       php-gd
81 Requires:       php-imap
82 Requires:       php-mysql
83 Requires:       php-pcre
84 Requires:       php-pear-Benchmark
85 Requires:       php-pear-DB
86 Requires:       php-pear-Date
87 Requires:       php-pear-HTTP_Request
88 Requires:       php-pear-Mail
89 Requires:       php-pear-Mail_Mime
90 Requires:       php-pear-Math_Stats
91 Requires:       php-pear-Net_DIME
92 Requires:       php-pear-Net_SMTP
93 Requires:       php-pear-Net_Socket
94 Requires:       php-pear-Net_URL
95 Requires:       php-pear-Net_UserAgent_Detect
96 Requires:       php-pear-PEAR-core
97 Requires:       php-pear-Text_Diff
98 Requires:       php-pear-XML_RPC
99 Requires:       php-session
100 Requires:       webapps
101 BuildArch:      noarch
102 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
104 %define         _noautoreq      'pear(/etc/webapps/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)'
105
106 %define         _libdir         %{_prefix}/lib/%{name}
107 %define         _appdir         %{_datadir}/%{name}
108 %define         _smartyplugindir        %{_appdir}/include/smarty
109 %define         _smartydir      /usr/share/php/Smarty
110 %define         _webapps        /etc/webapps
111 %define         _webapp         %{name}
112 %define         _webappdir      %{_webapps}/%{_webapp}
113 %define         _sysconfdir     /etc/%{name}
114
115 %description
116 Eventum is a user-friendly and flexible issue tracking system that can
117 be used by a support department to track incoming technical support
118 requests, or by a software development team to quickly organize tasks
119 and bugs. Eventum is used by the MySQL AB Technical Support team, and
120 has allowed us to dramatically improve our response times.
121
122 %description -l pl
123 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
124 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
125 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
126 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
127 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
128 reakcji.
129
130 %package base
131 Summary:        Eventum base package
132 Summary(pl):    Podstawowy pakiet Eventum
133 Group:          Applications/WWW
134 Requires(postun):       /usr/sbin/groupdel
135 Requires(postun):       /usr/sbin/userdel
136 Requires(pre):  /bin/id
137 Requires(pre):  /usr/bin/getgid
138 Requires(pre):  /usr/sbin/groupadd
139 Requires(pre):  /usr/sbin/useradd
140 Provides:       group(eventum)
141 Provides:       user(eventum)
142
143 %description base
144 This package contains base directory structure for Eventum.
145
146 %description base -l pl
147 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
148
149 %package setup
150 Summary:        Eventum setup package
151 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
152 Group:          Applications/WWW
153 Requires:       %{name} = %{version}-%{release}
154
155 %description setup
156 Install this package to configure initial Eventum installation. You
157 should uninstall this package when you're done, as it considered
158 insecure to keep the setup files in place.
159
160 %description setup -l pl
161 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
162 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
163 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
164
165 %package mail-queue
166 Summary:        Eventum mail queue process
167 Summary(pl):    Przetwarzanie kolejki poczty Eventum
168 Group:          Applications/WWW
169 Requires:       %{name} = %{version}-%{release}
170 Requires:       crondaemon
171
172 %description mail-queue
173 Beginning with the first release of Eventum, emails are not directly
174 sent out from the various scripts, but rather added to a mail queue
175 table that is processed by a cron job. If an email cannot be sent, it
176 will be marked as such in the mail queue log, and the cron job script
177 will re-try to send it again the next time it runs.
178
179 This package contains the cron job.
180
181 %description mail-queue -l pl
182 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
183 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
184 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
185 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
186 nastêpnym razem.
187
188 Ten pakiet zawiera zadanie dla crona.
189
190 %package mail-download
191 Summary:        Eventum email download
192 Summary(pl):    ¦ci±ganie poczty Eventum
193 Group:          Applications/WWW
194 Requires:       %{name} = %{version}-%{release}
195 Requires:       crondaemon
196
197 %description mail-download
198 In order for Eventum's email integration feature to work, you need to
199 setup a cron job to run the script every so often.
200
201 This package contains the cron job.
202
203 %description mail-download -l pl
204 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
205 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
206 czêsto.
207
208 Ten pakiet zawiera zadanie dla crona.
209
210 %package reminder
211 Summary:        Eventum Reminder System
212 Summary(pl):    System przypominania dla Eventum
213 Group:          Applications/WWW
214 Requires:       %{name} = %{version}-%{release}
215 Requires:       crondaemon
216
217 %description reminder
218 The reminder system was designed with the objective as serving as a
219 safe net for issues that need attention. Depending on what
220 configuration you create, you may have several reminders (or alerts)
221 be sent out whenever an issue needs attention, for whatever parameter
222 you may deem necessary.
223
224 This package contains the cron job.
225
226 %description reminder -l pl
227 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
228 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
229 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
230 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
231 uwa¿aæ za potrzebny.
232
233 Ten pakiet zawiera zadanie dla crona.
234
235 %package monitor
236 Summary:        Eventum Heartbeat Monitor
237 Summary(pl):    Monitor ¿ycia dla Eventum
238 Group:          Applications/WWW
239 Requires:       %{name} = %{version}-%{release}
240 Requires:       crondaemon
241 Requires:       php-posix
242
243 %description monitor
244 The heartbeat monitor is a feature designed for the administrator that
245 wants to be alerted whenever a common problem in Eventum is detected,
246 like the database server not being available anymore, or maybe when
247 the recommended permissions for certain configuration files are
248 changed.
249
250 Please note that before running the heartbeat monitor, you may need to
251 customize some of the checks to be appropriate for your own system,
252 particularly the permission and file checks on
253 Monitor::checkConfiguration().
254
255 This package contains the cron job.
256
257 %description monitor -l pl
258 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
259 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
260 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
261 do plików konfiguracyjnych.
262
263 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
264 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
265 testów uprawnieñ i plików w Monitor::checkConfiguration().
266
267 Ten pakiet zawiera zadanie dla crona.
268
269 %package route-drafts
270 Summary:        Eventum Draft Routing
271 Summary(pl):    Przekazywanie szkiców dla Eventum
272 Group:          Applications/WWW
273 Requires:       %{name} = %{version}-%{release}
274 Requires:       eventum(router)
275
276 %description route-drafts
277 The draft routing feature is used to automatically associate a thread
278 of drafts into an Eventum issue. By setting up qmail (or even Postfix)
279 to deliver emails sent to a specific address (usually
280 draft-<number>@<domain>) to the above script, users are able to send
281 drafts written in their mail client to be stored in Eventum. These
282 drafts will NOT broadcasted to the notification list.
283
284 %description route-drafts -l pl
285 Przekazywanie szkiców s³u¿y do automatycznego wi±zania w±tku szkiców z
286 problemem w Eventum. Ustawiaj±c qmaila (czy nawet Postfiksa), aby
287 dostarcza³ pocztê wys³an± na podany adres (zwykle
288 draft-<liczba>@<domena>) do tego skryptu umo¿liwia siê u¿ytkownikom
289 wysy³anie szkiców napisanych w ich kliencie pocztowym do zapisania w
290 Eventum. Szkice te NIE bêd± wysy³ane na listê powiadomieñ.
291
292 %package route-emails
293 Summary:        Eventum Email Routing
294 Summary(pl):    Przekazywanie poczty dla Eventum
295 Group:          Applications/WWW
296 Requires:       %{name} = %{version}-%{release}
297 Requires:       eventum(router)
298
299 %description route-emails
300 The email routing feature is used to automatically associate a thread
301 of emails into an Eventum issue. By setting up qmail (or even postfix)
302 to deliver emails sent to a specific address (usually
303 issue-<number>@<domain>) to the above script, users are able to use
304 their email clients to reply to emails coming from Eventum, and those
305 replies will be automatically associated with the issue and
306 broadcasted to the entire notification list.
307
308 %description route-emails -l pl
309 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
310 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
311 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
312 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
313 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
314 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
315 rozprowadzane do ca³ej listy og³oszeniowej.
316
317 %package route-notes
318 Summary:        Eventum Note Routing
319 Summary(pl):    Przekazywanie notatek dla Eventum
320 Group:          Applications/WWW
321 Requires:       %{name} = %{version}-%{release}
322 Requires:       eventum(router)
323
324 %description route-notes
325 The note routing feature is used to automatically associate a thread
326 of notes into an Eventum issue. By setting up qmail (or even postfix)
327 to deliver emails sent to a specific address (usually
328 note-<number>@<domain>) to the above script, users are able to use
329 their email clients to reply to internal notes coming from Eventum,
330 and those replies will be automatically associated with the issue and
331 broadcasted to the notification list staff members.
332
333 %description route-notes -l pl
334 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
335 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
336 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
337 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
338 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
339 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
340 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
341
342 %package router-qmail
343 Summary:        Eventum Mail Routing - qmail
344 Summary(pl):    Przekazywanie poczty Eventum - qmail
345 Group:          Applications/Mail
346 # loose dep is intentional. qmail subpackage isn't built on PLD
347 # builders and there really nothing changes.
348 Requires:       %{name} >= %{version}-%{release}
349 Requires:       qmail >= 1.03
350 Provides:       eventum(router)
351 Obsoletes:      eventum(router)
352
353 %description router-qmail
354 This package provides way of routing notes and emails back to Eventum
355 via qmail.
356
357 %description router-qmail -l pl
358 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
359 przez qmaila.
360
361 %package router-postfix
362 Summary:        Eventum Mail Routing - Postfix
363 Summary(pl):    Przekazywanie poczty Eventum - Postfix
364 Group:          Applications/Mail
365 Requires:       %{name} = %{version}-%{release}
366 Requires:       postfix
367 Provides:       eventum(router)
368 Obsoletes:      eventum(router)
369
370 %description router-postfix
371 This package provides way of routing notes and emails back to Eventum
372 via Postfix.
373
374 The Postfix configuration instructions you can find from
375 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
376
377 %description router-postfix -l pl
378 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
379 przez Postfiksa.
380
381 Opis konfiguracji Postfiksa mo¿na znale¼æ pod adresem
382 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
383
384 %package irc
385 Summary:        Eventum IRC Notification Bot
386 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
387 Group:          Applications/WWW
388 Requires(post,preun):   /sbin/chkconfig
389 Requires(triggerpostun):        sed >= 4.0
390 Requires:       %{name} = %{version}-%{release}
391 Requires:       php-pear-Net_SmartIRC
392 Requires:       php-sockets
393 Requires:       rc-scripts >= 0.4.0.18
394
395 %description irc
396 The IRC notification bot is a nice feature for remote teams that want
397 to handle issues and want to have a quick and easy way to get simple
398 notifications. Right now the bot notifies of the following actions:
399 - New Issues
400 - Blocked emails
401 - Issues that got their assignment list changed
402
403 NOTE: You will need to manually edit the bot.php script to set your
404 appropriate preferences, like IRC server and channel that the bot
405 should join.
406
407 %description irc -l pl
408 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
409 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
410 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
411 nastêpuj±cych zdarzeniach:
412 - nowych sprawach
413 - zablokowanych listach
414 - sprawach, dla których zmieni³a siê lista powi±zañ
415
416 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
417 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
418
419 %package cli
420 Summary:        Eventum command-line interface
421 Summary(pl):    Interfejs linii poleceñ dla Eventum
422 Group:          Applications/WWW
423 Requires:       %{name}-base = %{version}-%{release}
424 Requires:       php-cli
425 Requires:       php-common >= 3:4.1.0
426 Requires:       php-pear-XML_RPC
427
428 %description cli
429 The Eventum command-line interface allows you to access most of the
430 features of the web interface straight from your command shell.
431
432 %description cli -l pl
433 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
434 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
435
436 %package scm
437 Summary:        Eventum SCM integration
438 Summary(pl):    Integracja SCM dla Eventum
439 Group:          Applications/WWW
440 Requires:       %{name}-base = %{version}-%{release}
441 Requires:       php-cli
442 Requires:       php-common >= 3:4.1.0
443 Requires:       php-pcre
444
445 %description scm
446 This feature allows your software development teams to integrate your
447 Source Control Management system with your Issue Tracking System.
448
449 The integration is implemented in such a way that it will be forward
450 compatible with pretty much any SCM system, such as CVS.
451
452 For installation see
453 </eventum/help.php?topic=scm_integration_installation>.
454
455 %description scm -l pl
456 Ten pakiet pozwala zespo³om programistów na integracjê systemu
457 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
458 ¶ledzenia spraw.
459
460 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
461 prawie ka¿dym systemem SCM, jak np. CVS.
462
463 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
464 </eventum/help.php?topic=scm_integration_installation>.
465
466 %prep
467 %setup -q %{?_snap:-n %{name}-%{_snap}}
468 # undos the source
469 find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
470
471 rm -f setup.conf.php # not to be installed by *.php glob
472 rm -rf misc/upgrade/*v1.[123]* # too old to support in PLD Linux
473 rm -f misc/upgrade/flush_compiled_templates.php
474 rm -rf misc/upgrade/*/upgrade_config.php # not needed in PLD Linux
475
476 # sample, not used in eventum
477 rm -f rpc/xmlrpc_client.php
478
479 # bug fixes.
480 %patch0 -p1
481 %patch1 -p1
482 %patch2 -p1
483 %patch3 -p1
484 %patch4 -p1
485 %patch5 -p1
486 %patch6 -p1
487 %patch7 -p1
488 %patch8 -p1
489 %patch9 -p1
490 %patch10 -p1
491 %{?with_order_patch:%patch11 -p1}
492 %patch12 -p1
493 %patch13 -p1
494 %patch14 -p1
495 %patch15 -p1
496 %patch16 -p1
497 %patch17 -p1
498
499 # packaging
500 %patch100 -p1
501 %patch101 -p1
502 %patch102 -p1
503 %patch103 -p1
504 %patch104 -p1
505 %patch105 -p1
506 %patch106 -p1
507 %patch107 -p1
508
509 sed -e '1s,#!.*/bin/php -q,#!%{_bindir}/php,' misc/cli/eventum > %{name}-cli
510 sed -e '1i#!%{_bindir}/php' misc/scm/process_cvs_commits.php > %{name}-scm
511 sed -e '1i#!%{_bindir}/php' misc/irc/bot.php > %{name}-bot
512 mv misc/cli/eventumrc_example eventumrc
513 sed -i -e '1i#!%{_bindir}/php' misc/*.php
514 chmod +x misc/*.php
515 mv include/private_key.php private_key.php.in
516
517 # replace in remaining scripts config.inc.php to system one
518 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
519         s,include_once(".*config.inc.php"),include_once("%{_webappdir}/core.php"),
520 '
521
522 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
523         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_webappdir}/private_key.php"),
524 '
525
526 # remove backups from patching as we use globs to package files to buildroot
527 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
528
529 %install
530 rm -rf $RPM_BUILD_ROOT
531 install -d \
532         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
533         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
534         $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
535         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
536         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
537
538 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
539 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
540 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
541 cp -a templates $RPM_BUILD_ROOT%{_appdir}
542 cp -a include/{customer,custom_field,jpgraph,workflow} $RPM_BUILD_ROOT%{_appdir}/include
543 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
544 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
545 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
546
547 cp -a favicon.ico $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
548 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
549 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
550
551 # cli
552 install -d $RPM_BUILD_ROOT%{_appdir}/cli
553 cp -a misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
554 cp -a misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
555 install %{name}-cli $RPM_BUILD_ROOT%{_bindir}/%{name}
556 install %{name}-bot $RPM_BUILD_ROOT%{_sbindir}
557
558 # scm
559 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
560 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
561
562 # private key
563 cp -a private_key.php.in $RPM_BUILD_ROOT%{_webappdir}/private_key.php
564
565 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
566 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
567 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
568 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
569 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
570 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
571 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
572 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
573 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
574
575 sed -e '
576 s,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}}%{?_rc:-%{_rc}},
577 s,%%{PHP_PEAR_DIR}%%,%{php_pear_dir},
578 s,%%{APP_PATH}%%,%{_appdir},
579 s,%%{SMARTY_DIR}%%,%{_smartydir},
580 s,%%{SYSCONFDIR}%%,%{_webappdir},
581 ' %{SOURCE10} > $RPM_BUILD_ROOT%{_webappdir}/core.php
582
583 # config
584 > $RPM_BUILD_ROOT%{_webappdir}/setup.php
585 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_webappdir}/config}.php
586
587 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
588 # These plugins are not in Smarty package (Smarty-2.6.2-3)
589 cp -a \
590         include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
591         include/Smarty/plugins/modifier.highlight_quoted.php \
592         $RPM_BUILD_ROOT%{_smartyplugindir}
593
594 # qmail router
595 %if %{with qmail}
596 d=$RPM_BUILD_ROOT/var/lib/%{name}
597 echo 'root' > $d/.qmail
598 echo 'root' > $d/.qmail-default
599 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
600 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
601 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
602 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
603 %endif
604 # postfix router
605 install %{SOURCE14} $RPM_BUILD_ROOT%{_libdir}/router-postfix
606
607 %clean
608 rm -rf $RPM_BUILD_ROOT
609
610 %pre
611 %addusertogroup http %{name}
612
613 %post
614 # check if the package is configured.
615 if grep -q 'header("Location: setup/")' %{_webappdir}/config.php; then
616 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
617 %banner %{name} -e <<EOF
618
619 You haven't yet configured Eventum!
620 Please open in browser <http://localhost/eventum/>
621 If you need access from elsewhere, you need to edit
622 %{_webappdir}/apache.conf and restart apache.
623
624 IMPORTANT: When You have configured Eventum, please uninstall the
625 setup package, so that %{name}-setup is able to secure your Eventum
626 installation.
627
628 EOF
629 #' vim syntax hack
630 else
631 %banner %{name} -e <<EOF
632
633 You haven't yet configured Eventum!
634
635 To setup eventum, please install %{name}-setup and open in browser
636 <http://localhost/eventum/>.
637 If you need access from elsewhere, you need to edit
638 %{_webappdir}/apache.conf and restart apache.
639
640 IMPORTANT: When You have configured Eventum, please uninstall the
641 setup package, so that %{name}-setup is able to secure your Eventum
642 installation.
643
644 EOF
645 #' vim syntax hack
646 fi
647
648 elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
649 %banner %{name} -e <<EOF
650
651 You have default private key installed!
652
653 Install %{name}-setup and open up http://yourserver/eventum/setup/
654 -- that will help you setup initial config.
655
656 when have configured Eventum, please uninstall the setup package,
657 so that %{name}-setup is able to secure your Eventum installation.
658
659 EOF
660         elif [ -d %{_appdir}/setup ]; then
661 %banner %{name} -e <<EOF
662
663 If you have have configured Eventum, please uninstall the setup package,
664 so that %{name}-setup is able to secure your Eventum installation.
665
666 EOF
667 fi
668
669 # nuke Smarty templates cache after upgrade
670 rm -f /var/cache/eventum/*.php
671
672 %preun
673 if [ "$1" = "0" ]; then
674         # nuke cache
675         rm -f /var/cache/eventum/*.php 2>/dev/null || :
676 fi
677
678 %pre base
679 %groupadd -P %{name}-base -g 146 %{name}
680 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
681
682 %postun base
683 if [ "$1" = "0" ]; then
684         %userremove %{name}
685         %groupremove %{name}
686 fi
687
688 %post router-qmail
689 CF=/etc/qmail/control/virtualdomains
690 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
691         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_webappdir}/config.php 2>/dev/null)
692         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
693         umask 022
694         echo "#${FQDN}:%{name}" >> $CF
695
696 %banner %{name}-qmail -e <<EOF
697
698 Added "#${FQDN}:%{name}" to $CF,
699 Please verify that it is correct and restart qmail:
700 # service qmail reload
701
702 Consult qmail-send(8) for more information on virtualdomains.
703
704 EOF
705 fi
706
707 %preun router-qmail
708 if [ "$1" = "0" ]; then
709         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
710 fi
711
712 %post setup
713 chmod 660 %{_webappdir}/{config,private_key}.php
714 chown root:eventum %{_webappdir}/{config,private_key}.php
715
716 %postun setup
717 if [ "$1" = "0" ]; then
718         chmod 640 %{_webappdir}/{config,private_key}.php
719         chown root:eventum %{_webappdir}/{config,private_key}.php
720 fi
721
722 %post irc
723 /sbin/chkconfig --add eventum-irc
724 %service eventum-irc restart "Eventum IRC Bot"
725
726 %triggerin -- apache1
727 %webapp_register apache %{_webapp}
728
729 %triggerun -- apache1
730 %webapp_unregister apache %{_webapp}
731
732 %triggerin -- apache < 2.2.0, apache-base
733 %webapp_register httpd %{_webapp}
734
735 %triggerun -- apache < 2.2.0, apache-base
736 %webapp_unregister httpd %{_webapp}
737
738 # FIXME
739 # only one upgrade trigger is called if you're upgrading over two
740 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
741 # use common trigger (the highest version and rpmvercmp from poldek?)
742 %triggerpostun -- eventum < 1.5.1-0.257
743 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
744 database_changes.php Perform database changes
745 EOF
746
747 %triggerpostun -- eventum < 1.5.2-0.289
748 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
749 database_changes.php Perform database changes
750 set_priority_ranks.php Fix the ranking of priority values
751 EOF
752
753 %triggerpostun -- eventum < 1.5.3-0.291
754 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
755 database_changes.php Perform database changes
756 EOF
757
758 %triggerpostun -- eventum < 1.5.4-1.12
759 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
760 database_changes.php Perform database changes
761 EOF
762
763 %triggerpostun -- eventum < 1.6.0-RC2.6
764 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.5_to_v1.6.0 <<EOF
765 database_changes.php Perform database changes
766 upgrade_saved_searches.php Upgrade existing custom filters (saved searches)
767 EOF
768
769 %triggerpostun -- eventum < 1.6.1-0.2
770 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.0_to_v1.6.1 <<EOF
771 database_changes.php Perform database changes
772 EOF
773
774 %triggerpostun irc -- eventum-irc < 1.6.1-3.14
775 sed -i -e '
776 s,\$irc_host,$irc_server_hostname,
777 s,\$irc_port,$irc_server_port,
778 s,\$irc_nick,$nickname,
779 s,\$irc_realname,$realname,
780 s,\$irc_username,$username,
781 s,\$irc_password,$password,
782 ' /etc/eventum/irc.php
783
784 %triggerpostun -- eventum < 1.7.0-2.0.48
785 # migrate from apache-config macros
786 if [ -f /etc/%{name}/apache.conf.rpmsave ]; then
787         if [ -d /etc/apache/webapps.d ]; then
788                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
789                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
790         fi
791
792         if [ -d /etc/httpd/webapps.d ]; then
793                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
794                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
795         fi
796 fi
797
798 if [ -L /etc/apache/conf.d/99_%{_webapp}.conf ]; then
799         /usr/sbin/webapp register apache %{_webapp}
800         rm -f /etc/apache/conf.d/99_%{_webapp}.conf
801         %service -q apache reload
802 fi
803 if [ -L /etc/httpd/httpd.conf/99_%{_webapp}.conf ]; then
804         /usr/sbin/webapp register httpd %{_webapp}
805         rm -f /etc/httpd/httpd.conf/99_%{_webapp}.conf
806         %service -q httpd reload
807 fi
808
809 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.1_to_v1.7.0 <<EOF
810 database_changes.php Perform database changes
811 set_root_message_ids.php Set iss_root_message_id
812 EOF
813
814 # regular configs
815 for i in apache.conf config.php private_key.php setup.php; do
816         if [ -f /etc/eventum/$i.rpmsave ]; then
817                 mv -f %{_webappdir}/$i{,.rpmnew}
818                 mv -f /etc/eventum/$i.rpmsave %{_webappdir}/$i
819         fi
820 done
821
822 %triggerpostun cli -- %{name}-cli < 1.7.0-3.4
823 if [ -f %{_webappdir}/cli.php.rpmsave ]; then
824         mv -f %{_sysconfdir}/cli.php{,.rpmnew}
825         mv -f %{_webappdir}/cli.php.rpmsave %{_sysconfdir}/cli.php
826 fi
827
828 %triggerpostun irc -- %{name}-irc < 1.7.0-3.4
829 if [ -f %{_webappdir}/irc.php.rpmsave ]; then
830         mv -f %{_sysconfdir}/irc.php{,.rpmnew}
831         mv -f %{_webappdir}/irc.php.rpmsave %{_sysconfdir}/irc.php
832 fi
833
834 %files
835 %defattr(644,root,root,755)
836 %doc ChangeLog FAQ INSTALL README UPGRADE CONTRIB
837 %doc docs/* setup/schema.sql
838 %attr(751,root,root) %dir %{_webappdir}
839 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
840 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
841 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
842 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
843 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
844 %attr(640,root,eventum) %config %verify(not mtime) %{_webappdir}/core.php
845
846 %dir %attr(731,root,eventum) /var/log/%{name}
847 %attr(620,root,eventum) %ghost /var/log/%{name}/*
848
849 %dir %{_appdir}/htdocs
850 %{_appdir}/htdocs/*.php
851 %{_appdir}/htdocs/*.ico
852 %{_appdir}/htdocs/css
853 %{_appdir}/htdocs/customer
854 %{_appdir}/htdocs/images
855 %{_appdir}/htdocs/js
856 %{_appdir}/htdocs/manage
857 %{_appdir}/htdocs/reports
858 %{_appdir}/htdocs/rpc
859 %{_appdir}/htdocs/misc
860 %{_appdir}/templates
861 %dir %{_appdir}/upgrade
862 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
863 %{_appdir}/upgrade/[!u]*
864 %{_smartyplugindir}
865
866 %dir %{_appdir}/include
867 %{_appdir}/include/customer
868 %{_appdir}/include/custom_field
869 %{_appdir}/include/jpgraph
870 %{_appdir}/include/workflow
871 %{_appdir}/include/class.[!m]*.php
872 %{_appdir}/include/class.mail.php
873 %{_appdir}/include/class.mail_queue.php
874 %{_appdir}/include/class.mime_helper.php
875 %{_appdir}/include/class.misc.php
876 %{_appdir}/include/db_access.php
877
878 %dir %attr(730,root,eventum) /var/run/%{name}
879 %dir %attr(730,root,eventum) /var/cache/%{name}
880
881 %files base
882 %defattr(644,root,root,755)
883 %attr(751,root,root) %dir %{_sysconfdir}
884 %dir %{_libdir}
885 %dir %{_appdir}
886 # qmail will ignore user, if it's home directory is not owned
887 %attr(750,eventum,eventum) %dir /var/lib/%{name}
888 # saved mail copies
889 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
890 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
891 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
892
893 %files setup
894 %defattr(644,root,root,755)
895 %{_appdir}/htdocs/setup
896
897 %files mail-queue
898 %defattr(644,root,root,755)
899 %attr(755,root,root) %{_appdir}/process_mail_queue.php
900 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
901
902 %files mail-download
903 %defattr(644,root,root,755)
904 %attr(755,root,root) %{_appdir}/download_emails.php
905 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
906
907 %files reminder
908 %defattr(644,root,root,755)
909 %attr(755,root,root) %{_appdir}/check_reminders.php
910 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
911
912 %files monitor
913 %defattr(644,root,root,755)
914 %{_appdir}/include/class.monitor.php
915 %attr(755,root,root) %{_appdir}/monitor.php
916 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
917
918 %files route-drafts
919 %defattr(644,root,root,755)
920 %attr(755,root,root) %{_appdir}/route_drafts.php
921
922 %files route-emails
923 %defattr(644,root,root,755)
924 %attr(755,root,root) %{_appdir}/route_emails.php
925
926 %files route-notes
927 %defattr(644,root,root,755)
928 %attr(755,root,root) %{_appdir}/route_notes.php
929
930 %if %{with qmail}
931 %files router-qmail
932 %defattr(644,root,root,755)
933 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
934 %attr(755,root,root) %{_libdir}/router-qmail
935 %endif
936
937 %files router-postfix
938 %defattr(644,root,root,755)
939 %attr(755,root,root) %{_libdir}/router-postfix
940
941 %files irc
942 %defattr(644,root,root,755)
943 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
944 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
945 %attr(755,root,root) %{_sbindir}/%{name}-bot
946 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
947
948 %files cli
949 %defattr(644,root,root,755)
950 %doc eventumrc
951 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
952 %attr(755,root,root) %{_bindir}/%{name}
953 %{_appdir}/cli
954
955 %files scm
956 %defattr(644,root,root,755)
957 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
958 %attr(755,root,root) %{_libdir}/scm
This page took 0.101052 seconds and 2 git commands to generate.