]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
d6f70b1341a1f9c45ae1848e9738207ef1a71f01
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1
6 %define         subver  11
7 %define         githash de1c95975
8 %define         php_min_version 7.1.3
9 Summary:        Eventum Issue / Bug tracking system
10 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
11 Name:           eventum
12 Version:        3.6.4
13 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
14 License:        GPL v2+
15 Group:          Applications/WWW
16 #Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.xz
17 Source0:        https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.xz
18 # Source0-md5:  4d371a3262a4be9a6368ed9ed53ac2fc
19 Source1:        %{name}-apache.conf
20 Source2:        %{name}-mail-queue.cron
21 Source3:        %{name}-mail-download.cron
22 Source4:        %{name}-reminder.cron
23 Source5:        %{name}-monitor.cron
24 Source10:       sphinx.crontab
25 Source13:       %{name}-router-postfix.sh
26 Source14:       %{name}.logrotate
27 Source15:       %{name}-lighttpd.conf
28 Source16:       http://www.isocra.com/images/updown2.gif
29 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
30 Source17:       %{name}.tmpfiles
31 Patch2:         %{name}-order.patch
32 #Patch3:                group-users.patch
33 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
34 # packaging patches that probably never go upstream
35 Patch100:       %{name}-paths.patch
36 Patch107:       %{name}-gettext.patch
37 Patch108:       autoload.patch
38 # some tests
39 Patch200:       %{name}-fixed-nav.patch
40 URL:            https://wiki.github.com/eventum/eventum/
41 BuildRequires:  gettext-tools
42 BuildRequires:  rpmbuild(macros) >= 1.654
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  tar >= 1:1.22
45 BuildRequires:  xz
46 Requires(post): sudo
47 Requires(postun):       /usr/sbin/groupdel
48 Requires(postun):       /usr/sbin/userdel
49 Requires(pre):  /bin/id
50 Requires(pre):  /usr/bin/getgid
51 Requires(pre):  /usr/sbin/groupadd
52 Requires(pre):  /usr/sbin/useradd
53 Requires:       fonts-TTF-RedHat-liberation
54 Requires:       php(core) >= %{php_min_version}
55 Requires:       php(ds)
56 Requires:       php(filter)
57 Requires:       php(iconv)
58 Requires:       php(imap)
59 Requires:       php(json)
60 Requires:       php(mbstring)
61 Requires:       php(pcre)
62 Requires:       php(pdo_mysql)
63 Requires:       php(session)
64 Requires:       php-Smarty >= 3.1
65 Requires:       php-Smarty-plugin-gettext
66 Requires:       php-ZendFramework-Config >= 2.4
67 Requires:       php-ZendFramework-Loader >= 2.4
68 Requires:       php-ZendFramework-Mail >= 2.4.13-2
69 Requires:       php-ZendFramework-Mime >= 2.4
70 Requires:       php-ZendFramework-ServiceManager >= 2.4
71 Requires:       php-ZendFramework-Validator >= 2.4
72 Requires:       php-monolog >= 1.17.2
73 Requires:       php-psr-Log >= 1.0.0-2
74 Requires:       phplot >= 5.8.0
75 Requires:       webapps
76 Requires:       webserver(access)
77 Requires:       webserver(alias)
78 Requires:       webserver(indexfile)
79 Requires:       webserver(php) >= 4.2.0
80 Suggests:       localedb
81 Suggests:       php(mcrypt)
82 Suggests:       php(openssl)
83 Suggests:       webserver(setenv)
84 Provides:       group(eventum)
85 Provides:       user(eventum)
86 Obsoletes:      eventum-base < 3.0.3-1.305
87 Obsoletes:      eventum-route-drafts < 3.0.8-1.1
88 Obsoletes:      eventum-route-emails < 3.0.8-1.1
89 Obsoletes:      eventum-route-notes < 3.0.8-1.1
90 Conflicts:      logrotate < 3.8.0
91 BuildArch:      noarch
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 %define         _libdir         %{_prefix}/lib/%{name}
95 %define         _appdir         %{_datadir}/%{name}
96 %define         _smartydir      %{php_data_dir}/Smarty
97 %define         _webapps        /etc/webapps
98 %define         _webapp         %{name}
99 %define         _webappdir      %{_webapps}/%{_webapp}
100 %define         _sysconfdir     /etc/%{name}
101
102 %description
103 Eventum is a user-friendly and flexible issue tracking system that can
104 be used by a support department to track incoming technical support
105 requests, or by a software development team to quickly organize tasks
106 and bugs.
107
108 %description -l pl.UTF-8
109 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
110 może być używany przez dział obsługi do śledzenia przychodzących żądań
111 obsługi technicznej albo przez zespół tworzący oprogramowanie do
112 szybkiej organizacji zadań i błędów.
113
114 %package setup
115 Summary:        Eventum setup package
116 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
117 Group:          Applications/WWW
118 Requires:       %{name} = %{version}-%{release}
119
120 %description setup
121 Install this package to configure initial Eventum installation. You
122 should uninstall this package when you're done, as it considered
123 insecure to keep the setup files in place.
124
125 %description setup -l pl.UTF-8
126 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
127 pierwszej instalacji. Potem należy go odinstalować, jako że
128 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
129
130 %package doc
131 Summary:        Eventum documentation and Wiki
132 Group:          Documentation
133
134 %description doc
135 Eventum documentation and copy of Wiki.
136
137 %package mail-queue
138 Summary:        Eventum mail queue process
139 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
140 Group:          Applications/WWW
141 Requires:       %{name} = %{version}-%{release}
142 Requires:       crondaemon
143
144 %description mail-queue
145 Beginning with the first release of Eventum, emails are not directly
146 sent out from the various scripts, but rather added to a mail queue
147 table that is processed by a cron job. If an email cannot be sent, it
148 will be marked as such in the mail queue log, and the cron job script
149 will re-try to send it again the next time it runs.
150
151 This package contains the cron job.
152
153 %description mail-queue -l pl.UTF-8
154 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
155 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
156 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
157 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
158 następnym razem.
159
160 Ten pakiet zawiera zadanie dla crona.
161
162 %package mail-download
163 Summary:        Eventum email download
164 Summary(pl.UTF-8):      Ściąganie poczty Eventum
165 Group:          Applications/WWW
166 Requires:       %{name} = %{version}-%{release}
167 Requires:       crondaemon
168
169 %description mail-download
170 In order for Eventum's email integration feature to work, you need to
171 setup a cron job to run the script every so often.
172
173 This package contains the cron job.
174
175 %description mail-download -l pl.UTF-8
176 Aby integracja poczty elektronicznej w Eventum działała, trzeba
177 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
178 często.
179
180 Ten pakiet zawiera zadanie dla crona.
181
182 %package reminder
183 Summary:        Eventum Reminder System
184 Summary(pl.UTF-8):      System przypominania dla Eventum
185 Group:          Applications/WWW
186 Requires:       %{name} = %{version}-%{release}
187 Requires:       crondaemon
188
189 %description reminder
190 The reminder system was designed with the objective as serving as a
191 safe net for issues that need attention. Depending on what
192 configuration you create, you may have several reminders (or alerts)
193 be sent out whenever an issue needs attention, for whatever parameter
194 you may deem necessary.
195
196 This package contains the cron job.
197
198 %description reminder -l pl.UTF-8
199 System przypominania został zaprojektowany tak, aby służył jako
200 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
201 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
202 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
203 uważać za potrzebny.
204
205 Ten pakiet zawiera zadanie dla crona.
206
207 %package monitor
208 Summary:        Eventum Heartbeat Monitor
209 Summary(pl.UTF-8):      Monitor życia dla Eventum
210 Group:          Applications/WWW
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       crondaemon
213 Requires:       php(posix)
214
215 %description monitor
216 The heartbeat monitor is a feature designed for the administrator that
217 wants to be alerted whenever a common problem in Eventum is detected,
218 like the database server not being available anymore, or maybe when
219 the recommended permissions for certain configuration files are
220 changed.
221
222 Please note that before running the heartbeat monitor, you may need to
223 customize some of the checks to be appropriate for your own system,
224 particularly the permission and file checks on
225 Monitor::checkConfiguration().
226
227 This package contains the cron job.
228
229 %description monitor -l pl.UTF-8
230 Monitor życia to funkcjonalność zaprojektowana dla administratora
231 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
232 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
233 do plików konfiguracyjnych.
234
235 Należy zauważyć, że przed uruchomieniem tego monitora może być
236 konieczne dostosowanie niektórych testów do systemu, w szczególności
237 testów uprawnień i plików w Monitor::checkConfiguration().
238
239 Ten pakiet zawiera zadanie dla crona.
240
241 %package router-postfix
242 Summary:        Eventum Mail Routing - Postfix
243 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
244 Group:          Applications/Mail
245 Requires:       %{name} = %{version}-%{release}
246 Requires:       postfix
247 Provides:       eventum(router)
248 Obsoletes:      eventum(router)
249
250 %description router-postfix
251 This package provides way of routing notes and emails back to Eventum
252 via Postfix.
253
254 The Postfix configuration instructions you can find from
255 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
256
257 %description router-postfix -l pl.UTF-8
258 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
259 przez Postfiksa.
260
261 Opis konfiguracji Postfiksa można znaleźć pod adresem
262 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
263
264 %package sphinx
265 Summary:        Eventum Sphinx Search
266 Group:          Applications/WWW
267 Requires:       %{name} = %{version}-%{release}
268 Requires:       crondaemon
269 Requires:       sphinx
270
271 %description sphinx
272 Sphinx search integration for Eventum.
273
274 This package contains the cron job.
275
276 %prep
277 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
278
279 mv docs/examples .
280
281 # bug fixes / features
282 %{?with_order:%patch2 -p1}
283 #%patch3 -p0
284 #%patch4 -p1
285 %{?with_order:cp -p %{SOURCE16} htdocs/images}
286 #%patch200 -p1
287
288 # produce default sphinx config
289 # must be run before paths.patch
290 %if 0
291 cat <<'EOF' > config/config.php
292 <?php
293 define('APP_SQL_DBTYPE', 'mysql');
294 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
295 define('APP_SQL_DBPORT', 3306);
296 define('APP_SQL_DBNAME', 'eventum');
297 define('APP_SQL_DBUSER', 'mysql');
298 define('APP_SQL_DBPASS', '');
299 define('APP_TABLE_PREFIX', 'eventum_');
300 EOF
301 php config/sphinx.conf.php > config/sphinx.conf
302 rm config/config.php
303 %endif
304
305 # packaging
306 %patch100 -p1
307 %patch107 -p1
308 %patch108 -p1
309
310 rm htdocs/.htaccess.dist
311 rm config/config.dist.php
312
313 # cleanup libs taken from system, everything else gets bundled
314 rm -r vendor/fonts/liberation
315 rm -r vendor/monolog/monolog
316 rm -r vendor/php-gettext/php-gettext
317 rm -r vendor/phplot/phplot
318 rm -r vendor/psr/log
319 rm -r vendor/smarty-gettext/smarty-gettext
320 rm -r vendor/smarty/smarty
321 rm -r vendor/sphinx/php-sphinxapi
322 rm -r vendor/zendframework/zend-config
323 rm -r vendor/zendframework/zend-loader
324 rm -r vendor/zendframework/zend-mail
325 rm -r vendor/zendframework/zend-mime
326 rm -r vendor/zendframework/zend-servicemanager
327 rm -r vendor/zendframework/zend-stdlib
328 rm -r vendor/zendframework/zend-validator
329
330 # remove backups from patching as we use globs to package files to buildroot
331 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
332
333 %build
334 %{__make} -C localization
335
336 %install
337 rm -rf $RPM_BUILD_ROOT
338 install -d \
339         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
340         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
341         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
342         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
343         $RPM_BUILD_ROOT/var/lib/%{name}/{routed_{emails,drafts,notes},storage} \
344         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
345
346 %{__make} install-eventum install-localization \
347         sysconfdir=%{_webappdir} \
348         localedir=%{_localedir} \
349         DESTDIR=$RPM_BUILD_ROOT
350
351 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
352
353 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
354
355 # unsupported locale
356 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
357
358 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
359 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
360
361 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
362
363 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
364 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
365 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
366 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
367
368 install -d $RPM_BUILD_ROOT/etc/sphinx
369 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
370 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
371
372 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
373 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
374 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
375 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
376 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
377
378 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
379
380 # postfix router
381 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
382
383 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
384
385 %find_lang %{name}
386
387 %clean
388 rm -rf $RPM_BUILD_ROOT
389
390 %pre
391 %groupadd -g 146 %{name}
392 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
393 %addusertogroup http %{name}
394
395 %post
396 # create empty ghost files
397 # these permissions ensure the logs are write only
398 for a in \
399         errors.log login_attempts.log \
400         eventum.log \
401         auth.log cli.log \
402 ; do
403         test -f /var/log/%{name}/$a && continue
404         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
405 done
406
407 # run database update if configured
408 test -s %{_webappdir}/config.php && \
409 sudo -H -u http -- %{_appdir}/bin/upgrade.php || :
410
411 # nuke Smarty templates cache after upgrade
412 rm -f /var/cache/eventum/*.php
413
414 # Restart webserver on upgrade to get .mo translations reloaded.
415 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
416 %php_webserver_restart
417
418 %preun
419 if [ "$1" = "0" ]; then
420         # nuke cache
421         rm -f /var/cache/eventum/*.php 2>/dev/null || :
422 fi
423
424 %postun
425 if [ "$1" = "0" ]; then
426         %userremove %{name}
427         %groupremove %{name}
428 fi
429
430 %post setup
431 chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
432 chown root:http %{_webappdir}/{config,private_key,secret_key}.php
433
434 %postun setup
435 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
436         chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
437         chown root:http %{_webappdir}/{config,private_key,secret_key}.php
438 fi
439
440 %triggerin -- apache1 < 1.3.37-3, apache1-base
441 %webapp_register apache %{_webapp}
442
443 %triggerun -- apache1 < 1.3.37-3, apache1-base
444 %webapp_unregister apache %{_webapp}
445
446 %triggerin -- apache < 2.2.0, apache-base
447 %webapp_register httpd %{_webapp}
448
449 %triggerun -- apache < 2.2.0, apache-base
450 %webapp_unregister httpd %{_webapp}
451
452 %triggerin -- lighttpd
453 %webapp_register lighttpd %{_webapp}
454
455 %triggerun -- lighttpd
456 %webapp_unregister lighttpd %{_webapp}
457
458 %files -f %{name}.lang
459 %defattr(644,root,root,755)
460 %attr(771,root,http) %dir %{_webappdir}
461 %attr(751,root,http) %dir %{_webappdir}/crm
462 %attr(751,root,http) %dir %{_webappdir}/custom_field
463 %attr(751,root,http) %dir %{_webappdir}/partner
464 %attr(751,root,http) %dir %{_webappdir}/templates
465 %attr(751,root,http) %dir %{_webappdir}/workflow
466 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/bundles.php
467 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
468 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
469 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
470 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/routes.yml
471 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
472 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
473 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
474 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
475 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
476
477 %dir %attr(731,root,http) /var/log/%{name}
478 %attr(620,root,http) %ghost /var/log/%{name}/*
479 %dir %attr(750,root,root) /var/log/archive/%{name}
480 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
481
482 %dir %{_appdir}
483 %{_appdir}/config
484
485 %dir %{_appdir}/bin
486 %attr(755,root,root) %{_appdir}/bin/console.php
487 %attr(755,root,root) %{_appdir}/bin/extension.php
488 %attr(755,root,root) %{_appdir}/bin/ldapsync.php
489 %attr(755,root,root) %{_appdir}/bin/migrate_storage_adapter.php
490 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
491 %attr(755,root,root) %{_appdir}/bin/upgrade.php
492
493 %{_appdir}/autoload.php
494 %{_appdir}/globals.php
495 %{_appdir}/init.php
496 %{_appdir}/phinx.php
497 %dir %{_appdir}/htdocs
498 %{_appdir}/htdocs/*.php
499 %{_appdir}/htdocs/*.ico
500 %{_appdir}/htdocs/ajax
501 %{_appdir}/htdocs/css
502 %{_appdir}/htdocs/customer
503 %{_appdir}/htdocs/images
504 %{_appdir}/htdocs/js
505 %{_appdir}/htdocs/manage
506 %{_appdir}/htdocs/reports
507 %{_appdir}/htdocs/rpc
508 %{_appdir}/htdocs/components
509 %{_appdir}/templates
510
511 %dir %{_appdir}/db
512 %dir %{_appdir}/db/migrations
513 %{_appdir}/db/migrations/*.php
514
515 %{_appdir}/res
516 %{_appdir}/src
517 %{_appdir}/vendor
518 %dir %{_appdir}/lib
519 %{_appdir}/lib/eventum
520 %exclude %{_appdir}/src/Console/Command/MailDownloadCommand.php
521 %exclude %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
522 %exclude %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
523 %exclude %{_appdir}/src/Console/Command/MonitorCommand.php
524 %exclude %{_appdir}/src/Console/Command/ReminderCheckCommand.php
525
526 %dir %{_libdir}
527
528 %{systemdtmpfilesdir}/%{name}.conf
529
530 %dir /var/lib/%{name}
531 %dir %attr(730,root,http) /var/run/%{name}
532 %dir %attr(730,root,http) /var/cache/%{name}
533
534 # saved mail copies
535 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
536 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
537 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
538 # attachment storage
539 %attr(770,root,http) %dir /var/lib/%{name}/storage
540
541 %files setup
542 %defattr(644,root,root,755)
543 %{_appdir}/htdocs/setup
544
545 %files doc
546 %defattr(644,root,root,755)
547 %doc docs/*
548 %{_examplesdir}/%{name}-%{version}
549
550 %files mail-queue
551 %defattr(644,root,root,755)
552 %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
553 %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
554 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
555 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
556 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
557
558 %files mail-download
559 %defattr(644,root,root,755)
560 %{_appdir}/src/Console/Command/MailDownloadCommand.php
561 %attr(755,root,root) %{_appdir}/bin/download_emails.php
562 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
563
564 %files reminder
565 %defattr(644,root,root,755)
566 %{_appdir}/src/Console/Command/ReminderCheckCommand.php
567 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
568 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
569
570 %files monitor
571 %defattr(644,root,root,755)
572 %{_appdir}/src/Console/Command/MonitorCommand.php
573 %attr(755,root,root) %{_appdir}/bin/monitor.php
574 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
575
576 %files router-postfix
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{_libdir}/router-postfix
579
580 %files sphinx
581 %defattr(644,root,root,755)
582 %{_webappdir}/sphinx.conf.php
583 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
584 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.062963 seconds and 3 git commands to generate.