]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
c4e1bd967f00c8ecd7701ddcf2bc8f16cf876c77
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1
6 %define         subver  191
7 %define         githash a6336856a
8 %define         php_min_version 7.1.3
9 Summary:        Eventum Issue / Bug tracking system
10 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
11 Name:           eventum
12 Version:        3.6.2
13 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
14 License:        GPL v2+
15 Group:          Applications/WWW
16 #Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.xz
17 Source0:        https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.xz
18 # Source0-md5:  837a2f7c1be8dbf59f603154deda5e8f
19 Source1:        %{name}-apache.conf
20 Source2:        %{name}-mail-queue.cron
21 Source3:        %{name}-mail-download.cron
22 Source4:        %{name}-reminder.cron
23 Source5:        %{name}-monitor.cron
24 Source10:       sphinx.crontab
25 Source13:       %{name}-router-postfix.sh
26 Source14:       %{name}.logrotate
27 Source15:       %{name}-lighttpd.conf
28 Source16:       http://www.isocra.com/images/updown2.gif
29 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
30 Source17:       %{name}.tmpfiles
31 Patch2:         %{name}-order.patch
32 #Patch3:                group-users.patch
33 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
34 # packaging patches that probably never go upstream
35 Patch100:       %{name}-paths.patch
36 Patch107:       %{name}-gettext.patch
37 Patch108:       autoload.patch
38 # some tests
39 Patch200:       %{name}-fixed-nav.patch
40 URL:            https://wiki.github.com/eventum/eventum/
41 BuildRequires:  gettext-tools
42 BuildRequires:  rpmbuild(macros) >= 1.654
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  tar >= 1:1.22
45 BuildRequires:  xz
46 Requires(post): sudo
47 Requires(postun):       /usr/sbin/groupdel
48 Requires(postun):       /usr/sbin/userdel
49 Requires(pre):  /bin/id
50 Requires(pre):  /usr/bin/getgid
51 Requires(pre):  /usr/sbin/groupadd
52 Requires(pre):  /usr/sbin/useradd
53 Requires:       fonts-TTF-RedHat-liberation
54 Requires:       php(core) >= %{php_min_version}
55 Requires:       php(ds)
56 Requires:       php(filter)
57 Requires:       php(iconv)
58 Requires:       php(imap)
59 Requires:       php(json)
60 Requires:       php(mbstring)
61 Requires:       php(pcre)
62 Requires:       php(pdo_mysql)
63 Requires:       php(session)
64 Requires:       php-Smarty >= 3.1
65 Requires:       php-Smarty-plugin-gettext
66 Requires:       php-ZendFramework-Config >= 2.4
67 Requires:       php-ZendFramework-Loader >= 2.4
68 Requires:       php-ZendFramework-Mail >= 2.4.13-2
69 Requires:       php-ZendFramework-Mime >= 2.4
70 Requires:       php-ZendFramework-ServiceManager >= 2.4
71 Requires:       php-ZendFramework-Validator >= 2.4
72 Requires:       php-monolog >= 1.17.2
73 Requires:       php-pear-Math_Stats
74 Requires:       php-pear-PEAR-core
75 Requires:       php-psr-Log >= 1.0.0-2
76 Requires:       phplot >= 5.8.0
77 Requires:       webapps
78 Requires:       webserver(access)
79 Requires:       webserver(alias)
80 Requires:       webserver(indexfile)
81 Requires:       webserver(php) >= 4.2.0
82 Suggests:       localedb
83 Suggests:       php(mcrypt)
84 Suggests:       php(openssl)
85 Suggests:       php-pear-Net_POP3
86 Suggests:       webserver(setenv)
87 Provides:       group(eventum)
88 Provides:       user(eventum)
89 Obsoletes:      eventum-base < 3.0.3-1.305
90 Obsoletes:      eventum-route-drafts < 3.0.8-1.1
91 Obsoletes:      eventum-route-emails < 3.0.8-1.1
92 Obsoletes:      eventum-route-notes < 3.0.8-1.1
93 Conflicts:      logrotate < 3.8.0
94 BuildArch:      noarch
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %define         _libdir         %{_prefix}/lib/%{name}
98 %define         _appdir         %{_datadir}/%{name}
99 %define         _smartydir      %{php_data_dir}/Smarty
100 %define         _webapps        /etc/webapps
101 %define         _webapp         %{name}
102 %define         _webappdir      %{_webapps}/%{_webapp}
103 %define         _sysconfdir     /etc/%{name}
104
105 %description
106 Eventum is a user-friendly and flexible issue tracking system that can
107 be used by a support department to track incoming technical support
108 requests, or by a software development team to quickly organize tasks
109 and bugs.
110
111 %description -l pl.UTF-8
112 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
113 może być używany przez dział obsługi do śledzenia przychodzących żądań
114 obsługi technicznej albo przez zespół tworzący oprogramowanie do
115 szybkiej organizacji zadań i błędów.
116
117 %package setup
118 Summary:        Eventum setup package
119 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
120 Group:          Applications/WWW
121 Requires:       %{name} = %{version}-%{release}
122
123 %description setup
124 Install this package to configure initial Eventum installation. You
125 should uninstall this package when you're done, as it considered
126 insecure to keep the setup files in place.
127
128 %description setup -l pl.UTF-8
129 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
130 pierwszej instalacji. Potem należy go odinstalować, jako że
131 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
132
133 %package doc
134 Summary:        Eventum documentation and Wiki
135 Group:          Documentation
136
137 %description doc
138 Eventum documentation and copy of Wiki.
139
140 %package mail-queue
141 Summary:        Eventum mail queue process
142 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
143 Group:          Applications/WWW
144 Requires:       %{name} = %{version}-%{release}
145 Requires:       crondaemon
146
147 %description mail-queue
148 Beginning with the first release of Eventum, emails are not directly
149 sent out from the various scripts, but rather added to a mail queue
150 table that is processed by a cron job. If an email cannot be sent, it
151 will be marked as such in the mail queue log, and the cron job script
152 will re-try to send it again the next time it runs.
153
154 This package contains the cron job.
155
156 %description mail-queue -l pl.UTF-8
157 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
158 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
159 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
160 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
161 następnym razem.
162
163 Ten pakiet zawiera zadanie dla crona.
164
165 %package mail-download
166 Summary:        Eventum email download
167 Summary(pl.UTF-8):      Ściąganie poczty Eventum
168 Group:          Applications/WWW
169 Requires:       %{name} = %{version}-%{release}
170 Requires:       crondaemon
171
172 %description mail-download
173 In order for Eventum's email integration feature to work, you need to
174 setup a cron job to run the script every so often.
175
176 This package contains the cron job.
177
178 %description mail-download -l pl.UTF-8
179 Aby integracja poczty elektronicznej w Eventum działała, trzeba
180 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
181 często.
182
183 Ten pakiet zawiera zadanie dla crona.
184
185 %package reminder
186 Summary:        Eventum Reminder System
187 Summary(pl.UTF-8):      System przypominania dla Eventum
188 Group:          Applications/WWW
189 Requires:       %{name} = %{version}-%{release}
190 Requires:       crondaemon
191
192 %description reminder
193 The reminder system was designed with the objective as serving as a
194 safe net for issues that need attention. Depending on what
195 configuration you create, you may have several reminders (or alerts)
196 be sent out whenever an issue needs attention, for whatever parameter
197 you may deem necessary.
198
199 This package contains the cron job.
200
201 %description reminder -l pl.UTF-8
202 System przypominania został zaprojektowany tak, aby służył jako
203 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
204 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
205 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
206 uważać za potrzebny.
207
208 Ten pakiet zawiera zadanie dla crona.
209
210 %package monitor
211 Summary:        Eventum Heartbeat Monitor
212 Summary(pl.UTF-8):      Monitor życia dla Eventum
213 Group:          Applications/WWW
214 Requires:       %{name} = %{version}-%{release}
215 Requires:       crondaemon
216 Requires:       php(posix)
217
218 %description monitor
219 The heartbeat monitor is a feature designed for the administrator that
220 wants to be alerted whenever a common problem in Eventum is detected,
221 like the database server not being available anymore, or maybe when
222 the recommended permissions for certain configuration files are
223 changed.
224
225 Please note that before running the heartbeat monitor, you may need to
226 customize some of the checks to be appropriate for your own system,
227 particularly the permission and file checks on
228 Monitor::checkConfiguration().
229
230 This package contains the cron job.
231
232 %description monitor -l pl.UTF-8
233 Monitor życia to funkcjonalność zaprojektowana dla administratora
234 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
235 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
236 do plików konfiguracyjnych.
237
238 Należy zauważyć, że przed uruchomieniem tego monitora może być
239 konieczne dostosowanie niektórych testów do systemu, w szczególności
240 testów uprawnień i plików w Monitor::checkConfiguration().
241
242 Ten pakiet zawiera zadanie dla crona.
243
244 %package router-postfix
245 Summary:        Eventum Mail Routing - Postfix
246 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
247 Group:          Applications/Mail
248 Requires:       %{name} = %{version}-%{release}
249 Requires:       postfix
250 Provides:       eventum(router)
251 Obsoletes:      eventum(router)
252
253 %description router-postfix
254 This package provides way of routing notes and emails back to Eventum
255 via Postfix.
256
257 The Postfix configuration instructions you can find from
258 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
259
260 %description router-postfix -l pl.UTF-8
261 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
262 przez Postfiksa.
263
264 Opis konfiguracji Postfiksa można znaleźć pod adresem
265 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
266
267 %package sphinx
268 Summary:        Eventum Sphinx Search
269 Group:          Applications/WWW
270 Requires:       %{name} = %{version}-%{release}
271 Requires:       crondaemon
272 Requires:       sphinx
273
274 %description sphinx
275 Sphinx search integration for Eventum.
276
277 This package contains the cron job.
278
279 %prep
280 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
281
282 mv docs/examples .
283
284 # bug fixes / features
285 %{?with_order:%patch2 -p1}
286 #%patch3 -p0
287 #%patch4 -p1
288 %{?with_order:cp -p %{SOURCE16} htdocs/images}
289 #%patch200 -p1
290
291 # produce default sphinx config
292 # must be run before paths.patch
293 %if 0
294 cat <<'EOF' > config/config.php
295 <?php
296 define('APP_SQL_DBTYPE', 'mysql');
297 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
298 define('APP_SQL_DBPORT', 3306);
299 define('APP_SQL_DBNAME', 'eventum');
300 define('APP_SQL_DBUSER', 'mysql');
301 define('APP_SQL_DBPASS', '');
302 define('APP_TABLE_PREFIX', 'eventum_');
303 EOF
304 php config/sphinx.conf.php > config/sphinx.conf
305 rm config/config.php
306 %endif
307
308 # packaging
309 %patch100 -p1
310 %patch107 -p1
311 %patch108 -p1
312
313 rm htdocs/.htaccess.dist
314 rm config/config.dist.php
315
316 # cleanup libs taken from system, everything else gets bundled
317 rm -r vendor/fonts/liberation
318 rm -r vendor/monolog/monolog
319 rm -r vendor/pear/pear-core-minimal
320 rm -r vendor/pear/pear_exception
321 rm -r vendor/pear-pear.php.net/Math_Stats
322 rm -r vendor/php-gettext/php-gettext
323 rm -r vendor/phplot/phplot
324 rm -r vendor/psr/log
325 rm -r vendor/smarty-gettext/smarty-gettext
326 rm -r vendor/smarty/smarty
327 rm -r vendor/sphinx/php-sphinxapi
328 rm -r vendor/zendframework/zend-config
329 rm -r vendor/zendframework/zend-loader
330 rm -r vendor/zendframework/zend-mail
331 rm -r vendor/zendframework/zend-mime
332 rm -r vendor/zendframework/zend-servicemanager
333 rm -r vendor/zendframework/zend-stdlib
334 rm -r vendor/zendframework/zend-validator
335
336 # remove backups from patching as we use globs to package files to buildroot
337 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
338
339 %build
340 %{__make} -C localization
341
342 %install
343 rm -rf $RPM_BUILD_ROOT
344 install -d \
345         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
346         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
347         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
348         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
349         $RPM_BUILD_ROOT/var/lib/%{name}/{routed_{emails,drafts,notes},storage} \
350         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
351
352 %{__make} install-eventum install-localization \
353         sysconfdir=%{_webappdir} \
354         localedir=%{_localedir} \
355         DESTDIR=$RPM_BUILD_ROOT
356
357 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
358
359 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
360
361 # unsupported locale
362 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
363
364 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
365 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
366
367 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
368
369 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
370 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
371 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
372 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
373
374 install -d $RPM_BUILD_ROOT/etc/sphinx
375 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
376 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
377
378 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
379 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
380 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
381 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
382 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
383
384 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
385
386 # postfix router
387 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
388
389 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
390
391 %find_lang %{name}
392
393 %clean
394 rm -rf $RPM_BUILD_ROOT
395
396 %pre
397 %groupadd -g 146 %{name}
398 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
399 %addusertogroup http %{name}
400
401 %post
402 # create empty ghost files
403 # these permissions ensure the logs are write only
404 for a in \
405         errors.log login_attempts.log \
406         eventum.log \
407         auth.log cli.log \
408 ; do
409         test -f /var/log/%{name}/$a && continue
410         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
411 done
412
413 # run database update if configured
414 test -s %{_webappdir}/config.php && \
415 sudo -H -u http -- %{_appdir}/bin/upgrade.php || :
416
417 # nuke Smarty templates cache after upgrade
418 rm -f /var/cache/eventum/*.php
419
420 # Restart webserver on upgrade to get .mo translations reloaded.
421 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
422 %php_webserver_restart
423
424 %preun
425 if [ "$1" = "0" ]; then
426         # nuke cache
427         rm -f /var/cache/eventum/*.php 2>/dev/null || :
428 fi
429
430 %postun
431 if [ "$1" = "0" ]; then
432         %userremove %{name}
433         %groupremove %{name}
434 fi
435
436 %post setup
437 chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
438 chown root:http %{_webappdir}/{config,private_key,secret_key}.php
439
440 %postun setup
441 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
442         chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
443         chown root:http %{_webappdir}/{config,private_key,secret_key}.php
444 fi
445
446 %triggerin -- apache1 < 1.3.37-3, apache1-base
447 %webapp_register apache %{_webapp}
448
449 %triggerun -- apache1 < 1.3.37-3, apache1-base
450 %webapp_unregister apache %{_webapp}
451
452 %triggerin -- apache < 2.2.0, apache-base
453 %webapp_register httpd %{_webapp}
454
455 %triggerun -- apache < 2.2.0, apache-base
456 %webapp_unregister httpd %{_webapp}
457
458 %triggerin -- lighttpd
459 %webapp_register lighttpd %{_webapp}
460
461 %triggerun -- lighttpd
462 %webapp_unregister lighttpd %{_webapp}
463
464 %files -f %{name}.lang
465 %defattr(644,root,root,755)
466 %attr(771,root,http) %dir %{_webappdir}
467 %attr(751,root,http) %dir %{_webappdir}/crm
468 %attr(751,root,http) %dir %{_webappdir}/custom_field
469 %attr(751,root,http) %dir %{_webappdir}/partner
470 %attr(751,root,http) %dir %{_webappdir}/templates
471 %attr(751,root,http) %dir %{_webappdir}/workflow
472 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
473 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
474 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
475 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
476 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
477 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
478 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
479 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
480
481 %dir %attr(731,root,http) /var/log/%{name}
482 %attr(620,root,http) %ghost /var/log/%{name}/*
483 %dir %attr(750,root,root) /var/log/archive/%{name}
484 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
485
486 %dir %{_appdir}
487 %{_appdir}/config
488
489 %dir %{_appdir}/bin
490 %attr(755,root,root) %{_appdir}/bin/extension.php
491 %attr(755,root,root) %{_appdir}/bin/ldapsync.php
492 %attr(755,root,root) %{_appdir}/bin/migrate_storage_adapter.php
493 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
494 %attr(755,root,root) %{_appdir}/bin/upgrade.php
495
496 %{_appdir}/autoload.php
497 %{_appdir}/globals.php
498 %{_appdir}/init.php
499 %{_appdir}/phinx.php
500 %dir %{_appdir}/htdocs
501 %{_appdir}/htdocs/*.php
502 %{_appdir}/htdocs/*.ico
503 %{_appdir}/htdocs/ajax
504 %{_appdir}/htdocs/css
505 %{_appdir}/htdocs/customer
506 %{_appdir}/htdocs/images
507 %{_appdir}/htdocs/js
508 %{_appdir}/htdocs/manage
509 %{_appdir}/htdocs/reports
510 %{_appdir}/htdocs/rpc
511 %{_appdir}/htdocs/components
512 %{_appdir}/templates
513
514 %dir %{_appdir}/db
515 %dir %{_appdir}/db/migrations
516 %{_appdir}/db/migrations/*.php
517
518 %{_appdir}/res
519 %{_appdir}/src
520 %{_appdir}/vendor
521 %dir %{_appdir}/lib
522 %{_appdir}/lib/eventum
523 %exclude %{_appdir}/src/Console/Command/MailDownloadCommand.php
524 %exclude %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
525 %exclude %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
526 %exclude %{_appdir}/src/Console/Command/MonitorCommand.php
527 %exclude %{_appdir}/src/Console/Command/ReminderCheckCommand.php
528
529 %dir %{_libdir}
530
531 %{systemdtmpfilesdir}/%{name}.conf
532
533 %dir /var/lib/%{name}
534 %dir %attr(730,root,http) /var/run/%{name}
535 %dir %attr(730,root,http) /var/cache/%{name}
536
537 # saved mail copies
538 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
539 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
540 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
541 # attachment storage
542 %attr(770,root,http) %dir /var/lib/%{name}/storage
543
544 %files setup
545 %defattr(644,root,root,755)
546 %{_appdir}/htdocs/setup
547
548 %files doc
549 %defattr(644,root,root,755)
550 %doc docs/*
551 %{_examplesdir}/%{name}-%{version}
552
553 %files mail-queue
554 %defattr(644,root,root,755)
555 %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
556 %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
557 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
558 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
559 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
560
561 %files mail-download
562 %defattr(644,root,root,755)
563 %{_appdir}/src/Console/Command/MailDownloadCommand.php
564 %attr(755,root,root) %{_appdir}/bin/download_emails.php
565 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
566
567 %files reminder
568 %defattr(644,root,root,755)
569 %{_appdir}/src/Console/Command/ReminderCheckCommand.php
570 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
571 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
572
573 %files monitor
574 %defattr(644,root,root,755)
575 %{_appdir}/src/Console/Command/MonitorCommand.php
576 %attr(755,root,root) %{_appdir}/bin/monitor.php
577 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
578
579 %files router-postfix
580 %defattr(644,root,root,755)
581 %attr(755,root,root) %{_libdir}/router-postfix
582
583 %files sphinx
584 %defattr(644,root,root,755)
585 %{_webappdir}/sphinx.conf.php
586 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
587 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.153469 seconds and 3 git commands to generate.