]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
a5f73dbd43c217f87ddebdc077aaa79018d96bad
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1
6 #define         subver  347
7 #define         githash 3d9195fa
8 %define         php_min_version 5.5.0
9 %include        /usr/lib/rpm/macros.php
10 Summary:        Eventum Issue / Bug tracking system
11 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
12 Name:           eventum
13 Version:        3.2.1
14 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
15 License:        GPL v2+
16 Group:          Applications/WWW
17 Source0:        https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
18 # Source0-md5:  056b56b2cc5e2673ccbdc5cb65678798
19 #Source0:       https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.gz
20 Source1:        %{name}-apache.conf
21 Source2:        %{name}-mail-queue.cron
22 Source3:        %{name}-mail-download.cron
23 Source4:        %{name}-reminder.cron
24 Source5:        %{name}-monitor.cron
25 Source8:        %{name}-irc.init
26 Source9:        %{name}-irc.sysconfig
27 Source10:       sphinx.crontab
28 Source13:       %{name}-router-postfix.sh
29 Source14:       %{name}.logrotate
30 Source15:       %{name}-lighttpd.conf
31 Source16:       http://www.isocra.com/images/updown2.gif
32 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
33 Source17:       %{name}.tmpfiles
34 Patch2:         %{name}-order.patch
35 #Patch3:                group-users.patch
36 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
37 # packaging patches that probably never go upstream
38 Patch100:       %{name}-paths.patch
39 Patch107:       %{name}-gettext.patch
40 Patch108:       autoload.patch
41 # some tests
42 Patch200:       %{name}-fixed-nav.patch
43 URL:            https://wiki.github.com/eventum/eventum/
44 BuildRequires:  gettext-tools
45 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
46 BuildRequires:  rpmbuild(macros) >= 1.654
47 BuildRequires:  sed >= 4.0
48 Requires(postun):       /usr/sbin/groupdel
49 Requires(postun):       /usr/sbin/userdel
50 Requires(pre):  /bin/id
51 Requires(pre):  /usr/bin/getgid
52 Requires(pre):  /usr/sbin/groupadd
53 Requires(pre):  /usr/sbin/useradd
54 Requires:       fonts-TTF-RedHat-liberation
55 Requires:       php(core) >= %{php_min_version}
56 Requires:       php(filter)
57 Requires:       php(iconv)
58 Requires:       php(imap)
59 Requires:       php(json)
60 Requires:       php(mbstring)
61 Requires:       php(pcre)
62 Requires:       php(pdo_mysql)
63 Requires:       php(session)
64 Requires:       php-Smarty >= 3.1
65 Requires:       php-Smarty-plugin-gettext
66 Requires:       php-ZendFramework-Config >= 2.4
67 Requires:       php-ZendFramework-Loader >= 2.4
68 Requires:       php-ZendFramework-Mail >= 2.4.9-2
69 Requires:       php-ZendFramework-Mime >= 2.4
70 Requires:       php-ZendFramework-ServiceManager >= 2.4
71 Requires:       php-ZendFramework-Validator >= 2.4
72 Requires:       php-monolog >= 1.17.2
73 Requires:       php-pear-Mail_Mime
74 Requires:       php-pear-Mail_mimeDecode
75 Requires:       php-pear-Math_Stats
76 Requires:       php-pear-Net_SMTP
77 Requires:       php-pear-Net_Socket
78 Requires:       php-pear-Net_URL
79 Requires:       php-pear-PEAR-core
80 Requires:       php-pear-Text_Diff
81 Requires:       php-psr-Log >= 1.0.0-2
82 Requires:       php-symfony2-Config >= 2.7.7
83 Requires:       php-symfony2-Console >= 2.7.7
84 Requires:       php-symfony2-EventDispatcher >= 2.7.7
85 Requires:       php-symfony2-Filesystem >= 2.7.7
86 Requires:       php-symfony2-HttpFoundation >= 2.7.7
87 Requires:       php-symfony2-OptionsResolver >= 2.7.7
88 Requires:       php-symfony2-Serializer >= 2.7.7
89 Requires:       php-symfony2-Yaml >= 2.7.7
90 Requires:       phplot >= 5.8.0
91 Requires:       webapps
92 Requires:       webserver(access)
93 Requires:       webserver(alias)
94 Requires:       webserver(indexfile)
95 Requires:       webserver(php) >= 4.2.0
96 Suggests:       localedb
97 Suggests:       php(mcrypt)
98 Suggests:       php(openssl)
99 Suggests:       php-pear-Net_LDAP2
100 Suggests:       php-pear-Net_POP3
101 Suggests:       webserver(setenv)
102 Provides:       group(eventum)
103 Provides:       user(eventum)
104 Obsoletes:      eventum-base < 3.0.3-1.305
105 Obsoletes:      eventum-route-drafts < 3.0.8-1.1
106 Obsoletes:      eventum-route-emails < 3.0.8-1.1
107 Obsoletes:      eventum-route-notes < 3.0.8-1.1
108 Conflicts:      logrotate < 3.8.0
109 BuildArch:      noarch
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 %define         _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
113
114 # exclude optional php dependencies
115 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
116
117 %define         _noautoreq      %{_noautophp}
118
119 %define         _libdir         %{_prefix}/lib/%{name}
120 %define         _appdir         %{_datadir}/%{name}
121 %define         _smartydir      %{php_data_dir}/Smarty
122 %define         _webapps        /etc/webapps
123 %define         _webapp         %{name}
124 %define         _webappdir      %{_webapps}/%{_webapp}
125 %define         _sysconfdir     /etc/%{name}
126
127 %description
128 Eventum is a user-friendly and flexible issue tracking system that can
129 be used by a support department to track incoming technical support
130 requests, or by a software development team to quickly organize tasks
131 and bugs.
132
133 %description -l pl.UTF-8
134 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
135 może być używany przez dział obsługi do śledzenia przychodzących żądań
136 obsługi technicznej albo przez zespół tworzący oprogramowanie do
137 szybkiej organizacji zadań i błędów.
138
139 %package setup
140 Summary:        Eventum setup package
141 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
142 Group:          Applications/WWW
143 Requires:       %{name} = %{version}-%{release}
144
145 %description setup
146 Install this package to configure initial Eventum installation. You
147 should uninstall this package when you're done, as it considered
148 insecure to keep the setup files in place.
149
150 %description setup -l pl.UTF-8
151 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
152 pierwszej instalacji. Potem należy go odinstalować, jako że
153 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
154
155 %package doc
156 Summary:        Eventum documentation and Wiki
157 Group:          Documentation
158
159 %description doc
160 Eventum documentation and copy of Wiki.
161
162 %package mail-queue
163 Summary:        Eventum mail queue process
164 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
165 Group:          Applications/WWW
166 Requires:       %{name} = %{version}-%{release}
167 Requires:       crondaemon
168
169 %description mail-queue
170 Beginning with the first release of Eventum, emails are not directly
171 sent out from the various scripts, but rather added to a mail queue
172 table that is processed by a cron job. If an email cannot be sent, it
173 will be marked as such in the mail queue log, and the cron job script
174 will re-try to send it again the next time it runs.
175
176 This package contains the cron job.
177
178 %description mail-queue -l pl.UTF-8
179 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
180 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
181 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
182 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
183 następnym razem.
184
185 Ten pakiet zawiera zadanie dla crona.
186
187 %package mail-download
188 Summary:        Eventum email download
189 Summary(pl.UTF-8):      Ściąganie poczty Eventum
190 Group:          Applications/WWW
191 Requires:       %{name} = %{version}-%{release}
192 Requires:       crondaemon
193
194 %description mail-download
195 In order for Eventum's email integration feature to work, you need to
196 setup a cron job to run the script every so often.
197
198 This package contains the cron job.
199
200 %description mail-download -l pl.UTF-8
201 Aby integracja poczty elektronicznej w Eventum działała, trzeba
202 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
203 często.
204
205 Ten pakiet zawiera zadanie dla crona.
206
207 %package reminder
208 Summary:        Eventum Reminder System
209 Summary(pl.UTF-8):      System przypominania dla Eventum
210 Group:          Applications/WWW
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       crondaemon
213
214 %description reminder
215 The reminder system was designed with the objective as serving as a
216 safe net for issues that need attention. Depending on what
217 configuration you create, you may have several reminders (or alerts)
218 be sent out whenever an issue needs attention, for whatever parameter
219 you may deem necessary.
220
221 This package contains the cron job.
222
223 %description reminder -l pl.UTF-8
224 System przypominania został zaprojektowany tak, aby służył jako
225 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
226 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
227 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
228 uważać za potrzebny.
229
230 Ten pakiet zawiera zadanie dla crona.
231
232 %package monitor
233 Summary:        Eventum Heartbeat Monitor
234 Summary(pl.UTF-8):      Monitor życia dla Eventum
235 Group:          Applications/WWW
236 Requires:       %{name} = %{version}-%{release}
237 Requires:       crondaemon
238 Requires:       php(posix)
239
240 %description monitor
241 The heartbeat monitor is a feature designed for the administrator that
242 wants to be alerted whenever a common problem in Eventum is detected,
243 like the database server not being available anymore, or maybe when
244 the recommended permissions for certain configuration files are
245 changed.
246
247 Please note that before running the heartbeat monitor, you may need to
248 customize some of the checks to be appropriate for your own system,
249 particularly the permission and file checks on
250 Monitor::checkConfiguration().
251
252 This package contains the cron job.
253
254 %description monitor -l pl.UTF-8
255 Monitor życia to funkcjonalność zaprojektowana dla administratora
256 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
257 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
258 do plików konfiguracyjnych.
259
260 Należy zauważyć, że przed uruchomieniem tego monitora może być
261 konieczne dostosowanie niektórych testów do systemu, w szczególności
262 testów uprawnień i plików w Monitor::checkConfiguration().
263
264 Ten pakiet zawiera zadanie dla crona.
265
266 %package router-postfix
267 Summary:        Eventum Mail Routing - Postfix
268 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
269 Group:          Applications/Mail
270 Requires:       %{name} = %{version}-%{release}
271 Requires:       postfix
272 Provides:       eventum(router)
273 Obsoletes:      eventum(router)
274
275 %description router-postfix
276 This package provides way of routing notes and emails back to Eventum
277 via Postfix.
278
279 The Postfix configuration instructions you can find from
280 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
281
282 %description router-postfix -l pl.UTF-8
283 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
284 przez Postfiksa.
285
286 Opis konfiguracji Postfiksa można znaleźć pod adresem
287 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
288
289 %package irc
290 Summary:        Eventum IRC Notification Bot
291 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
292 Group:          Applications/WWW
293 Requires(post,preun):   /sbin/chkconfig
294 Requires:       %{name} = %{version}-%{release}
295 Requires:       php(pcntl)
296 Requires:       php(sockets)
297 Requires:       php-pear-Net_SmartIRC >= 1.1.9
298 Requires:       rc-scripts >= 0.4.0.18
299
300 %description irc
301 The IRC notification bot is a nice feature for remote teams that want
302 to handle issues and want to have a quick and easy way to get simple
303 notifications. Right now the bot notifies of the following actions:
304 - New Issues
305 - Blocked emails
306 - Issues that got their assignment list changed
307
308 NOTE: You will need to manually edit the bot.php script to set your
309 appropriate preferences, like IRC server and channel that the bot
310 should join.
311
312 %description irc -l pl.UTF-8
313 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
314 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
315 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
316 następujących zdarzeniach:
317 - nowych sprawach
318 - zablokowanych listach
319 - sprawach, dla których zmieniła się lista powiązań
320
321 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
322 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
323
324 %package cli
325 Summary:        Eventum command-line interface
326 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
327 Group:          Applications/WWW
328 Requires:       php(core) >= %{php_min_version}
329 Requires:       php(phar)
330
331 %description cli
332 The Eventum command-line interface allows you to access most of the
333 features of the web interface straight from your command shell.
334
335 %description cli -l pl.UTF-8
336 Interfejs linii poleceń Eventum pozwala na dostęp do większości
337 funkcji interfejsu WWW prosto z linii poleceń powłoki.
338
339 %package sphinx
340 Summary:        Eventum Sphinx Search
341 Group:          Applications/WWW
342 Requires:       %{name} = %{version}-%{release}
343 Requires:       crondaemon
344 Requires:       sphinx
345
346 %description sphinx
347 Sphinx search integration for Eventum.
348
349 This package contains the cron job.
350
351 %prep
352 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
353
354 # hotfix
355 # https://github.com/eventum/eventum/commit/e86bc0ccb5d1ea0b784a2a2e3c409fa00cb78ae2
356 sed -i -e '/upgrade/d' Makefile
357
358 mv docs/examples .
359
360 # bug fixes / features
361 %{?with_order:%patch2 -p1}
362 #%patch3 -p0
363 #%patch4 -p1
364
365 %{?with_order:cp -p %{SOURCE16} htdocs/images}
366
367 #%patch200 -p1
368
369 # produce default sphinx config
370 # must be run before paths.patch
371 %if 0
372 cat <<'EOF' > config/config.php
373 <?php
374 define('APP_SQL_DBTYPE', 'mysql');
375 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
376 define('APP_SQL_DBPORT', 3306);
377 define('APP_SQL_DBNAME', 'eventum');
378 define('APP_SQL_DBUSER', 'mysql');
379 define('APP_SQL_DBPASS', '');
380 define('APP_TABLE_PREFIX', 'eventum_');
381 EOF
382 php config/sphinx.conf.php > config/sphinx.conf
383 rm config/config.php
384 %endif
385
386 # packaging
387 %patch100 -p1
388 %patch107 -p1
389 %patch108 -p1
390
391 rm htdocs/.htaccess.dist
392
393 mv config/irc_config{.dist.php,.php}
394 rm config/config.dist.php
395
396 # cleanup vendor. keep only needed libraries.
397 # (the rest are packaged with system packages)
398 mv vendor vendor.dist
399 vendor() {
400         local path dir
401         for path; do
402                 dir=$(dirname $path)
403                 test -d vendor/$dir || mkdir -p vendor/$dir
404                 mv vendor.dist/$path vendor/$path
405         done
406 }
407 vendor autoload.php
408 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
409 vendor composer/ClassLoader.php
410 vendor ircmaxell/{random-lib,security-lib}
411 vendor defuse/php-encryption
412 vendor willdurand/email-reply-parser
413 vendor theorchard/monolog-cascade
414 vendor malkusch/lock
415 vendor phpxmlrpc/phpxmlrpc
416 vendor robmorgan/phinx
417
418 # remove backups from patching as we use globs to package files to buildroot
419 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
420
421 %build
422 %{__make} -C localization
423
424 %install
425 rm -rf $RPM_BUILD_ROOT
426 install -d \
427         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
428         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
429         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
430         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
431         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
432         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
433
434 %{__make} install-eventum install-cli install-localization \
435         sysconfdir=%{_webappdir} \
436         localedir=%{_localedir} \
437         DESTDIR=$RPM_BUILD_ROOT
438
439 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
440
441 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
442
443 # unsupported locale
444 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
445
446 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
447 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
448
449 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
450
451 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
452 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
453 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
454 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
455
456 install -d $RPM_BUILD_ROOT/etc/sphinx
457 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
458 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
459
460 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
461 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
462 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
463 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
464 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
465
466 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
467 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
468
469 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
470
471 # postfix router
472 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
473
474 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
475
476 %find_lang %{name}
477
478 %clean
479 rm -rf $RPM_BUILD_ROOT
480
481 %pre
482 %groupadd -g 146 %{name}
483 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
484 %addusertogroup http %{name}
485
486 %post
487 # create empty ghost files
488 # these permissions ensure the logs are write only
489 for a in \
490         errors.log login_attempts.log \
491         eventum.log \
492         auth.log cli.log \
493         irc_bot_error.log irc_bot_smartirc.log \
494 ; do
495         test -f /var/log/%{name}/$a && continue
496         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
497 done
498
499 # run database update if configured
500 test -s %{_webappdir}/config.php && \
501 %{_appdir}/bin/upgrade.php || :
502
503 # nuke Smarty templates cache after upgrade
504 rm -f /var/cache/eventum/*.php
505
506 # Restart webserver on upgrade to get .mo translations reloaded.
507 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
508 %php_webserver_restart
509
510 %preun
511 if [ "$1" = "0" ]; then
512         # nuke cache
513         rm -f /var/cache/eventum/*.php 2>/dev/null || :
514 fi
515
516 %postun
517 if [ "$1" = "0" ]; then
518         %userremove %{name}
519         %groupremove %{name}
520 fi
521
522 %post setup
523 chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
524 chown root:http %{_webappdir}/{config,private_key,secret_key}.php
525
526 %postun setup
527 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
528         chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
529         chown root:http %{_webappdir}/{config,private_key,secret_key}.php
530 fi
531
532 %post irc
533 /sbin/chkconfig --add eventum-irc
534 %service eventum-irc restart "Eventum IRC Bot"
535
536 %preun irc
537 if [ "$1" = 0 ]; then
538         %service eventum-irc stop
539         /sbin/chkconfig --del eventum-irc
540 fi
541
542 %triggerin -- apache1 < 1.3.37-3, apache1-base
543 %webapp_register apache %{_webapp}
544
545 %triggerun -- apache1 < 1.3.37-3, apache1-base
546 %webapp_unregister apache %{_webapp}
547
548 %triggerin -- apache < 2.2.0, apache-base
549 %webapp_register httpd %{_webapp}
550
551 %triggerun -- apache < 2.2.0, apache-base
552 %webapp_unregister httpd %{_webapp}
553
554 %triggerin -- lighttpd
555 %webapp_register lighttpd %{_webapp}
556
557 %triggerun -- lighttpd
558 %webapp_unregister lighttpd %{_webapp}
559
560 %triggerpostun -- %{name} < 3.0.0-0.2
561 for f in /etc/cron.d/eventum-*; do
562         # crontabs moved to bin
563         %{__sed} -i -e '
564                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
565                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
566                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
567                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
568         ' $f
569 done
570
571 %files -f %{name}.lang
572 %defattr(644,root,root,755)
573 %attr(751,root,root) %dir %{_webappdir}
574 %attr(751,root,http) %dir %{_webappdir}/crm
575 %attr(751,root,http) %dir %{_webappdir}/custom_field
576 %attr(751,root,http) %dir %{_webappdir}/partner
577 %attr(751,root,http) %dir %{_webappdir}/templates
578 %attr(751,root,http) %dir %{_webappdir}/workflow
579 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
580 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
581 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
582 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
583 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
584 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
585 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
586 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
587
588 %dir %attr(731,root,http) /var/log/%{name}
589 %attr(620,root,http) %ghost /var/log/%{name}/*
590 %dir %attr(750,root,root) /var/log/archive/%{name}
591 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
592
593 %dir %{_appdir}
594 %{_appdir}/config
595
596 %dir %{_appdir}/bin
597 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
598 %attr(755,root,root) %{_appdir}/bin/upgrade.php
599
600 %{_appdir}/autoload.php
601 %{_appdir}/globals.php
602 %{_appdir}/init.php
603 %{_appdir}/phinx.php
604 %dir %{_appdir}/htdocs
605 %{_appdir}/htdocs/*.php
606 %{_appdir}/htdocs/*.ico
607 %{_appdir}/htdocs/ajax
608 %{_appdir}/htdocs/css
609 %{_appdir}/htdocs/customer
610 %{_appdir}/htdocs/images
611 %{_appdir}/htdocs/js
612 %{_appdir}/htdocs/manage
613 %{_appdir}/htdocs/reports
614 %{_appdir}/htdocs/rpc
615 %{_appdir}/htdocs/components
616 %{_appdir}/templates
617
618 %dir %{_appdir}/db
619 %dir %{_appdir}/db/migrations
620 %{_appdir}/db/migrations/*.php
621
622 %{_appdir}/res
623 %{_appdir}/src
624 %{_appdir}/vendor
625 %dir %{_appdir}/lib
626 %{_appdir}/lib/eventum
627 %exclude %{_appdir}/lib/eventum/class.monitor.php
628
629 %dir %{_libdir}
630
631 %{systemdtmpfilesdir}/%{name}.conf
632
633 %dir /var/lib/%{name}
634 %dir %attr(730,root,http) /var/run/%{name}
635 %dir %attr(730,root,http) /var/cache/%{name}
636
637 # saved mail copies
638 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
639 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
640 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
641
642 %files setup
643 %defattr(644,root,root,755)
644 %{_appdir}/htdocs/setup
645
646 %files doc
647 %defattr(644,root,root,755)
648 %doc docs/*
649 %{_examplesdir}/%{name}-%{version}
650
651 %files mail-queue
652 %defattr(644,root,root,755)
653 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
654 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
655 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
656
657 %files mail-download
658 %defattr(644,root,root,755)
659 %attr(755,root,root) %{_appdir}/bin/download_emails.php
660 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
661
662 %files reminder
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
665 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
666
667 %files monitor
668 %defattr(644,root,root,755)
669 %{_appdir}/lib/eventum/class.monitor.php
670 %attr(755,root,root) %{_appdir}/bin/monitor.php
671 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
672
673 %files router-postfix
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_libdir}/router-postfix
676
677 %files irc
678 %defattr(644,root,root,755)
679 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
680 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
681 %attr(755,root,root) %{_appdir}/bin/irc-bot.php
682 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
683
684 %files cli
685 %defattr(644,root,root,755)
686 %doc cli/eventumrc
687 %attr(755,root,root) %{_bindir}/%{name}
688
689 %files sphinx
690 %defattr(644,root,root,755)
691 %{_webappdir}/sphinx.conf.php
692 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
693 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.087996 seconds and 3 git commands to generate.