]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
85833aae3f257a028285f57e36fe5dff8e8255f9
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 #
9 # Conditional build:
10 %bcond_with     order   # with experimental order patch
11
12 %define         subver  pre1
13 %define         rel             0.5
14 %define         php_min_version 5.3.3
15 %include        /usr/lib/rpm/macros.php
16 Summary:        Eventum Issue / Bug tracking system
17 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
18 Name:           eventum
19 Version:        3.0.0
20 Release:        0.%{subver}.%{rel}
21 License:        GPL v2
22 Group:          Applications/WWW
23 Source0:        https://github.com/eventum/eventum/releases/download/v%{version}-pre1/%{name}-%{version}-pre1.tar.gz
24 # Source0-md5:  786930171e278f03baa7b174f52e43d0
25 Source1:        %{name}-apache.conf
26 Source2:        %{name}-mail-queue.cron
27 Source3:        %{name}-mail-download.cron
28 Source4:        %{name}-reminder.cron
29 Source5:        %{name}-monitor.cron
30 Source6:        %{name}-cvs.php
31 Source7:        %{name}-irc.php
32 Source8:        %{name}-irc.init
33 Source9:        %{name}-irc.sysconfig
34 Source10:       sphinx.crontab
35 Source13:       %{name}-router-postfix.sh
36 Source14:       %{name}.logrotate
37 Source15:       %{name}-lighttpd.conf
38 Source16:       http://www.isocra.com/images/updown2.gif
39 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
40 Source17:       %{name}.tmpfiles
41 #Patch0:                %{name}-lf.patch
42 Patch2:         %{name}-order.patch
43 #Patch3:                group-users.patch
44 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
45 # packaging patches that probably never go upstream
46 Patch100:       %{name}-paths.patch
47 Patch101:       %{name}-cvs-config.patch
48 Patch105:       %{name}-bot-reconnect.patch
49 Patch107:       %{name}-gettext.patch
50 # some tests
51 Patch200:       %{name}-fixed-nav.patch
52 URL:            http://eventum.mysql.org/
53 BuildRequires:  /usr/bin/php
54 BuildRequires:  gettext-tools
55 BuildRequires:  php(core) >= %{php_min_version}
56 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
57 BuildRequires:  rpmbuild(macros) >= 1.654
58 BuildRequires:  sed >= 4.0
59 Requires:       %{name}-base = %{version}-%{release}
60 Requires:       Smarty >= 2.6.10-4
61 Requires:       Smarty-plugin-gettext
62 Requires:       php(core) >= %{php_min_version}
63 Requires:       php(filter)
64 Requires:       php(gd)
65 Requires:       php(iconv)
66 Requires:       php(imap)
67 Requires:       php(json)
68 Requires:       php(mbstring)
69 Requires:       php(mysql)
70 Requires:       php(pcre)
71 Requires:       php(session)
72 Requires:       php-pear-DB
73 Requires:       php-pear-Date
74 Requires:       php-pear-Mail
75 Requires:       php-pear-Mail_Mime
76 Requires:       php-pear-Mail_mimeDecode
77 Requires:       php-pear-Math_Stats
78 Requires:       php-pear-Net_DIME
79 Requires:       php-pear-Net_SMTP
80 Requires:       php-pear-Net_Socket
81 Requires:       php-pear-Net_URL
82 Requires:       php-pear-Net_UserAgent_Detect
83 Requires:       php-pear-PEAR-core
84 Requires:       php-pear-Text_Diff
85 Requires:       php-pear-XML_RPC
86 Requires:       webapps
87 Requires:       webserver(access)
88 Requires:       webserver(alias)
89 Requires:       webserver(indexfile)
90 Requires:       webserver(php) >= 4.2.0
91 Suggests:       localedb
92 Suggests:       php-pear-Net_LDAP2
93 Conflicts:      logrotate < 3.8.0
94 BuildArch:      noarch
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %define         _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* jpgraph_dir.php .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
98
99 # exclude optional php dependencies
100 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
101
102 %define         _noautoreq      %{_noautophp}
103
104 %define         _libdir         %{_prefix}/lib/%{name}
105 %define         _appdir         %{_datadir}/%{name}
106 %define         _smartydir      %{php_data_dir}/Smarty
107 %define         _webapps        /etc/webapps
108 %define         _webapp         %{name}
109 %define         _webappdir      %{_webapps}/%{_webapp}
110 %define         _sysconfdir     /etc/%{name}
111
112 %description
113 Eventum is a user-friendly and flexible issue tracking system that can
114 be used by a support department to track incoming technical support
115 requests, or by a software development team to quickly organize tasks
116 and bugs. Eventum is used by the MySQL AB Technical Support team, and
117 has allowed us to dramatically improve our response times.
118
119 %description -l pl.UTF-8
120 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
121 może być używany przez dział obsługi do śledzenia przychodzących żądań
122 obsługi technicznej albo przez zespół tworzący oprogramowanie do
123 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
124 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
125 reakcji.
126
127 %package base
128 Summary:        Eventum base package
129 Summary(pl.UTF-8):      Podstawowy pakiet Eventum
130 Group:          Applications/WWW
131 Requires(postun):       /usr/sbin/groupdel
132 Requires(postun):       /usr/sbin/userdel
133 Requires(pre):  /bin/id
134 Requires(pre):  /usr/bin/getgid
135 Requires(pre):  /usr/sbin/groupadd
136 Requires(pre):  /usr/sbin/useradd
137 Provides:       group(eventum)
138 Provides:       user(eventum)
139
140 %description base
141 This package contains base directory structure for Eventum.
142
143 %description base -l pl.UTF-8
144 Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
145
146 %package setup
147 Summary:        Eventum setup package
148 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
149 Group:          Applications/WWW
150 Requires:       %{name} = %{version}-%{release}
151
152 %description setup
153 Install this package to configure initial Eventum installation. You
154 should uninstall this package when you're done, as it considered
155 insecure to keep the setup files in place.
156
157 %description setup -l pl.UTF-8
158 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
159 pierwszej instalacji. Potem należy go odinstalować, jako że
160 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
161
162 %package mail-queue
163 Summary:        Eventum mail queue process
164 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
165 Group:          Applications/WWW
166 Requires:       %{name} = %{version}-%{release}
167 Requires:       crondaemon
168
169 %description mail-queue
170 Beginning with the first release of Eventum, emails are not directly
171 sent out from the various scripts, but rather added to a mail queue
172 table that is processed by a cron job. If an email cannot be sent, it
173 will be marked as such in the mail queue log, and the cron job script
174 will re-try to send it again the next time it runs.
175
176 This package contains the cron job.
177
178 %description mail-queue -l pl.UTF-8
179 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
180 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
181 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
182 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
183 następnym razem.
184
185 Ten pakiet zawiera zadanie dla crona.
186
187 %package mail-download
188 Summary:        Eventum email download
189 Summary(pl.UTF-8):      Ściąganie poczty Eventum
190 Group:          Applications/WWW
191 Requires:       %{name} = %{version}-%{release}
192 Requires:       crondaemon
193
194 %description mail-download
195 In order for Eventum's email integration feature to work, you need to
196 setup a cron job to run the script every so often.
197
198 This package contains the cron job.
199
200 %description mail-download -l pl.UTF-8
201 Aby integracja poczty elektronicznej w Eventum działała, trzeba
202 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
203 często.
204
205 Ten pakiet zawiera zadanie dla crona.
206
207 %package reminder
208 Summary:        Eventum Reminder System
209 Summary(pl.UTF-8):      System przypominania dla Eventum
210 Group:          Applications/WWW
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       crondaemon
213
214 %description reminder
215 The reminder system was designed with the objective as serving as a
216 safe net for issues that need attention. Depending on what
217 configuration you create, you may have several reminders (or alerts)
218 be sent out whenever an issue needs attention, for whatever parameter
219 you may deem necessary.
220
221 This package contains the cron job.
222
223 %description reminder -l pl.UTF-8
224 System przypominania został zaprojektowany tak, aby służył jako
225 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
226 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
227 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
228 uważać za potrzebny.
229
230 Ten pakiet zawiera zadanie dla crona.
231
232 %package monitor
233 Summary:        Eventum Heartbeat Monitor
234 Summary(pl.UTF-8):      Monitor życia dla Eventum
235 Group:          Applications/WWW
236 Requires:       %{name} = %{version}-%{release}
237 Requires:       crondaemon
238 Requires:       php(posix)
239
240 %description monitor
241 The heartbeat monitor is a feature designed for the administrator that
242 wants to be alerted whenever a common problem in Eventum is detected,
243 like the database server not being available anymore, or maybe when
244 the recommended permissions for certain configuration files are
245 changed.
246
247 Please note that before running the heartbeat monitor, you may need to
248 customize some of the checks to be appropriate for your own system,
249 particularly the permission and file checks on
250 Monitor::checkConfiguration().
251
252 This package contains the cron job.
253
254 %description monitor -l pl.UTF-8
255 Monitor życia to funkcjonalność zaprojektowana dla administratora
256 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
257 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
258 do plików konfiguracyjnych.
259
260 Należy zauważyć, że przed uruchomieniem tego monitora może być
261 konieczne dostosowanie niektórych testów do systemu, w szczególności
262 testów uprawnień i plików w Monitor::checkConfiguration().
263
264 Ten pakiet zawiera zadanie dla crona.
265
266 %package route-drafts
267 Summary:        Eventum Draft Routing
268 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
269 Group:          Applications/WWW
270 Requires:       %{name} = %{version}-%{release}
271 Requires:       eventum(router)
272
273 %description route-drafts
274 The draft routing feature is used to automatically associate a thread
275 of drafts into an Eventum issue. By setting up Postfix to deliver
276 emails sent to a specific address (usually draft-<number>@<domain>) to
277 the above script, users are able to send drafts written in their mail
278 client to be stored in Eventum. These drafts will NOT broadcasted to
279 the notification list.
280
281 %description route-drafts -l pl.UTF-8
282 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
283 problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
284 wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
285 skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
286 kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
287 na listę powiadomień.
288
289 %package route-emails
290 Summary:        Eventum Email Routing
291 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
292 Group:          Applications/WWW
293 Requires:       %{name} = %{version}-%{release}
294 Requires:       eventum(router)
295
296 %description route-emails
297 The email routing feature is used to automatically associate a thread
298 of emails into an Eventum issue. By setting up Postfix to deliver
299 emails sent to a specific address (usually issue-<number>@<domain>) to
300 the above script, users are able to use their email clients to reply
301 to emails coming from Eventum, and those replies will be automatically
302 associated with the issue and broadcasted to the entire notification
303 list.
304
305 %description route-emails -l pl.UTF-8
306 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
307 wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
308 aby dostarczał listy wysyłane na pewien adres (zwykle
309 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
310 używać klientów pocztowych do odpowiadania na listy przychodzące z
311 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
312 rozprowadzane do całej listy ogłoszeniowej.
313
314 %package route-notes
315 Summary:        Eventum Note Routing
316 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
317 Group:          Applications/WWW
318 Requires:       %{name} = %{version}-%{release}
319 Requires:       eventum(router)
320
321 %description route-notes
322 The note routing feature is used to automatically associate a thread
323 of notes into an Eventum issue. By setting up Postfix to deliver
324 emails sent to a specific address (usually note-<number>@<domain>) to
325 the above script, users are able to use their email clients to reply
326 to internal notes coming from Eventum, and those replies will be
327 automatically associated with the issue and broadcasted to the
328 notification list staff members.
329
330 %description route-notes -l pl.UTF-8
331 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
332 wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
333 dostarczał listy wysyłane na pewien adres (zwykle
334 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
335 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
336 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
337 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
338
339 %package router-postfix
340 Summary:        Eventum Mail Routing - Postfix
341 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
342 Group:          Applications/Mail
343 Requires:       %{name} = %{version}-%{release}
344 Requires:       postfix
345 Provides:       eventum(router)
346 Obsoletes:      eventum(router)
347
348 %description router-postfix
349 This package provides way of routing notes and emails back to Eventum
350 via Postfix.
351
352 The Postfix configuration instructions you can find from
353 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
354
355 %description router-postfix -l pl.UTF-8
356 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
357 przez Postfiksa.
358
359 Opis konfiguracji Postfiksa można znaleźć pod adresem
360 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
361
362 %package irc
363 Summary:        Eventum IRC Notification Bot
364 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
365 Group:          Applications/WWW
366 Requires(post,preun):   /sbin/chkconfig
367 Requires:       %{name} = %{version}-%{release}
368 Requires:       php(sockets)
369 Requires:       php-pear-Net_SmartIRC
370 Requires:       rc-scripts >= 0.4.0.18
371
372 %description irc
373 The IRC notification bot is a nice feature for remote teams that want
374 to handle issues and want to have a quick and easy way to get simple
375 notifications. Right now the bot notifies of the following actions:
376 - New Issues
377 - Blocked emails
378 - Issues that got their assignment list changed
379
380 NOTE: You will need to manually edit the bot.php script to set your
381 appropriate preferences, like IRC server and channel that the bot
382 should join.
383
384 %description irc -l pl.UTF-8
385 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
386 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
387 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
388 następujących zdarzeniach:
389 - nowych sprawach
390 - zablokowanych listach
391 - sprawach, dla których zmieniła się lista powiązań
392
393 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
394 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
395
396 %package cli
397 Summary:        Eventum command-line interface
398 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
399 Group:          Applications/WWW
400 Requires:       %{name}-base = %{version}-%{release}
401 Requires:       php(core) >= %{php_min_version}
402 Requires:       php(phar)
403 Requires:       php-pear-XML_RPC
404
405 %description cli
406 The Eventum command-line interface allows you to access most of the
407 features of the web interface straight from your command shell.
408
409 %description cli -l pl.UTF-8
410 Interfejs linii poleceń Eventum pozwala na dostęp do większości
411 funkcji interfejsu WWW prosto z linii poleceń powłoki.
412
413 %package scm
414 Summary:        Eventum SCM integration
415 Summary(pl.UTF-8):      Integracja SCM dla Eventum
416 Group:          Applications/WWW
417 Requires:       %{name}-base = %{version}-%{release}
418 Requires:       php(core) >= %{php_min_version}
419 Requires:       php(pcre)
420
421 %description scm
422 This feature allows your software development teams to integrate your
423 Source Control Management system with your Issue Tracking System.
424
425 The integration is implemented in such a way that it will be forward
426 compatible with pretty much any SCM system, such as CVS.
427
428 For installation see
429 </eventum/help.php?topic=scm_integration_installation>.
430
431 %description scm -l pl.UTF-8
432 Ten pakiet pozwala zespołom programistów na integrację systemu
433 zarządzania źródłami (SCM - Source Control Management) z systemem
434 śledzenia spraw.
435
436 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
437 prawie każdym systemem SCM, jak np. CVS.
438
439 Szczegóły na temat instalacji można przeczytać pod
440 </eventum/help.php?topic=scm_integration_installation>.
441
442 %package sphinx
443 Summary:        Eventum Sphinx Search
444 Group:          Applications/WWW
445 Requires:       %{name} = %{version}-%{release}
446 Requires:       crondaemon
447 Requires:       sphinx
448
449 %description sphinx
450 Sphinx search integration for Eventum.
451
452 This package contains the cron job.
453
454 %prep
455 %setup -qn %{name}-%{version}%{?subver:-%{subver}}
456
457 # GPL v2
458 rm docs/COPYING
459
460 # bug fixes / features
461 #%patch0 -p1
462 %{?with_order:%patch2 -p1}
463 #%patch3 -p0
464 #%patch4 -p1
465
466 %{?with_order:cp -p %{SOURCE16} htdocs/images}
467
468 #%patch200 -p1
469
470 # produce default sphinx config
471 # must be run before paths.patch
472 %if 0
473 cat <<'EOF' > config/config.php
474 <?php
475 define('APP_SQL_DBTYPE', 'mysql');
476 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
477 define('APP_SQL_DBPORT', 3306);
478 define('APP_SQL_DBNAME', 'eventum');
479 define('APP_SQL_DBUSER', 'mysql');
480 define('APP_SQL_DBPASS', '');
481 define('APP_TABLE_PREFIX', 'eventum_');
482 EOF
483 php config/sphinx.conf.php > config/sphinx.conf
484 rm -f config/config.php
485 %endif
486
487 # packaging
488 %patch100 -p1
489 #%patch101 -p1
490 %patch105 -p1
491 %patch107 -p1
492
493 %{__sed} -i -e "
494 s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
495 " upgrade/{*/,}*.php
496
497 # remove backups from patching as we use globs to package files to buildroot
498 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
499
500 %build
501 %{__make} -C localization
502
503 %install
504 rm -rf $RPM_BUILD_ROOT
505 install -d \
506         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
507         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
508         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
509         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
510         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
511         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
512         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
513
514 %{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
515         sysconfdir=%{_webappdir} \
516         localedir=%{_localedir} \
517         DESTDIR=$RPM_BUILD_ROOT
518
519 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
520
521 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
522
523 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
524 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
525 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
526 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
527
528 install -d $RPM_BUILD_ROOT/etc/sphinx
529 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
530 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
531
532 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
533 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
534 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
535 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
536 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
537
538 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
539
540 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
541 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
542
543 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
544
545 # postfix router
546 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
547
548 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
549
550 %find_lang %{name}
551
552 # scm
553 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
554
555 %clean
556 rm -rf $RPM_BUILD_ROOT
557
558 %pre
559 %addusertogroup http %{name}
560
561 %post
562 # greate empty ghost files
563 for a in cli.log errors.log irc_bot.log login_attempts.log; do
564         if [ ! -f /var/log/%{name}/$a ]; then
565                 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
566         fi
567 done
568
569 # run database update if configured
570 test -s %{_webappdir}/config.php && \
571 %{_appdir}/upgrade/update-database.php || :
572
573 # nuke Smarty templates cache after upgrade
574 rm -f /var/cache/eventum/*.php
575
576 # Restart webserver on upgrade to get .mo translations reloaded.
577 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
578 %php_webserver_restart
579
580 %preun
581 if [ "$1" = "0" ]; then
582         # nuke cache
583         rm -f /var/cache/eventum/*.php 2>/dev/null || :
584 fi
585
586 %pre base
587 %groupadd -P %{name}-base -g 146 %{name}
588 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
589
590 %postun base
591 if [ "$1" = "0" ]; then
592         %userremove %{name}
593         %groupremove %{name}
594 fi
595
596 %post setup
597 chmod 660 %{_webappdir}/{config,private_key}.php
598 chown root:http %{_webappdir}/{config,private_key}.php
599
600 %postun setup
601 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
602         chmod 640 %{_webappdir}/{config,private_key}.php
603         chown root:http %{_webappdir}/{config,private_key}.php
604 fi
605
606 %post irc
607 /sbin/chkconfig --add eventum-irc
608 %service eventum-irc restart "Eventum IRC Bot"
609
610 %preun irc
611 if [ "$1" = 0 ]; then
612         %service eventum-irc stop
613         /sbin/chkconfig --del eventum-irc
614 fi
615
616 %triggerin -- apache1 < 1.3.37-3, apache1-base
617 %webapp_register apache %{_webapp}
618
619 %triggerun -- apache1 < 1.3.37-3, apache1-base
620 %webapp_unregister apache %{_webapp}
621
622 %triggerin -- apache < 2.2.0, apache-base
623 %webapp_register httpd %{_webapp}
624
625 %triggerun -- apache < 2.2.0, apache-base
626 %webapp_unregister httpd %{_webapp}
627
628 %triggerin -- lighttpd
629 %webapp_register lighttpd %{_webapp}
630
631 %triggerun -- lighttpd
632 %webapp_unregister lighttpd %{_webapp}
633
634 %triggerpostun -- %{name} < 3.0.0-0.2
635 for f in /etc/cron.d/eventum-*; do
636         # crontabs moved to bin
637         %{__sed} -i -e '
638                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
639                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
640                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
641                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
642         ' $f
643 done
644
645 %files -f %{name}.lang
646 %defattr(644,root,root,755)
647 %doc docs/*
648 %attr(751,root,root) %dir %{_webappdir}
649 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
650 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
651 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
652 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
653 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
654 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
655 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
656
657 %dir %attr(731,root,http) /var/log/%{name}
658 %attr(620,root,http) %ghost /var/log/%{name}/*
659 %dir %attr(750,root,root) /var/log/archive/%{name}
660 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
661
662 %dir %{_appdir}/bin
663 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
664
665 %{_appdir}/init.php
666 %dir %{_appdir}/htdocs
667 %{_appdir}/htdocs/*.php
668 %{_appdir}/htdocs/*.ico
669 %{_appdir}/htdocs/ajax
670 %{_appdir}/htdocs/css
671 %{_appdir}/htdocs/customer
672 %{_appdir}/htdocs/images
673 %{_appdir}/htdocs/js
674 %{_appdir}/htdocs/manage
675 %{_appdir}/htdocs/misc
676 %{_appdir}/htdocs/reports
677 %{_appdir}/htdocs/rpc
678 %{_appdir}/htdocs/components
679 %{_appdir}/templates
680
681 %dir %{_appdir}/upgrade
682 %{_appdir}/upgrade/flush_compiled_templates.php
683 %{_appdir}/upgrade/*.sql
684 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
685 %attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
686 %attr(755,root,root) %{_appdir}/upgrade/ldap_update_users.php
687 %attr(755,root,root) %{_appdir}/upgrade/scm_trac_import.php
688 %{_appdir}/upgrade/patches
689
690 %dir %{_appdir}/lib
691 %{_appdir}/lib/eventum
692 %{_appdir}/lib/jpgraph
693 %exclude %{_appdir}/lib/eventum/class.monitor.php
694
695 %{_appdir}/vendor
696
697 %{systemdtmpfilesdir}/%{name}.conf
698 %dir %attr(730,root,http) /var/run/%{name}
699 %dir %attr(730,root,http) /var/cache/%{name}
700
701 %files base
702 %defattr(644,root,root,755)
703 %attr(751,root,root) %dir %{_sysconfdir}
704 %dir %{_libdir}
705 %dir %{_appdir}
706 %dir /var/lib/%{name}
707 # saved mail copies
708 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
709 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
710 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
711
712 %files setup
713 %defattr(644,root,root,755)
714 %{_appdir}/htdocs/setup
715
716 %files mail-queue
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
719 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
720
721 %files mail-download
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{_appdir}/bin/download_emails.php
724 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
725
726 %files reminder
727 %defattr(644,root,root,755)
728 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
729 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
730
731 %files monitor
732 %defattr(644,root,root,755)
733 %{_appdir}/lib/eventum/class.monitor.php
734 %attr(755,root,root) %{_appdir}/bin/monitor.php
735 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
736
737 %files route-drafts
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_appdir}/bin/route_drafts.php
740
741 %files route-emails
742 %defattr(644,root,root,755)
743 %attr(755,root,root) %{_appdir}/bin/route_emails.php
744
745 %files route-notes
746 %defattr(644,root,root,755)
747 %attr(755,root,root) %{_appdir}/bin/route_notes.php
748
749 %files router-postfix
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_libdir}/router-postfix
752
753 %files irc
754 %defattr(644,root,root,755)
755 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
756 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
757 %attr(755,root,root) %{_sbindir}/%{name}-irc-bot
758 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
759
760 %files cli
761 %defattr(644,root,root,755)
762 %doc cli/eventumrc
763 %attr(755,root,root) %{_bindir}/%{name}
764
765 %files scm
766 %defattr(644,root,root,755)
767 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
768 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
769 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
770
771 %files sphinx
772 %defattr(644,root,root,755)
773 %{_webappdir}/sphinx.conf.php
774 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
775 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.10076 seconds and 3 git commands to generate.