]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
753d5aa24e31a5cc6d5b3194b8b05752368ab222
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1
6 #define         subver  37
7 #define         githash 2276dac77
8 %define         php_min_version 7.3.0
9 Summary:        Eventum Issue / Bug tracking system
10 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
11 Name:           eventum
12 Version:        3.10.1
13 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
14 License:        GPL v2+
15 Group:          Applications/WWW
16 Source0:        https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.xz
17 # Source0-md5:  ff8f9bd0bdddba5eaa38174a4c08ddaa
18 #Source0:       https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.xz
19 Source1:        %{name}-apache.conf
20 Source2:        %{name}-mail-queue.cron
21 Source3:        %{name}-mail-download.cron
22 Source4:        %{name}-reminder.cron
23 Source5:        %{name}-monitor.cron
24 Source10:       sphinx.crontab
25 Source13:       %{name}-router-postfix.sh
26 Source14:       %{name}.logrotate
27 Source15:       %{name}-lighttpd.conf
28 Source16:       http://www.isocra.com/images/updown2.gif
29 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
30 Source17:       %{name}.tmpfiles
31 Patch2:         %{name}-order.patch
32 #Patch3:                group-users.patch
33 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
34 # packaging patches that probably never go upstream
35 Patch100:       %{name}-paths.patch
36 Patch107:       %{name}-gettext.patch
37 Patch108:       autoload.patch
38 # some tests
39 Patch200:       %{name}-fixed-nav.patch
40 URL:            https://github.com/eventum/eventum
41 BuildRequires:  gettext-tools
42 BuildRequires:  rpmbuild(macros) >= 1.654
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  tar >= 1:1.22
45 BuildRequires:  xz
46 Requires(post): sudo
47 Requires(postun):       /usr/sbin/groupdel
48 Requires(postun):       /usr/sbin/userdel
49 Requires(pre):  /bin/id
50 Requires(pre):  /usr/bin/getgid
51 Requires(pre):  /usr/sbin/groupadd
52 Requires(pre):  /usr/sbin/useradd
53 Requires:       fonts-TTF-RedHat-liberation
54 Requires:       php(core) >= %{php_min_version}
55 Requires:       php(ds)
56 Requires:       php(filter)
57 Requires:       php(iconv)
58 Requires:       php(imap)
59 Requires:       php(json)
60 Requires:       php(mbstring)
61 Requires:       php(pcre)
62 Requires:       php(pdo_mysql)
63 Requires:       php(session)
64 Requires:       php-Smarty >= 3.1
65 Requires:       php-Smarty-plugin-gettext
66 Requires:       php-monolog >= 1.17.2
67 Requires:       php-psr-Log >= 1.0.0-2
68 Requires:       phplot >= 5.8.0
69 Requires:       webapps
70 Requires:       webserver(access)
71 Requires:       webserver(alias)
72 Requires:       webserver(indexfile)
73 Requires:       webserver(php) >= 4.2.0
74 Suggests:       localedb
75 Suggests:       php(openssl)
76 Suggests:       webserver(setenv)
77 Provides:       group(eventum)
78 Provides:       user(eventum)
79 Obsoletes:      eventum-base < 3.0.3-1.305
80 Obsoletes:      eventum-route-drafts < 3.0.8-1.1
81 Obsoletes:      eventum-route-emails < 3.0.8-1.1
82 Obsoletes:      eventum-route-notes < 3.0.8-1.1
83 Conflicts:      logrotate < 3.8.0
84 BuildArch:      noarch
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %define         _noautoreq_pear .*
88 %define         _libdir         %{_prefix}/lib/%{name}
89 %define         _appdir         %{_datadir}/%{name}
90 %define         _smartydir      %{php_data_dir}/Smarty
91 %define         _webapps        /etc/webapps
92 %define         _webapp         %{name}
93 %define         _webappdir      %{_webapps}/%{_webapp}
94 %define         _sysconfdir     /etc/%{name}
95
96 %description
97 Eventum is a user-friendly and flexible issue tracking system that can
98 be used by a support department to track incoming technical support
99 requests, or by a software development team to quickly organize tasks
100 and bugs.
101
102 %description -l pl.UTF-8
103 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
104 może być używany przez dział obsługi do śledzenia przychodzących żądań
105 obsługi technicznej albo przez zespół tworzący oprogramowanie do
106 szybkiej organizacji zadań i błędów.
107
108 %package setup
109 Summary:        Eventum setup package
110 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
111 Group:          Applications/WWW
112 Requires:       %{name} = %{version}-%{release}
113
114 %description setup
115 Install this package to configure initial Eventum installation. You
116 should uninstall this package when you're done, as it considered
117 insecure to keep the setup files in place.
118
119 %description setup -l pl.UTF-8
120 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
121 pierwszej instalacji. Potem należy go odinstalować, jako że
122 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
123
124 %package doc
125 Summary:        Eventum documentation and Wiki
126 Group:          Documentation
127
128 %description doc
129 Eventum documentation and Wiki.
130
131 %package mail-queue
132 Summary:        Eventum mail queue process
133 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
134 Group:          Applications/WWW
135 Requires:       %{name} = %{version}-%{release}
136 Requires:       crondaemon
137
138 %description mail-queue
139 Beginning with the first release of Eventum, emails are not directly
140 sent out from the various scripts, but rather added to a mail queue
141 table that is processed by a cron job. If an email cannot be sent, it
142 will be marked as such in the mail queue log, and the cron job script
143 will re-try to send it again the next time it runs.
144
145 This package contains the cron job.
146
147 %description mail-queue -l pl.UTF-8
148 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
149 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
150 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
151 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
152 następnym razem.
153
154 Ten pakiet zawiera zadanie dla crona.
155
156 %package mail-download
157 Summary:        Eventum email download
158 Summary(pl.UTF-8):      Ściąganie poczty Eventum
159 Group:          Applications/WWW
160 Requires:       %{name} = %{version}-%{release}
161 Requires:       crondaemon
162
163 %description mail-download
164 In order for Eventum's email integration feature to work, you need to
165 setup a cron job to run the script every so often.
166
167 This package contains the cron job.
168
169 %description mail-download -l pl.UTF-8
170 Aby integracja poczty elektronicznej w Eventum działała, trzeba
171 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
172 często.
173
174 Ten pakiet zawiera zadanie dla crona.
175
176 %package reminder
177 Summary:        Eventum Reminder System
178 Summary(pl.UTF-8):      System przypominania dla Eventum
179 Group:          Applications/WWW
180 Requires:       %{name} = %{version}-%{release}
181 Requires:       crondaemon
182
183 %description reminder
184 The reminder system was designed with the objective as serving as a
185 safe net for issues that need attention. Depending on what
186 configuration you create, you may have several reminders (or alerts)
187 be sent out whenever an issue needs attention, for whatever parameter
188 you may deem necessary.
189
190 This package contains the cron job.
191
192 %description reminder -l pl.UTF-8
193 System przypominania został zaprojektowany tak, aby służył jako
194 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
195 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
196 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
197 uważać za potrzebny.
198
199 Ten pakiet zawiera zadanie dla crona.
200
201 %package monitor
202 Summary:        Eventum Heartbeat Monitor
203 Summary(pl.UTF-8):      Monitor życia dla Eventum
204 Group:          Applications/WWW
205 Requires:       %{name} = %{version}-%{release}
206 Requires:       crondaemon
207 Requires:       php(posix)
208
209 %description monitor
210 The heartbeat monitor is a feature designed for the administrator that
211 wants to be alerted whenever a common problem in Eventum is detected,
212 like the database server not being available anymore, or maybe when
213 the recommended permissions for certain configuration files are
214 changed.
215
216 Please note that before running the heartbeat monitor, you may need to
217 customize some of the checks to be appropriate for your own system,
218 particularly the permission and file checks on
219 Monitor::checkConfiguration().
220
221 This package contains the cron job.
222
223 %description monitor -l pl.UTF-8
224 Monitor życia to funkcjonalność zaprojektowana dla administratora
225 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
226 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
227 do plików konfiguracyjnych.
228
229 Należy zauważyć, że przed uruchomieniem tego monitora może być
230 konieczne dostosowanie niektórych testów do systemu, w szczególności
231 testów uprawnień i plików w Monitor::checkConfiguration().
232
233 Ten pakiet zawiera zadanie dla crona.
234
235 %package router-postfix
236 Summary:        Eventum Mail Routing - Postfix
237 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
238 Group:          Applications/Mail
239 Requires:       %{name} = %{version}-%{release}
240 Requires:       postfix
241
242 %description router-postfix
243 This package provides way of routing notes and emails back to Eventum
244 via Postfix.
245
246 The Postfix configuration instructions you can find from
247 <https://github.com/eventum/eventum/blob/v%{version}/docs/wiki/System-Admin/Setting-up-email-routing-with-postfix.md>
248
249 %description router-postfix -l pl.UTF-8
250 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
251 przez Postfiksa.
252
253 Opis konfiguracji Postfiksa można znaleźć pod adresem
254 <https://github.com/eventum/eventum/blob/v%{version}/docs/wiki/System-Admin/Setting-up-email-routing-with-postfix.md>
255
256 %package sphinx
257 Summary:        Eventum Sphinx Search
258 Group:          Applications/WWW
259 Requires:       %{name} = %{version}-%{release}
260 Requires:       crondaemon
261 Requires:       sphinx
262
263 %description sphinx
264 Sphinx search integration for Eventum.
265
266 This package contains the cron job.
267
268 %prep
269 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
270
271 mv docs/examples .
272
273 # bug fixes / features
274 %{?with_order:%patch2 -p1}
275 #%patch3 -p0
276 #%patch4 -p1
277 %{?with_order:cp -p %{SOURCE16} htdocs/images}
278 #%patch200 -p1
279
280 # produce default sphinx config
281 # must be run before paths.patch
282 %if 0
283 cat <<'EOF' > config/config.php
284 <?php
285 define('APP_SQL_DBTYPE', 'mysql');
286 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
287 define('APP_SQL_DBPORT', 3306);
288 define('APP_SQL_DBNAME', 'eventum');
289 define('APP_SQL_DBUSER', 'mysql');
290 define('APP_SQL_DBPASS', '');
291 define('APP_TABLE_PREFIX', 'eventum_');
292 EOF
293 php config/sphinx.conf.php > config/sphinx.conf
294 rm config/config.php
295 %endif
296
297 # packaging
298 %patch100 -p1
299 %patch107 -p1
300 %patch108 -p1
301
302 rm htdocs/.htaccess.dist
303
304 # cleanup libs taken from system, everything else gets bundled
305 rm -r vendor/fonts/liberation
306 rm -r vendor/monolog/monolog
307 rm -r vendor/phplot/phplot
308 rm -r vendor/psr/log
309 rm -r vendor/smarty-gettext/smarty-gettext
310 rm -r vendor/smarty/smarty
311 rm -r vendor/sphinx/php-sphinxapi
312
313 %{__sed} -i '1s|^#!.*php\b|#!/usr/bin/php|' config/sphinx.conf.php bin/*.php
314
315 # remove backups from patching as we use globs to package files to buildroot
316 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
317
318 %build
319 %{__make} -C localization
320
321 %install
322 rm -rf $RPM_BUILD_ROOT
323 install -d \
324         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
325         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
326         $RPM_BUILD_ROOT/var/{run,lib,spool}/%{name} \
327         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
328         $RPM_BUILD_ROOT/var/lib/%{name}/{routed_{emails,drafts,notes},storage} \
329         $RPM_BUILD_ROOT/var/cache/%{name}/doctrine/proxies \
330         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
331
332 %{__make} install-eventum install-localization \
333         sysconfdir=%{_webappdir} \
334         localedir=%{_localedir} \
335         DESTDIR=$RPM_BUILD_ROOT
336
337 ln -s --relative $RPM_BUILD_ROOT{%{_webappdir},%{_appdir}/config}
338
339 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
340
341 # unsupported locale
342 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
343
344 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
345 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
346
347 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
348
349 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
350 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
351 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
352 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
353
354 install -d $RPM_BUILD_ROOT/etc/sphinx
355 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
356 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
357
358 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
359 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
360 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
361 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
362 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
363
364 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
365
366 # postfix router
367 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
368
369 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
370
371 %find_lang %{name}
372
373 %clean
374 rm -rf $RPM_BUILD_ROOT
375
376 %pre
377 %groupadd -g 146 %{name}
378 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
379 %addusertogroup http %{name}
380
381 %post
382 # create empty ghost files
383 # these permissions ensure the logs are write only
384 for a in \
385         errors.log login_attempts.log \
386         eventum.log \
387         auth.log cli.log \
388 ; do
389         test -f /var/log/%{name}/$a && continue
390         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
391 done
392
393 # run database update if configured
394 test -s %{_webappdir}/setup.php && \
395 sudo -H -u http -- %{_appdir}/bin/upgrade.php || :
396
397 # nuke Smarty templates cache after upgrade
398 rm -f /var/cache/eventum/smarty/*.php
399
400 # Restart webserver on upgrade to get .mo translations reloaded.
401 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
402 %php_webserver_restart
403
404 %postun
405 if [ "$1" = "0" ]; then
406         %userremove %{name}
407         %groupremove %{name}
408 fi
409
410 %post setup
411 chmod 660 %{_webappdir}/{setup,private_key,secret_key}.php
412 chown root:http %{_webappdir}/{setup,private_key,secret_key}.php
413
414 %postun setup
415 if [ "$1" = "0" ] && [ -f %{_webappdir}/setup.php ]; then
416         chmod 640 %{_webappdir}/{setup,private_key,secret_key}.php
417         chown root:http %{_webappdir}/{setup,private_key,secret_key}.php
418 fi
419
420 %triggerin -- apache1 < 1.3.37-3, apache1-base
421 %webapp_register apache %{_webapp}
422
423 %triggerun -- apache1 < 1.3.37-3, apache1-base
424 %webapp_unregister apache %{_webapp}
425
426 %triggerin -- apache < 2.2.0, apache-base
427 %webapp_register httpd %{_webapp}
428
429 %triggerun -- apache < 2.2.0, apache-base
430 %webapp_unregister httpd %{_webapp}
431
432 %triggerin -- lighttpd
433 %webapp_register lighttpd %{_webapp}
434
435 %triggerun -- lighttpd
436 %webapp_unregister lighttpd %{_webapp}
437
438 %files -f %{name}.lang
439 %defattr(644,root,root,755)
440 %attr(771,root,http) %dir %{_webappdir}
441 %attr(751,root,http) %dir %{_webappdir}/crm
442 %attr(751,root,http) %dir %{_webappdir}/custom_field
443 %attr(751,root,http) %dir %{_webappdir}/partner
444 %attr(751,root,http) %dir %{_webappdir}/templates
445 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
446 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
447 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
448 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
449 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
450 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
451 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
452
453 %dir %attr(731,root,http) /var/log/%{name}
454 %attr(620,root,http) %ghost /var/log/%{name}/*
455 %dir %attr(750,root,root) /var/log/archive/%{name}
456 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
457
458 %dir %{_appdir}
459 %{_appdir}/config
460
461 %dir %{_appdir}/bin
462 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
463 %attr(755,root,root) %{_appdir}/bin/console.php
464 %attr(755,root,root) %{_appdir}/bin/download_emails.php
465 %attr(755,root,root) %{_appdir}/bin/export-issues.php
466 %attr(755,root,root) %{_appdir}/bin/extension.php
467 %attr(755,root,root) %{_appdir}/bin/ldapsync.php
468 %attr(755,root,root) %{_appdir}/bin/migrate_storage_adapter.php
469 %attr(755,root,root) %{_appdir}/bin/monitor.php
470 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
471 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
472 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
473 %attr(755,root,root) %{_appdir}/bin/upgrade.php
474
475 %{_appdir}/autoload.php
476 %{_appdir}/init.php
477 %{_appdir}/phinx.php
478 %dir %{_appdir}/htdocs
479 %{_appdir}/htdocs/*.php
480 %{_appdir}/htdocs/*.ico
481 %{_appdir}/htdocs/mix-manifest.json
482 %{_appdir}/htdocs/ajax
483 %{_appdir}/htdocs/css
484 %{_appdir}/htdocs/customer
485 %{_appdir}/htdocs/fonts
486 %{_appdir}/htdocs/images
487 %{_appdir}/htdocs/js
488 %{_appdir}/htdocs/manage
489 %{_appdir}/htdocs/reports
490 %{_appdir}/htdocs/rpc
491 %{_appdir}/templates
492
493 %dir %{_appdir}/db
494 %dir %{_appdir}/db/migrations
495 %{_appdir}/db/migrations/*.php
496 %dir %{_appdir}/db/seeds
497 %{_appdir}/db/seeds/*.php
498
499 %{_appdir}/res
500 %{_appdir}/src
501 %{_appdir}/vendor
502 %dir %{_appdir}/lib
503 %{_appdir}/lib/eventum
504
505 %dir %{_libdir}
506
507 %{systemdtmpfilesdir}/%{name}.conf
508
509 %dir /var/lib/%{name}
510 %dir %attr(730,root,http) /var/run/%{name}
511 %dir %attr(730,root,http) /var/spool/%{name}
512 %dir %attr(730,root,http) /var/cache/%{name}
513 %dir %attr(730,root,http) /var/cache/%{name}/doctrine
514 %dir %attr(730,root,http) /var/cache/%{name}/doctrine/proxies
515
516 # saved mail copies
517 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
518 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
519 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
520 # attachment storage
521 %attr(770,root,http) %dir /var/lib/%{name}/storage
522
523 %files setup
524 %defattr(644,root,root,755)
525 %{_appdir}/htdocs/setup
526
527 %files doc
528 %defattr(644,root,root,755)
529 %doc docs/*
530 %{_examplesdir}/%{name}-%{version}
531
532 %files mail-queue
533 %defattr(644,root,root,755)
534 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
535
536 %files mail-download
537 %defattr(644,root,root,755)
538 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
539
540 %files reminder
541 %defattr(644,root,root,755)
542 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
543
544 %files monitor
545 %defattr(644,root,root,755)
546 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
547
548 %files router-postfix
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_libdir}/router-postfix
551
552 %files sphinx
553 %defattr(644,root,root,755)
554 %{_webappdir}/sphinx.conf.php
555 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
556 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.093857 seconds and 2 git commands to generate.