]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
4afe2e9a40f82ba2a198beedc38c9f1498ba86e6
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1
6 #define         subver  37
7 #define         githash 2276dac77
8 %define         php_min_version 7.1.3
9 Summary:        Eventum Issue / Bug tracking system
10 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
11 Name:           eventum
12 Version:        3.8.9
13 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
14 License:        GPL v2+
15 Group:          Applications/WWW
16 Source0:        https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.xz
17 # Source0-md5:  b06658cf1ce557a615d4e7fb6f559f7c
18 #Source0:       https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.xz
19 Source1:        %{name}-apache.conf
20 Source2:        %{name}-mail-queue.cron
21 Source3:        %{name}-mail-download.cron
22 Source4:        %{name}-reminder.cron
23 Source5:        %{name}-monitor.cron
24 Source10:       sphinx.crontab
25 Source13:       %{name}-router-postfix.sh
26 Source14:       %{name}.logrotate
27 Source15:       %{name}-lighttpd.conf
28 Source16:       http://www.isocra.com/images/updown2.gif
29 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
30 Source17:       %{name}.tmpfiles
31 Patch2:         %{name}-order.patch
32 #Patch3:                group-users.patch
33 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
34 # packaging patches that probably never go upstream
35 Patch100:       %{name}-paths.patch
36 Patch107:       %{name}-gettext.patch
37 Patch108:       autoload.patch
38 # some tests
39 Patch200:       %{name}-fixed-nav.patch
40 URL:            https://github.com/eventum/eventum
41 BuildRequires:  gettext-tools
42 BuildRequires:  rpmbuild(macros) >= 1.654
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  tar >= 1:1.22
45 BuildRequires:  xz
46 Requires(post): sudo
47 Requires(postun):       /usr/sbin/groupdel
48 Requires(postun):       /usr/sbin/userdel
49 Requires(pre):  /bin/id
50 Requires(pre):  /usr/bin/getgid
51 Requires(pre):  /usr/sbin/groupadd
52 Requires(pre):  /usr/sbin/useradd
53 Requires:       fonts-TTF-RedHat-liberation
54 Requires:       php(core) >= %{php_min_version}
55 Requires:       php(ds)
56 Requires:       php(filter)
57 Requires:       php(iconv)
58 Requires:       php(imap)
59 Requires:       php(json)
60 Requires:       php(mbstring)
61 Requires:       php(pcre)
62 Requires:       php(pdo_mysql)
63 Requires:       php(session)
64 Requires:       php-Smarty >= 3.1
65 Requires:       php-Smarty-plugin-gettext
66 Requires:       php-monolog >= 1.17.2
67 Requires:       php-psr-Log >= 1.0.0-2
68 Requires:       phplot >= 5.8.0
69 Requires:       webapps
70 Requires:       webserver(access)
71 Requires:       webserver(alias)
72 Requires:       webserver(indexfile)
73 Requires:       webserver(php) >= 4.2.0
74 Suggests:       localedb
75 Suggests:       php(mcrypt)
76 Suggests:       php(openssl)
77 Suggests:       webserver(setenv)
78 Provides:       group(eventum)
79 Provides:       user(eventum)
80 Obsoletes:      eventum-base < 3.0.3-1.305
81 Obsoletes:      eventum-route-drafts < 3.0.8-1.1
82 Obsoletes:      eventum-route-emails < 3.0.8-1.1
83 Obsoletes:      eventum-route-notes < 3.0.8-1.1
84 Conflicts:      logrotate < 3.8.0
85 BuildArch:      noarch
86 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
87
88 %define         _libdir         %{_prefix}/lib/%{name}
89 %define         _appdir         %{_datadir}/%{name}
90 %define         _smartydir      %{php_data_dir}/Smarty
91 %define         _webapps        /etc/webapps
92 %define         _webapp         %{name}
93 %define         _webappdir      %{_webapps}/%{_webapp}
94 %define         _sysconfdir     /etc/%{name}
95
96 %description
97 Eventum is a user-friendly and flexible issue tracking system that can
98 be used by a support department to track incoming technical support
99 requests, or by a software development team to quickly organize tasks
100 and bugs.
101
102 %description -l pl.UTF-8
103 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
104 może być używany przez dział obsługi do śledzenia przychodzących żądań
105 obsługi technicznej albo przez zespół tworzący oprogramowanie do
106 szybkiej organizacji zadań i błędów.
107
108 %package setup
109 Summary:        Eventum setup package
110 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
111 Group:          Applications/WWW
112 Requires:       %{name} = %{version}-%{release}
113
114 %description setup
115 Install this package to configure initial Eventum installation. You
116 should uninstall this package when you're done, as it considered
117 insecure to keep the setup files in place.
118
119 %description setup -l pl.UTF-8
120 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
121 pierwszej instalacji. Potem należy go odinstalować, jako że
122 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
123
124 %package doc
125 Summary:        Eventum documentation and Wiki
126 Group:          Documentation
127
128 %description doc
129 Eventum documentation and Wiki.
130
131 %package mail-queue
132 Summary:        Eventum mail queue process
133 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
134 Group:          Applications/WWW
135 Requires:       %{name} = %{version}-%{release}
136 Requires:       crondaemon
137
138 %description mail-queue
139 Beginning with the first release of Eventum, emails are not directly
140 sent out from the various scripts, but rather added to a mail queue
141 table that is processed by a cron job. If an email cannot be sent, it
142 will be marked as such in the mail queue log, and the cron job script
143 will re-try to send it again the next time it runs.
144
145 This package contains the cron job.
146
147 %description mail-queue -l pl.UTF-8
148 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
149 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
150 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
151 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
152 następnym razem.
153
154 Ten pakiet zawiera zadanie dla crona.
155
156 %package mail-download
157 Summary:        Eventum email download
158 Summary(pl.UTF-8):      Ściąganie poczty Eventum
159 Group:          Applications/WWW
160 Requires:       %{name} = %{version}-%{release}
161 Requires:       crondaemon
162
163 %description mail-download
164 In order for Eventum's email integration feature to work, you need to
165 setup a cron job to run the script every so often.
166
167 This package contains the cron job.
168
169 %description mail-download -l pl.UTF-8
170 Aby integracja poczty elektronicznej w Eventum działała, trzeba
171 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
172 często.
173
174 Ten pakiet zawiera zadanie dla crona.
175
176 %package reminder
177 Summary:        Eventum Reminder System
178 Summary(pl.UTF-8):      System przypominania dla Eventum
179 Group:          Applications/WWW
180 Requires:       %{name} = %{version}-%{release}
181 Requires:       crondaemon
182
183 %description reminder
184 The reminder system was designed with the objective as serving as a
185 safe net for issues that need attention. Depending on what
186 configuration you create, you may have several reminders (or alerts)
187 be sent out whenever an issue needs attention, for whatever parameter
188 you may deem necessary.
189
190 This package contains the cron job.
191
192 %description reminder -l pl.UTF-8
193 System przypominania został zaprojektowany tak, aby służył jako
194 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
195 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
196 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
197 uważać za potrzebny.
198
199 Ten pakiet zawiera zadanie dla crona.
200
201 %package monitor
202 Summary:        Eventum Heartbeat Monitor
203 Summary(pl.UTF-8):      Monitor życia dla Eventum
204 Group:          Applications/WWW
205 Requires:       %{name} = %{version}-%{release}
206 Requires:       crondaemon
207 Requires:       php(posix)
208
209 %description monitor
210 The heartbeat monitor is a feature designed for the administrator that
211 wants to be alerted whenever a common problem in Eventum is detected,
212 like the database server not being available anymore, or maybe when
213 the recommended permissions for certain configuration files are
214 changed.
215
216 Please note that before running the heartbeat monitor, you may need to
217 customize some of the checks to be appropriate for your own system,
218 particularly the permission and file checks on
219 Monitor::checkConfiguration().
220
221 This package contains the cron job.
222
223 %description monitor -l pl.UTF-8
224 Monitor życia to funkcjonalność zaprojektowana dla administratora
225 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
226 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
227 do plików konfiguracyjnych.
228
229 Należy zauważyć, że przed uruchomieniem tego monitora może być
230 konieczne dostosowanie niektórych testów do systemu, w szczególności
231 testów uprawnień i plików w Monitor::checkConfiguration().
232
233 Ten pakiet zawiera zadanie dla crona.
234
235 %package router-postfix
236 Summary:        Eventum Mail Routing - Postfix
237 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
238 Group:          Applications/Mail
239 Requires:       %{name} = %{version}-%{release}
240 Requires:       postfix
241 Provides:       eventum(router)
242 Obsoletes:      eventum(router)
243
244 %description router-postfix
245 This package provides way of routing notes and emails back to Eventum
246 via Postfix.
247
248 The Postfix configuration instructions you can find from
249 <https://github.com/eventum/eventum/blob/v%{version}/docs/wiki/System-Admin/Setting-up-email-routing-with-postfix.md>
250
251 %description router-postfix -l pl.UTF-8
252 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
253 przez Postfiksa.
254
255 Opis konfiguracji Postfiksa można znaleźć pod adresem
256 <https://github.com/eventum/eventum/blob/v%{version}/docs/wiki/System-Admin/Setting-up-email-routing-with-postfix.md>
257
258 %package sphinx
259 Summary:        Eventum Sphinx Search
260 Group:          Applications/WWW
261 Requires:       %{name} = %{version}-%{release}
262 Requires:       crondaemon
263 Requires:       sphinx
264
265 %description sphinx
266 Sphinx search integration for Eventum.
267
268 This package contains the cron job.
269
270 %prep
271 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
272
273 mv docs/examples .
274
275 # bug fixes / features
276 %{?with_order:%patch2 -p1}
277 #%patch3 -p0
278 #%patch4 -p1
279 %{?with_order:cp -p %{SOURCE16} htdocs/images}
280 #%patch200 -p1
281
282 # produce default sphinx config
283 # must be run before paths.patch
284 %if 0
285 cat <<'EOF' > config/config.php
286 <?php
287 define('APP_SQL_DBTYPE', 'mysql');
288 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
289 define('APP_SQL_DBPORT', 3306);
290 define('APP_SQL_DBNAME', 'eventum');
291 define('APP_SQL_DBUSER', 'mysql');
292 define('APP_SQL_DBPASS', '');
293 define('APP_TABLE_PREFIX', 'eventum_');
294 EOF
295 php config/sphinx.conf.php > config/sphinx.conf
296 rm config/config.php
297 %endif
298
299 # packaging
300 %patch100 -p1
301 %patch107 -p1
302 %patch108 -p1
303
304 rm htdocs/.htaccess.dist
305 rm config/config.dist.php
306
307 # cleanup libs taken from system, everything else gets bundled
308 rm -r vendor/fonts/liberation
309 rm -r vendor/monolog/monolog
310 rm -r vendor/phplot/phplot
311 rm -r vendor/psr/log
312 rm -r vendor/smarty-gettext/smarty-gettext
313 rm -r vendor/smarty/smarty
314 rm -r vendor/sphinx/php-sphinxapi
315
316 %{__sed} -i '1s|^#!.*php\b|#!/usr/bin/php|' config/sphinx.conf.php bin/*.php
317
318 # remove backups from patching as we use globs to package files to buildroot
319 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
320
321 %build
322 %{__make} -C localization
323
324 %install
325 rm -rf $RPM_BUILD_ROOT
326 install -d \
327         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
328         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
329         $RPM_BUILD_ROOT/var/{run,lib}/%{name} \
330         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
331         $RPM_BUILD_ROOT/var/lib/%{name}/{routed_{emails,drafts,notes},storage} \
332         $RPM_BUILD_ROOT/var/cache/%{name}/doctrine/proxies \
333         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
334
335 %{__make} install-eventum install-localization \
336         sysconfdir=%{_webappdir} \
337         localedir=%{_localedir} \
338         DESTDIR=$RPM_BUILD_ROOT
339
340 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
341
342 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
343
344 # unsupported locale
345 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
346
347 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
348 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
349
350 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
351
352 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
353 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
354 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
355 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
356
357 install -d $RPM_BUILD_ROOT/etc/sphinx
358 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
359 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
360
361 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
362 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
363 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
364 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
365 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
366
367 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
368
369 # postfix router
370 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
371
372 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
373
374 %find_lang %{name}
375
376 %clean
377 rm -rf $RPM_BUILD_ROOT
378
379 %pre
380 %groupadd -g 146 %{name}
381 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
382 %addusertogroup http %{name}
383
384 %post
385 # create empty ghost files
386 # these permissions ensure the logs are write only
387 for a in \
388         errors.log login_attempts.log \
389         eventum.log \
390         auth.log cli.log \
391 ; do
392         test -f /var/log/%{name}/$a && continue
393         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
394 done
395
396 # run database update if configured
397 test -s %{_webappdir}/config.php && \
398 sudo -H -u http -- %{_appdir}/bin/upgrade.php || :
399
400 # nuke Smarty templates cache after upgrade
401 rm -f /var/cache/eventum/*.php
402
403 # Restart webserver on upgrade to get .mo translations reloaded.
404 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
405 %php_webserver_restart
406
407 %preun
408 if [ "$1" = "0" ]; then
409         # nuke cache
410         rm -f /var/cache/eventum/*.php 2>/dev/null || :
411 fi
412
413 %postun
414 if [ "$1" = "0" ]; then
415         %userremove %{name}
416         %groupremove %{name}
417 fi
418
419 %post setup
420 chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
421 chown root:http %{_webappdir}/{config,private_key,secret_key}.php
422
423 %postun setup
424 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
425         chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
426         chown root:http %{_webappdir}/{config,private_key,secret_key}.php
427 fi
428
429 %triggerin -- apache1 < 1.3.37-3, apache1-base
430 %webapp_register apache %{_webapp}
431
432 %triggerun -- apache1 < 1.3.37-3, apache1-base
433 %webapp_unregister apache %{_webapp}
434
435 %triggerin -- apache < 2.2.0, apache-base
436 %webapp_register httpd %{_webapp}
437
438 %triggerun -- apache < 2.2.0, apache-base
439 %webapp_unregister httpd %{_webapp}
440
441 %triggerin -- lighttpd
442 %webapp_register lighttpd %{_webapp}
443
444 %triggerun -- lighttpd
445 %webapp_unregister lighttpd %{_webapp}
446
447 %files -f %{name}.lang
448 %defattr(644,root,root,755)
449 %attr(771,root,http) %dir %{_webappdir}
450 %attr(751,root,http) %dir %{_webappdir}/crm
451 %attr(751,root,http) %dir %{_webappdir}/custom_field
452 %attr(751,root,http) %dir %{_webappdir}/partner
453 %attr(751,root,http) %dir %{_webappdir}/templates
454 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
455 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
456 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
457 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
458 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
459 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
460 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
461 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
462
463 %dir %attr(731,root,http) /var/log/%{name}
464 %attr(620,root,http) %ghost /var/log/%{name}/*
465 %dir %attr(750,root,root) /var/log/archive/%{name}
466 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
467
468 %dir %{_appdir}
469 %{_appdir}/config
470
471 %dir %{_appdir}/bin
472 %attr(755,root,root) %{_appdir}/bin/console.php
473 %attr(755,root,root) %{_appdir}/bin/export-issues.php
474 %attr(755,root,root) %{_appdir}/bin/extension.php
475 %attr(755,root,root) %{_appdir}/bin/ldapsync.php
476 %attr(755,root,root) %{_appdir}/bin/migrate_storage_adapter.php
477 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
478 %attr(755,root,root) %{_appdir}/bin/upgrade.php
479
480 %{_appdir}/autoload.php
481 %{_appdir}/globals.php
482 %{_appdir}/init.php
483 %{_appdir}/phinx.php
484 %dir %{_appdir}/htdocs
485 %{_appdir}/htdocs/*.php
486 %{_appdir}/htdocs/*.ico
487 %{_appdir}/htdocs/mix-manifest.json
488 %{_appdir}/htdocs/ajax
489 %{_appdir}/htdocs/css
490 %{_appdir}/htdocs/customer
491 %{_appdir}/htdocs/fonts
492 %{_appdir}/htdocs/images
493 %{_appdir}/htdocs/js
494 %{_appdir}/htdocs/manage
495 %{_appdir}/htdocs/reports
496 %{_appdir}/htdocs/rpc
497 %{_appdir}/templates
498
499 %dir %{_appdir}/db
500 %dir %{_appdir}/db/migrations
501 %{_appdir}/db/migrations/*.php
502 %dir %{_appdir}/db/seeds
503 %{_appdir}/db/seeds/*.php
504
505 %{_appdir}/res
506 %{_appdir}/src
507 %{_appdir}/vendor
508 %dir %{_appdir}/lib
509 %{_appdir}/lib/eventum
510 %exclude %{_appdir}/src/Console/Command/MailDownloadCommand.php
511 %exclude %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
512 %exclude %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
513 %exclude %{_appdir}/src/Console/Command/MonitorCommand.php
514 %exclude %{_appdir}/src/Console/Command/ReminderCheckCommand.php
515
516 %dir %{_libdir}
517
518 %{systemdtmpfilesdir}/%{name}.conf
519
520 %dir /var/lib/%{name}
521 %dir %attr(730,root,http) /var/run/%{name}
522 %dir %attr(730,root,http) /var/cache/%{name}
523 %dir %attr(730,root,http) /var/cache/%{name}/doctrine
524 %dir %attr(730,root,http) /var/cache/%{name}/doctrine/proxies
525
526 # saved mail copies
527 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
528 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
529 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
530 # attachment storage
531 %attr(770,root,http) %dir /var/lib/%{name}/storage
532
533 %files setup
534 %defattr(644,root,root,755)
535 %{_appdir}/htdocs/setup
536
537 %files doc
538 %defattr(644,root,root,755)
539 %doc docs/*
540 %{_examplesdir}/%{name}-%{version}
541
542 %files mail-queue
543 %defattr(644,root,root,755)
544 %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
545 %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
546 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
547 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
548 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
549
550 %files mail-download
551 %defattr(644,root,root,755)
552 %{_appdir}/src/Console/Command/MailDownloadCommand.php
553 %attr(755,root,root) %{_appdir}/bin/download_emails.php
554 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
555
556 %files reminder
557 %defattr(644,root,root,755)
558 %{_appdir}/src/Console/Command/ReminderCheckCommand.php
559 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
560 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
561
562 %files monitor
563 %defattr(644,root,root,755)
564 %{_appdir}/src/Console/Command/MonitorCommand.php
565 %attr(755,root,root) %{_appdir}/bin/monitor.php
566 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
567
568 %files router-postfix
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{_libdir}/router-postfix
571
572 %files sphinx
573 %defattr(644,root,root,755)
574 %{_webappdir}/sphinx.conf.php
575 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
576 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.135302 seconds and 3 git commands to generate.