]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
470f06c66d8ad7c2c8d52abd37385c232d4d7e03
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1
6 %define         subver  191
7 %define         githash a6336856a
8 %define         php_min_version 7.1.3
9 Summary:        Eventum Issue / Bug tracking system
10 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
11 Name:           eventum
12 Version:        3.6.2
13 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
14 License:        GPL v2+
15 Group:          Applications/WWW
16 #Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.xz
17 Source0:        https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.xz
18 # Source0-md5:  837a2f7c1be8dbf59f603154deda5e8f
19 Source1:        %{name}-apache.conf
20 Source2:        %{name}-mail-queue.cron
21 Source3:        %{name}-mail-download.cron
22 Source4:        %{name}-reminder.cron
23 Source5:        %{name}-monitor.cron
24 Source10:       sphinx.crontab
25 Source13:       %{name}-router-postfix.sh
26 Source14:       %{name}.logrotate
27 Source15:       %{name}-lighttpd.conf
28 Source16:       http://www.isocra.com/images/updown2.gif
29 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
30 Source17:       %{name}.tmpfiles
31 Patch2:         %{name}-order.patch
32 #Patch3:                group-users.patch
33 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
34 # packaging patches that probably never go upstream
35 Patch100:       %{name}-paths.patch
36 Patch107:       %{name}-gettext.patch
37 Patch108:       autoload.patch
38 # some tests
39 Patch200:       %{name}-fixed-nav.patch
40 URL:            https://wiki.github.com/eventum/eventum/
41 BuildRequires:  gettext-tools
42 BuildRequires:  rpmbuild(macros) >= 1.654
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  tar >= 1:1.22
45 BuildRequires:  xz
46 Requires(post): sudo
47 Requires(postun):       /usr/sbin/groupdel
48 Requires(postun):       /usr/sbin/userdel
49 Requires(pre):  /bin/id
50 Requires(pre):  /usr/bin/getgid
51 Requires(pre):  /usr/sbin/groupadd
52 Requires(pre):  /usr/sbin/useradd
53 Requires:       fonts-TTF-RedHat-liberation
54 Requires:       php(core) >= %{php_min_version}
55 Requires:       php(ds)
56 Requires:       php(filter)
57 Requires:       php(iconv)
58 Requires:       php(imap)
59 Requires:       php(json)
60 Requires:       php(mbstring)
61 Requires:       php(pcre)
62 Requires:       php(pdo_mysql)
63 Requires:       php(session)
64 Requires:       php-Smarty >= 3.1
65 Requires:       php-Smarty-plugin-gettext
66 Requires:       php-ZendFramework-Config >= 2.4
67 Requires:       php-ZendFramework-Loader >= 2.4
68 Requires:       php-ZendFramework-Mail >= 2.4.13-2
69 Requires:       php-ZendFramework-Mime >= 2.4
70 Requires:       php-ZendFramework-ServiceManager >= 2.4
71 Requires:       php-ZendFramework-Validator >= 2.4
72 Requires:       php-monolog >= 1.17.2
73 Requires:       php-pear-Math_Stats
74 Requires:       php-pear-Net_SMTP
75 Requires:       php-pear-Net_Socket
76 Requires:       php-pear-Net_URL
77 Requires:       php-pear-PEAR-core
78 Requires:       php-psr-Log >= 1.0.0-2
79 Requires:       phplot >= 5.8.0
80 Requires:       webapps
81 Requires:       webserver(access)
82 Requires:       webserver(alias)
83 Requires:       webserver(indexfile)
84 Requires:       webserver(php) >= 4.2.0
85 Suggests:       localedb
86 Suggests:       php(mcrypt)
87 Suggests:       php(openssl)
88 Suggests:       php-pear-Net_POP3
89 Suggests:       webserver(setenv)
90 Provides:       group(eventum)
91 Provides:       user(eventum)
92 Obsoletes:      eventum-base < 3.0.3-1.305
93 Obsoletes:      eventum-route-drafts < 3.0.8-1.1
94 Obsoletes:      eventum-route-emails < 3.0.8-1.1
95 Obsoletes:      eventum-route-notes < 3.0.8-1.1
96 Conflicts:      logrotate < 3.8.0
97 BuildArch:      noarch
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %define         _libdir         %{_prefix}/lib/%{name}
101 %define         _appdir         %{_datadir}/%{name}
102 %define         _smartydir      %{php_data_dir}/Smarty
103 %define         _webapps        /etc/webapps
104 %define         _webapp         %{name}
105 %define         _webappdir      %{_webapps}/%{_webapp}
106 %define         _sysconfdir     /etc/%{name}
107
108 %description
109 Eventum is a user-friendly and flexible issue tracking system that can
110 be used by a support department to track incoming technical support
111 requests, or by a software development team to quickly organize tasks
112 and bugs.
113
114 %description -l pl.UTF-8
115 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
116 może być używany przez dział obsługi do śledzenia przychodzących żądań
117 obsługi technicznej albo przez zespół tworzący oprogramowanie do
118 szybkiej organizacji zadań i błędów.
119
120 %package setup
121 Summary:        Eventum setup package
122 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
123 Group:          Applications/WWW
124 Requires:       %{name} = %{version}-%{release}
125
126 %description setup
127 Install this package to configure initial Eventum installation. You
128 should uninstall this package when you're done, as it considered
129 insecure to keep the setup files in place.
130
131 %description setup -l pl.UTF-8
132 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
133 pierwszej instalacji. Potem należy go odinstalować, jako że
134 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
135
136 %package doc
137 Summary:        Eventum documentation and Wiki
138 Group:          Documentation
139
140 %description doc
141 Eventum documentation and copy of Wiki.
142
143 %package mail-queue
144 Summary:        Eventum mail queue process
145 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
146 Group:          Applications/WWW
147 Requires:       %{name} = %{version}-%{release}
148 Requires:       crondaemon
149
150 %description mail-queue
151 Beginning with the first release of Eventum, emails are not directly
152 sent out from the various scripts, but rather added to a mail queue
153 table that is processed by a cron job. If an email cannot be sent, it
154 will be marked as such in the mail queue log, and the cron job script
155 will re-try to send it again the next time it runs.
156
157 This package contains the cron job.
158
159 %description mail-queue -l pl.UTF-8
160 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
161 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
162 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
163 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
164 następnym razem.
165
166 Ten pakiet zawiera zadanie dla crona.
167
168 %package mail-download
169 Summary:        Eventum email download
170 Summary(pl.UTF-8):      Ściąganie poczty Eventum
171 Group:          Applications/WWW
172 Requires:       %{name} = %{version}-%{release}
173 Requires:       crondaemon
174
175 %description mail-download
176 In order for Eventum's email integration feature to work, you need to
177 setup a cron job to run the script every so often.
178
179 This package contains the cron job.
180
181 %description mail-download -l pl.UTF-8
182 Aby integracja poczty elektronicznej w Eventum działała, trzeba
183 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
184 często.
185
186 Ten pakiet zawiera zadanie dla crona.
187
188 %package reminder
189 Summary:        Eventum Reminder System
190 Summary(pl.UTF-8):      System przypominania dla Eventum
191 Group:          Applications/WWW
192 Requires:       %{name} = %{version}-%{release}
193 Requires:       crondaemon
194
195 %description reminder
196 The reminder system was designed with the objective as serving as a
197 safe net for issues that need attention. Depending on what
198 configuration you create, you may have several reminders (or alerts)
199 be sent out whenever an issue needs attention, for whatever parameter
200 you may deem necessary.
201
202 This package contains the cron job.
203
204 %description reminder -l pl.UTF-8
205 System przypominania został zaprojektowany tak, aby służył jako
206 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
207 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
208 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
209 uważać za potrzebny.
210
211 Ten pakiet zawiera zadanie dla crona.
212
213 %package monitor
214 Summary:        Eventum Heartbeat Monitor
215 Summary(pl.UTF-8):      Monitor życia dla Eventum
216 Group:          Applications/WWW
217 Requires:       %{name} = %{version}-%{release}
218 Requires:       crondaemon
219 Requires:       php(posix)
220
221 %description monitor
222 The heartbeat monitor is a feature designed for the administrator that
223 wants to be alerted whenever a common problem in Eventum is detected,
224 like the database server not being available anymore, or maybe when
225 the recommended permissions for certain configuration files are
226 changed.
227
228 Please note that before running the heartbeat monitor, you may need to
229 customize some of the checks to be appropriate for your own system,
230 particularly the permission and file checks on
231 Monitor::checkConfiguration().
232
233 This package contains the cron job.
234
235 %description monitor -l pl.UTF-8
236 Monitor życia to funkcjonalność zaprojektowana dla administratora
237 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
238 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
239 do plików konfiguracyjnych.
240
241 Należy zauważyć, że przed uruchomieniem tego monitora może być
242 konieczne dostosowanie niektórych testów do systemu, w szczególności
243 testów uprawnień i plików w Monitor::checkConfiguration().
244
245 Ten pakiet zawiera zadanie dla crona.
246
247 %package router-postfix
248 Summary:        Eventum Mail Routing - Postfix
249 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
250 Group:          Applications/Mail
251 Requires:       %{name} = %{version}-%{release}
252 Requires:       postfix
253 Provides:       eventum(router)
254 Obsoletes:      eventum(router)
255
256 %description router-postfix
257 This package provides way of routing notes and emails back to Eventum
258 via Postfix.
259
260 The Postfix configuration instructions you can find from
261 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
262
263 %description router-postfix -l pl.UTF-8
264 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
265 przez Postfiksa.
266
267 Opis konfiguracji Postfiksa można znaleźć pod adresem
268 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
269
270 %package sphinx
271 Summary:        Eventum Sphinx Search
272 Group:          Applications/WWW
273 Requires:       %{name} = %{version}-%{release}
274 Requires:       crondaemon
275 Requires:       sphinx
276
277 %description sphinx
278 Sphinx search integration for Eventum.
279
280 This package contains the cron job.
281
282 %prep
283 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
284
285 mv docs/examples .
286
287 # bug fixes / features
288 %{?with_order:%patch2 -p1}
289 #%patch3 -p0
290 #%patch4 -p1
291 %{?with_order:cp -p %{SOURCE16} htdocs/images}
292 #%patch200 -p1
293
294 # produce default sphinx config
295 # must be run before paths.patch
296 %if 0
297 cat <<'EOF' > config/config.php
298 <?php
299 define('APP_SQL_DBTYPE', 'mysql');
300 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
301 define('APP_SQL_DBPORT', 3306);
302 define('APP_SQL_DBNAME', 'eventum');
303 define('APP_SQL_DBUSER', 'mysql');
304 define('APP_SQL_DBPASS', '');
305 define('APP_TABLE_PREFIX', 'eventum_');
306 EOF
307 php config/sphinx.conf.php > config/sphinx.conf
308 rm config/config.php
309 %endif
310
311 # packaging
312 %patch100 -p1
313 %patch107 -p1
314 %patch108 -p1
315
316 rm htdocs/.htaccess.dist
317 rm config/config.dist.php
318
319 # cleanup libs taken from system, everything else gets bundled
320 rm -r vendor/fonts/liberation
321 rm -r vendor/monolog/monolog
322 rm -r vendor/pear/pear-core-minimal
323 rm -r vendor/pear/pear_exception
324 rm -r vendor/pear-pear.php.net/Math_Stats
325 rm -r vendor/php-gettext/php-gettext
326 rm -r vendor/phplot/phplot
327 rm -r vendor/psr/log
328 rm -r vendor/smarty-gettext/smarty-gettext
329 rm -r vendor/smarty/smarty
330 rm -r vendor/sphinx/php-sphinxapi
331 rm -r vendor/zendframework/zend-config
332 rm -r vendor/zendframework/zend-loader
333 rm -r vendor/zendframework/zend-mail
334 rm -r vendor/zendframework/zend-mime
335 rm -r vendor/zendframework/zend-servicemanager
336 rm -r vendor/zendframework/zend-stdlib
337 rm -r vendor/zendframework/zend-validator
338
339 # remove backups from patching as we use globs to package files to buildroot
340 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
341
342 %build
343 %{__make} -C localization
344
345 %install
346 rm -rf $RPM_BUILD_ROOT
347 install -d \
348         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
349         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
350         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
351         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
352         $RPM_BUILD_ROOT/var/lib/%{name}/{routed_{emails,drafts,notes},storage} \
353         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
354
355 %{__make} install-eventum install-localization \
356         sysconfdir=%{_webappdir} \
357         localedir=%{_localedir} \
358         DESTDIR=$RPM_BUILD_ROOT
359
360 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
361
362 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
363
364 # unsupported locale
365 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
366
367 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
368 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
369
370 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
371
372 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
373 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
374 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
375 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
376
377 install -d $RPM_BUILD_ROOT/etc/sphinx
378 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
379 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
380
381 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
382 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
383 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
384 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
385 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
386
387 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
388
389 # postfix router
390 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
391
392 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
393
394 %find_lang %{name}
395
396 %clean
397 rm -rf $RPM_BUILD_ROOT
398
399 %pre
400 %groupadd -g 146 %{name}
401 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
402 %addusertogroup http %{name}
403
404 %post
405 # create empty ghost files
406 # these permissions ensure the logs are write only
407 for a in \
408         errors.log login_attempts.log \
409         eventum.log \
410         auth.log cli.log \
411 ; do
412         test -f /var/log/%{name}/$a && continue
413         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
414 done
415
416 # run database update if configured
417 test -s %{_webappdir}/config.php && \
418 sudo -H -u http -- %{_appdir}/bin/upgrade.php || :
419
420 # nuke Smarty templates cache after upgrade
421 rm -f /var/cache/eventum/*.php
422
423 # Restart webserver on upgrade to get .mo translations reloaded.
424 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
425 %php_webserver_restart
426
427 %preun
428 if [ "$1" = "0" ]; then
429         # nuke cache
430         rm -f /var/cache/eventum/*.php 2>/dev/null || :
431 fi
432
433 %postun
434 if [ "$1" = "0" ]; then
435         %userremove %{name}
436         %groupremove %{name}
437 fi
438
439 %post setup
440 chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
441 chown root:http %{_webappdir}/{config,private_key,secret_key}.php
442
443 %postun setup
444 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
445         chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
446         chown root:http %{_webappdir}/{config,private_key,secret_key}.php
447 fi
448
449 %triggerin -- apache1 < 1.3.37-3, apache1-base
450 %webapp_register apache %{_webapp}
451
452 %triggerun -- apache1 < 1.3.37-3, apache1-base
453 %webapp_unregister apache %{_webapp}
454
455 %triggerin -- apache < 2.2.0, apache-base
456 %webapp_register httpd %{_webapp}
457
458 %triggerun -- apache < 2.2.0, apache-base
459 %webapp_unregister httpd %{_webapp}
460
461 %triggerin -- lighttpd
462 %webapp_register lighttpd %{_webapp}
463
464 %triggerun -- lighttpd
465 %webapp_unregister lighttpd %{_webapp}
466
467 %files -f %{name}.lang
468 %defattr(644,root,root,755)
469 %attr(771,root,http) %dir %{_webappdir}
470 %attr(751,root,http) %dir %{_webappdir}/crm
471 %attr(751,root,http) %dir %{_webappdir}/custom_field
472 %attr(751,root,http) %dir %{_webappdir}/partner
473 %attr(751,root,http) %dir %{_webappdir}/templates
474 %attr(751,root,http) %dir %{_webappdir}/workflow
475 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
476 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
477 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
478 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
479 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
480 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
481 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
482 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
483
484 %dir %attr(731,root,http) /var/log/%{name}
485 %attr(620,root,http) %ghost /var/log/%{name}/*
486 %dir %attr(750,root,root) /var/log/archive/%{name}
487 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
488
489 %dir %{_appdir}
490 %{_appdir}/config
491
492 %dir %{_appdir}/bin
493 %attr(755,root,root) %{_appdir}/bin/extension.php
494 %attr(755,root,root) %{_appdir}/bin/ldapsync.php
495 %attr(755,root,root) %{_appdir}/bin/migrate_storage_adapter.php
496 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
497 %attr(755,root,root) %{_appdir}/bin/upgrade.php
498
499 %{_appdir}/autoload.php
500 %{_appdir}/globals.php
501 %{_appdir}/init.php
502 %{_appdir}/phinx.php
503 %dir %{_appdir}/htdocs
504 %{_appdir}/htdocs/*.php
505 %{_appdir}/htdocs/*.ico
506 %{_appdir}/htdocs/ajax
507 %{_appdir}/htdocs/css
508 %{_appdir}/htdocs/customer
509 %{_appdir}/htdocs/images
510 %{_appdir}/htdocs/js
511 %{_appdir}/htdocs/manage
512 %{_appdir}/htdocs/reports
513 %{_appdir}/htdocs/rpc
514 %{_appdir}/htdocs/components
515 %{_appdir}/templates
516
517 %dir %{_appdir}/db
518 %dir %{_appdir}/db/migrations
519 %{_appdir}/db/migrations/*.php
520
521 %{_appdir}/res
522 %{_appdir}/src
523 %{_appdir}/vendor
524 %dir %{_appdir}/lib
525 %{_appdir}/lib/eventum
526 %exclude %{_appdir}/src/Console/Command/MailDownloadCommand.php
527 %exclude %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
528 %exclude %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
529 %exclude %{_appdir}/src/Console/Command/MonitorCommand.php
530 %exclude %{_appdir}/src/Console/Command/ReminderCheckCommand.php
531
532 %dir %{_libdir}
533
534 %{systemdtmpfilesdir}/%{name}.conf
535
536 %dir /var/lib/%{name}
537 %dir %attr(730,root,http) /var/run/%{name}
538 %dir %attr(730,root,http) /var/cache/%{name}
539
540 # saved mail copies
541 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
542 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
543 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
544 # attachment storage
545 %attr(770,root,http) %dir /var/lib/%{name}/storage
546
547 %files setup
548 %defattr(644,root,root,755)
549 %{_appdir}/htdocs/setup
550
551 %files doc
552 %defattr(644,root,root,755)
553 %doc docs/*
554 %{_examplesdir}/%{name}-%{version}
555
556 %files mail-queue
557 %defattr(644,root,root,755)
558 %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
559 %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
560 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
561 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
562 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
563
564 %files mail-download
565 %defattr(644,root,root,755)
566 %{_appdir}/src/Console/Command/MailDownloadCommand.php
567 %attr(755,root,root) %{_appdir}/bin/download_emails.php
568 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
569
570 %files reminder
571 %defattr(644,root,root,755)
572 %{_appdir}/src/Console/Command/ReminderCheckCommand.php
573 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
574 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
575
576 %files monitor
577 %defattr(644,root,root,755)
578 %{_appdir}/src/Console/Command/MonitorCommand.php
579 %attr(755,root,root) %{_appdir}/bin/monitor.php
580 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
581
582 %files router-postfix
583 %defattr(644,root,root,755)
584 %attr(755,root,root) %{_libdir}/router-postfix
585
586 %files sphinx
587 %defattr(644,root,root,755)
588 %{_webappdir}/sphinx.conf.php
589 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
590 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.06442 seconds and 3 git commands to generate.