]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
34560038502c8953a349c780d572f3b86d84df31
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1.8
6 %define         subver  144
7 %define         githash 9fcce7c
8 %define         php_min_version 5.3.3
9 %include        /usr/lib/rpm/macros.php
10 Summary:        Eventum Issue / Bug tracking system
11 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
12 Name:           eventum
13 Version:        3.0.3
14 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
15 License:        GPL v2
16 Group:          Applications/WWW
17 #Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
18 Source0:        %{name}-%{version}-%{subver}-g%{githash}.tar.gz
19 # Source0-md5:  f488e72825c21ddb8adb0d9180848a52
20 Source1:        %{name}-apache.conf
21 Source2:        %{name}-mail-queue.cron
22 Source3:        %{name}-mail-download.cron
23 Source4:        %{name}-reminder.cron
24 Source5:        %{name}-monitor.cron
25 Source6:        %{name}-cvs.php
26 Source7:        %{name}-irc.php
27 Source8:        %{name}-irc.init
28 Source9:        %{name}-irc.sysconfig
29 Source10:       sphinx.crontab
30 Source13:       %{name}-router-postfix.sh
31 Source14:       %{name}.logrotate
32 Source15:       %{name}-lighttpd.conf
33 Source16:       http://www.isocra.com/images/updown2.gif
34 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
35 Source17:       %{name}.tmpfiles
36 Patch2:         %{name}-order.patch
37 #Patch3:                group-users.patch
38 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
39 # packaging patches that probably never go upstream
40 Patch100:       %{name}-paths.patch
41 Patch101:       %{name}-cvs-config.patch
42 Patch105:       %{name}-bot-reconnect.patch
43 Patch107:       %{name}-gettext.patch
44 Patch108:       autoload.patch
45 # some tests
46 Patch200:       %{name}-fixed-nav.patch
47 URL:            http://eventum.mysql.org/
48 BuildRequires:  /usr/bin/php
49 BuildRequires:  gettext-devel
50 BuildRequires:  php(core) >= %{php_min_version}
51 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
52 BuildRequires:  rpmbuild(macros) >= 1.654
53 BuildRequires:  sed >= 4.0
54 Requires:       %{name}-base = %{version}-%{release}
55 Requires:       fonts-TTF-RedHat-liberation
56 Requires:       php(core) >= %{php_min_version}
57 Requires:       php(filter)
58 Requires:       php(iconv)
59 Requires:       php(imap)
60 Requires:       php(json)
61 Requires:       php(mbstring)
62 Requires:       php(mysqli)
63 Requires:       php(pcre)
64 Requires:       php(session)
65 Requires:       php-Smarty >= 3.1
66 Requires:       php-Smarty-plugin-gettext
67 Requires:       php-pear-DB
68 Requires:       php-pear-Mail
69 Requires:       php-pear-Mail_Mime
70 Requires:       php-pear-Mail_mimeDecode
71 Requires:       php-pear-Math_Stats
72 Requires:       php-pear-Net_DIME
73 Requires:       php-pear-Net_SMTP
74 Requires:       php-pear-Net_Socket
75 Requires:       php-pear-Net_URL
76 Requires:       php-pear-Net_UserAgent_Detect
77 Requires:       php-pear-PEAR-core
78 Requires:       php-pear-Text_Diff
79 Requires:       php-pear-XML_RPC
80 Requires:       phplot >= 5.8.0
81 Requires:       webapps
82 Requires:       webserver(access)
83 Requires:       webserver(alias)
84 Requires:       webserver(indexfile)
85 Requires:       webserver(php) >= 4.2.0
86 Suggests:       localedb
87 Suggests:       php-pear-Net_LDAP2
88 Conflicts:      logrotate < 3.8.0
89 BuildArch:      noarch
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define         _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
93
94 # exclude optional php dependencies
95 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
96
97 %define         _noautoreq      %{_noautophp}
98
99 %define         _libdir         %{_prefix}/lib/%{name}
100 %define         _appdir         %{_datadir}/%{name}
101 %define         _smartydir      %{php_data_dir}/Smarty
102 %define         _webapps        /etc/webapps
103 %define         _webapp         %{name}
104 %define         _webappdir      %{_webapps}/%{_webapp}
105 %define         _sysconfdir     /etc/%{name}
106
107 %description
108 Eventum is a user-friendly and flexible issue tracking system that can
109 be used by a support department to track incoming technical support
110 requests, or by a software development team to quickly organize tasks
111 and bugs. Eventum is used by the MySQL AB Technical Support team, and
112 has allowed us to dramatically improve our response times.
113
114 %description -l pl.UTF-8
115 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
116 może być używany przez dział obsługi do śledzenia przychodzących żądań
117 obsługi technicznej albo przez zespół tworzący oprogramowanie do
118 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
119 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
120 reakcji.
121
122 %package base
123 Summary:        Eventum base package
124 Summary(pl.UTF-8):      Podstawowy pakiet Eventum
125 Group:          Applications/WWW
126 Requires(postun):       /usr/sbin/groupdel
127 Requires(postun):       /usr/sbin/userdel
128 Requires(pre):  /bin/id
129 Requires(pre):  /usr/bin/getgid
130 Requires(pre):  /usr/sbin/groupadd
131 Requires(pre):  /usr/sbin/useradd
132 Provides:       group(eventum)
133 Provides:       user(eventum)
134
135 %description base
136 This package contains base directory structure for Eventum.
137
138 %description base -l pl.UTF-8
139 Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
140
141 %package setup
142 Summary:        Eventum setup package
143 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
144 Group:          Applications/WWW
145 Requires:       %{name} = %{version}-%{release}
146
147 %description setup
148 Install this package to configure initial Eventum installation. You
149 should uninstall this package when you're done, as it considered
150 insecure to keep the setup files in place.
151
152 %description setup -l pl.UTF-8
153 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
154 pierwszej instalacji. Potem należy go odinstalować, jako że
155 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
156
157 %package doc
158 Summary:        Eventum documentation and Wiki
159 Group:          Documentation
160
161 %description doc
162 Eventum documentation and copy of Wiki.
163
164 %package mail-queue
165 Summary:        Eventum mail queue process
166 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
167 Group:          Applications/WWW
168 Requires:       %{name} = %{version}-%{release}
169 Requires:       crondaemon
170
171 %description mail-queue
172 Beginning with the first release of Eventum, emails are not directly
173 sent out from the various scripts, but rather added to a mail queue
174 table that is processed by a cron job. If an email cannot be sent, it
175 will be marked as such in the mail queue log, and the cron job script
176 will re-try to send it again the next time it runs.
177
178 This package contains the cron job.
179
180 %description mail-queue -l pl.UTF-8
181 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
182 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
183 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
184 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
185 następnym razem.
186
187 Ten pakiet zawiera zadanie dla crona.
188
189 %package mail-download
190 Summary:        Eventum email download
191 Summary(pl.UTF-8):      Ściąganie poczty Eventum
192 Group:          Applications/WWW
193 Requires:       %{name} = %{version}-%{release}
194 Requires:       crondaemon
195
196 %description mail-download
197 In order for Eventum's email integration feature to work, you need to
198 setup a cron job to run the script every so often.
199
200 This package contains the cron job.
201
202 %description mail-download -l pl.UTF-8
203 Aby integracja poczty elektronicznej w Eventum działała, trzeba
204 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
205 często.
206
207 Ten pakiet zawiera zadanie dla crona.
208
209 %package reminder
210 Summary:        Eventum Reminder System
211 Summary(pl.UTF-8):      System przypominania dla Eventum
212 Group:          Applications/WWW
213 Requires:       %{name} = %{version}-%{release}
214 Requires:       crondaemon
215
216 %description reminder
217 The reminder system was designed with the objective as serving as a
218 safe net for issues that need attention. Depending on what
219 configuration you create, you may have several reminders (or alerts)
220 be sent out whenever an issue needs attention, for whatever parameter
221 you may deem necessary.
222
223 This package contains the cron job.
224
225 %description reminder -l pl.UTF-8
226 System przypominania został zaprojektowany tak, aby służył jako
227 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
228 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
229 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
230 uważać za potrzebny.
231
232 Ten pakiet zawiera zadanie dla crona.
233
234 %package monitor
235 Summary:        Eventum Heartbeat Monitor
236 Summary(pl.UTF-8):      Monitor życia dla Eventum
237 Group:          Applications/WWW
238 Requires:       %{name} = %{version}-%{release}
239 Requires:       crondaemon
240 Requires:       php(posix)
241
242 %description monitor
243 The heartbeat monitor is a feature designed for the administrator that
244 wants to be alerted whenever a common problem in Eventum is detected,
245 like the database server not being available anymore, or maybe when
246 the recommended permissions for certain configuration files are
247 changed.
248
249 Please note that before running the heartbeat monitor, you may need to
250 customize some of the checks to be appropriate for your own system,
251 particularly the permission and file checks on
252 Monitor::checkConfiguration().
253
254 This package contains the cron job.
255
256 %description monitor -l pl.UTF-8
257 Monitor życia to funkcjonalność zaprojektowana dla administratora
258 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
259 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
260 do plików konfiguracyjnych.
261
262 Należy zauważyć, że przed uruchomieniem tego monitora może być
263 konieczne dostosowanie niektórych testów do systemu, w szczególności
264 testów uprawnień i plików w Monitor::checkConfiguration().
265
266 Ten pakiet zawiera zadanie dla crona.
267
268 %package route-drafts
269 Summary:        Eventum Draft Routing
270 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
271 Group:          Applications/WWW
272 Requires:       %{name} = %{version}-%{release}
273 Requires:       eventum(router)
274
275 %description route-drafts
276 The draft routing feature is used to automatically associate a thread
277 of drafts into an Eventum issue. By setting up Postfix to deliver
278 emails sent to a specific address (usually draft-<number>@<domain>) to
279 the above script, users are able to send drafts written in their mail
280 client to be stored in Eventum. These drafts will NOT broadcasted to
281 the notification list.
282
283 %description route-drafts -l pl.UTF-8
284 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
285 problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
286 wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
287 skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
288 kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
289 na listę powiadomień.
290
291 %package route-emails
292 Summary:        Eventum Email Routing
293 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
294 Group:          Applications/WWW
295 Requires:       %{name} = %{version}-%{release}
296 Requires:       eventum(router)
297
298 %description route-emails
299 The email routing feature is used to automatically associate a thread
300 of emails into an Eventum issue. By setting up Postfix to deliver
301 emails sent to a specific address (usually issue-<number>@<domain>) to
302 the above script, users are able to use their email clients to reply
303 to emails coming from Eventum, and those replies will be automatically
304 associated with the issue and broadcasted to the entire notification
305 list.
306
307 %description route-emails -l pl.UTF-8
308 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
309 wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
310 aby dostarczał listy wysyłane na pewien adres (zwykle
311 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
312 używać klientów pocztowych do odpowiadania na listy przychodzące z
313 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
314 rozprowadzane do całej listy ogłoszeniowej.
315
316 %package route-notes
317 Summary:        Eventum Note Routing
318 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
319 Group:          Applications/WWW
320 Requires:       %{name} = %{version}-%{release}
321 Requires:       eventum(router)
322
323 %description route-notes
324 The note routing feature is used to automatically associate a thread
325 of notes into an Eventum issue. By setting up Postfix to deliver
326 emails sent to a specific address (usually note-<number>@<domain>) to
327 the above script, users are able to use their email clients to reply
328 to internal notes coming from Eventum, and those replies will be
329 automatically associated with the issue and broadcasted to the
330 notification list staff members.
331
332 %description route-notes -l pl.UTF-8
333 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
334 wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
335 dostarczał listy wysyłane na pewien adres (zwykle
336 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
337 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
338 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
339 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
340
341 %package router-postfix
342 Summary:        Eventum Mail Routing - Postfix
343 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
344 Group:          Applications/Mail
345 Requires:       %{name} = %{version}-%{release}
346 Requires:       postfix
347 Provides:       eventum(router)
348 Obsoletes:      eventum(router)
349
350 %description router-postfix
351 This package provides way of routing notes and emails back to Eventum
352 via Postfix.
353
354 The Postfix configuration instructions you can find from
355 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
356
357 %description router-postfix -l pl.UTF-8
358 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
359 przez Postfiksa.
360
361 Opis konfiguracji Postfiksa można znaleźć pod adresem
362 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
363
364 %package irc
365 Summary:        Eventum IRC Notification Bot
366 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
367 Group:          Applications/WWW
368 Requires(post,preun):   /sbin/chkconfig
369 Requires:       %{name} = %{version}-%{release}
370 Requires:       php(sockets)
371 Requires:       php-pear-Net_SmartIRC
372 Requires:       rc-scripts >= 0.4.0.18
373
374 %description irc
375 The IRC notification bot is a nice feature for remote teams that want
376 to handle issues and want to have a quick and easy way to get simple
377 notifications. Right now the bot notifies of the following actions:
378 - New Issues
379 - Blocked emails
380 - Issues that got their assignment list changed
381
382 NOTE: You will need to manually edit the bot.php script to set your
383 appropriate preferences, like IRC server and channel that the bot
384 should join.
385
386 %description irc -l pl.UTF-8
387 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
388 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
389 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
390 następujących zdarzeniach:
391 - nowych sprawach
392 - zablokowanych listach
393 - sprawach, dla których zmieniła się lista powiązań
394
395 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
396 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
397
398 %package cli
399 Summary:        Eventum command-line interface
400 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
401 Group:          Applications/WWW
402 Requires:       %{name}-base = %{version}-%{release}
403 Requires:       php(core) >= %{php_min_version}
404 Requires:       php(phar)
405 Requires:       php-pear-XML_RPC
406
407 %description cli
408 The Eventum command-line interface allows you to access most of the
409 features of the web interface straight from your command shell.
410
411 %description cli -l pl.UTF-8
412 Interfejs linii poleceń Eventum pozwala na dostęp do większości
413 funkcji interfejsu WWW prosto z linii poleceń powłoki.
414
415 %package scm
416 Summary:        Eventum SCM integration
417 Summary(pl.UTF-8):      Integracja SCM dla Eventum
418 Group:          Applications/WWW
419 Requires:       php(core) >= %{php_min_version}
420 Requires:       php(json)
421 Requires:       php(pcre)
422 Requires:       php(spl)
423 Suggests:       cvs
424 Suggests:       git-core
425 Suggests:       php(openssl)
426 Suggests:       subversion
427
428 %description scm
429 This feature allows your software development teams to integrate your
430 Source Control Management system with your Issue Tracking System.
431
432 The integration is implemented in such a way that it will be forward
433 compatible with pretty much any SCM system, such as CVS.
434
435 For installation see
436 </eventum/help.php?topic=scm_integration_installation>.
437
438 %description scm -l pl.UTF-8
439 Ten pakiet pozwala zespołom programistów na integrację systemu
440 zarządzania źródłami (SCM - Source Control Management) z systemem
441 śledzenia spraw.
442
443 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
444 prawie każdym systemem SCM, jak np. CVS.
445
446 Szczegóły na temat instalacji można przeczytać pod
447 </eventum/help.php?topic=scm_integration_installation>.
448
449 %package sphinx
450 Summary:        Eventum Sphinx Search
451 Group:          Applications/WWW
452 Requires:       %{name} = %{version}-%{release}
453 Requires:       crondaemon
454 Requires:       sphinx
455
456 %description sphinx
457 Sphinx search integration for Eventum.
458
459 This package contains the cron job.
460
461 %prep
462 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
463
464 mv docs/examples .
465
466 # GPL v2
467 rm docs/COPYING
468
469 # bug fixes / features
470 %{?with_order:%patch2 -p1}
471 #%patch3 -p0
472 #%patch4 -p1
473
474 %{?with_order:cp -p %{SOURCE16} htdocs/images}
475
476 #%patch200 -p1
477
478 # produce default sphinx config
479 # must be run before paths.patch
480 %if 0
481 cat <<'EOF' > config/config.php
482 <?php
483 define('APP_SQL_DBTYPE', 'mysql');
484 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
485 define('APP_SQL_DBPORT', 3306);
486 define('APP_SQL_DBNAME', 'eventum');
487 define('APP_SQL_DBUSER', 'mysql');
488 define('APP_SQL_DBPASS', '');
489 define('APP_TABLE_PREFIX', 'eventum_');
490 EOF
491 php config/sphinx.conf.php > config/sphinx.conf
492 rm -f config/config.php
493 %endif
494
495 # packaging
496 %patch100 -p1
497 %patch101 -p1
498 %patch105 -p1
499 %patch107 -p1
500 %patch108 -p1
501
502 # cleanup vendor. keep only needed libraries.
503 # (the rest are packaged with system packages)
504 mv vendor vendor.dist
505 vendor() {
506         local path dir
507         for path; do
508                 dir=$(dirname $path)
509                 test -d vendor/$dir || mkdir -p vendor/$dir
510                 mv vendor.dist/$path vendor/$path
511         done
512 }
513 vendor autoload.php
514 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
515 vendor composer/ClassLoader.php
516 vendor ircmaxell/{password-compat,random-lib,security-lib}
517 vendor zendframework/zend-config
518
519 # remove backups from patching as we use globs to package files to buildroot
520 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
521
522 %build
523 %{__make} -C localization
524
525 %install
526 rm -rf $RPM_BUILD_ROOT
527 install -d \
528         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
529         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
530         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
531         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
532         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
533         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
534         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
535
536 %{__make} install-eventum install-cli install-irc install-scm install-localization \
537         sysconfdir=%{_webappdir} \
538         localedir=%{_localedir} \
539         DESTDIR=$RPM_BUILD_ROOT
540
541 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
542
543 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
544
545 # unsupported locale
546 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
547
548 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
549 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
550
551 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
552
553 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
554 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
555 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
556 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
557
558 install -d $RPM_BUILD_ROOT/etc/sphinx
559 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
560 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
561
562 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
563 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
564 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
565 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
566 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
567
568 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
569
570 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
571 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
572
573 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
574
575 # postfix router
576 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
577
578 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
579
580 %find_lang %{name}
581
582 # scm
583 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
584
585 %clean
586 rm -rf $RPM_BUILD_ROOT
587
588 %pre
589 %addusertogroup http %{name}
590
591 %post
592 # greate empty ghost files
593 for a in cli.log errors.log irc_bot.log login_attempts.log; do
594         if [ ! -f /var/log/%{name}/$a ]; then
595                 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
596         fi
597 done
598
599 # run database update if configured
600 test -s %{_webappdir}/config.php && \
601 %{_appdir}/upgrade/update-database.php || :
602
603 # nuke Smarty templates cache after upgrade
604 rm -f /var/cache/eventum/*.php
605
606 # Restart webserver on upgrade to get .mo translations reloaded.
607 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
608 %php_webserver_restart
609
610 %preun
611 if [ "$1" = "0" ]; then
612         # nuke cache
613         rm -f /var/cache/eventum/*.php 2>/dev/null || :
614 fi
615
616 %pre base
617 %groupadd -P %{name}-base -g 146 %{name}
618 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
619
620 %postun base
621 if [ "$1" = "0" ]; then
622         %userremove %{name}
623         %groupremove %{name}
624 fi
625
626 %post setup
627 chmod 660 %{_webappdir}/{config,private_key}.php
628 chown root:http %{_webappdir}/{config,private_key}.php
629
630 %postun setup
631 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
632         chmod 640 %{_webappdir}/{config,private_key}.php
633         chown root:http %{_webappdir}/{config,private_key}.php
634 fi
635
636 %post irc
637 /sbin/chkconfig --add eventum-irc
638 %service eventum-irc restart "Eventum IRC Bot"
639
640 %preun irc
641 if [ "$1" = 0 ]; then
642         %service eventum-irc stop
643         /sbin/chkconfig --del eventum-irc
644 fi
645
646 %triggerin -- apache1 < 1.3.37-3, apache1-base
647 %webapp_register apache %{_webapp}
648
649 %triggerun -- apache1 < 1.3.37-3, apache1-base
650 %webapp_unregister apache %{_webapp}
651
652 %triggerin -- apache < 2.2.0, apache-base
653 %webapp_register httpd %{_webapp}
654
655 %triggerun -- apache < 2.2.0, apache-base
656 %webapp_unregister httpd %{_webapp}
657
658 %triggerin -- lighttpd
659 %webapp_register lighttpd %{_webapp}
660
661 %triggerun -- lighttpd
662 %webapp_unregister lighttpd %{_webapp}
663
664 %triggerpostun -- %{name} < 3.0.0-0.2
665 for f in /etc/cron.d/eventum-*; do
666         # crontabs moved to bin
667         %{__sed} -i -e '
668                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
669                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
670                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
671                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
672         ' $f
673 done
674
675 %files -f %{name}.lang
676 %defattr(644,root,root,755)
677 %attr(751,root,root) %dir %{_webappdir}
678 %attr(751,root,root) %dir %{_webappdir}/custom_field
679 %attr(751,root,root) %dir %{_webappdir}/templates
680 %attr(751,root,root) %dir %{_webappdir}/workflow
681 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
682 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
683 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
684 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
685 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
686 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
687 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
688
689 %dir %attr(731,root,http) /var/log/%{name}
690 %attr(620,root,http) %ghost /var/log/%{name}/*
691 %dir %attr(750,root,root) /var/log/archive/%{name}
692 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
693
694 %{_appdir}/config
695
696 %dir %{_appdir}/bin
697 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
698
699 %{_appdir}/autoload.php
700 %{_appdir}/init.php
701 %dir %{_appdir}/htdocs
702 %{_appdir}/htdocs/*.php
703 %{_appdir}/htdocs/*.ico
704 %{_appdir}/htdocs/ajax
705 %{_appdir}/htdocs/css
706 %{_appdir}/htdocs/customer
707 %{_appdir}/htdocs/images
708 %{_appdir}/htdocs/js
709 %{_appdir}/htdocs/manage
710 %{_appdir}/htdocs/misc
711 %{_appdir}/htdocs/reports
712 %{_appdir}/htdocs/rpc
713 %{_appdir}/htdocs/components
714 %{_appdir}/templates
715
716 %dir %{_appdir}/upgrade
717 %{_appdir}/upgrade/flush_compiled_templates.php
718 %{_appdir}/upgrade/*.sql
719 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
720 %attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
721 %attr(755,root,root) %{_appdir}/upgrade/ldap_update_users.php
722 %attr(755,root,root) %{_appdir}/upgrade/scm_trac_import.php
723 %{_appdir}/upgrade/patches
724
725 %{_appdir}/vendor
726
727 %dir %{_appdir}/lib
728 %{_appdir}/lib/eventum
729 %exclude %{_appdir}/lib/eventum/class.monitor.php
730
731 %{systemdtmpfilesdir}/%{name}.conf
732 %dir %attr(730,root,http) /var/run/%{name}
733 %dir %attr(730,root,http) /var/cache/%{name}
734
735 %files base
736 %defattr(644,root,root,755)
737 %attr(751,root,root) %dir %{_sysconfdir}
738 %dir %{_libdir}
739 %dir %{_appdir}
740 %dir /var/lib/%{name}
741 # saved mail copies
742 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
743 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
744 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
745
746 %files setup
747 %defattr(644,root,root,755)
748 %{_appdir}/htdocs/setup
749
750 %files doc
751 %doc docs/*
752 %{_examplesdir}/%{name}-%{version}
753
754 %files mail-queue
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
757 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
758 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
759
760 %files mail-download
761 %defattr(644,root,root,755)
762 %attr(755,root,root) %{_appdir}/bin/download_emails.php
763 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
764
765 %files reminder
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
768 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
769
770 %files monitor
771 %defattr(644,root,root,755)
772 %{_appdir}/lib/eventum/class.monitor.php
773 %attr(755,root,root) %{_appdir}/bin/monitor.php
774 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
775
776 %files route-drafts
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{_appdir}/bin/route_drafts.php
779
780 %files route-emails
781 %defattr(644,root,root,755)
782 %attr(755,root,root) %{_appdir}/bin/route_emails.php
783
784 %files route-notes
785 %defattr(644,root,root,755)
786 %attr(755,root,root) %{_appdir}/bin/route_notes.php
787
788 %files router-postfix
789 %defattr(644,root,root,755)
790 %attr(755,root,root) %{_libdir}/router-postfix
791
792 %files irc
793 %defattr(644,root,root,755)
794 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
795 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
796 %attr(755,root,root) %{_sbindir}/%{name}-irc-bot
797 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
798
799 %files cli
800 %defattr(644,root,root,755)
801 %doc cli/eventumrc
802 %attr(755,root,root) %{_bindir}/%{name}
803
804 %files scm
805 %defattr(644,root,root,755)
806 %attr(751,root,root) %dir %{_sysconfdir}
807 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
808 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
809 %attr(755,root,root) %{_sbindir}/eventum-git-hook
810 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
811 %attr(755,root,root) %{_sbindir}/helpers.php
812
813 %files sphinx
814 %defattr(644,root,root,755)
815 %{_webappdir}/sphinx.conf.php
816 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
817 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.071112 seconds and 2 git commands to generate.