]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
1ab30e48f7f602c4ca9b27f8d2d3a4148be248cd
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 #
9 # Conditional build:
10 %bcond_without  order   # with experimental order patch
11
12 %define         php_min_version 5.1.2
13 #define         subver  RC3
14 %define         rel             1
15 %include        /usr/lib/rpm/macros.php
16 Summary:        Eventum Issue / Bug tracking system
17 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
18 Name:           eventum
19 Version:        2.3.3
20 Release:        %{rel}
21 #Release:       %{rel}.bzr%{subver}
22 License:        GPL
23 Group:          Applications/WWW
24 Source0:        http://launchpad.net/eventum/trunk/%{version}/+download/%{name}-%{version}.tar.gz
25 # Source0-md5:  e1a5097d191468061865065678665f0e
26 #Source0:       %{name}-%{version}-dev-r%{subver}.tar.gz
27 #Source0:       %{name}-%{version}%{subver}.tar.gz
28 Source1:        %{name}-apache.conf
29 Source2:        %{name}-mail-queue.cron
30 Source3:        %{name}-mail-download.cron
31 Source4:        %{name}-reminder.cron
32 Source5:        %{name}-monitor.cron
33 Source6:        %{name}-cvs.php
34 Source7:        %{name}-irc.php
35 Source8:        %{name}-irc.init
36 Source9:        %{name}-irc.sysconfig
37 Source10:       sphinx.crontab
38 Source13:       %{name}-router-postfix.sh
39 Source14:       %{name}.logrotate
40 Source15:       %{name}-lighttpd.conf
41 Source16:       http://www.isocra.com/images/updown2.gif
42 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
43 Source17:       %{name}.tmpfiles
44 Patch0:         %{name}-lf.patch
45 Patch2:         %{name}-order.patch
46 Patch3:         group-users.patch
47 # packaging patches that probably never go upstream
48 Patch100:       %{name}-paths.patch
49 Patch101:       %{name}-cvs-config.patch
50 Patch105:       %{name}-bot-reconnect.patch
51 Patch107:       %{name}-gettext.patch
52 # some tests
53 Patch200:       %{name}-fixed-nav.patch
54 URL:            http://eventum.mysql.org/
55 BuildRequires:  gettext-devel
56 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
57 BuildRequires:  rpmbuild(macros) >= 1.461
58 BuildRequires:  sed >= 4.0
59 Requires:       %{name}-base = %{version}-%{release}
60 Requires:       Smarty >= 2.6.10-4
61 Requires:       php-common >= 4:%{php_min_version}
62 Requires:       php-filter
63 Requires:       php-gd
64 Requires:       php-iconv
65 Requires:       php-imap
66 Requires:       php-json
67 Requires:       php-mbstring
68 Requires:       php-mysql
69 Requires:       php-pcre
70 Requires:       php-pear-DB
71 Requires:       php-pear-Date
72 Requires:       php-pear-Mail
73 Requires:       php-pear-Mail_Mime
74 Requires:       php-pear-Mail_mimeDecode
75 Requires:       php-pear-Math_Stats
76 Requires:       php-pear-Net_DIME
77 Requires:       php-pear-Net_SMTP
78 Requires:       php-pear-Net_Socket
79 Requires:       php-pear-Net_URL
80 Requires:       php-pear-Net_UserAgent_Detect
81 Requires:       php-pear-PEAR-core
82 Requires:       php-pear-Text_Diff
83 Requires:       php-pear-XML_RPC
84 Requires:       php-session
85 Requires:       smarty-gettext
86 Requires:       webapps
87 Requires:       webserver(access)
88 Requires:       webserver(alias)
89 Requires:       webserver(indexfile)
90 Requires:       webserver(php) >= 4.2.0
91 Suggests:       localedb
92 Suggests:       php-pear-Net_LDAP2
93 Conflicts:      logrotate < 3.8.0
94 BuildArch:      noarch
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %define         _noautopear     pear(../init.php) pear(init.php) pear(/usr/share/eventum/init.php) pear(/etc/webapps/.*) pear(%{_appdir}/.*) pear(jpgraph_dir.php) pear(.*Smarty.class.php) pear(Services/JSON.php) pear(class.date_helper.php) pear(sphinxapi.php) pear(Net/LDAP2.php)
98
99 # exclude optional php dependencies
100 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
101
102 %define         _noautoreq      %{_noautophp} %{_noautopear}
103
104 %define         _libdir         %{_prefix}/lib/%{name}
105 %define         _appdir         %{_datadir}/%{name}
106 %define         _smartydir      %{php_data_dir}/Smarty
107 %define         _webapps        /etc/webapps
108 %define         _webapp         %{name}
109 %define         _webappdir      %{_webapps}/%{_webapp}
110 %define         _sysconfdir     /etc/%{name}
111
112 %description
113 Eventum is a user-friendly and flexible issue tracking system that can
114 be used by a support department to track incoming technical support
115 requests, or by a software development team to quickly organize tasks
116 and bugs. Eventum is used by the MySQL AB Technical Support team, and
117 has allowed us to dramatically improve our response times.
118
119 %description -l pl.UTF-8
120 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
121 może być używany przez dział obsługi do śledzenia przychodzących żądań
122 obsługi technicznej albo przez zespół tworzący oprogramowanie do
123 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
124 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
125 reakcji.
126
127 %package base
128 Summary:        Eventum base package
129 Summary(pl.UTF-8):      Podstawowy pakiet Eventum
130 Group:          Applications/WWW
131 Requires(postun):       /usr/sbin/groupdel
132 Requires(postun):       /usr/sbin/userdel
133 Requires(pre):  /bin/id
134 Requires(pre):  /usr/bin/getgid
135 Requires(pre):  /usr/sbin/groupadd
136 Requires(pre):  /usr/sbin/useradd
137 Provides:       group(eventum)
138 Provides:       user(eventum)
139
140 %description base
141 This package contains base directory structure for Eventum.
142
143 %description base -l pl.UTF-8
144 Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
145
146 %package setup
147 Summary:        Eventum setup package
148 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
149 Group:          Applications/WWW
150 Requires:       %{name} = %{version}-%{release}
151
152 %description setup
153 Install this package to configure initial Eventum installation. You
154 should uninstall this package when you're done, as it considered
155 insecure to keep the setup files in place.
156
157 %description setup -l pl.UTF-8
158 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
159 pierwszej instalacji. Potem należy go odinstalować, jako że
160 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
161
162 %package mail-queue
163 Summary:        Eventum mail queue process
164 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
165 Group:          Applications/WWW
166 Requires:       %{name} = %{version}-%{release}
167 Requires:       crondaemon
168
169 %description mail-queue
170 Beginning with the first release of Eventum, emails are not directly
171 sent out from the various scripts, but rather added to a mail queue
172 table that is processed by a cron job. If an email cannot be sent, it
173 will be marked as such in the mail queue log, and the cron job script
174 will re-try to send it again the next time it runs.
175
176 This package contains the cron job.
177
178 %description mail-queue -l pl.UTF-8
179 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
180 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
181 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
182 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
183 następnym razem.
184
185 Ten pakiet zawiera zadanie dla crona.
186
187 %package mail-download
188 Summary:        Eventum email download
189 Summary(pl.UTF-8):      Ściąganie poczty Eventum
190 Group:          Applications/WWW
191 Requires:       %{name} = %{version}-%{release}
192 Requires:       crondaemon
193
194 %description mail-download
195 In order for Eventum's email integration feature to work, you need to
196 setup a cron job to run the script every so often.
197
198 This package contains the cron job.
199
200 %description mail-download -l pl.UTF-8
201 Aby integracja poczty elektronicznej w Eventum działała, trzeba
202 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
203 często.
204
205 Ten pakiet zawiera zadanie dla crona.
206
207 %package reminder
208 Summary:        Eventum Reminder System
209 Summary(pl.UTF-8):      System przypominania dla Eventum
210 Group:          Applications/WWW
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       crondaemon
213
214 %description reminder
215 The reminder system was designed with the objective as serving as a
216 safe net for issues that need attention. Depending on what
217 configuration you create, you may have several reminders (or alerts)
218 be sent out whenever an issue needs attention, for whatever parameter
219 you may deem necessary.
220
221 This package contains the cron job.
222
223 %description reminder -l pl.UTF-8
224 System przypominania został zaprojektowany tak, aby służył jako
225 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
226 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
227 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
228 uważać za potrzebny.
229
230 Ten pakiet zawiera zadanie dla crona.
231
232 %package monitor
233 Summary:        Eventum Heartbeat Monitor
234 Summary(pl.UTF-8):      Monitor życia dla Eventum
235 Group:          Applications/WWW
236 Requires:       %{name} = %{version}-%{release}
237 Requires:       crondaemon
238 Requires:       php-posix
239
240 %description monitor
241 The heartbeat monitor is a feature designed for the administrator that
242 wants to be alerted whenever a common problem in Eventum is detected,
243 like the database server not being available anymore, or maybe when
244 the recommended permissions for certain configuration files are
245 changed.
246
247 Please note that before running the heartbeat monitor, you may need to
248 customize some of the checks to be appropriate for your own system,
249 particularly the permission and file checks on
250 Monitor::checkConfiguration().
251
252 This package contains the cron job.
253
254 %description monitor -l pl.UTF-8
255 Monitor życia to funkcjonalność zaprojektowana dla administratora
256 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
257 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
258 do plików konfiguracyjnych.
259
260 Należy zauważyć, że przed uruchomieniem tego monitora może być
261 konieczne dostosowanie niektórych testów do systemu, w szczególności
262 testów uprawnień i plików w Monitor::checkConfiguration().
263
264 Ten pakiet zawiera zadanie dla crona.
265
266 %package route-drafts
267 Summary:        Eventum Draft Routing
268 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
269 Group:          Applications/WWW
270 Requires:       %{name} = %{version}-%{release}
271 Requires:       eventum(router)
272
273 %description route-drafts
274 The draft routing feature is used to automatically associate a thread
275 of drafts into an Eventum issue. By setting up Postfix to deliver
276 emails sent to a specific address (usually draft-<number>@<domain>) to
277 the above script, users are able to send drafts written in their mail
278 client to be stored in Eventum. These drafts will NOT broadcasted to
279 the notification list.
280
281 %description route-drafts -l pl.UTF-8
282 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
283 problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
284 wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
285 skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
286 kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
287 na listę powiadomień.
288
289 %package route-emails
290 Summary:        Eventum Email Routing
291 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
292 Group:          Applications/WWW
293 Requires:       %{name} = %{version}-%{release}
294 Requires:       eventum(router)
295
296 %description route-emails
297 The email routing feature is used to automatically associate a thread
298 of emails into an Eventum issue. By setting up Postfix to deliver
299 emails sent to a specific address (usually issue-<number>@<domain>) to
300 the above script, users are able to use their email clients to reply
301 to emails coming from Eventum, and those replies will be automatically
302 associated with the issue and broadcasted to the entire notification
303 list.
304
305 %description route-emails -l pl.UTF-8
306 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
307 wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
308 aby dostarczał listy wysyłane na pewien adres (zwykle
309 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
310 używać klientów pocztowych do odpowiadania na listy przychodzące z
311 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
312 rozprowadzane do całej listy ogłoszeniowej.
313
314 %package route-notes
315 Summary:        Eventum Note Routing
316 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
317 Group:          Applications/WWW
318 Requires:       %{name} = %{version}-%{release}
319 Requires:       eventum(router)
320
321 %description route-notes
322 The note routing feature is used to automatically associate a thread
323 of notes into an Eventum issue. By setting up Postfix to deliver
324 emails sent to a specific address (usually note-<number>@<domain>) to
325 the above script, users are able to use their email clients to reply
326 to internal notes coming from Eventum, and those replies will be
327 automatically associated with the issue and broadcasted to the
328 notification list staff members.
329
330 %description route-notes -l pl.UTF-8
331 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
332 wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
333 dostarczał listy wysyłane na pewien adres (zwykle
334 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
335 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
336 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
337 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
338
339 %package router-postfix
340 Summary:        Eventum Mail Routing - Postfix
341 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
342 Group:          Applications/Mail
343 Requires:       %{name} = %{version}-%{release}
344 Requires:       postfix
345 Provides:       eventum(router)
346 Obsoletes:      eventum(router)
347
348 %description router-postfix
349 This package provides way of routing notes and emails back to Eventum
350 via Postfix.
351
352 The Postfix configuration instructions you can find from
353 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
354
355 %description router-postfix -l pl.UTF-8
356 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
357 przez Postfiksa.
358
359 Opis konfiguracji Postfiksa można znaleźć pod adresem
360 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
361
362 %package irc
363 Summary:        Eventum IRC Notification Bot
364 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
365 Group:          Applications/WWW
366 Requires(post,preun):   /sbin/chkconfig
367 Requires:       %{name} = %{version}-%{release}
368 Requires:       php-pear-Net_SmartIRC
369 Requires:       php-sockets
370 Requires:       rc-scripts >= 0.4.0.18
371
372 %description irc
373 The IRC notification bot is a nice feature for remote teams that want
374 to handle issues and want to have a quick and easy way to get simple
375 notifications. Right now the bot notifies of the following actions:
376 - New Issues
377 - Blocked emails
378 - Issues that got their assignment list changed
379
380 NOTE: You will need to manually edit the bot.php script to set your
381 appropriate preferences, like IRC server and channel that the bot
382 should join.
383
384 %description irc -l pl.UTF-8
385 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
386 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
387 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
388 następujących zdarzeniach:
389 - nowych sprawach
390 - zablokowanych listach
391 - sprawach, dla których zmieniła się lista powiązań
392
393 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
394 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
395
396 %package cli
397 Summary:        Eventum command-line interface
398 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
399 Group:          Applications/WWW
400 Requires:       %{name}-base = %{version}-%{release}
401 Requires:       php-cli
402 Requires:       php-common >= 4:%{php_min_version}
403 Requires:       php-pear-XML_RPC
404
405 %description cli
406 The Eventum command-line interface allows you to access most of the
407 features of the web interface straight from your command shell.
408
409 %description cli -l pl.UTF-8
410 Interfejs linii poleceń Eventum pozwala na dostęp do większości
411 funkcji interfejsu WWW prosto z linii poleceń powłoki.
412
413 %package scm
414 Summary:        Eventum SCM integration
415 Summary(pl.UTF-8):      Integracja SCM dla Eventum
416 Group:          Applications/WWW
417 Requires:       %{name}-base = %{version}-%{release}
418 Requires:       php-cli
419 Requires:       php-common >= 4:%{php_min_version}
420 Requires:       php-pcre
421
422 %description scm
423 This feature allows your software development teams to integrate your
424 Source Control Management system with your Issue Tracking System.
425
426 The integration is implemented in such a way that it will be forward
427 compatible with pretty much any SCM system, such as CVS.
428
429 For installation see
430 </eventum/help.php?topic=scm_integration_installation>.
431
432 %description scm -l pl.UTF-8
433 Ten pakiet pozwala zespołom programistów na integrację systemu
434 zarządzania źródłami (SCM - Source Control Management) z systemem
435 śledzenia spraw.
436
437 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
438 prawie każdym systemem SCM, jak np. CVS.
439
440 Szczegóły na temat instalacji można przeczytać pod
441 </eventum/help.php?topic=scm_integration_installation>.
442
443 %package sphinx
444 Summary:        Eventum Sphinx Search
445 Group:          Applications/WWW
446 Requires:       %{name} = %{version}-%{release}
447 Requires:       crondaemon
448 Requires:       sphinx
449
450 %description sphinx
451 Sphinx search integration for Eventum.
452
453 This package contains the cron job.
454
455 %prep
456 %setup -q
457
458 # GPL v2
459 rm docs/COPYING
460
461 rm -r upgrade/*v1.[123]* # too old to support in PLD Linux
462 rm -r upgrade/v{1.,2.0,2.1_}* # no longer supported in PLD Linux
463 rm upgrade/flush_compiled_templates.php
464 rm -r upgrade/{*/,}index.html # not needed in PLD Linux
465
466 # bug fixes / features
467 %patch0 -p1
468 %{?with_order:%patch2 -p1}
469 %patch3 -p0
470
471 cp -p %{SOURCE16} htdocs/images
472
473 #%patch200 -p1
474
475 # produce default sphinx config
476 # must be run before paths.patch
477 cat <<'EOF' > config/config.php
478 <?php
479 define('APP_SQL_DBTYPE', 'mysql');
480 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
481 define('APP_SQL_DBPORT', 3306);
482 define('APP_SQL_DBNAME', 'eventum');
483 define('APP_SQL_DBUSER', 'mysql');
484 define('APP_SQL_DBPASS', '');
485 define('APP_TABLE_PREFIX', 'eventum_');
486 EOF
487 php config/sphinx.conf.php > config/sphinx.conf
488 rm -f config/config.php
489
490 # packaging
491 %patch100 -p1
492 %patch101 -p1
493 %patch105 -p1
494 %patch107 -p1
495
496 %{__sed} -i -e "
497 s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
498 " upgrade/{*/,}*.php
499
500 # remove backups from patching as we use globs to package files to buildroot
501 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
502
503 %build
504 %{__make} -C localization
505
506 %install
507 rm -rf $RPM_BUILD_ROOT
508 install -d \
509         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
510         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
511         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
512         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
513         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
514         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
515         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
516
517 %{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
518         sysconfdir=%{_webappdir} \
519         DESTDIR=$RPM_BUILD_ROOT
520
521 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
522
523 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
524 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
525 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
526 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
527
528 install -d $RPM_BUILD_ROOT/etc/sphinx
529 cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
530 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
531
532 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
533 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
534 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
535 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
536 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
537
538 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
539
540 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
541 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
542
543 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
544
545 # postfix router
546 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
547
548 install %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
549
550 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
551
552 %find_lang %{name}
553
554 # scm
555 install -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
556
557 # old compat
558 ln -s %{_sbindir}/eventum-cvs-hook $RPM_BUILD_ROOT%{_libdir}/process_cvs_commits
559 ln -s %{_sbindir}/eventum-svn-hook $RPM_BUILD_ROOT%{_libdir}/process_svn_commits
560
561 # skip pear for cli
562 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
563 cp -a cli/lib/eventum $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
564
565 %clean
566 rm -rf $RPM_BUILD_ROOT
567
568 %pre
569 %addusertogroup http %{name}
570
571 %post
572 # greate empty ghost files
573 for a in cli.log errors.log irc_bot.log login_attempts.log; do
574         if [ ! -f /var/log/%{name}/$a ]; then
575                 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
576         fi
577 done
578
579 # database update
580 %{_appdir}/upgrade/update-database.php || :
581
582 # nuke Smarty templates cache after upgrade
583 rm -f /var/cache/eventum/*.php
584
585 # Restart webserver on upgrade to get .mo translations reloaded.
586 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
587 %php_webserver_restart
588
589 %preun
590 if [ "$1" = "0" ]; then
591         # nuke cache
592         rm -f /var/cache/eventum/*.php 2>/dev/null || :
593 fi
594
595 %pre base
596 %groupadd -P %{name}-base -g 146 %{name}
597 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
598
599 %postun base
600 if [ "$1" = "0" ]; then
601         %userremove %{name}
602         %groupremove %{name}
603 fi
604
605 %post setup
606 chmod 660 %{_webappdir}/{config,private_key}.php
607 chown root:http %{_webappdir}/{config,private_key}.php
608
609 %postun setup
610 if [ "$1" = "0" ]; then
611         chmod 640 %{_webappdir}/{config,private_key}.php
612         chown root:http %{_webappdir}/{config,private_key}.php
613 fi
614
615 %post irc
616 /sbin/chkconfig --add eventum-irc
617 %service eventum-irc restart "Eventum IRC Bot"
618
619 %preun irc
620 if [ "$1" = 0 ]; then
621         %service eventum-irc stop
622         /sbin/chkconfig --del eventum-irc
623 fi
624
625 %triggerin -- apache1 < 1.3.37-3, apache1-base
626 %webapp_register apache %{_webapp}
627
628 %triggerun -- apache1 < 1.3.37-3, apache1-base
629 %webapp_unregister apache %{_webapp}
630
631 %triggerin -- apache < 2.2.0, apache-base
632 %webapp_register httpd %{_webapp}
633
634 %triggerun -- apache < 2.2.0, apache-base
635 %webapp_unregister httpd %{_webapp}
636
637 %triggerin -- lighttpd
638 %webapp_register lighttpd %{_webapp}
639
640 %triggerun -- lighttpd
641 %webapp_unregister lighttpd %{_webapp}
642
643 %triggerpostun -- %{name} < 2.2-2.57
644 # switching eventum->http user
645 chgrp http %{_webappdir}/config.php
646 chgrp http %{_webappdir}/private_key.php
647 chgrp http %{_webappdir}/setup.php
648 chgrp http /var/log/%{name}/*
649 # update crontab user
650 for a in /etc/cron.d/eventum-*; do
651         [ -f "$a" ] || continue
652         awk '!/#/ && NR > 6 && $6 =="eventum" {sub("eventum", "http", $6)}{print}'  $a > $a.rpmtmp && cat $a.rpmtmp > $a
653         rm -f $a.rpmtmp
654
655         # crontabs moved to crons subdir
656         %{__sed} -i -e '
657                 s,/usr/share/eventum/process_mail_queue.php,/usr/share/eventum/crons/process_mail_queue.php,
658                 s,/usr/share/eventum/download_emails.php,/usr/share/eventum/crons/download_emails.php,
659                 s,/usr/share/eventum/check_reminders.php,/usr/share/eventum/crons/check_reminders.php,
660                 s,/usr/share/eventum/monitor.php,/usr/share/eventum/crons/monitor.php,
661         ' $a
662 done
663
664 %files -f %{name}.lang
665 %defattr(644,root,root,755)
666 %doc docs/* htdocs/setup/schema.sql
667 %attr(751,root,root) %dir %{_webappdir}
668 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
669 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
670 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
671 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
672 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
673 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
674 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
675
676 %dir %attr(731,root,http) /var/log/%{name}
677 %attr(620,root,http) %ghost /var/log/%{name}/*
678 %dir %attr(750,root,root) /var/log/archive/%{name}
679 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
680
681 %dir %{_appdir}/crons
682 %{_appdir}/init.php
683 %dir %{_appdir}/htdocs
684 %{_appdir}/htdocs/*.php
685 %{_appdir}/htdocs/*.ico
686 %{_appdir}/htdocs/css
687 %{_appdir}/htdocs/customer
688 %{_appdir}/htdocs/images
689 %{_appdir}/htdocs/js
690 %{_appdir}/htdocs/manage
691 %{_appdir}/htdocs/reports
692 %{_appdir}/htdocs/rpc
693 %{_appdir}/htdocs/misc
694 %if %{with order}
695 %{_appdir}/htdocs/ajax
696 %endif
697 %{_appdir}/templates
698
699 %dir %{_appdir}/upgrade
700 %{_appdir}/upgrade/init.php
701 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
702 %attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
703 %dir %{_appdir}/upgrade/v*
704 %attr(755,root,root) %{_appdir}/upgrade/v*/*.php
705 %{_appdir}/upgrade/patches
706
707 %dir %{_appdir}/lib
708 %{_appdir}/lib/eventum
709 %{_appdir}/lib/jpgraph
710 %exclude %{_appdir}/lib/eventum/class.monitor.php
711 %{systemdtmpfilesdir}/%{name}.conf
712 %dir %attr(730,root,http) /var/run/%{name}
713 %dir %attr(730,root,http) /var/cache/%{name}
714
715 %files base
716 %defattr(644,root,root,755)
717 %attr(751,root,root) %dir %{_sysconfdir}
718 %dir %{_libdir}
719 %dir %{_appdir}
720 %dir /var/lib/%{name}
721 # saved mail copies
722 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
723 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
724 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
725
726 %files setup
727 %defattr(644,root,root,755)
728 %{_appdir}/htdocs/setup
729
730 %files mail-queue
731 %defattr(644,root,root,755)
732 %attr(755,root,root) %{_appdir}/crons/process_mail_queue.php
733 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
734
735 %files mail-download
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{_appdir}/crons/download_emails.php
738 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
739
740 %files reminder
741 %defattr(644,root,root,755)
742 %attr(755,root,root) %{_appdir}/crons/check_reminders.php
743 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
744
745 %files monitor
746 %defattr(644,root,root,755)
747 %{_appdir}/lib/eventum/class.monitor.php
748 %attr(755,root,root) %{_appdir}/crons/monitor.php
749 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
750
751 %files route-drafts
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_appdir}/route_drafts.php
754
755 %files route-emails
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_appdir}/route_emails.php
758
759 %files route-notes
760 %defattr(644,root,root,755)
761 %attr(755,root,root) %{_appdir}/route_notes.php
762
763 %files router-postfix
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_libdir}/router-postfix
766
767 %files irc
768 %defattr(644,root,root,755)
769 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
770 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
771 %attr(755,root,root) %{_sbindir}/%{name}-irc-bot
772 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
773
774 %files cli
775 %defattr(644,root,root,755)
776 %doc cli/eventumrc
777 %attr(755,root,root) %{_bindir}/%{name}
778 %{_appdir}/cli
779
780 %files scm
781 %defattr(644,root,root,755)
782 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
783 %attr(755,root,root) %{_libdir}/process_cvs_commits
784 %attr(755,root,root) %{_libdir}/process_svn_commits
785 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
786 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
787
788 %files sphinx
789 %defattr(644,root,root,755)
790 %{_webappdir}/sphinx.conf.php
791 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
792 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.443492 seconds and 3 git commands to generate.