]> git.pld-linux.org Git - packages/eventum.git/blame_incremental - eventum.spec
update autoloader patches
[packages/eventum.git] / eventum.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with order # with experimental order patch
4
5%define rel 1
6%define subver 136
7%define githash bd09ead2
8%define php_min_version 5.6.0
9%include /usr/lib/rpm/macros.php
10Summary: Eventum Issue / Bug tracking system
11Summary(pl.UTF-8): Eventum - system śledzenia spraw/błędów
12Name: eventum
13Version: 3.2.3
14Release: %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
15License: GPL v2+
16Group: Applications/WWW
17#Source0: https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
18Source0: https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.gz
19# Source0-md5: a8edbaab9794b68e84eec719e3841a78
20Source1: %{name}-apache.conf
21Source2: %{name}-mail-queue.cron
22Source3: %{name}-mail-download.cron
23Source4: %{name}-reminder.cron
24Source5: %{name}-monitor.cron
25Source8: %{name}-irc.init
26Source9: %{name}-irc.sysconfig
27Source10: sphinx.crontab
28Source13: %{name}-router-postfix.sh
29Source14: %{name}.logrotate
30Source15: %{name}-lighttpd.conf
31Source16: http://www.isocra.com/images/updown2.gif
32# Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
33Source17: %{name}.tmpfiles
34Patch2: %{name}-order.patch
35#Patch3: group-users.patch
36#Patch4: https://github.com/glensc/eventum/compare/cf_escape.patch
37# packaging patches that probably never go upstream
38Patch100: %{name}-paths.patch
39Patch107: %{name}-gettext.patch
40Patch108: autoload.patch
41# some tests
42Patch200: %{name}-fixed-nav.patch
43URL: https://wiki.github.com/eventum/eventum/
44BuildRequires: gettext-tools
45BuildRequires: rpm-php-pearprov >= 4.0.2-98
46BuildRequires: rpmbuild(macros) >= 1.654
47BuildRequires: sed >= 4.0
48Requires(postun): /usr/sbin/groupdel
49Requires(postun): /usr/sbin/userdel
50Requires(pre): /bin/id
51Requires(pre): /usr/bin/getgid
52Requires(pre): /usr/sbin/groupadd
53Requires(pre): /usr/sbin/useradd
54Requires: fonts-TTF-RedHat-liberation
55Requires: php(core) >= %{php_min_version}
56Requires: php(filter)
57Requires: php(iconv)
58Requires: php(imap)
59Requires: php(json)
60Requires: php(mbstring)
61Requires: php(pcre)
62Requires: php(pdo_mysql)
63Requires: php(session)
64Requires: php-Smarty >= 3.1
65Requires: php-Smarty-plugin-gettext
66Requires: php-ZendFramework-Config >= 2.4
67Requires: php-ZendFramework-Loader >= 2.4
68Requires: php-ZendFramework-Mail >= 2.4.11-4
69Requires: php-ZendFramework-Mime >= 2.4
70Requires: php-ZendFramework-ServiceManager >= 2.4
71Requires: php-ZendFramework-Validator >= 2.4
72Requires: php-monolog >= 1.17.2
73Requires: php-pear-Mail_Mime
74Requires: php-pear-Mail_mimeDecode
75Requires: php-pear-Math_Stats
76Requires: php-pear-Net_SMTP
77Requires: php-pear-Net_Socket
78Requires: php-pear-Net_URL
79Requires: php-pear-PEAR-core
80Requires: php-pear-Text_Diff
81Requires: php-psr-Log >= 1.0.0-2
82Requires: php-symfony2-Config >= 2.7.7
83Requires: php-symfony2-Console >= 2.7.7
84Requires: php-symfony2-EventDispatcher >= 2.7.7
85Requires: php-symfony2-Filesystem >= 2.7.7
86Requires: php-symfony2-HttpFoundation >= 2.7.7
87Requires: php-symfony2-OptionsResolver >= 2.7.7
88Requires: php-symfony2-Serializer >= 2.7.7
89Requires: php-symfony2-Yaml >= 2.7.7
90Requires: phplot >= 5.8.0
91Requires: webapps
92Requires: webserver(access)
93Requires: webserver(alias)
94Requires: webserver(indexfile)
95Requires: webserver(php) >= 4.2.0
96Suggests: localedb
97Suggests: php(mcrypt)
98Suggests: php(openssl)
99Suggests: php-pear-Net_LDAP2
100Suggests: php-pear-Net_POP3
101Suggests: webserver(setenv)
102Provides: group(eventum)
103Provides: user(eventum)
104Obsoletes: eventum-base < 3.0.3-1.305
105Obsoletes: eventum-route-drafts < 3.0.8-1.1
106Obsoletes: eventum-route-emails < 3.0.8-1.1
107Obsoletes: eventum-route-notes < 3.0.8-1.1
108Conflicts: logrotate < 3.8.0
109BuildArch: noarch
110BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112%define _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
113
114# exclude optional php dependencies
115%define _noautophp php-gnupg php-hash php-pecl-http php-tk
116
117%define _noautoreq %{_noautophp}
118
119%define _libdir %{_prefix}/lib/%{name}
120%define _appdir %{_datadir}/%{name}
121%define _smartydir %{php_data_dir}/Smarty
122%define _webapps /etc/webapps
123%define _webapp %{name}
124%define _webappdir %{_webapps}/%{_webapp}
125%define _sysconfdir /etc/%{name}
126
127%description
128Eventum is a user-friendly and flexible issue tracking system that can
129be used by a support department to track incoming technical support
130requests, or by a software development team to quickly organize tasks
131and bugs.
132
133%description -l pl.UTF-8
134Eventum to przyjazny dla użytkownika system śledzenia spraw, który
135może być używany przez dział obsługi do śledzenia przychodzących żądań
136obsługi technicznej albo przez zespół tworzący oprogramowanie do
137szybkiej organizacji zadań i błędów.
138
139%package setup
140Summary: Eventum setup package
141Summary(pl.UTF-8): Pakiet do wstępnej konfiguracji Eventum
142Group: Applications/WWW
143Requires: %{name} = %{version}-%{release}
144
145%description setup
146Install this package to configure initial Eventum installation. You
147should uninstall this package when you're done, as it considered
148insecure to keep the setup files in place.
149
150%description setup -l pl.UTF-8
151Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
152pierwszej instalacji. Potem należy go odinstalować, jako że
153pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
154
155%package doc
156Summary: Eventum documentation and Wiki
157Group: Documentation
158
159%description doc
160Eventum documentation and copy of Wiki.
161
162%package mail-queue
163Summary: Eventum mail queue process
164Summary(pl.UTF-8): Przetwarzanie kolejki poczty Eventum
165Group: Applications/WWW
166Requires: %{name} = %{version}-%{release}
167Requires: crondaemon
168
169%description mail-queue
170Beginning with the first release of Eventum, emails are not directly
171sent out from the various scripts, but rather added to a mail queue
172table that is processed by a cron job. If an email cannot be sent, it
173will be marked as such in the mail queue log, and the cron job script
174will re-try to send it again the next time it runs.
175
176This package contains the cron job.
177
178%description mail-queue -l pl.UTF-8
179Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
180różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
181Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
182kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
183następnym razem.
184
185Ten pakiet zawiera zadanie dla crona.
186
187%package mail-download
188Summary: Eventum email download
189Summary(pl.UTF-8): Ściąganie poczty Eventum
190Group: Applications/WWW
191Requires: %{name} = %{version}-%{release}
192Requires: crondaemon
193
194%description mail-download
195In order for Eventum's email integration feature to work, you need to
196setup a cron job to run the script every so often.
197
198This package contains the cron job.
199
200%description mail-download -l pl.UTF-8
201Aby integracja poczty elektronicznej w Eventum działała, trzeba
202ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
203często.
204
205Ten pakiet zawiera zadanie dla crona.
206
207%package reminder
208Summary: Eventum Reminder System
209Summary(pl.UTF-8): System przypominania dla Eventum
210Group: Applications/WWW
211Requires: %{name} = %{version}-%{release}
212Requires: crondaemon
213
214%description reminder
215The reminder system was designed with the objective as serving as a
216safe net for issues that need attention. Depending on what
217configuration you create, you may have several reminders (or alerts)
218be sent out whenever an issue needs attention, for whatever parameter
219you may deem necessary.
220
221This package contains the cron job.
222
223%description reminder -l pl.UTF-8
224System przypominania został zaprojektowany tak, aby służył jako
225bezpieczna sieć dla spraw wymagających uwagi. W zależności od
226konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
227przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
228uważać za potrzebny.
229
230Ten pakiet zawiera zadanie dla crona.
231
232%package monitor
233Summary: Eventum Heartbeat Monitor
234Summary(pl.UTF-8): Monitor życia dla Eventum
235Group: Applications/WWW
236Requires: %{name} = %{version}-%{release}
237Requires: crondaemon
238Requires: php(posix)
239
240%description monitor
241The heartbeat monitor is a feature designed for the administrator that
242wants to be alerted whenever a common problem in Eventum is detected,
243like the database server not being available anymore, or maybe when
244the recommended permissions for certain configuration files are
245changed.
246
247Please note that before running the heartbeat monitor, you may need to
248customize some of the checks to be appropriate for your own system,
249particularly the permission and file checks on
250Monitor::checkConfiguration().
251
252This package contains the cron job.
253
254%description monitor -l pl.UTF-8
255Monitor życia to funkcjonalność zaprojektowana dla administratora
256chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
257Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
258do plików konfiguracyjnych.
259
260Należy zauważyć, że przed uruchomieniem tego monitora może być
261konieczne dostosowanie niektórych testów do systemu, w szczególności
262testów uprawnień i plików w Monitor::checkConfiguration().
263
264Ten pakiet zawiera zadanie dla crona.
265
266%package router-postfix
267Summary: Eventum Mail Routing - Postfix
268Summary(pl.UTF-8): Przekazywanie poczty Eventum - Postfix
269Group: Applications/Mail
270Requires: %{name} = %{version}-%{release}
271Requires: postfix
272Provides: eventum(router)
273Obsoletes: eventum(router)
274
275%description router-postfix
276This package provides way of routing notes and emails back to Eventum
277via Postfix.
278
279The Postfix configuration instructions you can find from
280<https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
281
282%description router-postfix -l pl.UTF-8
283Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
284przez Postfiksa.
285
286Opis konfiguracji Postfiksa można znaleźć pod adresem
287<https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
288
289%package irc
290Summary: Eventum IRC Notification Bot
291Summary(pl.UTF-8): IRC-owy bot powiadamiający dla Eventum
292Group: Applications/WWW
293Requires(post,preun): /sbin/chkconfig
294Requires: %{name} = %{version}-%{release}
295Requires: php(pcntl)
296Requires: php(sockets)
297Requires: php-pear-Net_SmartIRC >= 1.1.9
298Requires: rc-scripts >= 0.4.0.18
299
300%description irc
301The IRC notification bot is a nice feature for remote teams that want
302to handle issues and want to have a quick and easy way to get simple
303notifications. Right now the bot notifies of the following actions:
304- New Issues
305- Blocked emails
306- Issues that got their assignment list changed
307
308NOTE: You will need to manually edit the bot.php script to set your
309appropriate preferences, like IRC server and channel that the bot
310should join.
311
312%description irc -l pl.UTF-8
313IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
314zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
315uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
316następujących zdarzeniach:
317- nowych sprawach
318- zablokowanych listach
319- sprawach, dla których zmieniła się lista powiązań
320
321UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
322kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
323
324%package cli
325Summary: Eventum command-line interface
326Summary(pl.UTF-8): Interfejs linii poleceń dla Eventum
327Group: Applications/WWW
328Requires: php(core) >= %{php_min_version}
329Requires: php(phar)
330
331%description cli
332The Eventum command-line interface allows you to access most of the
333features of the web interface straight from your command shell.
334
335%description cli -l pl.UTF-8
336Interfejs linii poleceń Eventum pozwala na dostęp do większości
337funkcji interfejsu WWW prosto z linii poleceń powłoki.
338
339%package sphinx
340Summary: Eventum Sphinx Search
341Group: Applications/WWW
342Requires: %{name} = %{version}-%{release}
343Requires: crondaemon
344Requires: sphinx
345
346%description sphinx
347Sphinx search integration for Eventum.
348
349This package contains the cron job.
350
351%prep
352%setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
353
354mv docs/examples .
355
356# bug fixes / features
357%{?with_order:%patch2 -p1}
358#%patch3 -p0
359#%patch4 -p1
360
361%{?with_order:cp -p %{SOURCE16} htdocs/images}
362
363#%patch200 -p1
364
365# produce default sphinx config
366# must be run before paths.patch
367%if 0
368cat <<'EOF' > config/config.php
369<?php
370define('APP_SQL_DBTYPE', 'mysql');
371define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
372define('APP_SQL_DBPORT', 3306);
373define('APP_SQL_DBNAME', 'eventum');
374define('APP_SQL_DBUSER', 'mysql');
375define('APP_SQL_DBPASS', '');
376define('APP_TABLE_PREFIX', 'eventum_');
377EOF
378php config/sphinx.conf.php > config/sphinx.conf
379rm config/config.php
380%endif
381
382# packaging
383%patch100 -p1
384%patch107 -p1
385%patch108 -p1
386
387rm htdocs/.htaccess.dist
388
389mv config/irc_config{.dist.php,.php}
390rm config/config.dist.php
391
392# cleanup vendor. keep only needed libraries.
393# (the rest are packaged with system packages)
394mv vendor vendor.dist
395vendor() {
396 local path dir
397 for path; do
398 dir=$(dirname $path)
399 test -d vendor/$dir || mkdir -p vendor/$dir
400 mv vendor.dist/$path vendor/$path
401 done
402}
403vendor autoload.php
404vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
405vendor composer/ClassLoader.php
406vendor ircmaxell/{random-lib,security-lib}
407vendor defuse/php-encryption
408vendor willdurand/email-reply-parser
409vendor theorchard/monolog-cascade
410vendor malkusch/lock
411vendor phpxmlrpc/phpxmlrpc
412vendor robmorgan/phinx
413
414# remove backups from patching as we use globs to package files to buildroot
415find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
416
417%build
418%{__make} -C localization
419
420%install
421rm -rf $RPM_BUILD_ROOT
422install -d \
423 $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
424 $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
425 $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
426 $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
427 $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
428 $RPM_BUILD_ROOT%{systemdtmpfilesdir}
429
430%{__make} install-eventum install-cli install-localization \
431 sysconfdir=%{_webappdir} \
432 localedir=%{_localedir} \
433 DESTDIR=$RPM_BUILD_ROOT
434
435ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
436
437cp -a vendor $RPM_BUILD_ROOT%{_appdir}
438
439# unsupported locale
440%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
441
442install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
443cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
444
445%{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
446
447touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
448cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
449cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
450cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
451
452install -d $RPM_BUILD_ROOT/etc/sphinx
453#cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
454cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
455
456cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
457cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
458cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
459cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
460cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
461
462install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
463cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
464
465cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
466
467# postfix router
468install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
469
470cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
471
472%find_lang %{name}
473
474%clean
475rm -rf $RPM_BUILD_ROOT
476
477%pre
478%groupadd -g 146 %{name}
479%useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
480%addusertogroup http %{name}
481
482%post
483# create empty ghost files
484# these permissions ensure the logs are write only
485for a in \
486 errors.log login_attempts.log \
487 eventum.log \
488 auth.log cli.log \
489 irc_bot_error.log irc_bot_smartirc.log \
490; do
491 test -f /var/log/%{name}/$a && continue
492 install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
493done
494
495# run database update if configured
496test -s %{_webappdir}/config.php && \
497%{_appdir}/bin/upgrade.php || :
498
499# nuke Smarty templates cache after upgrade
500rm -f /var/cache/eventum/*.php
501
502# Restart webserver on upgrade to get .mo translations reloaded.
503# actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
504%php_webserver_restart
505
506%preun
507if [ "$1" = "0" ]; then
508 # nuke cache
509 rm -f /var/cache/eventum/*.php 2>/dev/null || :
510fi
511
512%postun
513if [ "$1" = "0" ]; then
514 %userremove %{name}
515 %groupremove %{name}
516fi
517
518%post setup
519chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
520chown root:http %{_webappdir}/{config,private_key,secret_key}.php
521
522%postun setup
523if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
524 chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
525 chown root:http %{_webappdir}/{config,private_key,secret_key}.php
526fi
527
528%post irc
529/sbin/chkconfig --add eventum-irc
530%service eventum-irc restart "Eventum IRC Bot"
531
532%preun irc
533if [ "$1" = 0 ]; then
534 %service eventum-irc stop
535 /sbin/chkconfig --del eventum-irc
536fi
537
538%triggerin -- apache1 < 1.3.37-3, apache1-base
539%webapp_register apache %{_webapp}
540
541%triggerun -- apache1 < 1.3.37-3, apache1-base
542%webapp_unregister apache %{_webapp}
543
544%triggerin -- apache < 2.2.0, apache-base
545%webapp_register httpd %{_webapp}
546
547%triggerun -- apache < 2.2.0, apache-base
548%webapp_unregister httpd %{_webapp}
549
550%triggerin -- lighttpd
551%webapp_register lighttpd %{_webapp}
552
553%triggerun -- lighttpd
554%webapp_unregister lighttpd %{_webapp}
555
556%triggerpostun -- %{name} < 3.0.0-0.2
557for f in /etc/cron.d/eventum-*; do
558 # crontabs moved to bin
559 %{__sed} -i -e '
560 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
561 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
562 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
563 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
564 ' $f
565done
566
567%files -f %{name}.lang
568%defattr(644,root,root,755)
569%attr(751,root,root) %dir %{_webappdir}
570%attr(751,root,http) %dir %{_webappdir}/crm
571%attr(751,root,http) %dir %{_webappdir}/custom_field
572%attr(751,root,http) %dir %{_webappdir}/partner
573%attr(751,root,http) %dir %{_webappdir}/templates
574%attr(751,root,http) %dir %{_webappdir}/workflow
575%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
576%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
577%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
578%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
579%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
580%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
581%attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
582%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
583
584%dir %attr(731,root,http) /var/log/%{name}
585%attr(620,root,http) %ghost /var/log/%{name}/*
586%dir %attr(750,root,root) /var/log/archive/%{name}
587%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
588
589%dir %{_appdir}
590%{_appdir}/config
591
592%dir %{_appdir}/bin
593%attr(755,root,root) %{_appdir}/bin/process_all_emails.php
594%attr(755,root,root) %{_appdir}/bin/upgrade.php
595
596%{_appdir}/autoload.php
597%{_appdir}/globals.php
598%{_appdir}/init.php
599%{_appdir}/phinx.php
600%dir %{_appdir}/htdocs
601%{_appdir}/htdocs/*.php
602%{_appdir}/htdocs/*.ico
603%{_appdir}/htdocs/ajax
604%{_appdir}/htdocs/css
605%{_appdir}/htdocs/customer
606%{_appdir}/htdocs/images
607%{_appdir}/htdocs/js
608%{_appdir}/htdocs/manage
609%{_appdir}/htdocs/reports
610%{_appdir}/htdocs/rpc
611%{_appdir}/htdocs/components
612%{_appdir}/templates
613
614%dir %{_appdir}/db
615%dir %{_appdir}/db/migrations
616%{_appdir}/db/migrations/*.php
617
618%{_appdir}/res
619%{_appdir}/src
620%{_appdir}/vendor
621%dir %{_appdir}/lib
622%{_appdir}/lib/eventum
623%exclude %{_appdir}/lib/eventum/class.monitor.php
624
625%dir %{_libdir}
626
627%{systemdtmpfilesdir}/%{name}.conf
628
629%dir /var/lib/%{name}
630%dir %attr(730,root,http) /var/run/%{name}
631%dir %attr(730,root,http) /var/cache/%{name}
632
633# saved mail copies
634%attr(770,root,http) %dir /var/lib/%{name}/routed_emails
635%attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
636%attr(770,root,http) %dir /var/lib/%{name}/routed_notes
637
638%files setup
639%defattr(644,root,root,755)
640%{_appdir}/htdocs/setup
641
642%files doc
643%defattr(644,root,root,755)
644%doc docs/*
645%{_examplesdir}/%{name}-%{version}
646
647%files mail-queue
648%defattr(644,root,root,755)
649%attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
650%attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
651%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
652
653%files mail-download
654%defattr(644,root,root,755)
655%attr(755,root,root) %{_appdir}/bin/download_emails.php
656%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
657
658%files reminder
659%defattr(644,root,root,755)
660%attr(755,root,root) %{_appdir}/bin/check_reminders.php
661%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
662
663%files monitor
664%defattr(644,root,root,755)
665%{_appdir}/lib/eventum/class.monitor.php
666%attr(755,root,root) %{_appdir}/bin/monitor.php
667%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
668
669%files router-postfix
670%defattr(644,root,root,755)
671%attr(755,root,root) %{_libdir}/router-postfix
672
673%files irc
674%defattr(644,root,root,755)
675%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
676%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
677%attr(755,root,root) %{_appdir}/bin/irc-bot.php
678%attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
679
680%files cli
681%defattr(644,root,root,755)
682%doc cli/eventumrc
683%attr(755,root,root) %{_bindir}/%{name}
684
685%files sphinx
686%defattr(644,root,root,755)
687%{_webappdir}/sphinx.conf.php
688#%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
689%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.060525 seconds and 4 git commands to generate.