]> git.pld-linux.org Git - packages/eventum.git/blame_incremental - eventum.spec
up to 3.0.2
[packages/eventum.git] / eventum.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with order # with experimental order patch
4
5%define rel 1
6#define subver 207
7#define githash 0ce2ec6
8%define php_min_version 5.3.3
9%include /usr/lib/rpm/macros.php
10Summary: Eventum Issue / Bug tracking system
11Summary(pl.UTF-8): Eventum - system śledzenia spraw/błędów
12Name: eventum
13Version: 3.0.2
14Release: %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
15License: GPL v2
16Group: Applications/WWW
17Source0: https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
18# Source0-md5: c6a5236ddfb1ae47cb09b08babbc37df
19#Source0: %{name}-%{version}-%{subver}-g%{githash}.tar.gz
20Source1: %{name}-apache.conf
21Source2: %{name}-mail-queue.cron
22Source3: %{name}-mail-download.cron
23Source4: %{name}-reminder.cron
24Source5: %{name}-monitor.cron
25Source6: %{name}-cvs.php
26Source7: %{name}-irc.php
27Source8: %{name}-irc.init
28Source9: %{name}-irc.sysconfig
29Source10: sphinx.crontab
30Source13: %{name}-router-postfix.sh
31Source14: %{name}.logrotate
32Source15: %{name}-lighttpd.conf
33Source16: http://www.isocra.com/images/updown2.gif
34# Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
35Source17: %{name}.tmpfiles
36#Patch0: %{name}-lf.patch
37Patch2: %{name}-order.patch
38#Patch3: group-users.patch
39#Patch4: https://github.com/glensc/eventum/compare/cf_escape.patch
40# packaging patches that probably never go upstream
41Patch100: %{name}-paths.patch
42Patch101: %{name}-cvs-config.patch
43Patch105: %{name}-bot-reconnect.patch
44Patch107: %{name}-gettext.patch
45# some tests
46Patch200: %{name}-fixed-nav.patch
47URL: http://eventum.mysql.org/
48BuildRequires: /usr/bin/php
49BuildRequires: gettext-devel
50BuildRequires: php(core) >= %{php_min_version}
51BuildRequires: rpm-php-pearprov >= 4.0.2-98
52BuildRequires: rpmbuild(macros) >= 1.654
53BuildRequires: sed >= 4.0
54Requires: %{name}-base = %{version}-%{release}
55Requires: fonts-TTF-RedHat-liberation
56Requires: php(core) >= %{php_min_version}
57Requires: php(filter)
58Requires: php(iconv)
59Requires: php(imap)
60Requires: php(json)
61Requires: php(mbstring)
62Requires: php(mysqli)
63Requires: php(pcre)
64Requires: php(session)
65Requires: php-Smarty >= 3.1
66Requires: php-Smarty-plugin-gettext
67Requires: php-pear-DB
68Requires: php-pear-Mail
69Requires: php-pear-Mail_Mime
70Requires: php-pear-Mail_mimeDecode
71Requires: php-pear-Math_Stats
72Requires: php-pear-Net_DIME
73Requires: php-pear-Net_SMTP
74Requires: php-pear-Net_Socket
75Requires: php-pear-Net_URL
76Requires: php-pear-Net_UserAgent_Detect
77Requires: php-pear-PEAR-core
78Requires: php-pear-Text_Diff
79Requires: php-pear-XML_RPC
80Requires: phplot >= 5.8.0
81Requires: webapps
82Requires: webserver(access)
83Requires: webserver(alias)
84Requires: webserver(indexfile)
85Requires: webserver(php) >= 4.2.0
86Suggests: localedb
87Suggests: php-pear-Net_LDAP2
88Conflicts: logrotate < 3.8.0
89BuildArch: noarch
90BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92%define _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
93
94# exclude optional php dependencies
95%define _noautophp php-gnupg php-hash php-pecl-http php-tk
96
97%define _noautoreq %{_noautophp}
98
99%define _libdir %{_prefix}/lib/%{name}
100%define _appdir %{_datadir}/%{name}
101%define _smartydir %{php_data_dir}/Smarty
102%define _webapps /etc/webapps
103%define _webapp %{name}
104%define _webappdir %{_webapps}/%{_webapp}
105%define _sysconfdir /etc/%{name}
106
107%description
108Eventum is a user-friendly and flexible issue tracking system that can
109be used by a support department to track incoming technical support
110requests, or by a software development team to quickly organize tasks
111and bugs. Eventum is used by the MySQL AB Technical Support team, and
112has allowed us to dramatically improve our response times.
113
114%description -l pl.UTF-8
115Eventum to przyjazny dla użytkownika system śledzenia spraw, który
116może być używany przez dział obsługi do śledzenia przychodzących żądań
117obsługi technicznej albo przez zespół tworzący oprogramowanie do
118szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
119Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
120reakcji.
121
122%package base
123Summary: Eventum base package
124Summary(pl.UTF-8): Podstawowy pakiet Eventum
125Group: Applications/WWW
126Requires(postun): /usr/sbin/groupdel
127Requires(postun): /usr/sbin/userdel
128Requires(pre): /bin/id
129Requires(pre): /usr/bin/getgid
130Requires(pre): /usr/sbin/groupadd
131Requires(pre): /usr/sbin/useradd
132Provides: group(eventum)
133Provides: user(eventum)
134
135%description base
136This package contains base directory structure for Eventum.
137
138%description base -l pl.UTF-8
139Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
140
141%package setup
142Summary: Eventum setup package
143Summary(pl.UTF-8): Pakiet do wstępnej konfiguracji Eventum
144Group: Applications/WWW
145Requires: %{name} = %{version}-%{release}
146
147%description setup
148Install this package to configure initial Eventum installation. You
149should uninstall this package when you're done, as it considered
150insecure to keep the setup files in place.
151
152%description setup -l pl.UTF-8
153Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
154pierwszej instalacji. Potem należy go odinstalować, jako że
155pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
156
157%package mail-queue
158Summary: Eventum mail queue process
159Summary(pl.UTF-8): Przetwarzanie kolejki poczty Eventum
160Group: Applications/WWW
161Requires: %{name} = %{version}-%{release}
162Requires: crondaemon
163
164%description mail-queue
165Beginning with the first release of Eventum, emails are not directly
166sent out from the various scripts, but rather added to a mail queue
167table that is processed by a cron job. If an email cannot be sent, it
168will be marked as such in the mail queue log, and the cron job script
169will re-try to send it again the next time it runs.
170
171This package contains the cron job.
172
173%description mail-queue -l pl.UTF-8
174Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
175różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
176Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
177kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
178następnym razem.
179
180Ten pakiet zawiera zadanie dla crona.
181
182%package mail-download
183Summary: Eventum email download
184Summary(pl.UTF-8): Ściąganie poczty Eventum
185Group: Applications/WWW
186Requires: %{name} = %{version}-%{release}
187Requires: crondaemon
188
189%description mail-download
190In order for Eventum's email integration feature to work, you need to
191setup a cron job to run the script every so often.
192
193This package contains the cron job.
194
195%description mail-download -l pl.UTF-8
196Aby integracja poczty elektronicznej w Eventum działała, trzeba
197ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
198często.
199
200Ten pakiet zawiera zadanie dla crona.
201
202%package reminder
203Summary: Eventum Reminder System
204Summary(pl.UTF-8): System przypominania dla Eventum
205Group: Applications/WWW
206Requires: %{name} = %{version}-%{release}
207Requires: crondaemon
208
209%description reminder
210The reminder system was designed with the objective as serving as a
211safe net for issues that need attention. Depending on what
212configuration you create, you may have several reminders (or alerts)
213be sent out whenever an issue needs attention, for whatever parameter
214you may deem necessary.
215
216This package contains the cron job.
217
218%description reminder -l pl.UTF-8
219System przypominania został zaprojektowany tak, aby służył jako
220bezpieczna sieć dla spraw wymagających uwagi. W zależności od
221konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
222przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
223uważać za potrzebny.
224
225Ten pakiet zawiera zadanie dla crona.
226
227%package monitor
228Summary: Eventum Heartbeat Monitor
229Summary(pl.UTF-8): Monitor życia dla Eventum
230Group: Applications/WWW
231Requires: %{name} = %{version}-%{release}
232Requires: crondaemon
233Requires: php(posix)
234
235%description monitor
236The heartbeat monitor is a feature designed for the administrator that
237wants to be alerted whenever a common problem in Eventum is detected,
238like the database server not being available anymore, or maybe when
239the recommended permissions for certain configuration files are
240changed.
241
242Please note that before running the heartbeat monitor, you may need to
243customize some of the checks to be appropriate for your own system,
244particularly the permission and file checks on
245Monitor::checkConfiguration().
246
247This package contains the cron job.
248
249%description monitor -l pl.UTF-8
250Monitor życia to funkcjonalność zaprojektowana dla administratora
251chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
252Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
253do plików konfiguracyjnych.
254
255Należy zauważyć, że przed uruchomieniem tego monitora może być
256konieczne dostosowanie niektórych testów do systemu, w szczególności
257testów uprawnień i plików w Monitor::checkConfiguration().
258
259Ten pakiet zawiera zadanie dla crona.
260
261%package route-drafts
262Summary: Eventum Draft Routing
263Summary(pl.UTF-8): Przekazywanie szkiców dla Eventum
264Group: Applications/WWW
265Requires: %{name} = %{version}-%{release}
266Requires: eventum(router)
267
268%description route-drafts
269The draft routing feature is used to automatically associate a thread
270of drafts into an Eventum issue. By setting up Postfix to deliver
271emails sent to a specific address (usually draft-<number>@<domain>) to
272the above script, users are able to send drafts written in their mail
273client to be stored in Eventum. These drafts will NOT broadcasted to
274the notification list.
275
276%description route-drafts -l pl.UTF-8
277Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
278problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
279wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
280skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
281kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
282na listę powiadomień.
283
284%package route-emails
285Summary: Eventum Email Routing
286Summary(pl.UTF-8): Przekazywanie poczty dla Eventum
287Group: Applications/WWW
288Requires: %{name} = %{version}-%{release}
289Requires: eventum(router)
290
291%description route-emails
292The email routing feature is used to automatically associate a thread
293of emails into an Eventum issue. By setting up Postfix to deliver
294emails sent to a specific address (usually issue-<number>@<domain>) to
295the above script, users are able to use their email clients to reply
296to emails coming from Eventum, and those replies will be automatically
297associated with the issue and broadcasted to the entire notification
298list.
299
300%description route-emails -l pl.UTF-8
301Funkcjonalność przekazywania poczty służy do automatycznego wiązania
302wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
303aby dostarczał listy wysyłane na pewien adres (zwykle
304issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
305używać klientów pocztowych do odpowiadania na listy przychodzące z
306Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
307rozprowadzane do całej listy ogłoszeniowej.
308
309%package route-notes
310Summary: Eventum Note Routing
311Summary(pl.UTF-8): Przekazywanie notatek dla Eventum
312Group: Applications/WWW
313Requires: %{name} = %{version}-%{release}
314Requires: eventum(router)
315
316%description route-notes
317The note routing feature is used to automatically associate a thread
318of notes into an Eventum issue. By setting up Postfix to deliver
319emails sent to a specific address (usually note-<number>@<domain>) to
320the above script, users are able to use their email clients to reply
321to internal notes coming from Eventum, and those replies will be
322automatically associated with the issue and broadcasted to the
323notification list staff members.
324
325%description route-notes -l pl.UTF-8
326Funkcjonalność przekazywania notatek służy do automatycznego wiązania
327wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
328dostarczał listy wysyłane na pewien adres (zwykle
329note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
330używać klientów pocztowych do odpowiadania na wewnętrzne notatki
331pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
332sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
333
334%package router-postfix
335Summary: Eventum Mail Routing - Postfix
336Summary(pl.UTF-8): Przekazywanie poczty Eventum - Postfix
337Group: Applications/Mail
338Requires: %{name} = %{version}-%{release}
339Requires: postfix
340Provides: eventum(router)
341Obsoletes: eventum(router)
342
343%description router-postfix
344This package provides way of routing notes and emails back to Eventum
345via Postfix.
346
347The Postfix configuration instructions you can find from
348<http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
349
350%description router-postfix -l pl.UTF-8
351Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
352przez Postfiksa.
353
354Opis konfiguracji Postfiksa można znaleźć pod adresem
355<http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
356
357%package irc
358Summary: Eventum IRC Notification Bot
359Summary(pl.UTF-8): IRC-owy bot powiadamiający dla Eventum
360Group: Applications/WWW
361Requires(post,preun): /sbin/chkconfig
362Requires: %{name} = %{version}-%{release}
363Requires: php(sockets)
364Requires: php-pear-Net_SmartIRC
365Requires: rc-scripts >= 0.4.0.18
366
367%description irc
368The IRC notification bot is a nice feature for remote teams that want
369to handle issues and want to have a quick and easy way to get simple
370notifications. Right now the bot notifies of the following actions:
371- New Issues
372- Blocked emails
373- Issues that got their assignment list changed
374
375NOTE: You will need to manually edit the bot.php script to set your
376appropriate preferences, like IRC server and channel that the bot
377should join.
378
379%description irc -l pl.UTF-8
380IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
381zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
382uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
383następujących zdarzeniach:
384- nowych sprawach
385- zablokowanych listach
386- sprawach, dla których zmieniła się lista powiązań
387
388UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
389kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
390
391%package cli
392Summary: Eventum command-line interface
393Summary(pl.UTF-8): Interfejs linii poleceń dla Eventum
394Group: Applications/WWW
395Requires: %{name}-base = %{version}-%{release}
396Requires: php(core) >= %{php_min_version}
397Requires: php(phar)
398Requires: php-pear-XML_RPC
399
400%description cli
401The Eventum command-line interface allows you to access most of the
402features of the web interface straight from your command shell.
403
404%description cli -l pl.UTF-8
405Interfejs linii poleceń Eventum pozwala na dostęp do większości
406funkcji interfejsu WWW prosto z linii poleceń powłoki.
407
408%package scm
409Summary: Eventum SCM integration
410Summary(pl.UTF-8): Integracja SCM dla Eventum
411Group: Applications/WWW
412Requires: php(core) >= %{php_min_version}
413Requires: php(json)
414Requires: php(pcre)
415Requires: php(spl)
416Suggests: cvs
417Suggests: git-core
418Suggests: php(openssl)
419Suggests: subversion
420
421%description scm
422This feature allows your software development teams to integrate your
423Source Control Management system with your Issue Tracking System.
424
425The integration is implemented in such a way that it will be forward
426compatible with pretty much any SCM system, such as CVS.
427
428For installation see
429</eventum/help.php?topic=scm_integration_installation>.
430
431%description scm -l pl.UTF-8
432Ten pakiet pozwala zespołom programistów na integrację systemu
433zarządzania źródłami (SCM - Source Control Management) z systemem
434śledzenia spraw.
435
436Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
437prawie każdym systemem SCM, jak np. CVS.
438
439Szczegóły na temat instalacji można przeczytać pod
440</eventum/help.php?topic=scm_integration_installation>.
441
442%package sphinx
443Summary: Eventum Sphinx Search
444Group: Applications/WWW
445Requires: %{name} = %{version}-%{release}
446Requires: crondaemon
447Requires: sphinx
448
449%description sphinx
450Sphinx search integration for Eventum.
451
452This package contains the cron job.
453
454%prep
455%setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
456
457mv docs/examples .
458
459# GPL v2
460rm docs/COPYING
461
462# bug fixes / features
463#%patch0 -p1
464%{?with_order:%patch2 -p1}
465#%patch3 -p0
466#%patch4 -p1
467
468%{?with_order:cp -p %{SOURCE16} htdocs/images}
469
470#%patch200 -p1
471
472# produce default sphinx config
473# must be run before paths.patch
474%if 0
475cat <<'EOF' > config/config.php
476<?php
477define('APP_SQL_DBTYPE', 'mysql');
478define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
479define('APP_SQL_DBPORT', 3306);
480define('APP_SQL_DBNAME', 'eventum');
481define('APP_SQL_DBUSER', 'mysql');
482define('APP_SQL_DBPASS', '');
483define('APP_TABLE_PREFIX', 'eventum_');
484EOF
485php config/sphinx.conf.php > config/sphinx.conf
486rm -f config/config.php
487%endif
488
489# packaging
490%patch100 -p1
491%patch101 -p1
492%patch105 -p1
493%patch107 -p1
494
495%{__sed} -i -e "
496s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
497" upgrade/{*/,}*.php
498
499# remove backups from patching as we use globs to package files to buildroot
500find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
501
502%build
503%{__make} -C localization
504
505%install
506rm -rf $RPM_BUILD_ROOT
507install -d \
508 $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
509 $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
510 $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
511 $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
512 $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
513 $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
514 $RPM_BUILD_ROOT%{systemdtmpfilesdir}
515
516%{__make} install-eventum install-cli install-irc install-scm install-localization \
517 sysconfdir=%{_webappdir} \
518 localedir=%{_localedir} \
519 DESTDIR=$RPM_BUILD_ROOT
520
521# unsupported locale
522%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
523
524install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
525cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
526
527%{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
528
529touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
530cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
531cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
532cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
533
534install -d $RPM_BUILD_ROOT/etc/sphinx
535#cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
536cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
537
538cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
539cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
540cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
541cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
542cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
543
544cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
545
546install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
547cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
548
549cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
550
551# postfix router
552install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
553
554cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
555
556%find_lang %{name}
557
558# scm
559cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
560
561%clean
562rm -rf $RPM_BUILD_ROOT
563
564%pre
565%addusertogroup http %{name}
566
567%post
568# greate empty ghost files
569for a in cli.log errors.log irc_bot.log login_attempts.log; do
570 if [ ! -f /var/log/%{name}/$a ]; then
571 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
572 fi
573done
574
575# run database update if configured
576test -s %{_webappdir}/config.php && \
577%{_appdir}/upgrade/update-database.php || :
578
579# nuke Smarty templates cache after upgrade
580rm -f /var/cache/eventum/*.php
581
582# Restart webserver on upgrade to get .mo translations reloaded.
583# actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
584%php_webserver_restart
585
586%preun
587if [ "$1" = "0" ]; then
588 # nuke cache
589 rm -f /var/cache/eventum/*.php 2>/dev/null || :
590fi
591
592%pre base
593%groupadd -P %{name}-base -g 146 %{name}
594%useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
595
596%postun base
597if [ "$1" = "0" ]; then
598 %userremove %{name}
599 %groupremove %{name}
600fi
601
602%post setup
603chmod 660 %{_webappdir}/{config,private_key}.php
604chown root:http %{_webappdir}/{config,private_key}.php
605
606%postun setup
607if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
608 chmod 640 %{_webappdir}/{config,private_key}.php
609 chown root:http %{_webappdir}/{config,private_key}.php
610fi
611
612%post irc
613/sbin/chkconfig --add eventum-irc
614%service eventum-irc restart "Eventum IRC Bot"
615
616%preun irc
617if [ "$1" = 0 ]; then
618 %service eventum-irc stop
619 /sbin/chkconfig --del eventum-irc
620fi
621
622%triggerin -- apache1 < 1.3.37-3, apache1-base
623%webapp_register apache %{_webapp}
624
625%triggerun -- apache1 < 1.3.37-3, apache1-base
626%webapp_unregister apache %{_webapp}
627
628%triggerin -- apache < 2.2.0, apache-base
629%webapp_register httpd %{_webapp}
630
631%triggerun -- apache < 2.2.0, apache-base
632%webapp_unregister httpd %{_webapp}
633
634%triggerin -- lighttpd
635%webapp_register lighttpd %{_webapp}
636
637%triggerun -- lighttpd
638%webapp_unregister lighttpd %{_webapp}
639
640%triggerpostun -- %{name} < 3.0.0-0.2
641for f in /etc/cron.d/eventum-*; do
642 # crontabs moved to bin
643 %{__sed} -i -e '
644 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
645 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
646 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
647 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
648 ' $f
649done
650
651%files -f %{name}.lang
652%defattr(644,root,root,755)
653%doc docs/*
654%attr(751,root,root) %dir %{_webappdir}
655%attr(751,root,root) %dir %{_webappdir}/custom_field
656%attr(751,root,root) %dir %{_webappdir}/templates
657%attr(751,root,root) %dir %{_webappdir}/workflow
658%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
659%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
660%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
661%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
662%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
663%attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
664%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
665
666%dir %attr(731,root,http) /var/log/%{name}
667%attr(620,root,http) %ghost /var/log/%{name}/*
668%dir %attr(750,root,root) /var/log/archive/%{name}
669%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
670
671%dir %{_appdir}/bin
672%attr(755,root,root) %{_appdir}/bin/process_all_emails.php
673
674%{_appdir}/autoload.php
675%{_appdir}/init.php
676%dir %{_appdir}/htdocs
677%{_appdir}/htdocs/*.php
678%{_appdir}/htdocs/*.ico
679%{_appdir}/htdocs/ajax
680%{_appdir}/htdocs/css
681%{_appdir}/htdocs/customer
682%{_appdir}/htdocs/images
683%{_appdir}/htdocs/js
684%{_appdir}/htdocs/manage
685%{_appdir}/htdocs/misc
686%{_appdir}/htdocs/reports
687%{_appdir}/htdocs/rpc
688%{_appdir}/htdocs/components
689%{_appdir}/templates
690
691%dir %{_appdir}/upgrade
692%{_appdir}/upgrade/flush_compiled_templates.php
693%{_appdir}/upgrade/*.sql
694%attr(755,root,root) %{_appdir}/upgrade/update-database.php
695%attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
696%attr(755,root,root) %{_appdir}/upgrade/ldap_update_users.php
697%attr(755,root,root) %{_appdir}/upgrade/scm_trac_import.php
698%{_appdir}/upgrade/patches
699
700%dir %{_appdir}/lib
701%{_appdir}/lib/eventum
702%exclude %{_appdir}/lib/eventum/class.monitor.php
703
704%{_examplesdir}/%{name}-%{version}
705
706%{systemdtmpfilesdir}/%{name}.conf
707%dir %attr(730,root,http) /var/run/%{name}
708%dir %attr(730,root,http) /var/cache/%{name}
709
710%files base
711%defattr(644,root,root,755)
712%attr(751,root,root) %dir %{_sysconfdir}
713%dir %{_libdir}
714%dir %{_appdir}
715%dir /var/lib/%{name}
716# saved mail copies
717%attr(770,root,http) %dir /var/lib/%{name}/routed_emails
718%attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
719%attr(770,root,http) %dir /var/lib/%{name}/routed_notes
720
721%files setup
722%defattr(644,root,root,755)
723%{_appdir}/htdocs/setup
724
725%files mail-queue
726%defattr(644,root,root,755)
727%attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
728%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
729
730%files mail-download
731%defattr(644,root,root,755)
732%attr(755,root,root) %{_appdir}/bin/download_emails.php
733%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
734
735%files reminder
736%defattr(644,root,root,755)
737%attr(755,root,root) %{_appdir}/bin/check_reminders.php
738%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
739
740%files monitor
741%defattr(644,root,root,755)
742%{_appdir}/lib/eventum/class.monitor.php
743%attr(755,root,root) %{_appdir}/bin/monitor.php
744%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
745
746%files route-drafts
747%defattr(644,root,root,755)
748%attr(755,root,root) %{_appdir}/bin/route_drafts.php
749
750%files route-emails
751%defattr(644,root,root,755)
752%attr(755,root,root) %{_appdir}/bin/route_emails.php
753
754%files route-notes
755%defattr(644,root,root,755)
756%attr(755,root,root) %{_appdir}/bin/route_notes.php
757
758%files router-postfix
759%defattr(644,root,root,755)
760%attr(755,root,root) %{_libdir}/router-postfix
761
762%files irc
763%defattr(644,root,root,755)
764%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
765%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
766%attr(755,root,root) %{_sbindir}/%{name}-irc-bot
767%attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
768
769%files cli
770%defattr(644,root,root,755)
771%doc cli/eventumrc
772%attr(755,root,root) %{_bindir}/%{name}
773
774%files scm
775%defattr(644,root,root,755)
776%attr(751,root,root) %dir %{_sysconfdir}
777%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
778%attr(755,root,root) %{_sbindir}/eventum-cvs-hook
779%attr(755,root,root) %{_sbindir}/eventum-git-hook
780%attr(755,root,root) %{_sbindir}/eventum-svn-hook
781%attr(755,root,root) %{_sbindir}/helpers.php
782
783%files sphinx
784%defattr(644,root,root,755)
785%{_webappdir}/sphinx.conf.php
786#%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
787%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.294383 seconds and 4 git commands to generate.