]> git.pld-linux.org Git - packages/eventum.git/blame_incremental - eventum.spec
- up to r4371
[packages/eventum.git] / eventum.spec
... / ...
CommitLineData
1# TODO
2# - discard bundled packages (from INSTALL):
3# - JpGraph 1.5.3 (last GPL version)
4# - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5# - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6# - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7# - A few other small javascript libraries
8#
9# Conditional build:
10%bcond_without order # with experimental order patch
11
12%define php_min_version 5.1.2
13%define subver 4371
14%define rel 1
15%include /usr/lib/rpm/macros.php
16Summary: Eventum Issue / Bug tracking system
17Summary(pl.UTF-8): Eventum - system śledzenia spraw/błędów
18Name: eventum
19Version: 2.3.1
20#Release: %{rel}
21Release: %{rel}.bzr%{subver}
22License: GPL
23Group: Applications/WWW
24#Source0: http://launchpad.net/eventum/trunk/%{version}/+download/%{name}-%{version}.tar.gz
25Source0: %{name}-%{version}-dev-r%{subver}.tar.gz
26# Source0-md5: 2462dc71b438a4fc4fd1369c69f8fba1
27Source1: %{name}-apache.conf
28Source2: %{name}-mail-queue.cron
29Source3: %{name}-mail-download.cron
30Source4: %{name}-reminder.cron
31Source5: %{name}-monitor.cron
32Source6: %{name}-cvs.php
33Source7: %{name}-irc.php
34Source8: %{name}-irc.init
35Source9: %{name}-irc.sysconfig
36Source13: %{name}-router-postfix.sh
37Source14: %{name}.logrotate
38Source15: %{name}-lighttpd.conf
39Source16: http://www.isocra.com/images/updown2.gif
40# Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
41Patch0: %{name}-lf.patch
42Patch2: %{name}-order.patch
43Patch3: group-users.patch
44# packaging patches that probably never go upstream
45Patch100: %{name}-paths.patch
46Patch101: %{name}-cvs-config.patch
47Patch105: %{name}-bot-reconnect.patch
48Patch107: %{name}-gettext.patch
49# some tests
50Patch200: %{name}-fixed-nav.patch
51URL: http://eventum.mysql.org/
52BuildRequires: gettext-devel
53BuildRequires: rpm-php-pearprov >= 4.0.2-98
54BuildRequires: rpmbuild(macros) >= 1.461
55BuildRequires: sed >= 4.0
56Requires: %{name}-base = %{version}-%{release}
57Requires: Smarty >= 2.6.10-4
58Requires: php-common >= 4:%{php_min_version}
59Requires: php-filter
60Requires: php-gd
61Requires: php-iconv
62Requires: php-imap
63Requires: php-mbstring
64Requires: php-mysql
65Requires: php-pcre
66Requires: php-pear-DB
67Requires: php-pear-Date
68Requires: php-pear-Mail
69Requires: php-pear-Mail_Mime
70Requires: php-pear-Mail_mimeDecode
71Requires: php-pear-Math_Stats
72Requires: php-pear-Net_DIME
73Requires: php-pear-Net_SMTP
74Requires: php-pear-Net_Socket
75Requires: php-pear-Net_URL
76Requires: php-pear-Net_UserAgent_Detect
77Requires: php-pear-PEAR-core
78Requires: php-pear-Text_Diff
79Requires: php-pear-XML_RPC
80Requires: php-session
81Requires: smarty-gettext
82Requires: webapps
83Requires: webserver(access)
84Requires: webserver(alias)
85Requires: webserver(indexfile)
86Requires: webserver(php) >= 4.2.0
87Suggests: localedb
88Conflicts: logrotate < 3.7-4
89BuildArch: noarch
90BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92%define _noautopear pear(../init.php) pear(init.php) pear(/etc/webapps/.*) pear(%{_appdir}/.*) pear(jpgraph_dir.php) pear(.*Smarty.class.php) pear(Services/JSON.php) pear(class.date_helper.php)
93
94# exclude optional php dependencies
95%define _noautophp php-gnupg php-hash php-pecl-http php-json php-tk
96
97%define _noautoreq %{_noautophp} %{_noautopear}
98
99%define _libdir %{_prefix}/lib/%{name}
100%define _appdir %{_datadir}/%{name}
101%define _smartydir %{php_data_dir}/Smarty
102%define _webapps /etc/webapps
103%define _webapp %{name}
104%define _webappdir %{_webapps}/%{_webapp}
105%define _sysconfdir /etc/%{name}
106
107%description
108Eventum is a user-friendly and flexible issue tracking system that can
109be used by a support department to track incoming technical support
110requests, or by a software development team to quickly organize tasks
111and bugs. Eventum is used by the MySQL AB Technical Support team, and
112has allowed us to dramatically improve our response times.
113
114%description -l pl.UTF-8
115Eventum to przyjazny dla użytkownika system śledzenia spraw, który
116może być używany przez dział obsługi do śledzenia przychodzących żądań
117obsługi technicznej albo przez zespół tworzący oprogramowanie do
118szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
119Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
120reakcji.
121
122%package base
123Summary: Eventum base package
124Summary(pl.UTF-8): Podstawowy pakiet Eventum
125Group: Applications/WWW
126Requires(postun): /usr/sbin/groupdel
127Requires(postun): /usr/sbin/userdel
128Requires(pre): /bin/id
129Requires(pre): /usr/bin/getgid
130Requires(pre): /usr/sbin/groupadd
131Requires(pre): /usr/sbin/useradd
132Provides: group(eventum)
133Provides: user(eventum)
134
135%description base
136This package contains base directory structure for Eventum.
137
138%description base -l pl.UTF-8
139Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
140
141%package setup
142Summary: Eventum setup package
143Summary(pl.UTF-8): Pakiet do wstępnej konfiguracji Eventum
144Group: Applications/WWW
145Requires: %{name} = %{version}-%{release}
146
147%description setup
148Install this package to configure initial Eventum installation. You
149should uninstall this package when you're done, as it considered
150insecure to keep the setup files in place.
151
152%description setup -l pl.UTF-8
153Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
154pierwszej instalacji. Potem należy go odinstalować, jako że
155pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
156
157%package mail-queue
158Summary: Eventum mail queue process
159Summary(pl.UTF-8): Przetwarzanie kolejki poczty Eventum
160Group: Applications/WWW
161Requires: %{name} = %{version}-%{release}
162Requires: crondaemon
163
164%description mail-queue
165Beginning with the first release of Eventum, emails are not directly
166sent out from the various scripts, but rather added to a mail queue
167table that is processed by a cron job. If an email cannot be sent, it
168will be marked as such in the mail queue log, and the cron job script
169will re-try to send it again the next time it runs.
170
171This package contains the cron job.
172
173%description mail-queue -l pl.UTF-8
174Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
175różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
176Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
177kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
178następnym razem.
179
180Ten pakiet zawiera zadanie dla crona.
181
182%package mail-download
183Summary: Eventum email download
184Summary(pl.UTF-8): Ściąganie poczty Eventum
185Group: Applications/WWW
186Requires: %{name} = %{version}-%{release}
187Requires: crondaemon
188
189%description mail-download
190In order for Eventum's email integration feature to work, you need to
191setup a cron job to run the script every so often.
192
193This package contains the cron job.
194
195%description mail-download -l pl.UTF-8
196Aby integracja poczty elektronicznej w Eventum działała, trzeba
197ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
198często.
199
200Ten pakiet zawiera zadanie dla crona.
201
202%package reminder
203Summary: Eventum Reminder System
204Summary(pl.UTF-8): System przypominania dla Eventum
205Group: Applications/WWW
206Requires: %{name} = %{version}-%{release}
207Requires: crondaemon
208
209%description reminder
210The reminder system was designed with the objective as serving as a
211safe net for issues that need attention. Depending on what
212configuration you create, you may have several reminders (or alerts)
213be sent out whenever an issue needs attention, for whatever parameter
214you may deem necessary.
215
216This package contains the cron job.
217
218%description reminder -l pl.UTF-8
219System przypominania został zaprojektowany tak, aby służył jako
220bezpieczna sieć dla spraw wymagających uwagi. W zależności od
221konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
222przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
223uważać za potrzebny.
224
225Ten pakiet zawiera zadanie dla crona.
226
227%package monitor
228Summary: Eventum Heartbeat Monitor
229Summary(pl.UTF-8): Monitor życia dla Eventum
230Group: Applications/WWW
231Requires: %{name} = %{version}-%{release}
232Requires: crondaemon
233Requires: php(posix)
234
235%description monitor
236The heartbeat monitor is a feature designed for the administrator that
237wants to be alerted whenever a common problem in Eventum is detected,
238like the database server not being available anymore, or maybe when
239the recommended permissions for certain configuration files are
240changed.
241
242Please note that before running the heartbeat monitor, you may need to
243customize some of the checks to be appropriate for your own system,
244particularly the permission and file checks on
245Monitor::checkConfiguration().
246
247This package contains the cron job.
248
249%description monitor -l pl.UTF-8
250Monitor życia to funkcjonalność zaprojektowana dla administratora
251chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
252Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
253do plików konfiguracyjnych.
254
255Należy zauważyć, że przed uruchomieniem tego monitora może być
256konieczne dostosowanie niektórych testów do systemu, w szczególności
257testów uprawnień i plików w Monitor::checkConfiguration().
258
259Ten pakiet zawiera zadanie dla crona.
260
261%package route-drafts
262Summary: Eventum Draft Routing
263Summary(pl.UTF-8): Przekazywanie szkiców dla Eventum
264Group: Applications/WWW
265Requires: %{name} = %{version}-%{release}
266Requires: eventum(router)
267
268%description route-drafts
269The draft routing feature is used to automatically associate a thread
270of drafts into an Eventum issue. By setting up Postfix to deliver
271emails sent to a specific address (usually draft-<number>@<domain>) to
272the above script, users are able to send drafts written in their mail
273client to be stored in Eventum. These drafts will NOT broadcasted to
274the notification list.
275
276%description route-drafts -l pl.UTF-8
277Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
278problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
279wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
280skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
281kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
282na listę powiadomień.
283
284%package route-emails
285Summary: Eventum Email Routing
286Summary(pl.UTF-8): Przekazywanie poczty dla Eventum
287Group: Applications/WWW
288Requires: %{name} = %{version}-%{release}
289Requires: eventum(router)
290
291%description route-emails
292The email routing feature is used to automatically associate a thread
293of emails into an Eventum issue. By setting up Postfix to deliver
294emails sent to a specific address (usually issue-<number>@<domain>) to
295the above script, users are able to use their email clients to reply
296to emails coming from Eventum, and those replies will be automatically
297associated with the issue and broadcasted to the entire notification
298list.
299
300%description route-emails -l pl.UTF-8
301Funkcjonalność przekazywania poczty służy do automatycznego wiązania
302wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
303aby dostarczał listy wysyłane na pewien adres (zwykle
304issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
305używać klientów pocztowych do odpowiadania na listy przychodzące z
306Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
307rozprowadzane do całej listy ogłoszeniowej.
308
309%package route-notes
310Summary: Eventum Note Routing
311Summary(pl.UTF-8): Przekazywanie notatek dla Eventum
312Group: Applications/WWW
313Requires: %{name} = %{version}-%{release}
314Requires: eventum(router)
315
316%description route-notes
317The note routing feature is used to automatically associate a thread
318of notes into an Eventum issue. By setting up Postfix to deliver
319emails sent to a specific address (usually note-<number>@<domain>) to
320the above script, users are able to use their email clients to reply
321to internal notes coming from Eventum, and those replies will be
322automatically associated with the issue and broadcasted to the
323notification list staff members.
324
325%description route-notes -l pl.UTF-8
326Funkcjonalność przekazywania notatek służy do automatycznego wiązania
327wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
328dostarczał listy wysyłane na pewien adres (zwykle
329note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
330używać klientów pocztowych do odpowiadania na wewnętrzne notatki
331pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
332sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
333
334%package router-postfix
335Summary: Eventum Mail Routing - Postfix
336Summary(pl.UTF-8): Przekazywanie poczty Eventum - Postfix
337Group: Applications/Mail
338Requires: %{name} = %{version}-%{release}
339Requires: postfix
340Provides: eventum(router)
341Obsoletes: eventum(router)
342
343%description router-postfix
344This package provides way of routing notes and emails back to Eventum
345via Postfix.
346
347The Postfix configuration instructions you can find from
348<http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
349
350%description router-postfix -l pl.UTF-8
351Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
352przez Postfiksa.
353
354Opis konfiguracji Postfiksa można znaleźć pod adresem
355<http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
356
357%package irc
358Summary: Eventum IRC Notification Bot
359Summary(pl.UTF-8): IRC-owy bot powiadamiający dla Eventum
360Group: Applications/WWW
361Requires(post,preun): /sbin/chkconfig
362Requires: %{name} = %{version}-%{release}
363Requires: php(sockets)
364Requires: php-pear-Net_SmartIRC
365Requires: rc-scripts >= 0.4.0.18
366
367%description irc
368The IRC notification bot is a nice feature for remote teams that want
369to handle issues and want to have a quick and easy way to get simple
370notifications. Right now the bot notifies of the following actions:
371- New Issues
372- Blocked emails
373- Issues that got their assignment list changed
374
375NOTE: You will need to manually edit the bot.php script to set your
376appropriate preferences, like IRC server and channel that the bot
377should join.
378
379%description irc -l pl.UTF-8
380IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
381zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
382uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
383następujących zdarzeniach:
384- nowych sprawach
385- zablokowanych listach
386- sprawach, dla których zmieniła się lista powiązań
387
388UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
389kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
390
391%package cli
392Summary: Eventum command-line interface
393Summary(pl.UTF-8): Interfejs linii poleceń dla Eventum
394Group: Applications/WWW
395Requires: %{name}-base = %{version}-%{release}
396Requires: php-cli
397Requires: php-common >= 4:%{php_min_version}
398Requires: php-pear-XML_RPC
399
400%description cli
401The Eventum command-line interface allows you to access most of the
402features of the web interface straight from your command shell.
403
404%description cli -l pl.UTF-8
405Interfejs linii poleceń Eventum pozwala na dostęp do większości
406funkcji interfejsu WWW prosto z linii poleceń powłoki.
407
408%package scm
409Summary: Eventum SCM integration
410Summary(pl.UTF-8): Integracja SCM dla Eventum
411Group: Applications/WWW
412Requires: %{name}-base = %{version}-%{release}
413Requires: php-cli
414Requires: php-common >= 4:%{php_min_version}
415Requires: php-pcre
416
417%description scm
418This feature allows your software development teams to integrate your
419Source Control Management system with your Issue Tracking System.
420
421The integration is implemented in such a way that it will be forward
422compatible with pretty much any SCM system, such as CVS.
423
424For installation see
425</eventum/help.php?topic=scm_integration_installation>.
426
427%description scm -l pl.UTF-8
428Ten pakiet pozwala zespołom programistów na integrację systemu
429zarządzania źródłami (SCM - Source Control Management) z systemem
430śledzenia spraw.
431
432Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
433prawie każdym systemem SCM, jak np. CVS.
434
435Szczegóły na temat instalacji można przeczytać pod
436</eventum/help.php?topic=scm_integration_installation>.
437
438%prep
439%setup -q
440
441# GPL v2
442rm docs/COPYING
443
444rm -r upgrade/*v1.[123]* # too old to support in PLD Linux
445rm -r upgrade/v{1.,2.0,2.1_}* # no longer supported in PLD Linux
446rm upgrade/flush_compiled_templates.php
447rm -r upgrade/{*/,}index.html # not needed in PLD Linux
448
449# bug fixes / features
450%patch0 -p1
451%{?with_order:%patch2 -p1}
452%patch3 -p0
453
454cp -p %{SOURCE16} htdocs/images
455
456#%patch200 -p1
457
458# packaging
459%patch100 -p1
460%patch101 -p1
461%patch105 -p1
462%patch107 -p1
463
464%{__sed} -i -e "
465s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
466" upgrade/{*/,}*.php
467
468# remove backups from patching as we use globs to package files to buildroot
469find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
470
471%build
472%{__make} -C localization
473
474%install
475rm -rf $RPM_BUILD_ROOT
476install -d \
477 $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
478 $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
479 $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
480 $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
481 $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
482 $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
483
484%{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
485 sysconfdir=%{_webappdir} \
486 DESTDIR=$RPM_BUILD_ROOT
487
488%{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
489
490touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
491cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
492cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
493cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
494
495cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
496cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
497cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
498cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
499
500cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
501
502install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
503cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
504
505cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
506
507# postfix router
508install %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
509
510%{__rm} $RPM_BUILD_ROOT%{_datadir}/locale/ht
511
512%find_lang %{name}
513
514# scm
515install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
516
517# old compat
518ln -s %{_sbindir}/eventum-cvs-hook $RPM_BUILD_ROOT%{_libdir}/process_cvs_commits
519ln -s %{_sbindir}/eventum-svn-hook $RPM_BUILD_ROOT%{_libdir}/process_svn_commits
520
521# skip pear for cli
522rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
523cp -a cli/lib/eventum $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
524
525%clean
526rm -rf $RPM_BUILD_ROOT
527
528%pre
529%addusertogroup http %{name}
530
531%post
532# greate empty ghost files
533for a in cli.log errors.log irc_bot.log login_attempts.log; do
534 if [ ! -f /var/log/%{name}/$a ]; then
535 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
536 fi
537done
538
539# database update
540%{_appdir}/upgrade/update-database.php || :
541
542# nuke Smarty templates cache after upgrade
543rm -f /var/cache/eventum/*.php
544
545# Restart webserver on upgrade to get .mo translations reloaded.
546# actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
547%php_webserver_restart
548
549%preun
550if [ "$1" = "0" ]; then
551 # nuke cache
552 rm -f /var/cache/eventum/*.php 2>/dev/null || :
553fi
554
555%pre base
556%groupadd -P %{name}-base -g 146 %{name}
557%useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
558
559%postun base
560if [ "$1" = "0" ]; then
561 %userremove %{name}
562 %groupremove %{name}
563fi
564
565%post setup
566chmod 660 %{_webappdir}/{config,private_key}.php
567chown root:http %{_webappdir}/{config,private_key}.php
568
569%postun setup
570if [ "$1" = "0" ]; then
571 chmod 640 %{_webappdir}/{config,private_key}.php
572 chown root:http %{_webappdir}/{config,private_key}.php
573fi
574
575%post irc
576/sbin/chkconfig --add eventum-irc
577%service eventum-irc restart "Eventum IRC Bot"
578
579%preun irc
580if [ "$1" = 0 ]; then
581 %service eventum-irc stop
582 /sbin/chkconfig --del eventum-irc
583fi
584
585%triggerin -- apache1 < 1.3.37-3, apache1-base
586%webapp_register apache %{_webapp}
587
588%triggerun -- apache1 < 1.3.37-3, apache1-base
589%webapp_unregister apache %{_webapp}
590
591%triggerin -- apache < 2.2.0, apache-base
592%webapp_register httpd %{_webapp}
593
594%triggerun -- apache < 2.2.0, apache-base
595%webapp_unregister httpd %{_webapp}
596
597%triggerin -- lighttpd
598%webapp_register lighttpd %{_webapp}
599
600%triggerun -- lighttpd
601%webapp_unregister lighttpd %{_webapp}
602
603%triggerpostun -- %{name} < 2.2-2.57
604# switching eventum->http user
605chgrp http %{_webappdir}/config.php
606chgrp http %{_webappdir}/private_key.php
607chgrp http %{_webappdir}/setup.php
608chgrp http /var/log/%{name}/*
609# update crontab user
610for a in /etc/cron.d/eventum-*; do
611 [ -f "$a" ] || continue
612 awk '!/#/ && NR > 6 && $6 =="eventum" {sub("eventum", "http", $6)}{print}' $a > $a.rpmtmp && cat $a.rpmtmp > $a
613 rm -f $a.rpmtmp
614
615 # crontabs moved to crons subdir
616 %{__sed} -i -e '
617 s,/usr/share/eventum/process_mail_queue.php,/usr/share/eventum/crons/process_mail_queue.php,
618 s,/usr/share/eventum/download_emails.php,/usr/share/eventum/crons/download_emails.php,
619 s,/usr/share/eventum/check_reminders.php,/usr/share/eventum/crons/check_reminders.php,
620 s,/usr/share/eventum/monitor.php,/usr/share/eventum/crons/monitor.php,
621 ' $a
622done
623
624%files -f %{name}.lang
625%defattr(644,root,root,755)
626%doc docs/* htdocs/setup/schema.sql
627%attr(751,root,root) %dir %{_webappdir}
628%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
629%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
630%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
631%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
632%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
633%attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
634%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
635
636%dir %attr(731,root,http) /var/log/%{name}
637%attr(620,root,http) %ghost /var/log/%{name}/*
638%dir %attr(750,root,root) /var/log/archive/%{name}
639%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
640
641%dir %{_appdir}/crons
642%{_appdir}/init.php
643%dir %{_appdir}/htdocs
644%{_appdir}/htdocs/*.php
645%{_appdir}/htdocs/*.ico
646%{_appdir}/htdocs/css
647%{_appdir}/htdocs/customer
648%{_appdir}/htdocs/images
649%{_appdir}/htdocs/js
650%{_appdir}/htdocs/manage
651%{_appdir}/htdocs/reports
652%{_appdir}/htdocs/rpc
653%{_appdir}/htdocs/misc
654%if %{with order}
655%{_appdir}/htdocs/ajax
656%endif
657%{_appdir}/templates
658
659%dir %{_appdir}/upgrade
660%{_appdir}/upgrade/init.php
661%attr(755,root,root) %{_appdir}/upgrade/update-database.php
662%dir %{_appdir}/upgrade/v*
663%attr(755,root,root) %{_appdir}/upgrade/v*/*.php
664%{_appdir}/upgrade/patches
665
666%dir %{_appdir}/lib
667%{_appdir}/lib/eventum
668%{_appdir}/lib/jpgraph
669%exclude %{_appdir}/lib/eventum/class.monitor.php
670
671%dir %attr(730,root,http) /var/run/%{name}
672%dir %attr(730,root,http) /var/cache/%{name}
673
674%files base
675%defattr(644,root,root,755)
676%attr(751,root,root) %dir %{_sysconfdir}
677%dir %{_libdir}
678%dir %{_appdir}
679%dir /var/lib/%{name}
680# saved mail copies
681%attr(770,root,http) %dir /var/lib/%{name}/routed_emails
682%attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
683%attr(770,root,http) %dir /var/lib/%{name}/routed_notes
684
685%files setup
686%defattr(644,root,root,755)
687%{_appdir}/htdocs/setup
688
689%files mail-queue
690%defattr(644,root,root,755)
691%attr(755,root,root) %{_appdir}/crons/process_mail_queue.php
692%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
693
694%files mail-download
695%defattr(644,root,root,755)
696%attr(755,root,root) %{_appdir}/crons/download_emails.php
697%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
698
699%files reminder
700%defattr(644,root,root,755)
701%attr(755,root,root) %{_appdir}/crons/check_reminders.php
702%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
703
704%files monitor
705%defattr(644,root,root,755)
706%{_appdir}/lib/eventum/class.monitor.php
707%attr(755,root,root) %{_appdir}/crons/monitor.php
708%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
709
710%files route-drafts
711%defattr(644,root,root,755)
712%attr(755,root,root) %{_appdir}/route_drafts.php
713
714%files route-emails
715%defattr(644,root,root,755)
716%attr(755,root,root) %{_appdir}/route_emails.php
717
718%files route-notes
719%defattr(644,root,root,755)
720%attr(755,root,root) %{_appdir}/route_notes.php
721
722%files router-postfix
723%defattr(644,root,root,755)
724%attr(755,root,root) %{_libdir}/router-postfix
725
726%files irc
727%defattr(644,root,root,755)
728%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
729%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
730%attr(755,root,root) %{_sbindir}/%{name}-irc-bot
731%attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
732
733%files cli
734%defattr(644,root,root,755)
735%doc cli/eventumrc
736%attr(755,root,root) %{_bindir}/%{name}
737%{_appdir}/cli
738
739%files scm
740%defattr(644,root,root,755)
741%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
742%attr(755,root,root) %{_libdir}/process_cvs_commits
743%attr(755,root,root) %{_libdir}/process_svn_commits
744%attr(755,root,root) %{_sbindir}/eventum-cvs-hook
745%attr(755,root,root) %{_sbindir}/eventum-svn-hook
This page took 0.0695789999999999 seconds and 4 git commands to generate.