]> git.pld-linux.org Git - packages/evas.git/blobdiff - evas.spec
- up to 0.9.9.024
[packages/evas.git] / evas.spec
index 57dd704e61d5f1680284f695e674ac0e8ffa9428..b4816d989b639c26a6c4e80f28c3c6324db03f8e 100644 (file)
--- a/evas.spec
+++ b/evas.spec
@@ -1,12 +1,15 @@
 #
+# Conditional build:
 %bcond_without mmx             # without MMX and MMX2
 %bcond_without sse             # without SSE
 %bcond_without altivec         # without altivec
+%bcond_without directfb        # build without DirectFB support
+%bcond_without static_libs     # don't build static library
 #
-%ifnarch i586 i686 athlon
+%ifnarch i586 i686 athlon %{x8664}
 %undefine      with_mmx
 %endif
-%ifnarch i686 athlon
+%ifnarch i686 athlon %{x8664}
 %undefine      with_sse
 %endif
 %ifnarch ppc
 Summary:       Multi-platform Canvas Library
 Summary(pl):   Wieloplatformowa biblioteka do rysowania
 Name:          evas
-Version:       0.9.9.010
-%define        _snap   20050706
-Release:       0.%{_snap}.0.1
+Version:       0.9.9.024
+Release:       1
 License:       BSD
 Group:         Libraries
-#Source0:      http://dl.sourceforge.net/enlightenment/%{name}-%{version}_%{_pre}.tar.gz
-Source0:       http://sparky.homelinux.org/snaps/enli/e17/libs/%{name}-%{_snap}.tar.gz
-# Source0-md5: a798480eacc9437d84ed12d64f789fc5
-URL:           http://enlightenment.org/
-BuildRequires: DirectFB-devel
+Source0:       http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
+# Source0-md5: e363ee32718b209b66a3e0bcb4215e14
+#Patch0:               %{name}-missing_m4.patch
+URL:           http://enlightenment.org/Libraries/Evas/
+%{?with_directfb:BuildRequires:        DirectFB-devel}
 BuildRequires: OpenGL-devel
 BuildRequires: autoconf
 BuildRequires: automake
@@ -36,9 +38,12 @@ BuildRequires:       libjpeg-devel
 BuildRequires: libpng-devel
 BuildRequires: libtool
 BuildRequires: pkgconfig
+Requires:      %{name}-libs = %{version}-%{release}
 Requires:      fonts-TTF-bitstream-vera
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%undefine      __cxx
+
 %description
 Evas is a clean display canvas API for several target display systems
 that can draw anti-aliased text, smooth super and sub-sampled scaled
@@ -49,12 +54,23 @@ Evas to czyste API "p
 bêd±ce w stanie rysowaæ tekst z antyaliasingiem, wyg³adzane, skalowane
 obrazy, obiekty z alpha-blendingiem i inne elementy.
 
+%package libs
+Summary:       Evas library
+Summary(pl):   Biblioteka evas
+Group:         X11/Libraries
+
+%description libs
+Evas library.
+
+%description libs -l pl
+Biblioteka evas.
+
 %package devel
 Summary:       Evas header files
 Summary(pl):   Pliki nag³ówkowe Evas
 Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
-Requires:      DirectFB-devel
+Requires:      %{name}-libs = %{version}-%{release}
+%{?with_directfb:Requires:     DirectFB-devel}
 Requires:      OpenGL-devel
 Requires:      edb-devel
 Requires:      eet-devel
@@ -81,23 +97,25 @@ Static Evas library.
 Statyczna biblioteka Evas.
 
 %prep
-#%%setup -q -n %{name}-%{version}_%{_pre}
-%setup -q -n %{name}
+%setup -q
+#%%patch0 -p1
 
 %build
-%{__libtoolize}
-%{__aclocal} -I m4
-%{__autoconf}
-%{__autoheader}
-%{__automake}
+#%%{__libtoolize}
+#%%{__aclocal}
+#%%{__autoconf}
+#%%{__autoheader}
+#%%{__automake}
 %configure \
+       %{!?with_static_libs:--disable-static} \
        --enable-software-x11   \
        --disable-software-xcb  \
-       --enable-direct-fb      \
+       --%{?with_directfb:en}%{!?with_directfb:dis}able-directfb       \
        --enable-fb             \
        --enable-buffer         \
        --disable-software-qtopia \
        --enable-gl-x11         \
+       --enable-xrender-x11    \
        --enable-image-loader-png       \
        --enable-image-loader-jpeg      \
        --enable-image-loader-eet       \
@@ -118,7 +136,8 @@ Statyczna biblioteka Evas.
 %else
        --disable-cpu-altivec   \
 %endif
-       --enable-cpu-c
+       --enable-cpu-c          \
+       --disable-valgrind
 
 %{__make}
 
@@ -138,16 +157,25 @@ done
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post   -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+%post  libs -p /sbin/ldconfig
+%postun        libs -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS COPYING COPYING-PLAIN INSTALL README
 %attr(755,root,root) %{_bindir}/evas_*
-%attr(755,root,root) %{_libdir}/libevas.so.*.*.*
 %{_datadir}/%{name}
 
+%files libs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libevas.so.*.*.*
+%dir %{_libdir}/%{name}
+%dir %{_libdir}/%{name}/modules
+%dir %{_libdir}/%{name}/modules/*
+%dir %{_libdir}/%{name}/modules/*/*
+%dir %{_libdir}/%{name}/modules/*/*/linux-gnu-*
+%attr(755,root,root) %{_libdir}/%{name}/modules/*/*/linux-gnu-*/module.so
+
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/evas-config
@@ -156,6 +184,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_pkgconfigdir}/evas.pc
 %{_includedir}/Evas*
 
+%if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libevas.a
+%endif
This page took 0.150494 seconds and 4 git commands to generate.