]> git.pld-linux.org Git - packages/evas.git/blobdiff - evas.spec
- updated to 0.9.9.019
[packages/evas.git] / evas.spec
index 32bb5a0f135f98ec6ca1814d5780ebf6a31c017a..6632ede12784761d84543a09c528ea4d246ad669 100644 (file)
--- a/evas.spec
+++ b/evas.spec
@@ -1,27 +1,41 @@
+#
+%bcond_without mmx             # without MMX and MMX2
+%bcond_without sse             # without SSE
+%bcond_without altivec         # without altivec
+#
+%ifnarch i586 i686 athlon
+%undefine      with_mmx
+%endif
+%ifnarch i686 athlon
+%undefine      with_sse
+%endif
+%ifnarch ppc
+%undefine      with_altivec
+%endif
+#
 Summary:       Multi-platform Canvas Library
 Summary(pl):   Wieloplatformowa biblioteka do rysowania
 Name:          evas
-Version:       1.0.0
-#%define _pre  pre13
-%define _snap  20050106
-Release:       0.%{_snap}.0.1
+Version:       0.9.9.019
+Release:       1
 License:       BSD
 Group:         Libraries
-#Source0:      http://dl.sourceforge.net/enlightenment/%{name}-%{version}_%{_pre}.tar.gz
-Source0:       ftp://ftp.sparky.homelinux.org/pub/e17/%{name}-%{version}-%{_snap}.tar.gz
-# Source0-md5: 90bf34e3e6aaedaaa20856b2b5bbf6ad
-URL:           http://enlightenment.org/
+Source0:       http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
+# Source0-md5: 1766c37200f2efb37076e302fd07517b
+Patch0:                %{name}-missing_m4.patch
+URL:           http://enlightenment.org/Libraries/Evas/
 BuildRequires: DirectFB-devel
 BuildRequires: OpenGL-devel
 BuildRequires: autoconf
 BuildRequires: automake
-#BuildRequires:        cairo-devel
 BuildRequires: edb-devel
 BuildRequires: eet-devel
 BuildRequires: freetype-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
 BuildRequires: libtool
+BuildRequires: pkgconfig
+Requires:      fonts-TTF-bitstream-vera
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -41,7 +55,6 @@ Group:                Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      DirectFB-devel
 Requires:      OpenGL-devel
-#Requires:     cairo-devel
 Requires:      edb-devel
 Requires:      eet-devel
 Requires:      freetype-devel
@@ -67,8 +80,8 @@ Static Evas library.
 Statyczna biblioteka Evas.
 
 %prep
-#%%setup -q -n %{name}-%{version}_%{_pre}
-%setup -q -n %{name}
+%setup -q
+%patch0 -p1
 
 %build
 %{__libtoolize}
@@ -77,10 +90,35 @@ Statyczna biblioteka Evas.
 %{__autoheader}
 %{__automake}
 %configure \
-       --disable-cairo-x11
-#/usr/lib/libcairo.so: undefined reference to `pixman_image_get_format'
-#/usr/lib/libcairo.so: undefined reference to `pixman_format_get_masks'
-# -- it looks like cairo problem, not evas; too  old libpixman?
+       --enable-software-x11   \
+       --disable-software-xcb  \
+       --enable-direct-fb      \
+       --enable-fb             \
+       --enable-buffer         \
+       --disable-software-qtopia \
+       --enable-gl-x11         \
+       --enable-image-loader-png       \
+       --enable-image-loader-jpeg      \
+       --enable-image-loader-eet       \
+       --enable-font-loader-eet        \
+       --enable-image-loader-edb       \
+%if %{with mmx}
+       --enable-cpu-mmx        \
+%else
+       --disable-cpu-mmx       \
+%endif
+%if %{with sse}
+       --enable-cpu-sse        \
+%else
+       --disable-cpu-sse       \
+%endif
+%if %{with altivec}
+       --enable-cpu-altivec    \
+%else
+       --disable-cpu-altivec   \
+%endif
+       --enable-cpu-c
+
 %{__make}
 
 %install
@@ -89,6 +127,13 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+cd $RPM_BUILD_ROOT%{_datadir}/%{name}
+VERA=$(ls Vera*.ttf)
+for FONT in $VERA; do
+       rm -f $FONT
+       ln -s %{_fontsdir}/TTF/$FONT .
+done
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -97,7 +142,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS README COPYING
+%doc AUTHORS COPYING COPYING-PLAIN INSTALL README
 %attr(755,root,root) %{_bindir}/evas_*
 %attr(755,root,root) %{_libdir}/libevas.so.*.*.*
 %{_datadir}/%{name}
This page took 0.051927 seconds and 4 git commands to generate.