]> git.pld-linux.org Git - packages/evas.git/blobdiff - evas.spec
- updated to 0.9.9.019
[packages/evas.git] / evas.spec
index 13f9b52c9494f7178199db2db98a0bb398571330..6632ede12784761d84543a09c528ea4d246ad669 100644 (file)
--- a/evas.spec
+++ b/evas.spec
@@ -1,26 +1,41 @@
+#
+%bcond_without mmx             # without MMX and MMX2
+%bcond_without sse             # without SSE
+%bcond_without altivec         # without altivec
+#
+%ifnarch i586 i686 athlon
+%undefine      with_mmx
+%endif
+%ifnarch i686 athlon
+%undefine      with_sse
+%endif
+%ifnarch ppc
+%undefine      with_altivec
+%endif
+#
 Summary:       Multi-platform Canvas Library
+Summary(pl):   Wieloplatformowa biblioteka do rysowania
 Name:          evas
-Version:       1.0.0
-#%define _pre  pre13
-%define _snap  20050106
-Release:       0.%{_snap}.0.1
+Version:       0.9.9.019
+Release:       1
 License:       BSD
 Group:         Libraries
-#Source0:      http://dl.sourceforge.net/enlightenment/%{name}-%{version}_%{_pre}.tar.gz
-Source0:       ftp://ftp.sparky.homelinux.org/pub/e17/%{name}-%{version}-%{_snap}.tar.gz
-# Source0-md5: 90bf34e3e6aaedaaa20856b2b5bbf6ad
-URL:           http://enlightenment.org/
+Source0:       http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
+# Source0-md5: 1766c37200f2efb37076e302fd07517b
+Patch0:                %{name}-missing_m4.patch
+URL:           http://enlightenment.org/Libraries/Evas/
+BuildRequires: DirectFB-devel
+BuildRequires: OpenGL-devel
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: DirectFB-devel
-BuildRequires: X11-OpenGL-devel
-#BuildRequires:        cairo-devel
 BuildRequires: edb-devel
 BuildRequires: eet-devel
 BuildRequires: freetype-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
 BuildRequires: libtool
+BuildRequires: pkgconfig
+Requires:      fonts-TTF-bitstream-vera
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -28,13 +43,18 @@ Evas is a clean display canvas API for several target display systems
 that can draw anti-aliased text, smooth super and sub-sampled scaled
 images, alpha-blend objects much and more.
 
+%description -l pl
+Evas to czyste API "p³ótna obrazu" dla ró¿nych systemów wy¶wietlania,
+bêd±ce w stanie rysowaæ tekst z antyaliasingiem, wyg³adzane, skalowane
+obrazy, obiekty z alpha-blendingiem i inne elementy.
+
 %package devel
-Summary:       Evas headers, documentation and test programs
+Summary:       Evas header files
+Summary(pl):   Pliki nag³ówkowe Evas
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 Requires:      DirectFB-devel
-Requires:      X11-OpenGL-devel
-#Requires:     cairo-devel
+Requires:      OpenGL-devel
 Requires:      edb-devel
 Requires:      eet-devel
 Requires:      freetype-devel
@@ -42,19 +62,26 @@ Requires:   libjpeg-devel
 Requires:      libpng-devel
 
 %description devel
-Headers, static libraries, test programs and documentation for Evas.
+Header files for Evas.
+
+%description devel -l pl
+Pliki nag³ówkowe Evas.
 
 %package static
-Summary:       Static libraries
+Summary:       Static Evas library
+Summary(pl):   Statyczna biblioteka Evas
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
-Static libraries for Evas.
+Static Evas library.
+
+%description static -l pl
+Statyczna biblioteka Evas.
 
 %prep
-#%%setup -q -n %{name}-%{version}_%{_pre}
-%setup -q -n %{name}
+%setup -q
+%patch0 -p1
 
 %build
 %{__libtoolize}
@@ -63,16 +90,50 @@ Static libraries for Evas.
 %{__autoheader}
 %{__automake}
 %configure \
-       --disable-cairo-x11
-#/usr/lib/libcairo.so: undefined reference to `pixman_image_get_format'
-#/usr/lib/libcairo.so: undefined reference to `pixman_format_get_masks'
+       --enable-software-x11   \
+       --disable-software-xcb  \
+       --enable-direct-fb      \
+       --enable-fb             \
+       --enable-buffer         \
+       --disable-software-qtopia \
+       --enable-gl-x11         \
+       --enable-image-loader-png       \
+       --enable-image-loader-jpeg      \
+       --enable-image-loader-eet       \
+       --enable-font-loader-eet        \
+       --enable-image-loader-edb       \
+%if %{with mmx}
+       --enable-cpu-mmx        \
+%else
+       --disable-cpu-mmx       \
+%endif
+%if %{with sse}
+       --enable-cpu-sse        \
+%else
+       --disable-cpu-sse       \
+%endif
+%if %{with altivec}
+       --enable-cpu-altivec    \
+%else
+       --disable-cpu-altivec   \
+%endif
+       --enable-cpu-c
+
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+cd $RPM_BUILD_ROOT%{_datadir}/%{name}
+VERA=$(ls Vera*.ttf)
+for FONT in $VERA; do
+       rm -f $FONT
+       ln -s %{_fontsdir}/TTF/$FONT .
+done
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -81,9 +142,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS README COPYING
-%attr(755,root,root) %{_libdir}/libevas.so.*
+%doc AUTHORS COPYING COPYING-PLAIN INSTALL README
 %attr(755,root,root) %{_bindir}/evas_*
+%attr(755,root,root) %{_libdir}/libevas.so.*.*.*
 %{_datadir}/%{name}
 
 %files devel
This page took 0.082235 seconds and 4 git commands to generate.