]> git.pld-linux.org Git - packages/euler.git/blob - euler.spec
- from scratch, STBR
[packages/euler.git] / euler.spec
1 %define         ver1    1.59
2 %define         ver2    1
3
4 Summary:        EULER, a program for doing mathematics on the computer
5 Summary(pl):    EULER, program dla obliczeñ patematycznych na komputerze
6 Name:           euler
7 Version:        %{ver1}.%{ver2}
8 Release:        1
9 License:        GPL
10 Group:          Applications/Math
11 Group(de):      Applikationen/Mathematik
12 Group(pl):      Aplikacje/Matematyczne
13 Source0:        http://prdownloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
14 URL:            http://euler.sourceforge.net/
15 BuildRequires:  gtk+-devel >= 1.2.0
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _prefix /usr/X11R6
19
20 %description
21 EULER is a program for quickly and interactively computing with real
22 and complex numbers and matrices, or with intervals, in the style of
23 MatLab, Octave,... It can draw and animate your functions in two and
24 three dimensions.
25
26 %prep
27 %setup -q -n %{name}-%{ver1}
28
29 %build
30 cd source
31 %{__make} \
32         CC="%{__cc} %{rpmcflags} -DINSTALL_DIR=\\\"%{_prefix}\\\""
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT{%{_datadir},%{_bindir}}
37 cd source
38 %{__make} install \
39         INSTALL_DIR=$RPM_BUILD_ROOT%{_prefix}
40 cd ..
41
42 rm -rf $RPM_BUILD_ROOT%{_datadir}/euler/docs
43 gzip -9nf README ChangeLog TODO
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %attr(755,root,root) %{_bindir}/*
51 %{_datadir}/euler
52 %doc docs/*
53 %doc *.gz
This page took 0.101482 seconds and 3 git commands to generate.