]> git.pld-linux.org Git - packages/ettercap.git/blob - ettercap.spec
- new URLs, updated to 0.8.3
[packages/ettercap.git] / ettercap.spec
1 #
2 # Conditional build:
3 %bcond_without  geoip   # GeoIP support
4 %bcond_without  gtk     # gtk-based frontend
5 %bcond_with     gtk2    # use GTK+ 2.x instead of 3.x
6 %bcond_with     lua     # experimental Lua support
7 #
8 Summary:        ettercap - a ncurses-based sniffer/interceptor utility
9 Summary(pl.UTF-8):      ettercap - oparte o ncurses narzędzie do sniffowania/przechwytywania
10 Summary(pt_BR.UTF-8):   ettercap e um interceptador/sniffer paseado em ncurses
11 Name:           ettercap
12 Version:        0.8.3
13 Release:        1
14 Epoch:          1
15 License:        GPL v2+ with OpenSSL exception
16 Group:          Networking/Utilities
17 #Source0Download: https://github.com/Ettercap/ettercap/releases
18 Source0:        https://github.com/Ettercap/ettercap/releases/download/v%{version}/%{name}-%{version}.tar.gz
19 # Source0-md5:  6b27d329a509e65fef9044c95a2dde35
20 Patch0:         %{name}-buildtype.patch
21 Patch1:         %{name}-gtk3.patch
22 Patch2:         %{name}-link.patch
23 URL:            https://www.ettercap-project.org/
24 %{?with_geoip:BuildRequires:    GeoIP-devel}
25 BuildRequires:  bison
26 BuildRequires:  cmake >= 2.8
27 BuildRequires:  curl-devel >= 7.26.0
28 BuildRequires:  flex
29 %if %{with gtk}
30 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.10}
31 %{!?with_gtk2:BuildRequires:    gtk+3-devel >= 3.12.0}
32 %endif
33 BuildRequires:  libbsd-devel
34 BuildRequires:  libnet-devel >= 1:1.1.5
35 BuildRequires:  libpcap-devel
36 %{?with_lua:BuildRequires:      luajit-devel >= 2.0.0}
37 BuildRequires:  ncurses-ext-devel
38 BuildRequires:  openssl-devel >= 0.9.7d
39 BuildRequires:  pcre-devel
40 BuildRequires:  pkgconfig
41 BuildRequires:  zlib-devel
42 Requires:       curl-libs >= 7.26.0
43 %if %{with gtk}
44 %{?with_gtk2:Requires:  gtk+2 >= 2:2.10}
45 %{!?with_gtk2:Requires: gtk+3 >= 3.12.0}
46 %endif
47 Requires:       libnet >= 1:1.1.5
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         specflags       -fomit-frame-pointer
51
52 %description
53 ettercap is a network sniffer/interceptor/logger for ethernet LANs
54 (both switched or not). It supports active and passive dissection of
55 many protocols (even ciphered ones, like SSH and HTTPS). Data
56 injection in an established connection and filtering (substitute or
57 drop a packet) on the fly is also possible, keeping the connection
58 synchronized. Many sniffing modes were implemented to give you a
59 powerful and complete sniffing suite. Plugins are supported. It has
60 the ability to check whether you are in a switched LAN or not, and to
61 use OS fingerprints (active or passive) to let you know the geometry
62 of the LAN. The passive scan of the LAN retrieves infos about: hosts
63 in the lan, open ports, services version, type of the host (gateway,
64 router or simple host) and extimated distance in hop.
65
66 %description -l pl.UTF-8
67 ettercap jest wieloczynnościowym snifferem/przechwytywaczem/loggerem
68 dla sieci LAN (opartych na switchach lub hubach). Obsługuje aktywną i
69 pasywną analizę wielu protokołów (nawet szyfrowanych, jak SSH czy
70 HTTPS). Możliwe jest także wstrzykiwanie lub filtrowanie danych
71 (podmiana lub usunięcie pakietu) w locie, przy podtrzymaniu
72 synchronizacji połączenia. Program ma zaimplementowane wiele trybów
73 sniffowania, aby dać potężne i kompletne narzędzie. Obsługiwane są
74 wtyczki. Program ma możliwość sprawdzania, czy pracuje w sieci ze
75 switchami oraz używania odcisków systemów (aktywnego lub pasywnego) do
76 poznania geometrii sieci. Pasywne skanowanie sieci uzyskuje informacje
77 o: hostach w sieci, otwartych portach, wersjach usług, rodzajach
78 hostów (bramki, routery lub zwykłe komputery) oraz przybliżonych
79 odległościach (w hopach).
80
81 %description -l pt_BR.UTF-8
82 ettercap é um sniffer/interceptor/logger de rede para redes locais
83 (com uso de switches ou não). Suporta operações ativas e passivas de
84 vários protocolos (mesmo os criptografados, como SSH e HTTPS). Também
85 é possível injeção de dados em uma conexão estabelecida e filtragem
86 (substituição ou descarte de um pacote) em tempo real mantendo a
87 conexão sincronizada. Muitos modos de sniffing foram implementadas
88 para proporcionar a você um completo conjunto de sniffing. Plugins são
89 suportados. Tem a habilidade de verificar se você está em uma rede
90 local com switches ou não. Utiliza fingerprints do Sistema Operacional
91 (ativo ou passivo) para permitir que você conheça a geometria da rede
92 local. A varredura passiva da rede local obtém informações sobre:
93 hosts na rede local, portas abertas, versão de serviços, tipo de host
94 (gateway, router ou um computador) e a distância estimada no hop.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99 %patch1 -p1
100 %patch2 -p1
101
102 %build
103 install -d build
104 cd build
105 %cmake .. \
106         -DBUNDLED_LIBS=OFF \
107         %{!?with_geoip:-DENABLE_GEOIP=OFF} \
108         %{!?with_gtk:-DENABLE_GTK=OFF} \
109         -DENABLE_IPV6=ON
110         %{?with_lua:-DENABLE_LUA=ON} \
111         %{?with_gtk2:-DGTK_BUILD_TYPE=GTK2}
112
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} -C build install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 # API not exported
122 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libettercap*.so
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS CHANGELOG LICENSE.OPENSSL README README.{BINARIES,BUGS} THANKS TODO doc/*
133 %attr(755,root,root) %{_bindir}/ettercap
134 %attr(755,root,root) %{_bindir}/ettercap-pkexec
135 %attr(755,root,root) %{_bindir}/etterfilter
136 %attr(755,root,root) %{_bindir}/etterlog
137 %attr(755,root,root) %{_libdir}/libettercap.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/libettercap.so.0
139 %attr(755,root,root) %{_libdir}/libettercap-ui.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libettercap-ui.so.0
141 %dir %{_libdir}/ettercap
142 %attr(755,root,root) %{_libdir}/ettercap/ec_*.so
143 %dir %{_sysconfdir}/ettercap
144 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ettercap/etter.conf
145 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ettercap/etter.dns
146 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ettercap/etter.mdns
147 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ettercap/etter.nbns
148 %{_datadir}/appdata/ettercap.appdata.xml
149 %{_datadir}/ettercap
150 %{_datadir}/polkit-1/actions/org.pkexec.ettercap.policy
151 %{_desktopdir}/ettercap.desktop
152 %{_pixmapsdir}/ettercap.svg
153 %{_mandir}/man5/etter.conf.5*
154 %{_mandir}/man8/ettercap.8*
155 %{_mandir}/man8/ettercap-pkexec.8*
156 %{_mandir}/man8/ettercap_curses.8*
157 %{_mandir}/man8/ettercap_plugins.8*
158 %{_mandir}/man8/etterfilter.8*
159 %{_mandir}/man8/etterlog.8*
This page took 0.073349 seconds and 4 git commands to generate.