]> git.pld-linux.org Git - packages/ettercap.git/blob - ettercap.spec
rebuild with openssl 3.0.0
[packages/ettercap.git] / ettercap.spec
1 #
2 # Conditional build:
3 %bcond_without  geoip   # GeoIP support
4 %bcond_without  gtk     # gtk-based frontend
5 %bcond_with     gtk2    # use GTK+ 2.x instead of 3.x
6 %bcond_with     lua     # experimental Lua support
7 #
8 Summary:        ettercap - a ncurses-based sniffer/interceptor utility
9 Summary(pl.UTF-8):      ettercap - oparte o ncurses narzędzie do sniffowania/przechwytywania
10 Summary(pt_BR.UTF-8):   ettercap e um interceptador/sniffer paseado em ncurses
11 Name:           ettercap
12 Version:        0.8.3
13 Release:        2
14 Epoch:          1
15 License:        GPL v2+ with OpenSSL exception
16 Group:          Networking/Utilities
17 #Source0Download: https://github.com/Ettercap/ettercap/releases
18 Source0:        https://github.com/Ettercap/ettercap/releases/download/v%{version}/%{name}-%{version}.tar.gz
19 # Source0-md5:  6b27d329a509e65fef9044c95a2dde35
20 Patch0:         %{name}-buildtype.patch
21 Patch1:         %{name}-gtk3.patch
22 Patch2:         %{name}-link.patch
23 Patch3:         %{name}-no-common.patch
24 URL:            https://www.ettercap-project.org/
25 %{?with_geoip:BuildRequires:    GeoIP-devel}
26 BuildRequires:  bison
27 BuildRequires:  cmake >= 2.8
28 BuildRequires:  curl-devel >= 7.26.0
29 BuildRequires:  flex
30 %if %{with gtk}
31 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.10}
32 %{!?with_gtk2:BuildRequires:    gtk+3-devel >= 3.12.0}
33 %endif
34 BuildRequires:  libbsd-devel
35 BuildRequires:  libnet-devel >= 1:1.1.5
36 BuildRequires:  libpcap-devel
37 %{?with_lua:BuildRequires:      luajit-devel >= 2.0.0}
38 BuildRequires:  ncurses-ext-devel
39 BuildRequires:  openssl-devel >= 0.9.7d
40 BuildRequires:  pcre-devel
41 BuildRequires:  pkgconfig
42 BuildRequires:  zlib-devel
43 Requires:       curl-libs >= 7.26.0
44 %if %{with gtk}
45 %{?with_gtk2:Requires:  gtk+2 >= 2:2.10}
46 %{!?with_gtk2:Requires: gtk+3 >= 3.12.0}
47 %endif
48 Requires:       libnet >= 1:1.1.5
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %define         specflags       -fomit-frame-pointer
52
53 %description
54 ettercap is a network sniffer/interceptor/logger for ethernet LANs
55 (both switched or not). It supports active and passive dissection of
56 many protocols (even ciphered ones, like SSH and HTTPS). Data
57 injection in an established connection and filtering (substitute or
58 drop a packet) on the fly is also possible, keeping the connection
59 synchronized. Many sniffing modes were implemented to give you a
60 powerful and complete sniffing suite. Plugins are supported. It has
61 the ability to check whether you are in a switched LAN or not, and to
62 use OS fingerprints (active or passive) to let you know the geometry
63 of the LAN. The passive scan of the LAN retrieves infos about: hosts
64 in the lan, open ports, services version, type of the host (gateway,
65 router or simple host) and extimated distance in hop.
66
67 %description -l pl.UTF-8
68 ettercap jest wieloczynnościowym snifferem/przechwytywaczem/loggerem
69 dla sieci LAN (opartych na switchach lub hubach). Obsługuje aktywną i
70 pasywną analizę wielu protokołów (nawet szyfrowanych, jak SSH czy
71 HTTPS). Możliwe jest także wstrzykiwanie lub filtrowanie danych
72 (podmiana lub usunięcie pakietu) w locie, przy podtrzymaniu
73 synchronizacji połączenia. Program ma zaimplementowane wiele trybów
74 sniffowania, aby dać potężne i kompletne narzędzie. Obsługiwane są
75 wtyczki. Program ma możliwość sprawdzania, czy pracuje w sieci ze
76 switchami oraz używania odcisków systemów (aktywnego lub pasywnego) do
77 poznania geometrii sieci. Pasywne skanowanie sieci uzyskuje informacje
78 o: hostach w sieci, otwartych portach, wersjach usług, rodzajach
79 hostów (bramki, routery lub zwykłe komputery) oraz przybliżonych
80 odległościach (w hopach).
81
82 %description -l pt_BR.UTF-8
83 ettercap é um sniffer/interceptor/logger de rede para redes locais
84 (com uso de switches ou não). Suporta operações ativas e passivas de
85 vários protocolos (mesmo os criptografados, como SSH e HTTPS). Também
86 é possível injeção de dados em uma conexão estabelecida e filtragem
87 (substituição ou descarte de um pacote) em tempo real mantendo a
88 conexão sincronizada. Muitos modos de sniffing foram implementadas
89 para proporcionar a você um completo conjunto de sniffing. Plugins são
90 suportados. Tem a habilidade de verificar se você está em uma rede
91 local com switches ou não. Utiliza fingerprints do Sistema Operacional
92 (ativo ou passivo) para permitir que você conheça a geometria da rede
93 local. A varredura passiva da rede local obtém informações sobre:
94 hosts na rede local, portas abertas, versão de serviços, tipo de host
95 (gateway, router ou um computador) e a distância estimada no hop.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 %patch1 -p1
101 %patch2 -p1
102 %patch3 -p1
103
104 %build
105 install -d build
106 cd build
107 %cmake .. \
108         -DBUNDLED_LIBS=OFF \
109         %{!?with_geoip:-DENABLE_GEOIP=OFF} \
110         %{!?with_gtk:-DENABLE_GTK=OFF} \
111         -DENABLE_IPV6=ON
112         %{?with_lua:-DENABLE_LUA=ON} \
113         %{?with_gtk2:-DGTK_BUILD_TYPE=GTK2}
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} -C build install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 # API not exported
124 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libettercap*.so
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc AUTHORS CHANGELOG LICENSE.OPENSSL README README.{BINARIES,BUGS} THANKS TODO doc/*
135 %attr(755,root,root) %{_bindir}/ettercap
136 %attr(755,root,root) %{_bindir}/ettercap-pkexec
137 %attr(755,root,root) %{_bindir}/etterfilter
138 %attr(755,root,root) %{_bindir}/etterlog
139 %attr(755,root,root) %{_libdir}/libettercap.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libettercap.so.0
141 %attr(755,root,root) %{_libdir}/libettercap-ui.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libettercap-ui.so.0
143 %dir %{_libdir}/ettercap
144 %attr(755,root,root) %{_libdir}/ettercap/ec_*.so
145 %dir %{_sysconfdir}/ettercap
146 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ettercap/etter.conf
147 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ettercap/etter.dns
148 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ettercap/etter.mdns
149 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ettercap/etter.nbns
150 %{_datadir}/appdata/ettercap.appdata.xml
151 %{_datadir}/ettercap
152 %{_datadir}/polkit-1/actions/org.pkexec.ettercap.policy
153 %{_desktopdir}/ettercap.desktop
154 %{_pixmapsdir}/ettercap.svg
155 %{_mandir}/man5/etter.conf.5*
156 %{_mandir}/man8/ettercap.8*
157 %{_mandir}/man8/ettercap-pkexec.8*
158 %{_mandir}/man8/ettercap_curses.8*
159 %{_mandir}/man8/ettercap_plugins.8*
160 %{_mandir}/man8/etterfilter.8*
161 %{_mandir}/man8/etterlog.8*
This page took 0.075676 seconds and 4 git commands to generate.