]> git.pld-linux.org Git - packages/etherwake.git/commitdiff
- initial auto/th/etherwake-1.09-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 16 Dec 2012 12:47:12 +0000 (13:47 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 16 Dec 2012 12:47:12 +0000 (13:47 +0100)
etherwake-build.patch [new file with mode: 0644]
etherwake.spec [new file with mode: 0644]

diff --git a/etherwake-build.patch b/etherwake-build.patch
new file mode 100644 (file)
index 0000000..6ec414d
--- /dev/null
@@ -0,0 +1,21 @@
+diff -urN etherwake-1.09.orig.org/ether-wake.c etherwake-1.09.orig/ether-wake.c
+--- etherwake-1.09.orig.org/ether-wake.c       2012-12-16 13:43:11.000000000 +0100
++++ etherwake-1.09.orig/ether-wake.c   2012-12-16 13:43:55.310189554 +0100
+@@ -131,7 +131,7 @@
+               case 'D': debug++;                      break;
+               case 'i': ifname = optarg;      break;
+               case 'p': get_wol_pw(optarg); break;
+-              case 'u': printf(usage_msg); return 0;
++              case 'u': printf("%s", usage_msg); return 0;
+               case 'v': verbose++;            break;
+               case 'V': do_version++;         break;
+               case '?':
+@@ -140,7 +140,7 @@
+       if (verbose || do_version)
+               printf("%s\n", version_msg);
+       if (errflag) {
+-              fprintf(stderr, brief_usage_msg);
++              fprintf(stderr, "%s", brief_usage_msg);
+               return 3;
+       }
diff --git a/etherwake.spec b/etherwake.spec
new file mode 100644 (file)
index 0000000..e2f7faa
--- /dev/null
@@ -0,0 +1,48 @@
+Summary:       etherwake - send a wake-on-lan packet
+Summary(pl.UTF-8):     etherwake - wysyła pakiet WOL
+Name:          etherwake
+Version:       1.09
+Release:       1
+License:       GPL
+Group:         Networking/Utilities
+Source0:       ftp://ftp.debian.org/debian/pool/main/e/etherwake/%{name}_%{version}.orig.tar.gz
+# Source0-md5: 628e8b2a28d47f262e4c26c989402a59
+Patch0:                ftp://ftp.debian.org/debian/pool/main/e/etherwake/%{name}_%{version}-3.diff.gz
+# Patch0-md5:  c6fbb2cfde669866d67f6cf8c2cc686b
+Patch1:                %{name}-build.patch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+WakeLan sends a properly formatted UDP packet across the network which
+will cause a wake-on-lan enabled computer to power on.
+
+%description -l pl.UTF-8
+WakeLan wysyła pakiet UDP przez sieć, który powoduje włączenie
+komputera z WOL.
+
+%prep
+%setup -q -n %{name}-%{version}.orig
+%patch0 -p1
+%patch1 -p1
+
+%build
+%{__make} \
+       CC="%{__cc}" \
+       CFLAGS="%{rpmcflags} %{rpmcppflags} %{rpmldflags}"
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8}
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+install etherwake.8 $RPM_BUILD_ROOT%{_mandir}/man8
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_sbindir}/etherwake
+%{_mandir}/man8/etherwake.8*
This page took 0.088508 seconds and 4 git commands to generate.