]> git.pld-linux.org Git - packages/etckeeper.git/blob - etckeeper.spec
3363eda22cfeff7f054e44dcb4b1bd88002e59a9
[packages/etckeeper.git] / etckeeper.spec
1 #TODO:
2 # - Subpackages for yum and apt plugins
3 # - Subpackages for backends (git, bzr, etc)
4 # - Write PLD %pre and %post macros that trigger pre-install and post-install runs
5 # - %{py_sitescriptdir}/bzrlib/plugins also created by qbzr package?
6 Summary:        Store /etc in a SCM system (git, mercurial, bzr or darcs)
7 Name:           etckeeper
8 Version:        0.64
9 Release:        0.1
10 License:        GPL v2
11 Group:          Applications/System
12 Source0:        http://ftp.debian.org/debian/pool/main/e/etckeeper/%{name}_%{version}.tar.gz
13 # Source0-md5:  ddd3229028df8da9af03ec8128cebc9b
14 URL:            http://kitenet.net/~joey/code/etckeeper/
15 BuildRequires:  bzr
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.219
18 BuildRequires:  sed >= 4.0
19 Requires:       perl
20 Requires:       python-modules
21 Suggests:       %{name}-bash-completions
22 Suggests:       %{name}-bzr
23 Suggests:       git-core >= 1.6.1-1
24 Obsoletes:      yum-etckeeper
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The etckeeper program is a tool to let /etc be stored in a git,
30 mercurial, bzr or darcs repository. It hooks into APT to automatically
31 commit changes made to /etc during package upgrades. It tracks file
32 metadata that version control systems do not normally support, but
33 that is important for /etc, such as the permissions of /etc/shadow.
34 It's quite modular and configurable, while also being simple to use if
35 you understand the basics of working with version control.
36
37 The default backend is git, if want to use a another backend please
38 install the appropriate tool (mercurial, darcs or bzr). To use bzr as
39 backend, please also install the %{name}-bzr package.
40
41 To start using the package please read
42 %{_docdir}/%{name}-%{version}/README
43
44 %package bzr
45 Summary:        Support for bzr with etckeeper
46 Group:          Applications/System
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       bzr
49
50 %description bzr
51 This package provides a bzr backend for etckeeper, if you want to use
52 etckeeper with bzr backend, install this package.
53
54 %package bash-completions
55 Summary:        Bash completion routies for %{name}
56 Group:          Applications/Shells
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       bash-completion
59
60 %description bash-completions
61 Bash completion routines for %{name}
62
63 %prep
64 %setup -q -n %{name}
65 %{__sed} -i -e '
66         s|HIGHLEVEL_PACKAGE_MANAGER=apt|HIGHLEVEL_PACKAGE_MANAGER=poldek|;
67         s|LOWLEVEL_PACKAGE_MANAGER=dpkg|LOWLEVEL_PACKAGE_MANAGER=rpm|;
68 ' %{name}.conf
69
70 %build
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT{/etc/cron.daily,%{_localstatedir}/cache/%{name}}
76 %{__make} install \
77         INSTALL="install -p" \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 install -p debian/cron.daily $RPM_BUILD_ROOT/etc/cron.daily/%{name}
81
82 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
83 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
84 %py_postclean
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %if 0
90 %post
91 if [ $1 -gt 1 ] ; then
92         %{_bindir}/%{name} update-ignore
93 fi
94 %endif
95
96 %files
97 %defattr(644,root,root,755)
98 %doc INSTALL TODO README
99 %dir %{_sysconfdir}/%{name}
100 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}.conf
101 %dir %{_sysconfdir}/%{name}/*.d
102 %attr(755,root,root) %{_sysconfdir}/%{name}/*.d/[0-9]*
103 %{_sysconfdir}/%{name}/*.d/README
104
105 %attr(755,root,root) /etc/cron.daily/%{name}
106 %attr(755,root,root) %{_bindir}/%{name}
107 %{_mandir}/man8/%{name}.8*
108
109 %files bzr
110 %defattr(644,root,root,755)
111 %dir %{py_sitescriptdir}/bzrlib
112 %dir %{py_sitescriptdir}/bzrlib/plugins
113 %dir %{py_sitescriptdir}/bzrlib/plugins/%{name}
114 %{py_sitescriptdir}/bzrlib/plugins/%{name}/*.py[co]
115 %{py_sitescriptdir}/bzr_etckeeper-*.egg-info
116
117 %files bash-completions
118 %defattr(644,root,root,755)
119 %{_sysconfdir}/bash_completion.d/%{name}
This page took 0.167246 seconds and 2 git commands to generate.