]> git.pld-linux.org Git - packages/et.git/blob - et.spec
- removed translation of title
[packages/et.git] / et.spec
1 # TODO
2 # - create dedicated server subpackage
3 #
4 # Conditional build:
5 %bcond_without  data    # skip build of data subpackage (huge and resource consuming)
6 #
7 Summary:        Enemy Territory
8 Summary(pl):    Enemy Territory - Terytorium wroga
9 Name:           et
10 Version:        2.56
11 Release:        0.13
12 Epoch:          0
13 License:        RTCW-ETEULA
14 Group:          Applications/Games
15 Source0:        http://3dgamers.planetmirror.com/pub/3dgamers/games/wolfensteinet/et-linux-%{version}-2.x86.run
16 # NoSource0-md5:        4dddf1612b9ed5b3fe9d3348ec78c28f
17 Source1:        %{name}.desktop
18 NoSource:       0
19 URL:            http://www.idsoftware.com/
20 # loose dependancy is intentional
21 Requires:       %{name}-data = %{version}
22 ExclusiveArch:  %{ix86}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         no_install_post_strip   1
26 %define         no_install_post_chrpath 1
27 %define         _gamelibdir     %{_libdir}/games/et
28 %define         _gamedatadir    %{_datadir}/games/et
29
30 %description
31 Return to Castle Wolfenstein: Enemy Territory - standalone
32 multi-player game based on Return to Castle Wolfenstein.
33
34 %description -l pl
35 Return to Castle Wolfenstein: Enemy Territory jest to samodzielna gra
36 dla wielu graczy oparta na Return to Castle Wolfenstein.
37
38 %package data
39 Summary:        Enemy Territory data files
40 Summary(pl):    Pliki z danymi dla Enemy Territory
41 Group:          Applications/Games
42
43 %description data
44 This package contains the data files for Enemy Territory.
45
46 %description data -l pl
47 Pakiet ten zawiera pliki z danymi dla gry Enemy Territory.
48
49 %prep
50 %setup -qcT
51 sh %{SOURCE0} --tar xf
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_desktopdir}} \
56         $RPM_BUILD_ROOT{%{_gamelibdir},%{_gamedatadir}}
57
58 install bin/Linux/x86/et.x86 $RPM_BUILD_ROOT%{_gamelibdir}/%{name}
59
60 cat << EOF > $RPM_BUILD_ROOT%{_bindir}/%{name}
61 #!/bin/sh
62 # Needed to make symlinks/shortcuts work.
63 # the binaries must run with correct working directory
64 cd %{_gamelibdir}
65 export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:.
66 exec ./%{name} "\$@"
67 EOF
68
69 install ET.xpm $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.xpm
70 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
71 ln -s ../../../share/games/et/etmain $RPM_BUILD_ROOT%{_gamelibdir}
72
73 cp -a pb $RPM_BUILD_ROOT%{_gamelibdir}
74 # in DOCS
75 rm -f $RPM_BUILD_ROOT%{_gamelibdir}/pb/PB_EULA.txt
76
77 %if %{with data}
78 cp -a etmain $RPM_BUILD_ROOT%{_gamedatadir}
79 %endif
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %doc CHANGES v1.02_Readme.htm Docs pb/PB_EULA.txt
87 %attr(755,root,root) %{_bindir}/*
88
89 %dir %{_gamelibdir}
90 %attr(755,root,root) %{_gamelibdir}/et
91 %{_gamelibdir}/etmain
92
93 %dir %{_gamelibdir}/pb
94 %{_gamelibdir}/pb/htm
95 %attr(755,root,root) %{_gamelibdir}/pb/*.x86
96 %attr(755,root,root) %{_gamelibdir}/pb/*.so
97 %{_gamelibdir}/pb/*.db
98
99 %dir %{_gamedatadir}
100 %{_desktopdir}/%{name}.desktop
101 %{_pixmapsdir}/%{name}.xpm
102
103 %if %{with data}
104 %files data
105 %defattr(644,root,root,755)
106 %{_gamedatadir}/*
107 %endif
This page took 0.069955 seconds and 3 git commands to generate.