]> git.pld-linux.org Git - packages/esh.git/blob - esh.spec
- changed all BuildRoot definitons
[packages/esh.git] / esh.spec
1 Summary:        esh, the easy shell
2 Name:           esh
3 Version:        0.8
4 Release:        1
5 License:        GPL
6 Group:          Shells
7 Group(pl):      Pow³oki
8 Vendor:         Ivan Tkatchev <ivantk@yahoo.com>
9 Source0:        http://esh.netpedia.net/%{name}-%{version}.tar.gz
10 URL:            http://esh.netpedia.net/
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %define         _bindir         /bin
14
15 %description
16 esh was primarily written out of a need for a simple and lightweight shell
17 for Unix. As such, it deviates completely from all of the traditional
18 shells, opting instead for a Lisp-like syntax. This allows exceptionally
19 small size, both in terms of lines of code and memory consumption, while
20 retaining remarkable flexibility and programmability.
21
22 %prep
23 %setup -q -n esh
24
25 %build
26 make
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30
31 install -d $RPM_BUILD_ROOT{%{_bindir},%{_infodir}}
32
33 install -s esh $RPM_BUILD_ROOT%{_bindir}
34 install esh.info $RPM_BUILD_ROOT%{_prefix}/info
35
36 %post
37 /sbin/install-info %{_prefix}/info/esh.info.gz %{_prefix}/info/dir --entry="* esh: (esh).                 esh, the easy shell."
38
39 %preun
40 if [ $1 = 0 ]; then
41         /sbin/install-info --delete %{_prefix}/info/esh.info.gz %{_prefix}/info/dir --entry="* esh: (esh).                 esh, the easy shell."
42 fi
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc doc emacs examples CHANGELOG CREDITS GC_README INSTALL LICENSE READLNE-HACKS TODO
50 /bin/esh
51 %{_prefix}/info/esh.info.gz
This page took 0.056772 seconds and 3 git commands to generate.