]> git.pld-linux.org Git - packages/eric6.git/blob - eric6.spec
Version 6.1.10
[packages/eric6.git] / eric6.spec
1 # TODO: Switch to python3
2
3 %define         module  eric6
4 Summary:        Eric6 - a full featured Python IDE
5 Summary(pl.UTF-8):      Eric6 - pełnowartościowe IDE dla Pythona
6 # Name must match the python module/package name (as on pypi or in 'import' statement)
7 Name:           eric6
8 Version:        6.1.10
9 Release:        0.1
10 License:        GPL v3
11 Group:          Libraries/Python
12 Source0:        https://sourceforge.net/projects/eric-ide/files/eric6/stable/%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  b08a7669c6d2bb55e32e1bf1b82646f9
14 URL:            http://eric-ide.python-projects.org/index.html
15 BuildRequires:  rpm-pythonprov
16 # for the py_build, py_install macros
17 BuildRequires:  python-modules
18 BuildRequires:  python-setuptools
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 # NOTE: As for 6.1.8  eric6 still tries to import PyQt5 while having PyQt4 leading to crash
21 #       http://die-offenbachs.homelinux.org:48888/issues/issue204
22 # for --pyqt=4
23 # BuildRequires:        python-PyQt4-qscintilla2
24 # BuildRequires:        python-PyQt4-uic
25 # for --pyqt=5
26 BuildRequires:  python-PyQt5-qscintilla2
27 BuildRequires:  python-PyQt5-uic
28 Requires:       python-PyQt5-qscintilla2
29 Requires:       python-modules
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Eric is a Python IDE written using PyQt and QScintilla. It provides
35 various features such as any number of open editors, an integrated
36 (remote) debugger, project management facilities, unit test,
37 refactoring and much more.
38
39 %description -l pl.UTF-8
40 Eric jest pythonowym graficznym środowiskiem programistycznym
41 używającym PyQt i QScintilla.
42
43 %prep
44 %setup -q
45
46 %build
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 python install.py -z -c -b %{_bindir} -d %{py_sitescriptdir} -i $RPM_BUILD_ROOT  --pyqt=5
51 mkdir $RPM_BUILD_ROOT%{_datadir}/appdata
52 mv $RPM_BUILD_ROOT%{_datadir}/metainfo/eric6.appdata.xml $RPM_BUILD_ROOT%{_datadir}/appdata
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc README.rst
60 %{py_sitescriptdir}/%{module}
61 %attr(755,root,root) %{_bindir}/eric6
62 %attr(755,root,root) %{_bindir}/eric6_*
63 # for --pyqt=4
64 # %{_datadir}/qt4/qsci/api/qss/
65 # %{_datadir}/qt4/qsci/api/ruby/
66 # NOTE: file %{_datadir}/qt4/qsci/api/ruby/Ruby-1.8.7.api from install of eric6-6.1.8-0.1.noarch conflicts with file from package eric4-4.5.24-3.noarch
67 # %{_datadir}/qt4/qsci/api/python/eric6.*
68 # %{_datadir}/qt4/qsci/api/python/zope-*.api
69
70 # for --pyqt=5
71 %{_datadir}/qt5/qsci/api/qss/
72 %{_datadir}/qt5/qsci/api/ruby/
73 %{_datadir}/qt5/qsci/api/python/eric6.*
74 %{_datadir}/qt5/qsci/api/python/zope-*.api
75
76 %{_pixmapsdir}/eric*.png
77 %{_desktopdir}/eric6.desktop
78 %{_desktopdir}/eric6_webbrowser.desktop
79 %{_datadir}/appdata/eric6.appdata.xml
80 %{py_sitescriptdir}/eric6config.py
81 %{py_sitescriptdir}/eric6plugins
This page took 0.090331 seconds and 3 git commands to generate.