]> git.pld-linux.org Git - packages/eric6.git/blob - eric6.spec
0fa2e97080adb66038c86c73be229c8f64303775
[packages/eric6.git] / eric6.spec
1 # TODO: Switch to python3
2
3 %define         module  eric6
4 Summary:        Eric6 - a full featured Python IDE
5 Summary(pl.UTF-8):      Eric6 - pełnowartościowe IDE dla Pythona
6 # Name must match the python module/package name (as on pypi or in 'import' statement)
7 Name:           eric6
8 Version:        6.1.8
9 Release:        0.5
10 License:        GPL v3
11 Group:          Libraries/Python
12 Source0:        https://sourceforge.net/projects/eric-ide/files/eric6/stable/%{version}/eric6-%{version}.tar.gz
13 # Source0-md5:  a070c679fbc93fab4f3b718a5875e5d0
14 URL:            http://eric-ide.python-projects.org/index.html
15 BuildRequires:  rpm-pythonprov
16 # for the py_build, py_install macros
17 BuildRequires:  rpmbuild(macros) >= 1.714
18 %if %{with python2}
19 BuildRequires:  python-modules
20 BuildRequires:  python-setuptools
21 # NOTE: As for 6.1.8  eric6 still tries to import PyQt5 while having PyQt4 leading to crash
22 #       http://die-offenbachs.homelinux.org:48888/issues/issue204
23 # for --pyqt=4
24 # BuildRequires:        python-PyQt4-qscintilla2
25 # BuildRequires:        python-PyQt4-uic
26 # for --pyqt=5
27 BuildRequires:  python-PyQt5-qscintilla2
28 BuildRequires:  python-PyQt5-uic
29
30 %endif
31 %if %{with python3}
32 BuildRequires:  python3-modules
33 BuildRequires:  python3-setuptools
34 %endif
35 Requires:       python-modules
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Eric is a Python IDE written using PyQt and QScintilla. It provides
41 various features such as any number of open editors, an integrated
42 (remote) debugger, project management facilities, unit test,
43 refactoring and much more.
44
45 %description -l pl.UTF-8
46 Eric jest pythonowym graficznym środowiskiem programistycznym
47 używającym PyQt i QScintilla.
48
49 %prep
50 %setup -q
51
52 %build
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 python install.py -z -c -b %{_bindir} -d %{py_sitescriptdir} -i $RPM_BUILD_ROOT  --pyqt=5
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %if %{with python2}
62 %files
63 %defattr(644,root,root,755)
64 %doc README.rst
65 %{py_sitescriptdir}/%{module}
66 %attr(755,root,root) %{_bindir}/eric6
67 %attr(755,root,root) %{_bindir}/eric6_*
68 # for --pyqt=4
69 # %{_datadir}/qt4/qsci/api/qss/
70 # %{_datadir}/qt4/qsci/api/ruby/
71 # %{_datadir}/qt4/qsci/api/python/eric6.*
72 # %{_datadir}/qt4/qsci/api/python/zope-*.api
73
74 # for --pyqt=5
75 %{_datadir}/qt5/qsci/api/qss/
76 %{_datadir}/qt5/qsci/api/ruby/
77 %{_datadir}/qt5/qsci/api/python/eric6.*
78 %{_datadir}/qt5/qsci/api/python/zope-*.api
79
80 %{_pixmapsdir}/eric*.png
81 %{_desktopdir}/eric6.desktop
82 %{_desktopdir}/eric6_webbrowser.desktop
83 %{_datadir}/appdata/eric6.appdata.xml
84 # file %{_datadir}/qt4/qsci/api/ruby/Ruby-1.8.7.api from install of eric6-6.1.8-0.1.noarch conflicts with file from package eric4-4.5.24-3.noarch
85 %{py_sitescriptdir}/eric6config.py
86 %{py_sitescriptdir}/eric6plugins
87 %endif
This page took 0.062921 seconds and 2 git commands to generate.