]> git.pld-linux.org Git - packages/eric3.git/blob - eric3.spec
- qt-static is not necessary
[packages/eric3.git] / eric3.spec
1 %include        /usr/lib/rpm/macros.python
2 Summary:        Eric3 is a full featured Python IDE
3 Summary(pl):    Eric3 - pe³nowarto¶ciowe IDE dla Pythona
4 Name:           eric
5 Version:        3.0.1
6 Release:        1
7 License:        GPL
8 Group:          X11/Development/Tools
9 Source0:        http://www.die-offenbachs.de/detlev/files/%{name}-%{version}.tar.gz
10 URL:            http://www.die-offenbachs.de/detlev/eric3.html
11 BuildRequires:  python-PyQt-devel >= 2.2.1
12 BuildRequires:  qt-devel >= 3.0.2
13 BuildRequires:  rpm-pythonprov
14 BuildRequires:  sip >= 3.5
15 %requires_eq    sip
16 %pyrequires_eq  python
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Eric3 is a full featured Python IDE that is written in PyQt using the
21 QScintilla editor widget.
22
23 %description -l pl
24 Eric3 jest pe³nowarto¶ciowym IDE dla Pythona napisanym w PyQt i
25 u¿ywaj±cy edytora QScintilla.
26
27 %prep
28 %setup -q 
29
30 %build
31 python install.py -b $RPM_BUILD_ROOT%{_bindir} -d $RPM_BUILD_ROOT%{py_sitedir} -i temp
32
33 %{__make}
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT%{_examplesdir}/python/%{module}
38
39 %{__make} install \
40         DESTDIR=$RPM_BUILD_ROOT
41
42 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
43 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
44 cp -R examples3/* $RPM_BUILD_ROOT%{_examplesdir}/python/%{module}
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc NEWS README THANKS doc/%{module}/*
52 %attr(755,root,root) %{_bindir}/*
53 %attr(755,root,root) %{py_sitedir}/lib*.so*
This page took 0.168159 seconds and 4 git commands to generate.