]> git.pld-linux.org Git - packages/eric3.git/blob - eric3.spec
- massive attack: perl -pi -e "s/^#+\%\{/#\%\%\{/"
[packages/eric3.git] / eric3.spec
1 %include        /usr/lib/rpm/macros.python
2 Summary:        Eric3 is a full featured Python IDE
3 Summary(pl):    Eric3 jest pe³nowarto¶ciowym IDE dla Python'a
4 Name:           eric
5 Version:        3.0.1
6 Release:        1
7 License:        GPL
8 Group:          X11/Development/Tools
9 Source0:        http://www.die-offenbachs.de/detlev/files/%{name}-%{version}.tar.gz
10 URL:            http://www.die-offenbachs.de/detlev/eric3.html
11 BuildRequires:  python-PyQt-devel >= 2.2.1
12 BuildRequires:  qt-devel >= 3.0.2
13 BuildRequires:  qt-static >= 3.0.2
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  sip >= 3.5
16 %requires_eq    sip
17 %pyrequires_eq  python
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Eric3 is a full featured Python IDE that is written in PyQt using the QScintilla editor widget
22
23 %description -l pl
24 Eric3 jest pe³nowarto¶ciowym IDE dla Python'a napisanym w  PyQt i u¿ywaj±cy edytor QScintilla
25
26 #%package devel
27 #Summary: Files needed to build other bindings based on Qt
28 #Summary(pl): Pliki nag³ówkowe %{name}
29 #Requires: %{name} = %{version}
30 #Group: Development/Languages/Python
31
32 #%description devel
33 #Files needed to build other bindings for C++ classes that inherit from any
34 #of the Qt classes (e.g. KDE or your own).
35
36 #%description devel -l pl
37 #Files needed to build other bindings for C++ classes that inherit from any
38 #of the Qt classes (e.g. KDE or your own).
39
40 #%package examples
41 #Summary: Examples for PyQt
42 #Summary(pl): Przyklady dla PyQt
43 #Requires: %{name} = %{version}
44 #Group: Libraries/Python
45
46 #%description examples
47 #Examples code demonstrating how to use the Python bindings for Qt.
48
49 #%description examples -l pl
50 #Przykladowy kod demonstruj±cy jak u¿ywaæ PyQT.
51
52 %prep
53 %setup -q 
54
55 %build
56
57 #rm -rf $RPM_BUILD_ROOT
58 #install -d $RPM_BUILD_ROOT%{py_sitedir}
59 #install -d $RPM_BUILD_ROOT%{_bindir}
60 python install.py -b $RPM_BUILD_ROOT%{_bindir} -d $RPM_BUILD_ROOT%{py_sitedir} -i temp
61
62 %{__make}
63
64 %install
65 install -d $RPM_BUILD_ROOT%{_examplesdir}/python/%{module}
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
71 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
72 cp -R examples3/* $RPM_BUILD_ROOT%{_examplesdir}/python/%{module}
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc NEWS README THANKS doc/%{module}/*
79 %attr(755,root,root) %{_bindir}/*
80 %attr(755,root,root) %{py_sitedir}/lib*.so*
81
82 #%files devel
83 #%defattr(644,root,root,755)
84 #%%{py_sitedir}/*.py
85 #%%{py_sitedir}/*.py[co]
86
87 #%files examples
88 #%defattr(644,root,root,755)
89 #%%{_examplesdir}/python/%{module}
This page took 0.128983 seconds and 3 git commands to generate.