]> git.pld-linux.org Git - packages/eric3.git/blob - eric3.spec
4d74eaa4170c6dee23391cd9fcd5bda0fd1baf79
[packages/eric3.git] / eric3.spec
1 # TODO:
2 # - separate packages (eg. brm, KdeQt - with R: python-PyKDE)
3 #
4 %define         tar_name        eric
5 Summary:        Eric3 is a full featured Python IDE
6 Summary(pl):    Eric3 - pe³nowarto¶ciowe IDE dla Pythona
7 Name:           eric3
8 Version:        3.9.3
9 Release:        1
10 License:        GPL
11 Group:          X11/Development/Tools
12 Source0:        http://dl.sourceforge.net/eric-ide/%{tar_name}-%{version}.tar.gz
13 # Source0-md5:  7009ed286086ac263bacfc9f68285253
14 Source1:        %{name}.desktop
15 URL:            http://www.die-offenbachs.de/detlev/eric3.html
16 BuildRequires:  python-PyQt >= 3.15
17 BuildRequires:  qscintilla-devel >= 1:1.5
18 BuildRequires:  rpm-pythonprov
19 %pyrequires_eq  python-modules
20 Requires:       python-PyQt >= 3.15
21 Requires:       python-devel-tools
22 Obsoletes:      eric
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Eric3 is a full featured Python IDE that is written in PyQt using the
27 QScintilla editor widget.
28
29 %description -l pl
30 Eric3 jest pe³nowarto¶ciowym IDE dla Pythona napisanym w PyQt i
31 u¿ywaj±cym edytora QScintilla.
32
33 %package doc
34 Summary:        Documentation for Eric3
35 Summary(pl):    Dodatkowa dokumentacja dla Eric3
36 Group:          X11/Development/Tools
37 Requires:       %{name} = %{version}-%{release}
38
39 %description doc
40 Documentation for Eric3.
41
42 %description doc -l pl
43 Dodatkowa dokumentacja dla Eric3.
44
45 %prep
46 %setup -q -n %{tar_name}-%{version}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{_docdir}/%{name},%{_pixmapsdir},%{_desktopdir}}
51
52 python install.py -c -b %{_bindir} -d %{py_sitedir} -i $RPM_BUILD_ROOT
53
54 %py_comp $RPM_BUILD_ROOT%{py_sitedir}/*
55 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/*
56
57 cp $RPM_BUILD_ROOT%{py_sitedir}/%{name}/icons/default/eric.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
58 install %SOURCE1 $RPM_BUILD_ROOT%{_desktopdir}
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 # NOTE: eric3 uses *.py files for it's own purposes
64 # so do not remove them from package
65
66 %files
67 %defattr(644,root,root,755)
68 %doc HISTORY README* THANKS
69 %attr(755,root,root) %{_bindir}/*
70 %{py_sitedir}/eric3config.py
71 %{py_sitedir}/sitecustomize.py
72 %{py_sitedir}/%{name}
73 %exclude %{py_sitedir}/%{name}/Documentation
74 %{_desktopdir}/%{name}.desktop
75 %{_pixmapsdir}/%{name}.png
76
77 %files doc
78 %defattr(644,root,root,755)
79 %dir %{py_sitedir}/%{name}/Documentation
80 %{py_sitedir}/%{name}/Documentation/mod_python.*
81 %{py_sitedir}/%{name}/Documentation/Source
This page took 0.021874 seconds and 2 git commands to generate.