]> git.pld-linux.org Git - packages/epydoc.git/commitdiff
- Release: 3 auto/th/epydoc-3_0_1-3
authorJacek Konieczny <jajcus@pld-linux.org>
Sun, 8 May 2011 11:35:16 +0000 (11:35 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- restructured text parsing fix, based on the patch from https://bugzilla.redhat.com/show_bug.cgi?id=578920

Changed files:
    epydoc-rst.patch -> 1.1
    epydoc.spec -> 1.23

epydoc-rst.patch [new file with mode: 0644]
epydoc.spec

diff --git a/epydoc-rst.patch b/epydoc-rst.patch
new file mode 100644 (file)
index 0000000..d667e6e
--- /dev/null
@@ -0,0 +1,31 @@
+diff -dur epydoc-3.0.1.orig/epydoc/markup/restructuredtext.py epydoc-3.0.1/epydoc/markup/restructuredtext.py
+--- epydoc-3.0.1.orig/epydoc/markup/restructuredtext.py        2008-01-28 18:15:32.000000000 +0100
++++ epydoc-3.0.1/epydoc/markup/restructuredtext.py     2011-05-08 13:33:08.000000000 +0200
+@@ -304,10 +304,10 @@
+         # Extract the first sentence.
+         for child in node:
+             if isinstance(child, docutils.nodes.Text):
+-                m = self._SUMMARY_RE.match(child.data)
++                m = self._SUMMARY_RE.match(child)
+                 if m:
+                     summary_pieces.append(docutils.nodes.Text(m.group(1)))
+-                    other = child.data[m.end():]
++                    other = child[m.end():]
+                     if other and not other.isspace():
+                         self.other_docs = True
+                     break
+@@ -489,10 +489,10 @@
+             if (len(fbody[0]) > 0 and
+                 isinstance(fbody[0][0], docutils.nodes.Text)):
+                 child = fbody[0][0]
+-                if child.data[:1] in ':-':
+-                    child.data = child.data[1:].lstrip()
+-                elif child.data[:2] in (' -', ' :'):
+-                    child.data = child.data[2:].lstrip()
++                if child[:1] in ':-':
++                    child = child[1:].lstrip()
++                elif child[:2] in (' -', ' :'):
++                    child = child[2:].lstrip()
+             # Wrap the field body, and add a new field
+             self._add_field(tagname, arg, fbody)
index 198ed6d7bf8d01ef7c564e6f0219c2e58fff4e0a..3095e944a8864fd30972832d69bcecd9267fc86d 100644 (file)
@@ -2,11 +2,12 @@ Summary:      Tool for generating API documentation for Python modules
 Summary(pl.UTF-8):     Narzędzie do generowania dokumentacji API modułów Pythona
 Name:          epydoc
 Version:       3.0.1
-Release:       2
+Release:       3
 License:       MIT
 Group:         Development/Languages/Python
 Source0:       http://downloads.sourceforge.net/epydoc/%{name}-%{version}.zip
 # Source0-md5: 43223b2139c59ec60f064564bea82bf4
+Patch0:                %{name}-rst.patch
 URL:           http://epydoc.sourceforge.net/
 BuildRequires: python
 BuildRequires: python-modules >= 2.2.1
@@ -67,6 +68,7 @@ Ten pakiet zawiera graficzny interfejs użytkownika (GUI) dla epydoc.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 python setup.py build
This page took 0.058746 seconds and 4 git commands to generate.