]> git.pld-linux.org Git - packages/epydoc.git/blob - epydoc.spec
- cleanup
[packages/epydoc.git] / epydoc.spec
1 Summary:        Tool for generating API documentation for Python modules
2 Summary(pl.UTF-8):      Narzędzie do generowania dokumentacji API modułów Pythona
3 Name:           epydoc
4 Version:        3.0.1
5 Release:        6
6 License:        MIT
7 Group:          Development/Languages/Python
8 Source0:        http://downloads.sourceforge.net/epydoc/%{name}-%{version}.zip
9 # Source0-md5:  43223b2139c59ec60f064564bea82bf4
10 Patch0:         %{name}-rst.patch
11 Patch1:         %{name}-__package__.patch
12 Patch2:         %{name}-cons_fields_stripping.patch
13 URL:            http://epydoc.sourceforge.net/
14 BuildRequires:  python
15 BuildRequires:  python-modules >= 2.2.1
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  unzip
18 %pyrequires_eq  python-modules
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 epydoc is a tool for generating API documentation for Python modules,
24 based on their docstrings. For an example of epydoc's output, see the
25 API documentation for epydoc itself (html, pdf). A lightweight markup
26 language called epytext can be used to format docstrings and to add
27 information about specific fields, such as parameters and instance
28 variables. epydoc also understands docstrings written in
29 ReStructuredText, Javadoc and plaintext.
30
31 %description -l pl.UTF-8
32 epydoc jest narzędziem do generowania dokumentacji API modułów Pythona
33 w oparciu o ich wewnętrzne opisy (docstrings). Jako przykład wyniku
34 jego działania można obejrzeć jego własną dokumentację (html, pdf).
35 Dostępny jest prosty język znaczników o nazwie epytext, który można
36 wykorzystać do formatowania wewnętrznych opisów oraz do dodawania
37 informacji o konkretnych polach, takich jak parametry i zmienne
38 instancji. epydoc rozumie również wewnętrzne opisy stworzone w
39 formatach ReStructuredText i Javadoc oraz w postaci czystego tekstu.
40
41 %package gui
42 Summary:        GUI for epydoc
43 Summary(pl.UTF-8):      Interfejs graficzny dla epydoc
44 Group:          Development/Languages/Python
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       python-tkinter >= 2.2.1
47
48 %description gui
49 epydoc is a tool for generating API documentation for Python modules,
50 based on their docstrings. For an example of epydoc's output, see the
51 API documentation for epydoc itself (html, pdf). A lightweight markup
52 language called epytext can be used to format docstrings and to add
53 information about specific fields, such as parameters and instance
54 variables. epydoc also understands docstrings written in
55 ReStructuredText, Javadoc and plaintext.
56
57 This package contains GUI program for epydoc.
58
59 %description gui -l pl.UTF-8
60 epydoc jest narzędziem do generowania dokumentacji API modułów Pythona
61 w oparciu o ich wewnętrzne opisy (docstrings). Jako przykład wyniku
62 jego działania można obejrzeć jego własną dokumentację (html, pdf).
63 Dostępny jest prosty język znaczników o nazwie epytext, który można
64 wykorzystać do formatowania wewnętrznych opisów oraz do dodawania
65 informacji o konkretnych polach, takich jak parametry i zmienne
66 instancji. epydoc rozumie również wewnętrzne opisy stworzone w
67 formatach ReStructuredText i Javadoc oraz w postaci czystego tekstu.
68
69 Ten pakiet zawiera graficzny interfejs użytkownika (GUI) dla epydoc.
70
71 %prep
72 %setup -q
73 %patch0 -p1
74 %patch1 -p1
75 %patch2 -p1
76
77 %build
78 %{__python} setup.py build
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT%{_mandir}/man1
83
84 %{__python} setup.py install \
85         --optimize=2 \
86         --root=$RPM_BUILD_ROOT
87
88 install man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
89
90 %py_postclean
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
97 %doc doc/*
98 %attr(755,root,root) %{_bindir}/apirst2html.py
99 %attr(755,root,root) %{_bindir}/epydoc
100 %{_mandir}/man1/epydoc.1*
101 %{py_sitescriptdir}/epydoc
102 %exclude %{py_sitescriptdir}/epydoc/gui.py[co]
103 %{py_sitescriptdir}/epydoc-%{version}-py*.egg-info
104
105 %files gui
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_bindir}/epydocgui
108 %{py_sitescriptdir}/epydoc/gui.py[co]
109 %{_mandir}/man1/epydocgui.1*
This page took 0.060982 seconds and 4 git commands to generate.